Overclock.net › Forums › Software, Programming and Coding › Operating Systems › Linux, Unix › Curious freezingish problem in Ubuntu
New Posts  All Forums:Forum Nav:

Curious freezingish problem in Ubuntu

post #1 of 11
Thread Starter 

I'm sporting Ubuntu 12.04 LTS with gnome ui.

In both Unity and gnome, I get a really weird problem that requires a restart.

 

Seemingly at random, when I have my system on for a while (anywhere from 3 days to 3 weeks) the system will crash...ish.

I can't use any UI features using the super key or the notification bar, they just stop working.  However I can move windows around and close them.  And the icons on the desktop will still function (Cairo dock also works without issue).

 

Has anyone else experienced this...weird behavior?

It's happened maybe 10 times to me on 2 different systems

Free Speed
(16 items)
 
  
CPUMotherboardGraphicsRAM
Athlon X2 5400+ @ 3.57 GA-MA770-UD3 Geforce 6200SE 32-bit 2x2GB DDR2 G.Skill 1020MHz 4-4-4-5-2T 
Hard DriveCoolingOSMonitor
80GB Seagate Apogee GTZ with RV Antifreeze Windows XP 32-bit SP3 old 1440x900 monitor from goodwill 
PowerCaseOther
EVGA 500W none Antifreeze coolant for <0C overclocking 
  hide details  
Reply
Free Speed
(16 items)
 
  
CPUMotherboardGraphicsRAM
Athlon X2 5400+ @ 3.57 GA-MA770-UD3 Geforce 6200SE 32-bit 2x2GB DDR2 G.Skill 1020MHz 4-4-4-5-2T 
Hard DriveCoolingOSMonitor
80GB Seagate Apogee GTZ with RV Antifreeze Windows XP 32-bit SP3 old 1440x900 monitor from goodwill 
PowerCaseOther
EVGA 500W none Antifreeze coolant for <0C overclocking 
  hide details  
Reply
post #2 of 11
That's really weird, I'd guess it's an errant service that's taken a nose-dive, but there's probably not a lot you can do other than hope it gets bug-fixed frown.gif
You could log a ticket with Ubuntu, and hope they patch it or hassle Gnome to sort it out. Better than doing nothing I guess...
Little Beast
(12 items)
 
Black 'n' blue II
(15 items)
 
 
CPUGraphicsRAMHard Drive
Intel Core i7-4710MQ Nvidia Geforce GTX860M 2GB 16GB Kingston DDR3 1600MHz 240Gb Silicon Power S55/S60 SSD 
Hard DriveOSOSMonitor
1Tb Toshiba HDD 5400rpm Windows 8.1 Linux Mint 18 17.3" LED 1920x1080 
CaseMouseMouse PadAudio
PCSpecialist Optimus V ST17-860 Logitech MX518 Steelseries QcK Creative HS800 Fatal1ty 
CPUMotherboardGraphicsRAM
Core i7 860 @ 1.25V MSI P55-GD65 Xpertvision Radeon HD4850 4GB G.Skill Ripjaw 
Hard DriveOptical DriveCoolingOS
150Gb Velociraptor & 1Tb WD Caviar Black Opticon Lightscribe DVD-RW DL Noctua NH-U12P SE2 Vista Home Premium x64 
MonitorKeyboardPowerCase
Hyundai BlueH H224W 22" LCD Saitek Eclipse II Thermaltake Purepower RX 550 Galaxy III 
Mouse
Patuoxun optical gaming mouse 3200dpi 
  hide details  
Reply
Little Beast
(12 items)
 
Black 'n' blue II
(15 items)
 
 
CPUGraphicsRAMHard Drive
Intel Core i7-4710MQ Nvidia Geforce GTX860M 2GB 16GB Kingston DDR3 1600MHz 240Gb Silicon Power S55/S60 SSD 
Hard DriveOSOSMonitor
1Tb Toshiba HDD 5400rpm Windows 8.1 Linux Mint 18 17.3" LED 1920x1080 
CaseMouseMouse PadAudio
PCSpecialist Optimus V ST17-860 Logitech MX518 Steelseries QcK Creative HS800 Fatal1ty 
CPUMotherboardGraphicsRAM
Core i7 860 @ 1.25V MSI P55-GD65 Xpertvision Radeon HD4850 4GB G.Skill Ripjaw 
Hard DriveOptical DriveCoolingOS
150Gb Velociraptor & 1Tb WD Caviar Black Opticon Lightscribe DVD-RW DL Noctua NH-U12P SE2 Vista Home Premium x64 
MonitorKeyboardPowerCase
Hyundai BlueH H224W 22" LCD Saitek Eclipse II Thermaltake Purepower RX 550 Galaxy III 
Mouse
Patuoxun optical gaming mouse 3200dpi 
  hide details  
Reply
post #3 of 11
Thread Starter 
Quote:
Originally Posted by chemicalfan View Post

That's really weird, I'd guess it's an errant service that's taken a nose-dive, but there's probably not a lot you can do other than hope it gets bug-fixed frown.gif
You could log a ticket with Ubuntu, and hope they patch it or hassle Gnome to sort it out. Better than doing nothing I guess...

Thanks man, I'll ask them about it

Free Speed
(16 items)
 
  
CPUMotherboardGraphicsRAM
Athlon X2 5400+ @ 3.57 GA-MA770-UD3 Geforce 6200SE 32-bit 2x2GB DDR2 G.Skill 1020MHz 4-4-4-5-2T 
Hard DriveCoolingOSMonitor
80GB Seagate Apogee GTZ with RV Antifreeze Windows XP 32-bit SP3 old 1440x900 monitor from goodwill 
PowerCaseOther
EVGA 500W none Antifreeze coolant for <0C overclocking 
  hide details  
Reply
Free Speed
(16 items)
 
  
CPUMotherboardGraphicsRAM
Athlon X2 5400+ @ 3.57 GA-MA770-UD3 Geforce 6200SE 32-bit 2x2GB DDR2 G.Skill 1020MHz 4-4-4-5-2T 
Hard DriveCoolingOSMonitor
80GB Seagate Apogee GTZ with RV Antifreeze Windows XP 32-bit SP3 old 1440x900 monitor from goodwill 
PowerCaseOther
EVGA 500W none Antifreeze coolant for <0C overclocking 
  hide details  
Reply
post #4 of 11
it sounds like xorg is locking up. the next time it locks up ... you may be able to drop to a console and kill that process, then start it again vs hitting your power button.

did you try ctrl+alt+backspace which will kill the xsession (not ctrl+alt+delete which will restart the entire thing)

and if backspace doesn't work, alt+sysrq+r will get control of the keyboard out of xorg and into console mode, and then ctrl+alt+f1(f2,f3,f4,etc) will drop your screen out of the terminal running X and to one running a console. from there you can log in and kill it

http://en.wikipedia.org/wiki/Magic_SysRq_key < should be common knowledge but very few people know about that smile.gif

it sounds like a bug with whatever DE / WM you are using. Not a surprise at all considering you said "ubuntu". Check in their bug tracker for some other reports, surely others are experiencing the same thing. My suggestion would be to uninstall whatever is unstable and install a real window manager such as fluxbox.
Edited by lloyd mcclendon - 5/9/12 at 7:46am
stable again
(25 items)
 
  
CPUCPUMotherboardGraphics
E5-2687W E5-2687W ASUS Z9PED8-WS EVGA GTX 570 (Linux host) 
GraphicsRAMHard DriveHard Drive
EVGA GTX 970 FTW (win7 guest) 64GB G.SKILL 2133 2x Crucial M4 256GB raid1 4x 3TB raid 10 
CoolingCoolingCoolingCooling
2x Apogee HD  2x RX 480 2x MCP 655 RP-452x2 rev2 (new) 
CoolingCoolingOSOS
16x Cougar Turbine CFT12SB4 (new) EK FC 580 Gentoo (host) Gentoo (x23 guests) 
OSMonitorMonitorPower
windows 7 (guest w/ vfio-pci) Viewsonic 23" 1080P Viewsonic 19" Antec HCP Platinum 1000 (new) 
CaseOtherOther
Case Labs TH10 (still the best ever) 2x Lamptron FC-5 IOGEAR 2 way DVI KVM Switch 
  hide details  
Reply
stable again
(25 items)
 
  
CPUCPUMotherboardGraphics
E5-2687W E5-2687W ASUS Z9PED8-WS EVGA GTX 570 (Linux host) 
GraphicsRAMHard DriveHard Drive
EVGA GTX 970 FTW (win7 guest) 64GB G.SKILL 2133 2x Crucial M4 256GB raid1 4x 3TB raid 10 
CoolingCoolingCoolingCooling
2x Apogee HD  2x RX 480 2x MCP 655 RP-452x2 rev2 (new) 
CoolingCoolingOSOS
16x Cougar Turbine CFT12SB4 (new) EK FC 580 Gentoo (host) Gentoo (x23 guests) 
OSMonitorMonitorPower
windows 7 (guest w/ vfio-pci) Viewsonic 23" 1080P Viewsonic 19" Antec HCP Platinum 1000 (new) 
CaseOtherOther
Case Labs TH10 (still the best ever) 2x Lamptron FC-5 IOGEAR 2 way DVI KVM Switch 
  hide details  
Reply
post #5 of 11
If he drops into console he should run "TOP" and tell us what's running (pic?). I wouldn't kill xorg though, I'd run:

sudo service lightdm restart

If that won't restart Xorg you might just have to run the restart command. I just use the shortcut, if your in TTYL (console) you can always ctrl+alt+del for a reboot. It's quicker than typing reboot! lol
Current Rig
(14 items)
 
  
CPUMotherboardGraphicsRAM
FX-8350 4.6GHz@1.44v GA-990FXA-UD3 R4.0 HD 7950 (1100/1450) 8G Muskin DDR3 1866@8CLS 
Hard DriveOptical DriveOSMonitor
1TB WD LiteOn DVD-RW DL Linux/Windows 19" Phillips TV 1080p 
PowerCaseMouseMouse Pad
OCZ 600W Generic Junk Logitech MX400 Generic Junk 
Audio
SBL 5.1 
  hide details  
Reply
Current Rig
(14 items)
 
  
CPUMotherboardGraphicsRAM
FX-8350 4.6GHz@1.44v GA-990FXA-UD3 R4.0 HD 7950 (1100/1450) 8G Muskin DDR3 1866@8CLS 
Hard DriveOptical DriveOSMonitor
1TB WD LiteOn DVD-RW DL Linux/Windows 19" Phillips TV 1080p 
PowerCaseMouseMouse Pad
OCZ 600W Generic Junk Logitech MX400 Generic Junk 
Audio
SBL 5.1 
  hide details  
Reply
post #6 of 11
Quote:
Originally Posted by lloyd mcclendon View Post

it sounds like a bug with whatever DE / WM you are using. Not a surprise at all considering you said "ubuntu". Check in their bug tracker for some other reports, surely others are experiencing the same thing. My suggestion would be to uninstall whatever is unstable and install a real window manager such as fluxbox.

OP said it happens in Unity & Gnome Shell. This at least rules out the shell, and points the finger at Gnome (or Xorg, but as it's only some components, I'd pick Gnome). Suggesting another WM isn't that helpful, especially Fluxbox considering OP is using Unity (talk about poles apart!!!)
Little Beast
(12 items)
 
Black 'n' blue II
(15 items)
 
 
CPUGraphicsRAMHard Drive
Intel Core i7-4710MQ Nvidia Geforce GTX860M 2GB 16GB Kingston DDR3 1600MHz 240Gb Silicon Power S55/S60 SSD 
Hard DriveOSOSMonitor
1Tb Toshiba HDD 5400rpm Windows 8.1 Linux Mint 18 17.3" LED 1920x1080 
CaseMouseMouse PadAudio
PCSpecialist Optimus V ST17-860 Logitech MX518 Steelseries QcK Creative HS800 Fatal1ty 
CPUMotherboardGraphicsRAM
Core i7 860 @ 1.25V MSI P55-GD65 Xpertvision Radeon HD4850 4GB G.Skill Ripjaw 
Hard DriveOptical DriveCoolingOS
150Gb Velociraptor & 1Tb WD Caviar Black Opticon Lightscribe DVD-RW DL Noctua NH-U12P SE2 Vista Home Premium x64 
MonitorKeyboardPowerCase
Hyundai BlueH H224W 22" LCD Saitek Eclipse II Thermaltake Purepower RX 550 Galaxy III 
Mouse
Patuoxun optical gaming mouse 3200dpi 
  hide details  
Reply
Little Beast
(12 items)
 
Black 'n' blue II
(15 items)
 
 
CPUGraphicsRAMHard Drive
Intel Core i7-4710MQ Nvidia Geforce GTX860M 2GB 16GB Kingston DDR3 1600MHz 240Gb Silicon Power S55/S60 SSD 
Hard DriveOSOSMonitor
1Tb Toshiba HDD 5400rpm Windows 8.1 Linux Mint 18 17.3" LED 1920x1080 
CaseMouseMouse PadAudio
PCSpecialist Optimus V ST17-860 Logitech MX518 Steelseries QcK Creative HS800 Fatal1ty 
CPUMotherboardGraphicsRAM
Core i7 860 @ 1.25V MSI P55-GD65 Xpertvision Radeon HD4850 4GB G.Skill Ripjaw 
Hard DriveOptical DriveCoolingOS
150Gb Velociraptor & 1Tb WD Caviar Black Opticon Lightscribe DVD-RW DL Noctua NH-U12P SE2 Vista Home Premium x64 
MonitorKeyboardPowerCase
Hyundai BlueH H224W 22" LCD Saitek Eclipse II Thermaltake Purepower RX 550 Galaxy III 
Mouse
Patuoxun optical gaming mouse 3200dpi 
  hide details  
Reply
post #7 of 11
Quote:
Originally Posted by mushroomboy View Post

If he drops into console he should run "TOP" and tell us what's running (pic?). I wouldn't kill xorg though, I'd run:
sudo service lightdm restart
If that won't restart Xorg you might just have to run the restart command. I just use the shortcut, if your in TTYL (console) you can always ctrl+alt+del for a reboot. It's quicker than typing reboot! lol

sudo pkill X is easily quicker and more continent than a full system reboot (and fewer keystrokes than the service restart - which might not work anyway depending on how badly lightdm has locked up)

Though the [ctl]+[del]+[bk-sp] might work the same as pkill X (I can't even remember the last time I needed to use it)
Edited by Plan9 - 5/10/12 at 5:01am
post #8 of 11
Quote:
Suggesting another WM is very helpful, especially Fluxbox considering OP is using THE WILDY UNSTABLE Unity (talk about poles apart!!!)

fixed wink.gifthumb.gif
stable again
(25 items)
 
  
CPUCPUMotherboardGraphics
E5-2687W E5-2687W ASUS Z9PED8-WS EVGA GTX 570 (Linux host) 
GraphicsRAMHard DriveHard Drive
EVGA GTX 970 FTW (win7 guest) 64GB G.SKILL 2133 2x Crucial M4 256GB raid1 4x 3TB raid 10 
CoolingCoolingCoolingCooling
2x Apogee HD  2x RX 480 2x MCP 655 RP-452x2 rev2 (new) 
CoolingCoolingOSOS
16x Cougar Turbine CFT12SB4 (new) EK FC 580 Gentoo (host) Gentoo (x23 guests) 
OSMonitorMonitorPower
windows 7 (guest w/ vfio-pci) Viewsonic 23" 1080P Viewsonic 19" Antec HCP Platinum 1000 (new) 
CaseOtherOther
Case Labs TH10 (still the best ever) 2x Lamptron FC-5 IOGEAR 2 way DVI KVM Switch 
  hide details  
Reply
stable again
(25 items)
 
  
CPUCPUMotherboardGraphics
E5-2687W E5-2687W ASUS Z9PED8-WS EVGA GTX 570 (Linux host) 
GraphicsRAMHard DriveHard Drive
EVGA GTX 970 FTW (win7 guest) 64GB G.SKILL 2133 2x Crucial M4 256GB raid1 4x 3TB raid 10 
CoolingCoolingCoolingCooling
2x Apogee HD  2x RX 480 2x MCP 655 RP-452x2 rev2 (new) 
CoolingCoolingOSOS
16x Cougar Turbine CFT12SB4 (new) EK FC 580 Gentoo (host) Gentoo (x23 guests) 
OSMonitorMonitorPower
windows 7 (guest w/ vfio-pci) Viewsonic 23" 1080P Viewsonic 19" Antec HCP Platinum 1000 (new) 
CaseOtherOther
Case Labs TH10 (still the best ever) 2x Lamptron FC-5 IOGEAR 2 way DVI KVM Switch 
  hide details  
Reply
post #9 of 11
Personally I think he should ditch Xorg entirely and just use Bash. It's the only way to be sure.
post #10 of 11
agreed.

almost thumb.gif
stable again
(25 items)
 
  
CPUCPUMotherboardGraphics
E5-2687W E5-2687W ASUS Z9PED8-WS EVGA GTX 570 (Linux host) 
GraphicsRAMHard DriveHard Drive
EVGA GTX 970 FTW (win7 guest) 64GB G.SKILL 2133 2x Crucial M4 256GB raid1 4x 3TB raid 10 
CoolingCoolingCoolingCooling
2x Apogee HD  2x RX 480 2x MCP 655 RP-452x2 rev2 (new) 
CoolingCoolingOSOS
16x Cougar Turbine CFT12SB4 (new) EK FC 580 Gentoo (host) Gentoo (x23 guests) 
OSMonitorMonitorPower
windows 7 (guest w/ vfio-pci) Viewsonic 23" 1080P Viewsonic 19" Antec HCP Platinum 1000 (new) 
CaseOtherOther
Case Labs TH10 (still the best ever) 2x Lamptron FC-5 IOGEAR 2 way DVI KVM Switch 
  hide details  
Reply
stable again
(25 items)
 
  
CPUCPUMotherboardGraphics
E5-2687W E5-2687W ASUS Z9PED8-WS EVGA GTX 570 (Linux host) 
GraphicsRAMHard DriveHard Drive
EVGA GTX 970 FTW (win7 guest) 64GB G.SKILL 2133 2x Crucial M4 256GB raid1 4x 3TB raid 10 
CoolingCoolingCoolingCooling
2x Apogee HD  2x RX 480 2x MCP 655 RP-452x2 rev2 (new) 
CoolingCoolingOSOS
16x Cougar Turbine CFT12SB4 (new) EK FC 580 Gentoo (host) Gentoo (x23 guests) 
OSMonitorMonitorPower
windows 7 (guest w/ vfio-pci) Viewsonic 23" 1080P Viewsonic 19" Antec HCP Platinum 1000 (new) 
CaseOtherOther
Case Labs TH10 (still the best ever) 2x Lamptron FC-5 IOGEAR 2 way DVI KVM Switch 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Linux, Unix
Overclock.net › Forums › Software, Programming and Coding › Operating Systems › Linux, Unix › Curious freezingish problem in Ubuntu