post #1 of 1
Thread Starter 
Alright, first of all, I'm sorry if this does not fit in this category, but I looked all down the list, and I could not see my way out of the correct place to put it X\ So I'm just gonna drop it inhere!

Don't laugh, but I've had the same GPU(and computer in general really) For over 2 years, just cause it's been alittle rough financially lately <_<'

In either case, despite its age, my computer has not had a single glitch, or bug, or failing hardware! It has been shipped across the atlantic in a cardboard box and survived, despite getting alittle beaten up, it still continued to work flawlessly, and has been since the day I bought it.

It should be noted that I have an ATI Radeon HD 4300/4500 series GPU.

Then, about 4 days ago or so, Catalyst Control Center pops up saying there's a new display driver update, and I of course install it.

The next thing I know, ALL of my games start acting wierd =\ I started Portal 2, and it was like, the entire world was COVERED in little triangular holes...Like holes! In everything! It was like the whole world had turned into swiss cheese -_-'

I JUST got Portal 2, so I don't really think much of it, because I mean, it's not the first buggy game since my GPU and comp in general are so old. But then I try out games I've played for as long as 8 years!

322

322

322


WoW is just one game, but it's also other games.


Star Trek Online: Exact same issue, large holes in the world.
Skyrim: Exact same issue but to a much greater degree! TREMENDOUS bugs in this one, hole in EVERYTHING, I can't even see my characters face!

Pretty much all the games I have with a 3D world in it has this issue <_< And I have no idea how to fix it!

Things I've tried:

Going to amd.com and finding an older driver. This didn't work, seeing as the ONLY available download for my GPU is the Catalyst Control Center <_<<br />
Search Catalyst Control Center. It's just a worthless client, it does absolutely nothing but remind me of new updates. I can't even find a way to downgrade in case of bugs or glitches like this!

Sending a support request email to AMD. I did that the same day that I got this issue, and I have yet to get a response from them.

And now, asking you guys, since official sources are obviously worthless, I turn to the community I rely on alittle more closely...


IF ANYONE has ideas on how to fix this, I'd be incredibly grateful! Remember, it all started after I downloaded the new display driver, I personally believe that if I downgraded to my old one, the issue would be fixed, but I have no idea how to! T-T

Any help at all is greatly appreciated! Thank you for reading my plead-for-help wall of text <3
Saphstem
(13 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core 2 Quad Q8200 Unknown Radeon HD 4350 8GB DDR3 
Hard DriveMonitorKeyboardMouse
750GB HP w2338h HD Merc Stealth Razer Naga MMOG 
Mouse Pad
None 
  hide details  
Reply
Saphstem
(13 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core 2 Quad Q8200 Unknown Radeon HD 4350 8GB DDR3 
Hard DriveMonitorKeyboardMouse
750GB HP w2338h HD Merc Stealth Razer Naga MMOG 
Mouse Pad
None 
  hide details  
Reply