Overclock.net › Forums › Cooling › Water Cooling › MCP35X pump died?
New Posts  All Forums:Forum Nav:

MCP35X pump died?

post #1 of 3
Thread Starter 
MCP35X pump ran just fine, setup a new loop leak tested for 12 HR. Hooked up the pump and everything into the actual computer ready to go turned PC on, temps started to skyrocket and pump does not even attempt to turn on. Tried multiple power supply and molex connectors.
What can I do?
post #2 of 3
Have you ever dissemble the pump for modification? Upgraded tops, housings, etc? If not your probably still under Swiftech warranty.
You know your suppose to leak test without the computer running, right? You use the paperclip trick to get your PSU running without the rest of your components.

Or are you saying it worked before the leak test and now it doesn't? hm
Neutrality
(15 items)
 
  
CPUMotherboardGraphicsRAM
Intel 4670K @ 4.5 Gigabyte GA-Z87X-UD4H MSI 290X Gaming 2x4GB Samsung 1.35v Low Profile 
Hard DriveCoolingOSMonitor
2x OZC Arc 100 240GB, 2x Western Digital Caviar... EK Supremacy EVO + EK Thermosphere + Alphacool ... Windows 10 24" Asus VG248QE 144hz 
KeyboardPowerCaseMouse
CM Quickfire Pro MX Black EVGA 1050GS Modified HAF 932 Zowie FK1 
AudioAudio
Audio Technica AD700 Creative Sound Blaster X-Fi Titanium HD 
  hide details  
Reply
Neutrality
(15 items)
 
  
CPUMotherboardGraphicsRAM
Intel 4670K @ 4.5 Gigabyte GA-Z87X-UD4H MSI 290X Gaming 2x4GB Samsung 1.35v Low Profile 
Hard DriveCoolingOSMonitor
2x OZC Arc 100 240GB, 2x Western Digital Caviar... EK Supremacy EVO + EK Thermosphere + Alphacool ... Windows 10 24" Asus VG248QE 144hz 
KeyboardPowerCaseMouse
CM Quickfire Pro MX Black EVGA 1050GS Modified HAF 932 Zowie FK1 
AudioAudio
Audio Technica AD700 Creative Sound Blaster X-Fi Titanium HD 
  hide details  
Reply
post #3 of 3
Thread Starter 
It worked with the paper clip trick the whole 12 hr leak test. I moved everything over then the pump fails to start.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Water Cooling
Overclock.net › Forums › Cooling › Water Cooling › MCP35X pump died?