Overclock.net › Forums › Graphics Cards › NVIDIA › Multi-monitor Clocks (Kepler owners' input requested)
New Posts  All Forums:Forum Nav:

Multi-monitor Clocks (Kepler owners' input requested)

post #1 of 7
Thread Starter 
I remember looking into this way back when I got a GTX 480 around launch; what I found at the time was that Nvidia set up their drivers to go into full 3D clocks (P0 state) when more than one monitor was connected. I found it excessive, but I soon dropped the second monitor so the idea faded. Now that I'm back to two, I have questions.

1. Does anyone know of a workaround to prevent this? Possibly putting the GPU into P8 instead of P0 so at least it's only marginally higher clocked.

2. Are Kepler cards also going into P0 when more than one monitor is connected? Or have they implemented some proper power-saving?

3. Just for testing, I went into NVCP and disabled the second monitor. My clocks dropped to P8, then P12, but then the following happened. Any reason why it would keep... "oscillating"?

XQyAZ.png
post #2 of 7
Thread Starter 
Five day bump! tongue.gif
post #3 of 7
Thread Starter 
Three week bump D:
post #4 of 7
I don't have a Kepler card, but I do have 580s and they haven't behaved this way in a long time. I have two monitors plugged into my top card right now and it downclocks just fine along with the 2nd 580 with only a single monitor plugged into it. I'm pretty sure they resolved this in the drivers years ago. I do remember when the 480s came out it happened, but it's been a long time. Hopefully someone with a Kelper card can comment, but I'm almost positive your card will downclock just fine. Just make sure you have Power Management Mode in the Nvidia control panel set to adaptive.

Edit: By the way I currently only have 2x 580s in my rig even though my sig says I have 3, I sold one and have to update it. Just wanted to avoid any confusion.
Edited by willdearborn - 6/4/12 at 9:52pm
    
CPUMotherboardGraphicsRAM
Intel Core i7 3820 ASUS Rampage IV Extreme 3x EVGA GTX 780 Ti 16GB Corsair Dominator 
Hard DriveMonitorPowerCase
Intel 320 SSD 3x HP LP3065 30" LCDs in Surround 7680x1600 Corsair AX1200 Corsair 800D 
Audio
Creative Titanium HD 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
Intel Core i7 3820 ASUS Rampage IV Extreme 3x EVGA GTX 780 Ti 16GB Corsair Dominator 
Hard DriveMonitorPowerCase
Intel 320 SSD 3x HP LP3065 30" LCDs in Surround 7680x1600 Corsair AX1200 Corsair 800D 
Audio
Creative Titanium HD 
  hide details  
Reply
post #5 of 7
1.
Nvidia Inspector
Force Idle.bat
nvidiaInspector.exe -forcepstate:0,8
Default.bat
nvidiaInspector.exe -forcepstate:0,16
You can also adjust the clock speeds for multimonitor mode instead (possibly voltage too?). Export your settings and add the required command line entries to your batch files.

2. Using default settings and running 120hz 1680x1050 + 60hz 1920x1080 - my GTX670 stays in P8 idle mode.

3. No idea. Whenever I play video or some flash advert loads on a webpage my card goes into P0 mode.
My System
(17 items)
 
  
CPUGraphicsMonitorKeyboard
3570k @ 4.4ghz Gigabyte GTX670 @ 1300/1700 Sony FW900 + Asus VG236he CM QuickFire Red - PBT white keycaps 
MouseMouse PadAudioOther
g4Adder in progress Zowie P-TF Onkyo SE-90 Marantz PM7003 amplifier 
OtherOther
Wharfedale 10.1 speakers Sennheiser HD595 
  hide details  
Reply
My System
(17 items)
 
  
CPUGraphicsMonitorKeyboard
3570k @ 4.4ghz Gigabyte GTX670 @ 1300/1700 Sony FW900 + Asus VG236he CM QuickFire Red - PBT white keycaps 
MouseMouse PadAudioOther
g4Adder in progress Zowie P-TF Onkyo SE-90 Marantz PM7003 amplifier 
OtherOther
Wharfedale 10.1 speakers Sennheiser HD595 
  hide details  
Reply
post #6 of 7
Thread Starter 
Quote:
Originally Posted by willdearborn View Post

I don't have a Kepler card, but I do have 580s and they haven't behaved this way in a long time. I have two monitors plugged into my top card right now and it downclocks just fine along with the 2nd 580 with only a single monitor plugged into it. I'm pretty sure they resolved this in the drivers years ago. I do remember when the 480s came out it happened, but it's been a long time. Hopefully someone with a Kelper card can comment, but I'm almost positive your card will downclock just fine. Just make sure you have Power Management Mode in the Nvidia control panel set to adaptive.

Edit: By the way I currently only have 2x 580s in my rig even though my sig says I have 3, I sold one and have to update it. Just wanted to avoid any confusion.

Hmm. I've only had this second monitor for a few months, but it has acted this way through multiple driver updates. I always kept the setting at performance, since they were "3D" settings; I'll have to try it again and see if anything changes.

Quote:
Originally Posted by whybother View Post

1.
Nvidia Inspector
Force Idle.bat
nvidiaInspector.exe -forcepstate:0,8
Default.bat
nvidiaInspector.exe -forcepstate:0,16
You can also adjust the clock speeds for multimonitor mode instead (possibly voltage too?). Export your settings and add the required command line entries to your batch files.

2. Using default settings and running 120hz 1680x1050 + 60hz 1920x1080 - my GTX670 stays in P8 idle mode.

3. No idea. Whenever I play video or some flash advert loads on a webpage my card goes into P0 mode.

Thanks for the input. It seems like that flag simply makes only P0 and P8 available. If my card wants to default to 0, would it make any difference? Or am I missing something?

Also, I've used Inspector before, but I'm not familiar with it. Do you know of any resources to allow me to do what you're describing at the end of 1.?
Edited by EfemaN - 6/5/12 at 4:46pm
post #7 of 7
Thread Starter 
Setting the performance to adaptive doesn't change anything. And I don't think it's anything triggering P0, as disabling the second monitor allows clocks to drop pretty quick. I'm making somewhat of a big deal out of this simply because there's a difference of 10+ Celcius between the P0 idle and P12 idle. And Minnesota has been HOT lately...

EDIT: Seems the commands that whybother posted above work for forcing the GPU into a lower p-state, but that creates the annoyance of having to remember to run the defaults before playing a game. I'd like to see if there's a permanent solution, especially since willdearborn is not having the auto-P0 behavior I am seeing.
Edited by EfemaN - 6/7/12 at 9:21pm
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: NVIDIA
Overclock.net › Forums › Graphics Cards › NVIDIA › Multi-monitor Clocks (Kepler owners' input requested)