Overclock.net › Forums › Video Games › PC Gaming › Diablo 3 Performance Issues With a GTX670?
New Posts  All Forums:Forum Nav:

Diablo 3 Performance Issues With a GTX670? - Page 2

post #11 of 35
Thread Starter 
Quote:
Originally Posted by Penryn View Post

Turn on Vsync in the game options. It fixed all performance issues I was having on my 7970. The game was playing incredibly choppy even though I was getting 100fps. Turned on Vsync and all my problems went away.

I do play with vsync, but still have tons of issues. Turning vsync off makes it 1000x worse though.

Gear mentioned in this thread:

post #12 of 35
Quote:
Originally Posted by waylo88 View Post

I do play with vsync, but still have tons of issues. Turning vsync off makes it 1000x worse though.

Did you try playing fullscreen windowed mode?
Luminescence v1.1
(16 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i7 2600K [4.7Ghz @ 1.3v 24/7] Asus P8P67 Pro EVGA GTX 780 8GB Corsair XMS3/Vengeance Low Profile DDR3 1600C9 
Hard DriveOptical DriveCoolingOS
2x Spinpoint 1TB [Raid 0] Memorex 24x DVD +/- RW XSPC Rasa RS240 Windows 7 x64 Ultimate 
MonitorKeyboardPowerCase
Dell U2412M [NVidia Surround] Razer Lycosa Thermaltake TR2 RX 750W NZXT Switch 810 
MouseMouse PadAudioAudio
Razer Naga WoW Cataclysm Collectors Edition Pad Realtek onboard and Aiwa 5.1 Surround Creative Sound Blaster Tactic 3D Wrath 
  hide details  
Reply
Luminescence v1.1
(16 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i7 2600K [4.7Ghz @ 1.3v 24/7] Asus P8P67 Pro EVGA GTX 780 8GB Corsair XMS3/Vengeance Low Profile DDR3 1600C9 
Hard DriveOptical DriveCoolingOS
2x Spinpoint 1TB [Raid 0] Memorex 24x DVD +/- RW XSPC Rasa RS240 Windows 7 x64 Ultimate 
MonitorKeyboardPowerCase
Dell U2412M [NVidia Surround] Razer Lycosa Thermaltake TR2 RX 750W NZXT Switch 810 
MouseMouse PadAudioAudio
Razer Naga WoW Cataclysm Collectors Edition Pad Realtek onboard and Aiwa 5.1 Surround Creative Sound Blaster Tactic 3D Wrath 
  hide details  
Reply
post #13 of 35
Thread Starter 
Quote:
Originally Posted by Penryn View Post

Did you try playing fullscreen windowed mode?

Yup.
post #14 of 35
Quote:
Originally Posted by waylo88 View Post

Yup.

Do you have any conflicting settings in NVidia control panel or is it set to application controlled for D3?
Luminescence v1.1
(16 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i7 2600K [4.7Ghz @ 1.3v 24/7] Asus P8P67 Pro EVGA GTX 780 8GB Corsair XMS3/Vengeance Low Profile DDR3 1600C9 
Hard DriveOptical DriveCoolingOS
2x Spinpoint 1TB [Raid 0] Memorex 24x DVD +/- RW XSPC Rasa RS240 Windows 7 x64 Ultimate 
MonitorKeyboardPowerCase
Dell U2412M [NVidia Surround] Razer Lycosa Thermaltake TR2 RX 750W NZXT Switch 810 
MouseMouse PadAudioAudio
Razer Naga WoW Cataclysm Collectors Edition Pad Realtek onboard and Aiwa 5.1 Surround Creative Sound Blaster Tactic 3D Wrath 
  hide details  
Reply
Luminescence v1.1
(16 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i7 2600K [4.7Ghz @ 1.3v 24/7] Asus P8P67 Pro EVGA GTX 780 8GB Corsair XMS3/Vengeance Low Profile DDR3 1600C9 
Hard DriveOptical DriveCoolingOS
2x Spinpoint 1TB [Raid 0] Memorex 24x DVD +/- RW XSPC Rasa RS240 Windows 7 x64 Ultimate 
MonitorKeyboardPowerCase
Dell U2412M [NVidia Surround] Razer Lycosa Thermaltake TR2 RX 750W NZXT Switch 810 
MouseMouse PadAudioAudio
Razer Naga WoW Cataclysm Collectors Edition Pad Realtek onboard and Aiwa 5.1 Surround Creative Sound Blaster Tactic 3D Wrath 
  hide details  
Reply
post #15 of 35
Thread Starter 
Quote:
Originally Posted by Penryn View Post

Do you have any conflicting settings in NVidia control panel or is it set to application controlled for D3?

All app controlled. I did a fresh install too two days ago since I figured maybe the drivers got messed up when switching from my 580 to my 670. I'm pretty much just waiting for some patches and some new drivers now. Cant do anything but wait.
post #16 of 35
Quote:
Originally Posted by waylo88 View Post

All app controlled. I did a fresh install too two days ago since I figured maybe the drivers got messed up when switching from my 580 to my 670. I'm pretty much just waiting for some patches and some new drivers now. Cant do anything but wait.

Hmm seems really odd. On my m14x the game plays decently with 296.10 drivers. The performance of the game does leave a lot to be desired though. Knowing blizzard you may be waiting a while for them to do anything but hopefully NVidia gets your issue taken care of.
Luminescence v1.1
(16 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i7 2600K [4.7Ghz @ 1.3v 24/7] Asus P8P67 Pro EVGA GTX 780 8GB Corsair XMS3/Vengeance Low Profile DDR3 1600C9 
Hard DriveOptical DriveCoolingOS
2x Spinpoint 1TB [Raid 0] Memorex 24x DVD +/- RW XSPC Rasa RS240 Windows 7 x64 Ultimate 
MonitorKeyboardPowerCase
Dell U2412M [NVidia Surround] Razer Lycosa Thermaltake TR2 RX 750W NZXT Switch 810 
MouseMouse PadAudioAudio
Razer Naga WoW Cataclysm Collectors Edition Pad Realtek onboard and Aiwa 5.1 Surround Creative Sound Blaster Tactic 3D Wrath 
  hide details  
Reply
Luminescence v1.1
(16 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i7 2600K [4.7Ghz @ 1.3v 24/7] Asus P8P67 Pro EVGA GTX 780 8GB Corsair XMS3/Vengeance Low Profile DDR3 1600C9 
Hard DriveOptical DriveCoolingOS
2x Spinpoint 1TB [Raid 0] Memorex 24x DVD +/- RW XSPC Rasa RS240 Windows 7 x64 Ultimate 
MonitorKeyboardPowerCase
Dell U2412M [NVidia Surround] Razer Lycosa Thermaltake TR2 RX 750W NZXT Switch 810 
MouseMouse PadAudioAudio
Razer Naga WoW Cataclysm Collectors Edition Pad Realtek onboard and Aiwa 5.1 Surround Creative Sound Blaster Tactic 3D Wrath 
  hide details  
Reply
post #17 of 35
I think it is a game (read server) issue. Buddy and I were grinding away and he says "let me initiate on this next group", as soon as he cast his first skill we both dropped to <1 fps and wound up dead. Me with a 7970 and him with a gtx 460.

Either the servers, or he jynxed us.
See Pee Yoo
(17 items)
 
Lian Mi
(12 items)
 
 
CPUMotherboardGraphicsRAM
2500k asrock extreme4 evga gtx 970 SC acx 1.0 corsair vengeance  
Hard DriveHard DriveOptical DriveCooling
Crucial m3 seagate green lg dvdrw Noctua D14 
OSMonitorMonitorPower
win 7 64bit 2 x 1920 x 1080p (ASUS and LG) xl2420te ocz zx 1000w 
CaseMouseMouse PadAudio
haf bx g600 / / Roccat Savu Puretrak Talent Soundblaster Z 
Audio
sennheiser hd558 
CPUMotherboardRAMHard Drive
celereon g1610 g1 sniper m3 parema seagate barracuda 
Optical DriveOSMonitorPower
dvdrw windows vista vizio 3d tv rosewill green 530 
CaseMouse
lian li pc v354b logitech g300 
  hide details  
Reply
See Pee Yoo
(17 items)
 
Lian Mi
(12 items)
 
 
CPUMotherboardGraphicsRAM
2500k asrock extreme4 evga gtx 970 SC acx 1.0 corsair vengeance  
Hard DriveHard DriveOptical DriveCooling
Crucial m3 seagate green lg dvdrw Noctua D14 
OSMonitorMonitorPower
win 7 64bit 2 x 1920 x 1080p (ASUS and LG) xl2420te ocz zx 1000w 
CaseMouseMouse PadAudio
haf bx g600 / / Roccat Savu Puretrak Talent Soundblaster Z 
Audio
sennheiser hd558 
CPUMotherboardRAMHard Drive
celereon g1610 g1 sniper m3 parema seagate barracuda 
Optical DriveOSMonitorPower
dvdrw windows vista vizio 3d tv rosewill green 530 
CaseMouse
lian li pc v354b logitech g300 
  hide details  
Reply
post #18 of 35
Wonder if it has something to do with the latest drivers. I'm still using 29x.xx drivers with my gtx460. No vsync, no issues.

Sent from my Galaxy SII using Tapatalk 2
Red and Black
(15 items)
 
  
CPUMotherboardGraphicsRAM
Core i5 760 Asus Maximus III gene EVGA GTX 460 1GB 8GB G.Skill Sniper 1600 
Hard DriveHard DriveCoolingMonitor
128GB Crucial M4 640gb WD Caviar Black TT Silver Arrow Samsung T240HD 
Power
Seasonic X-750 
  hide details  
Reply
Red and Black
(15 items)
 
  
CPUMotherboardGraphicsRAM
Core i5 760 Asus Maximus III gene EVGA GTX 460 1GB 8GB G.Skill Sniper 1600 
Hard DriveHard DriveCoolingMonitor
128GB Crucial M4 640gb WD Caviar Black TT Silver Arrow Samsung T240HD 
Power
Seasonic X-750 
  hide details  
Reply
post #19 of 35

I have the same issue with a 460M

 

the game runs smooth as butter at 60fps than becomes 10 fps and than up again.

  
Reply
  
Reply
post #20 of 35
Thread Starter 
Quote:
Originally Posted by arctia View Post

Wonder if it has something to do with the latest drivers. I'm still using 29x.xx drivers with my gtx460. No vsync, no issues.
Sent from my Galaxy SII using Tapatalk 2

This is what I'm leaning towards. The 600 series drivers are really just the latest beta drivers. I'm hoping when nVidia releases some real drivers for their new cards these issues will be alleviated. Now that I think about it though, I was also having the same problems with my 580, so who knows. Regardless, whether its game or driver related, its annoying playing the game on the lowest settings and still having performance issues when using my sig rig. Unacceptable.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: PC Gaming

Gear mentioned in this thread:

Overclock.net › Forums › Video Games › PC Gaming › Diablo 3 Performance Issues With a GTX670?