Overclock.net › Forums › Video Games › PC Gaming › Civ V crashes when I try to launch DX10/DX11
New Posts  All Forums:Forum Nav:

Civ V crashes when I try to launch DX10/DX11

post #1 of 7
Thread Starter 
I'm using my sig rig to play CIV V with the latest expansion and the game would even go past the 2K Games logo and just crash. When I launch the game in DX9 mode it's completely fine.
Monkey_Butt
(15 items)
 
   
CPUMotherboardGraphicsRAM
Intel i7-2700k ASRock Z77E-ITX EVGA GTX 670 FTW Samsung 8GB DDR3 1600 Low Voltage 
Hard DriveHard DriveOptical DriveCooling
Plextor M3 128GB Western Digital Caviar Black  Asus 24X Corsair H100 
OSMonitorKeyboardPower
Windows 8 Pro 64-Bit Yamakasi Catleap 27" IPS Razer Black Widow Seasonic X650 
CaseMouseMouse Pad
BitFenix Prodigy White SteelSeries Sensei Raw (Rubber) Artisan Hein  
CPUMotherboardGraphicsGraphics
i5-2500K Oc'd 5.0Ghz @1.416v Asus P8P67 Pro B3 Rev. 3.1 MSI GTX 560 Ti Twin Frozr II MSI GTX 560 Ti TFII  
RAMHard DriveHard DriveHard Drive
G. Skill RipJaws X F3-12800CL8D-8GBXM OCZ Agility 3 60gb Western Digital Caviar Blue 500GB 6.0gb/s Western Digital Caviar Blue 500GB 6.0gb/s 
Hard DriveOptical DriveCoolingOS
Hitachi 500GB 3.0gb/s Lite-On 24x Thermalright Silver Arrow Windows 7 Professional 64-bit 
MonitorMonitorKeyboardPower
Samsung EX2220X Acer 23" LED Razer Blackwidow Seasonic X750 
CaseMouseMouse PadAudio
NZXT Phantom White with Red trim Logitech G400 HIEN SOFT M Japan black | SAMURAI Logitech Z506 
  hide details  
Reply
Monkey_Butt
(15 items)
 
   
CPUMotherboardGraphicsRAM
Intel i7-2700k ASRock Z77E-ITX EVGA GTX 670 FTW Samsung 8GB DDR3 1600 Low Voltage 
Hard DriveHard DriveOptical DriveCooling
Plextor M3 128GB Western Digital Caviar Black  Asus 24X Corsair H100 
OSMonitorKeyboardPower
Windows 8 Pro 64-Bit Yamakasi Catleap 27" IPS Razer Black Widow Seasonic X650 
CaseMouseMouse Pad
BitFenix Prodigy White SteelSeries Sensei Raw (Rubber) Artisan Hein  
CPUMotherboardGraphicsGraphics
i5-2500K Oc'd 5.0Ghz @1.416v Asus P8P67 Pro B3 Rev. 3.1 MSI GTX 560 Ti Twin Frozr II MSI GTX 560 Ti TFII  
RAMHard DriveHard DriveHard Drive
G. Skill RipJaws X F3-12800CL8D-8GBXM OCZ Agility 3 60gb Western Digital Caviar Blue 500GB 6.0gb/s Western Digital Caviar Blue 500GB 6.0gb/s 
Hard DriveOptical DriveCoolingOS
Hitachi 500GB 3.0gb/s Lite-On 24x Thermalright Silver Arrow Windows 7 Professional 64-bit 
MonitorMonitorKeyboardPower
Samsung EX2220X Acer 23" LED Razer Blackwidow Seasonic X750 
CaseMouseMouse PadAudio
NZXT Phantom White with Red trim Logitech G400 HIEN SOFT M Japan black | SAMURAI Logitech Z506 
  hide details  
Reply
post #2 of 7
I am having the exact same problem.
This only started happening when I installed the latest NVIDIA Beta GeForce drivers - 304.48

So unless anyone has a temporary solution, looks like I'll have to either revert back or wait for a stable driver release before playing Civ 5 in DX10/11 again D:
post #3 of 7
This is crazy but it may be your CPU overclock. I had the same exact problem you did but lowered it a bit and it worked fine. Just try your stock clocks and see if you can get past the logo. Weird as I never had any other problems in other games with my high overclock.
post #4 of 7
This is a known issue with the 304.48 drivers. It's likely to be fixed in the upcoming WHQL. In the meantime the only solutions are to either roll back or temporarily play in DX9 mode.
post #5 of 7
Thread Starter 
awww no wonder, I am thinking it might be drivers... ehh, I just wait for the next drivers, Nvidia updates frequently so I'll just wait it out. I find it very strange that a driver update will completely screw up dx11 rendering game mode.
Monkey_Butt
(15 items)
 
   
CPUMotherboardGraphicsRAM
Intel i7-2700k ASRock Z77E-ITX EVGA GTX 670 FTW Samsung 8GB DDR3 1600 Low Voltage 
Hard DriveHard DriveOptical DriveCooling
Plextor M3 128GB Western Digital Caviar Black  Asus 24X Corsair H100 
OSMonitorKeyboardPower
Windows 8 Pro 64-Bit Yamakasi Catleap 27" IPS Razer Black Widow Seasonic X650 
CaseMouseMouse Pad
BitFenix Prodigy White SteelSeries Sensei Raw (Rubber) Artisan Hein  
CPUMotherboardGraphicsGraphics
i5-2500K Oc'd 5.0Ghz @1.416v Asus P8P67 Pro B3 Rev. 3.1 MSI GTX 560 Ti Twin Frozr II MSI GTX 560 Ti TFII  
RAMHard DriveHard DriveHard Drive
G. Skill RipJaws X F3-12800CL8D-8GBXM OCZ Agility 3 60gb Western Digital Caviar Blue 500GB 6.0gb/s Western Digital Caviar Blue 500GB 6.0gb/s 
Hard DriveOptical DriveCoolingOS
Hitachi 500GB 3.0gb/s Lite-On 24x Thermalright Silver Arrow Windows 7 Professional 64-bit 
MonitorMonitorKeyboardPower
Samsung EX2220X Acer 23" LED Razer Blackwidow Seasonic X750 
CaseMouseMouse PadAudio
NZXT Phantom White with Red trim Logitech G400 HIEN SOFT M Japan black | SAMURAI Logitech Z506 
  hide details  
Reply
Monkey_Butt
(15 items)
 
   
CPUMotherboardGraphicsRAM
Intel i7-2700k ASRock Z77E-ITX EVGA GTX 670 FTW Samsung 8GB DDR3 1600 Low Voltage 
Hard DriveHard DriveOptical DriveCooling
Plextor M3 128GB Western Digital Caviar Black  Asus 24X Corsair H100 
OSMonitorKeyboardPower
Windows 8 Pro 64-Bit Yamakasi Catleap 27" IPS Razer Black Widow Seasonic X650 
CaseMouseMouse Pad
BitFenix Prodigy White SteelSeries Sensei Raw (Rubber) Artisan Hein  
CPUMotherboardGraphicsGraphics
i5-2500K Oc'd 5.0Ghz @1.416v Asus P8P67 Pro B3 Rev. 3.1 MSI GTX 560 Ti Twin Frozr II MSI GTX 560 Ti TFII  
RAMHard DriveHard DriveHard Drive
G. Skill RipJaws X F3-12800CL8D-8GBXM OCZ Agility 3 60gb Western Digital Caviar Blue 500GB 6.0gb/s Western Digital Caviar Blue 500GB 6.0gb/s 
Hard DriveOptical DriveCoolingOS
Hitachi 500GB 3.0gb/s Lite-On 24x Thermalright Silver Arrow Windows 7 Professional 64-bit 
MonitorMonitorKeyboardPower
Samsung EX2220X Acer 23" LED Razer Blackwidow Seasonic X750 
CaseMouseMouse PadAudio
NZXT Phantom White with Red trim Logitech G400 HIEN SOFT M Japan black | SAMURAI Logitech Z506 
  hide details  
Reply
post #6 of 7
Most DX11 games were unaffected and also showed significant performance gains so it's probably a side effect of whatever they did to improve DX11 performance.
post #7 of 7
If you have the Virtu software on your computer try disabling it to see if that fixes it as that is what fixed it for me.

I have the Virtu MVP version. At first I tried specifically disabling it for Civ 5 but that didn't work. When I disabled both Hyperformance and Virtual VSync in the main performance tab the game was then able to load past the intro movie. I still have the GPU Virtualization option enabled.

On a related note, if you are using any FXAA shaders for Skyrim then Skyrim will also exhibit the same behavior until you disable Virtu MVP for it as well. However with Skyrim I was able to just disable it for the application and not entirely as with Civ 5.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: PC Gaming
Overclock.net › Forums › Video Games › PC Gaming › Civ V crashes when I try to launch DX10/DX11