New Posts  All Forums:Forum Nav:

No Sound??

post #1 of 17
Thread Starter 
Ok so I plugged in my optical cable into the back of my asrock z77 extreme 4 motherboard (the optical out port) and I plugged the other end into my stereo under optical 1. Although, i just fired up battlefield and I have zero sound. What should I do? Ive messed with the volume to see if it was just down low but thats not the case.
post #2 of 17
Thread Starter 
bump
post #3 of 17
Go into the Windows 7 sound control panel. Make sure that s/pdif is showing on list of available playback devices. And if so, make sure that it is checked as the default sound device.
wevs rig
(19 items)
 
  
CPUMotherboardGraphicsRAM
i7 3770K Gigabyte GA-Z77X-UD5H MSI GTX 670 PE OC x2 SLi Team xTreem 16Gb (2x4Gb) DDR3 2400Mhz 
Hard DriveHard DriveHard DriveHard Drive
Crucial C300 128Gb x2 RAID0  SK Hynix SH910 128Gb x2 RAID0 Western Digital Black Edition 1Tb Western Digital Black Edition 640Gb 
Optical DriveOptical DriveCoolingOS
Asus DVD / Bluray LG Bluray / Burner Custom H20 - Swiftech, XSPC Windows 7 Pro x64 
MonitorKeyboardPowerCase
Acer P243Waid Razer Black Widow Ultimate Corsair HX1000 Corsair C70 White Edition 
MouseMouse PadAudio
Razer DeathAdder SteelSeries Creative Soundblaster X-FI Titanium HD 
  hide details  
Reply
wevs rig
(19 items)
 
  
CPUMotherboardGraphicsRAM
i7 3770K Gigabyte GA-Z77X-UD5H MSI GTX 670 PE OC x2 SLi Team xTreem 16Gb (2x4Gb) DDR3 2400Mhz 
Hard DriveHard DriveHard DriveHard Drive
Crucial C300 128Gb x2 RAID0  SK Hynix SH910 128Gb x2 RAID0 Western Digital Black Edition 1Tb Western Digital Black Edition 640Gb 
Optical DriveOptical DriveCoolingOS
Asus DVD / Bluray LG Bluray / Burner Custom H20 - Swiftech, XSPC Windows 7 Pro x64 
MonitorKeyboardPowerCase
Acer P243Waid Razer Black Widow Ultimate Corsair HX1000 Corsair C70 White Edition 
MouseMouse PadAudio
Razer DeathAdder SteelSeries Creative Soundblaster X-FI Titanium HD 
  hide details  
Reply
post #4 of 17
Thread Starter 
Quote:
Originally Posted by wevsspot View Post

Go into the Windows 7 sound control panel. Make sure that s/pdif is showing on list of available playback devices. And if so, make sure that it is checked as the default sound device.


I do not see my stereo listed under sound devices
post #5 of 17
Thread Starter 
ok i restarted the computer, and now "realtek digital output" is listed, I set that as default and now im getting sound from 1 of my 5 speakers..now whats happening?
post #6 of 17
Go back into your Sounds and Audio devices control panel. On one of the tabs you'll see a "speaker settings" option. You need to change that. It's probably set to 5.1 speakers or something similar right now. Change it to "Stereo". That will output the PCM stream to your a/v receiver which in return will decode it to 5.1 channels.
wevs rig
(19 items)
 
  
CPUMotherboardGraphicsRAM
i7 3770K Gigabyte GA-Z77X-UD5H MSI GTX 670 PE OC x2 SLi Team xTreem 16Gb (2x4Gb) DDR3 2400Mhz 
Hard DriveHard DriveHard DriveHard Drive
Crucial C300 128Gb x2 RAID0  SK Hynix SH910 128Gb x2 RAID0 Western Digital Black Edition 1Tb Western Digital Black Edition 640Gb 
Optical DriveOptical DriveCoolingOS
Asus DVD / Bluray LG Bluray / Burner Custom H20 - Swiftech, XSPC Windows 7 Pro x64 
MonitorKeyboardPowerCase
Acer P243Waid Razer Black Widow Ultimate Corsair HX1000 Corsair C70 White Edition 
MouseMouse PadAudio
Razer DeathAdder SteelSeries Creative Soundblaster X-FI Titanium HD 
  hide details  
Reply
wevs rig
(19 items)
 
  
CPUMotherboardGraphicsRAM
i7 3770K Gigabyte GA-Z77X-UD5H MSI GTX 670 PE OC x2 SLi Team xTreem 16Gb (2x4Gb) DDR3 2400Mhz 
Hard DriveHard DriveHard DriveHard Drive
Crucial C300 128Gb x2 RAID0  SK Hynix SH910 128Gb x2 RAID0 Western Digital Black Edition 1Tb Western Digital Black Edition 640Gb 
Optical DriveOptical DriveCoolingOS
Asus DVD / Bluray LG Bluray / Burner Custom H20 - Swiftech, XSPC Windows 7 Pro x64 
MonitorKeyboardPowerCase
Acer P243Waid Razer Black Widow Ultimate Corsair HX1000 Corsair C70 White Edition 
MouseMouse PadAudio
Razer DeathAdder SteelSeries Creative Soundblaster X-FI Titanium HD 
  hide details  
Reply
post #7 of 17
Thread Starter 
Quote:
Originally Posted by wevsspot View Post

Go back into your Sounds and Audio devices control panel. On one of the tabs you'll see a "speaker settings" option. You need to change that. It's probably set to 5.1 speakers or something similar right now. Change it to "Stereo". That will output the PCM stream to your a/v receiver which in return will decode it to 5.1 channels.

I do not see a speaker settings option..is this the right place?

338
post #8 of 17
Thread Starter 
bump
post #9 of 17
Sorry for the late response Fallacy. I had to get on a Windows 7 machine that has an s/pdif output. I see the problem. Setting the speaker configuration isn't an option when using s/pdif. What happens if you set "Speakers" as the default output device and then configure them at "Stereo". Same result as before i.e. no sound?

If the result is no sound do the following;

Once again open up Audio Control panel and select "Playback Devices"
Right Click on "Speakers" and set to "Disabled"
Right Click on "SPDIF OUT' and set "Enabled"
Now Right Click on SPDIF and choose "Properties"
There are four tabs on the top of the pop up box - choose "Supported Formats"
Make sure and check the boxes for "DTS Audio" and "Dolby Digital" The box for Microsoft WMA Pro Audio should not be check marked
Under the sample rate options be sure and check 48 kHZ - none of the other sampling rates should be checked
Click the "Apply" button
Now go to the Advanced Tab
Under the Default Format options choose "2 channel, 24 bit, 48000 Hz Studio Quality"
Click the "Apply" button
Reboot to set and make sure all changes are made
Now check the speaker output. You can also run a speaker configuration test from the audio control panel.
Edited by wevsspot - 6/26/12 at 8:28pm
wevs rig
(19 items)
 
  
CPUMotherboardGraphicsRAM
i7 3770K Gigabyte GA-Z77X-UD5H MSI GTX 670 PE OC x2 SLi Team xTreem 16Gb (2x4Gb) DDR3 2400Mhz 
Hard DriveHard DriveHard DriveHard Drive
Crucial C300 128Gb x2 RAID0  SK Hynix SH910 128Gb x2 RAID0 Western Digital Black Edition 1Tb Western Digital Black Edition 640Gb 
Optical DriveOptical DriveCoolingOS
Asus DVD / Bluray LG Bluray / Burner Custom H20 - Swiftech, XSPC Windows 7 Pro x64 
MonitorKeyboardPowerCase
Acer P243Waid Razer Black Widow Ultimate Corsair HX1000 Corsair C70 White Edition 
MouseMouse PadAudio
Razer DeathAdder SteelSeries Creative Soundblaster X-FI Titanium HD 
  hide details  
Reply
wevs rig
(19 items)
 
  
CPUMotherboardGraphicsRAM
i7 3770K Gigabyte GA-Z77X-UD5H MSI GTX 670 PE OC x2 SLi Team xTreem 16Gb (2x4Gb) DDR3 2400Mhz 
Hard DriveHard DriveHard DriveHard Drive
Crucial C300 128Gb x2 RAID0  SK Hynix SH910 128Gb x2 RAID0 Western Digital Black Edition 1Tb Western Digital Black Edition 640Gb 
Optical DriveOptical DriveCoolingOS
Asus DVD / Bluray LG Bluray / Burner Custom H20 - Swiftech, XSPC Windows 7 Pro x64 
MonitorKeyboardPowerCase
Acer P243Waid Razer Black Widow Ultimate Corsair HX1000 Corsair C70 White Edition 
MouseMouse PadAudio
Razer DeathAdder SteelSeries Creative Soundblaster X-FI Titanium HD 
  hide details  
Reply
post #10 of 17
Thread Starter 
Quote:
Originally Posted by wevsspot View Post

Sorry for the late response Fallacy. I had to get on a Windows 7 machine that has an s/pdif output. I see the problem. Setting the speaker configuration isn't an option when using s/pdif. What happens if you set "Speakers" as the default output device and then configure them at "Stereo". Same result as before i.e. no sound?
If the result is no sound do the following;
Once again open up Audio Control panel and select "Playback Devices"
Right Click on "Speakers" and set to "Disabled"
Right Click on "SPDIF OUT' and set "Enabled"
Now Right Click on SPDIF and choose "Properties"
There are four tabs on the top of the pop up box - choose "Supported Formats"
Make sure and check the boxes for "DTS Audio" and "Dolby Digital" The box for Microsoft WMA Pro Audio should not be check marked
Under the sample rate options be sure and check 48 kHZ - none of the other sampling rates should be checked
Click the "Apply" button
Now go to the Advanced Tab
Under the Default Format options choose "2 channel, 24 bit, 48000 Hz Studio Quality"
Click the "Apply" button
Reboot to set and make sure all changes are made
Now check the speaker output. You can also run a speaker configuration test from the audio control panel.

It says that speakers are not plugged in, look at the picture i posted above frown.gif
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Sound Cards and Computer Audio