Overclock.net › Forums › Graphics Cards › AMD/ATI › Just Upgraded my HD 6950 to HD 7970. Some Issues
New Posts  All Forums:Forum Nav:

Just Upgraded my HD 6950 to HD 7970. Some Issues

post #1 of 10
Thread Starter 
Good evening guys and gals,

I just upgraded my HD6950 to an HD7970. Everything seemed to be ok and removed the old drivers just in case and redownloaded catalyst 12.6, At first glance everything looked great and then I noticed that I had blue snow or blue dots if I stare at the screen in blacks. So I removed the drivers again, reinstalled same thing. I tried a different DVI-D cable, no more Blue Snow! Then I realized the text was blurry with this cable. Needless to say I am upset and find it hard to believe that both of the cables are bad. I will try putting the 6950 back but was wondering if there is anything else to try??? Also I tried the whole clear text thing and nothing.

The problem is my sig rig Stealth Bomber.
post #2 of 10
If you have your old card just pop it in and try. Really, it takes 5 mins. And that will tell you if your card is bad.
post #3 of 10
Thread Starter 
Just did and everything is fine. Man that really sucks. Finally scored an open box GPU on newegg and its ****.
post #4 of 10
Quote:
Originally Posted by iWorkAtStaples View Post

Just did and everything is fine. Man that really sucks. Finally scored an open box GPU on newegg and its ****.

Open box cards are mostly customer returns. they could have been returned because they are faulty . So I suggest you go for a completely new one. return this faulty card and get a refund. buy the Gigabyte HD 7970 Windforce for USD 440. good cooler. excellent price for a 1 Ghz card.

http://www.newegg.com/Product/Product.aspx?Item=N82E16814125413
Fragbox
(14 items)
 
  
CPUMotherboardGraphicsGraphics
Intel Core i5 2400 DH67BL AMD Radeon HD 6900 Series XFX HD 6950 2GB 
RAMRAMHard DriveOptical Drive
Corsair Corsair DDR3 1333 Mhz 2 GB Corsair DDR3 1333 Mhz 2 GB Western Digital Caviar Green SONY DVD-RW AD-7260S 
OSMonitorKeyboardPower
Windows 7 Professional 32 bit BENQ G2420HD Logitech K200 Seasonic VX550 psu 
CaseMouse
ANTEC 200 V2 Logitech mouse 
  hide details  
Reply
Fragbox
(14 items)
 
  
CPUMotherboardGraphicsGraphics
Intel Core i5 2400 DH67BL AMD Radeon HD 6900 Series XFX HD 6950 2GB 
RAMRAMHard DriveOptical Drive
Corsair Corsair DDR3 1333 Mhz 2 GB Corsair DDR3 1333 Mhz 2 GB Western Digital Caviar Green SONY DVD-RW AD-7260S 
OSMonitorKeyboardPower
Windows 7 Professional 32 bit BENQ G2420HD Logitech K200 Seasonic VX550 psu 
CaseMouse
ANTEC 200 V2 Logitech mouse 
  hide details  
Reply
post #5 of 10
Double check your card wasn't flashed with a different bios.
Dump the bios and run it through RBE, it'll tell you if the bios has been previously modified.
Mighty-iTX
(12 items)
 
One foot in..
(17 items)
 
mATX
(12 items)
 
CPUMotherboardGraphicsRAM
i7-4770K M7-Impact Strix GTX980 Samsung 
Hard DriveCoolingOSMonitor
Crucial M4 256 Glacer 240L W8.1 K272HUL 
KeyboardPowerCaseMouse
Saitek Seasonic X-650 Prodigy MX518 
CPUMotherboardGraphicsGraphics
4770K/45/43 Maximus VI Extreme R290X R290X 
RAMHard DriveHard DriveOptical Drive
Samsung Crucial M4 64GB RAIDR LSSWM 
CoolingOSMonitorKeyboard
Cooler Master Glacer 7 Ultimate 64 SyncMaster Eclipse 
PowerCaseMouseMouse Pad
XFX 1050 BE 600T Silver MX518 Desk 
CPUMotherboardGraphicsRAM
i5-4330 Z87 Gryphon GTX690 G.Skill RipJawsX 
Hard DriveCoolingOSMonitor
WD Blacks Hyper 212 W8.1 ACER 
KeyboardPowerCaseMouse
Logitech Ultra X3 1000w Corsair 230T Orange Razer 
  hide details  
Reply
Mighty-iTX
(12 items)
 
One foot in..
(17 items)
 
mATX
(12 items)
 
CPUMotherboardGraphicsRAM
i7-4770K M7-Impact Strix GTX980 Samsung 
Hard DriveCoolingOSMonitor
Crucial M4 256 Glacer 240L W8.1 K272HUL 
KeyboardPowerCaseMouse
Saitek Seasonic X-650 Prodigy MX518 
CPUMotherboardGraphicsGraphics
4770K/45/43 Maximus VI Extreme R290X R290X 
RAMHard DriveHard DriveOptical Drive
Samsung Crucial M4 64GB RAIDR LSSWM 
CoolingOSMonitorKeyboard
Cooler Master Glacer 7 Ultimate 64 SyncMaster Eclipse 
PowerCaseMouseMouse Pad
XFX 1050 BE 600T Silver MX518 Desk 
CPUMotherboardGraphicsRAM
i5-4330 Z87 Gryphon GTX690 G.Skill RipJawsX 
Hard DriveCoolingOSMonitor
WD Blacks Hyper 212 W8.1 ACER 
KeyboardPowerCaseMouse
Logitech Ultra X3 1000w Corsair 230T Orange Razer 
  hide details  
Reply
post #6 of 10
Thread Starter 
Quote:
Originally Posted by grunion View Post

Double check your card wasn't flashed with a different bios.
Dump the bios and run it through RBE, it'll tell you if the bios has been previously modified.

Sorry if I sound dumb, but what is RBE? Also, would I just GPU-Z to see if it was flashed for a different bios?

Sorry for the delay, been caught up with work and also RMAd the card to ASUS and they said there was no issue with it. Also, I have tried 3 different DVI-D Cables and each one gives me a different issue.

EDIT: Tried the fourth cable and it seems to have worked.
Edited by iWorkAtStaples - 8/18/12 at 12:07pm
post #7 of 10
Card is pixelating..RMA it.It will only get worse.
RBE=Radeon Bios editor
What the guy was telling you to do is: Download Gpu-z ..click the little camera and save the 7970 gpu BIOS to desktop..Then download RBE ..open the BIOS(which is on your desktop) and see if it has the original BIOS in it.
Edited by Schmuckley - 8/18/12 at 12:09pm
 
Thuban Powah!
(14 items)
 
 
CPUMotherboardGraphicsRAM
Xeon X5650 Asus P6X58D-E Sapphire HD 7950 G.Skill Trident-X 2600 CL10 
Hard DriveCoolingPowerCase
Samsung 840 pro Bong cooler / RASA waterblock Rosewill Capstone Gold 750 None 
MouseMouse PadAudio
cheap! Newegg box panel ibeats with onboard. 
CPUMotherboardGraphicsRAM
AMD Phenom II X6 1075T w/2 cores locked @ 4.2+ M4a89GTD-Pro XFX Radeon HD 5870 8gb Samsung ddr3 1600 11-11-11-28@ 8-8-8-24 
Hard DriveHard DriveOptical DriveCooling
OCZ Agility2 40gb WD Blue 500GB Lite-On RASA waterblock 
OSMonitorKeyboardPower
Windows & Linux Samsung 1080p 2 ms Dell Thermaltake TR2-800 
CaseMouse
Cooler Master Elite 330 (was) cheap 
  hide details  
Reply
 
Thuban Powah!
(14 items)
 
 
CPUMotherboardGraphicsRAM
Xeon X5650 Asus P6X58D-E Sapphire HD 7950 G.Skill Trident-X 2600 CL10 
Hard DriveCoolingPowerCase
Samsung 840 pro Bong cooler / RASA waterblock Rosewill Capstone Gold 750 None 
MouseMouse PadAudio
cheap! Newegg box panel ibeats with onboard. 
CPUMotherboardGraphicsRAM
AMD Phenom II X6 1075T w/2 cores locked @ 4.2+ M4a89GTD-Pro XFX Radeon HD 5870 8gb Samsung ddr3 1600 11-11-11-28@ 8-8-8-24 
Hard DriveHard DriveOptical DriveCooling
OCZ Agility2 40gb WD Blue 500GB Lite-On RASA waterblock 
OSMonitorKeyboardPower
Windows & Linux Samsung 1080p 2 ms Dell Thermaltake TR2-800 
CaseMouse
Cooler Master Elite 330 (was) cheap 
  hide details  
Reply
post #8 of 10
Thread Starter 
Quote:
Originally Posted by Schmuckley View Post

Card is pixelating..RMA it.It will only get worse.
RBE=Radeon Bios editor
What the guy was telling you to do is: download gpu-z ..click the little camera and save the 7970 gpu BIOS to desktop..Then download RBE ..open the BIOS(which is on your desktop) and see if it has the original BIOS in it.

Thank you, I will call them back. I restarted the computer and it happened again and after 3 minutes the problem disappears.

EDIT AGAIN: The white part is gone but when I open up my start menu there is some white dots running across. Awesome.
Edited by iWorkAtStaples - 8/18/12 at 12:18pm
post #9 of 10
Thread Starter 
Just got off the phone with ASUS Support and they told me that the reason it does not work is due to the fact that my motherboard is not compatible with it even though pci-e 3.0 should be compatible with 2.0 from what I understand. Maybe Im wrong but that just seems like a load of crap. Anyway, thanks for the help, I guess my ECS P67H2-A2 is the reason...Newegg also wont return it since I shipped it in the original box. Stuck with a brick.
post #10 of 10
Call Asus again and talk to someone else. Can it be that old? And why won't newegg let you ship it in its original box? Try a friend's pc and see if it acts the same.
    
CPUMotherboardGraphicsRAM
Intel Core i5 2500k Asrock Extreme3 Gen3 Sapphire Vapor X 7970Ghz  8GB Corsair Vengence 
Hard DriveHard DriveOptical DriveOS
1 TB Seagate 7200rpm 128 GB Crucial M4 SSD 24x Dvd-RW Windows 7 Professional 
MonitorPowerCase
Acer 22" LED Corsair 750W NZXT Phantom 410 Black & Orange Trim 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
Intel Core i5 2500k Asrock Extreme3 Gen3 Sapphire Vapor X 7970Ghz  8GB Corsair Vengence 
Hard DriveHard DriveOptical DriveOS
1 TB Seagate 7200rpm 128 GB Crucial M4 SSD 24x Dvd-RW Windows 7 Professional 
MonitorPowerCase
Acer 22" LED Corsair 750W NZXT Phantom 410 Black & Orange Trim 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: AMD/ATI
Overclock.net › Forums › Graphics Cards › AMD/ATI › Just Upgraded my HD 6950 to HD 7970. Some Issues