Overclock.net › Forums › Graphics Cards › AMD/ATI › No signal with 7970 (Sapphire)
New Posts  All Forums:Forum Nav:

No signal with 7970 (Sapphire)

post #1 of 14
Thread Starter 
Ok, All the fans for the CPU (2600k), Case (CM Storm Enforcer), and GPU (Radeon 7970) are all spinning. However, when the monitor is telling me there is no signal coming from the system!

It isn't the monitor because it was working fine with my previous computer this morning ( I am build an new rig from scratch) and also tried my sister's monitor. I tried all the connections (HDMI, DVI and VGA) and non of them are working. Also the keyboard isn't working, which is leading my Dad to think it is the motherboard and not the card (although he knows as little as I do since he has never built a PC before either!).

I'm a first time builder and this is really freaking me out!
post #2 of 14
It's possible that it's the video card, have you tried another video card? Also, how can you tell that the keyboard is not working if there is no video input?

Are you also sure it isn't just the cable that connects to the monitor? See if replacing that cable does anything.

Good Luck and keep us posted
    
CPUMotherboardGraphicsRAM
Core i5 - 750 @ 3.35GHz (159x21), Cooled by Hy... Asus P7P55D Pro Sapphire AMD Radeon R9 270X OC x2 4GB (8gb) Kingston DDR3 1600MHz 
Hard DriveOptical DriveOSMonitor
x2 500gb and a 1000gb CD/DVD RW drive Windows 7 Premium x64 22" Samsung SyncMaster 2233 120Hz 
KeyboardPowerCaseMouse
Logitech Internet 350 Antech True Power 750watt Coolermaster Storm Scout Gigabyte M7 800/1600/3200dpi 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
Core i5 - 750 @ 3.35GHz (159x21), Cooled by Hy... Asus P7P55D Pro Sapphire AMD Radeon R9 270X OC x2 4GB (8gb) Kingston DDR3 1600MHz 
Hard DriveOptical DriveOSMonitor
x2 500gb and a 1000gb CD/DVD RW drive Windows 7 Premium x64 22" Samsung SyncMaster 2233 120Hz 
KeyboardPowerCaseMouse
Logitech Internet 350 Antech True Power 750watt Coolermaster Storm Scout Gigabyte M7 800/1600/3200dpi 
  hide details  
Reply
post #3 of 14
What's your motherboard?
   
AGP bencher
(14 items)
 
CPUMotherboardGraphicsRAM
Ryzen R7 1700 Gigabyte GA-AX370-Gaming 5 Sapphire HD 6950 2GiB 2x8GB KFA2 HOF DDR4-3600 
Hard DriveHard DriveHard DriveHard Drive
Crucial MX100 256GB Seagate 600 Series 240GB Seagate 7200.14 2TB Samsung F3 1TB 
CoolingCoolingCoolingCooling
EKWB Supreme HF XSPC Rasa GPU EK XT360 EK 4.0 
OSMonitorMonitorKeyboard
W10 Pro LG IPS235 LG E2250V KUL ES-87 
PowerCaseMouseAudio
SF Leadex II 650W Lian Li PC-A05NB Logitech G9 Xonar DX 
AudioAudio
SMSL SA-S3+Technics CB-250 Sennheiser HD555 
CPUMotherboardRAMHard Drive
AMD A10-5700 Gigabyte F2A75M-HD2 G.SKILL Ares 2133 CL9 Hitachi 5K750 
Hard DriveCoolingOSMonitor
Momentus .7 200GB Noctua NH-L9a Server 2012 R2 Standard AUO B156HW01 
PowerCaseOther
PicoPSU-80-WI-25V AIO Aluminium Handmade TP-Link Archer Something Something Wi-Fi AC 
CPUCPUCPUMotherboard
Core2Duo E6400 Core2Quad Q6600 Pentium Dual Core E5200 AsRock 4COREDUAL-SATA2 R2.0 
GraphicsRAMHard DriveOptical Drive
A dumpload of ancient AGP cards Kingston Value DDR2-667 CL4 2T @CL3 1T Seagate 160GB 7200.10 LG IDE DVD-ROM 
CoolingCoolingOSMonitor
Ghettomade CPU waterblock 49cc 2stroke engine copper radiator WinXP SP2 32bit ProView 17" 
PowerCase
Tacens Radix V 550W Ghetto aluminium bench 
  hide details  
Reply
   
AGP bencher
(14 items)
 
CPUMotherboardGraphicsRAM
Ryzen R7 1700 Gigabyte GA-AX370-Gaming 5 Sapphire HD 6950 2GiB 2x8GB KFA2 HOF DDR4-3600 
Hard DriveHard DriveHard DriveHard Drive
Crucial MX100 256GB Seagate 600 Series 240GB Seagate 7200.14 2TB Samsung F3 1TB 
CoolingCoolingCoolingCooling
EKWB Supreme HF XSPC Rasa GPU EK XT360 EK 4.0 
OSMonitorMonitorKeyboard
W10 Pro LG IPS235 LG E2250V KUL ES-87 
PowerCaseMouseAudio
SF Leadex II 650W Lian Li PC-A05NB Logitech G9 Xonar DX 
AudioAudio
SMSL SA-S3+Technics CB-250 Sennheiser HD555 
CPUMotherboardRAMHard Drive
AMD A10-5700 Gigabyte F2A75M-HD2 G.SKILL Ares 2133 CL9 Hitachi 5K750 
Hard DriveCoolingOSMonitor
Momentus .7 200GB Noctua NH-L9a Server 2012 R2 Standard AUO B156HW01 
PowerCaseOther
PicoPSU-80-WI-25V AIO Aluminium Handmade TP-Link Archer Something Something Wi-Fi AC 
CPUCPUCPUMotherboard
Core2Duo E6400 Core2Quad Q6600 Pentium Dual Core E5200 AsRock 4COREDUAL-SATA2 R2.0 
GraphicsRAMHard DriveOptical Drive
A dumpload of ancient AGP cards Kingston Value DDR2-667 CL4 2T @CL3 1T Seagate 160GB 7200.10 LG IDE DVD-ROM 
CoolingCoolingOSMonitor
Ghettomade CPU waterblock 49cc 2stroke engine copper radiator WinXP SP2 32bit ProView 17" 
PowerCase
Tacens Radix V 550W Ghetto aluminium bench 
  hide details  
Reply
post #4 of 14
No problem at all, I have same issue here, Can't figure out if its the Hdmi cable or the card, i just try connecting the cable again, the end on the card and the end on the hdtv. After reconnecting the image shows again but I can't say what the heck is wrong with that, not sure dude. I'll clean my entire computer all over again and will try a new Hdmi cable, but I think it will be useless, maybe its for the faulty drivers or maybe a crappy card.
Scorpius Platform
(27 items)
 
Leo Platform
(19 items)
 
  hide details  
Reply
Scorpius Platform
(27 items)
 
Leo Platform
(19 items)
 
  hide details  
Reply
post #5 of 14
Thread Starter 
I don't have another video card to try!

On the topic of the keyboard, I know it isn't working because non of the lights, for example the caps lock indicator, are working.

My motherboard is a Sabertooth Z77 from Asus.

It can't be faulty drivers because I haven't installed any drivers. This happened on my first boot so Windows isn't installed yet either!
post #6 of 14
reseat your GPU...sometimes the GPU sag and it's pins dont come in contact with the PCI slot... because it is heavy...
Rievhardt Vulcan
(16 items)
 
  
CPUMotherboardGraphicsRAM
i5-2400 ASUS P8H61-MLE-USB3 Sapphire HD 7870 Corsair Vengeance LP 2x4GB 
Hard DriveOptical DriveCoolingOS
WD BLUE 500GB Samsung 22x stock Windows 7 Home Premium 64Bit FPP 
MonitorKeyboardPowerCase
HP X2301 SWORD CM Quickfire TK mx blue FSP Aurum 600w 80+Gold NZXT Vulcan 
MouseMouse PadAudioOther
TT Theron DragonWar ASUS Xonar DSX Aerocool Shark 120mm Orange Led (3) 
  hide details  
Reply
Rievhardt Vulcan
(16 items)
 
  
CPUMotherboardGraphicsRAM
i5-2400 ASUS P8H61-MLE-USB3 Sapphire HD 7870 Corsair Vengeance LP 2x4GB 
Hard DriveOptical DriveCoolingOS
WD BLUE 500GB Samsung 22x stock Windows 7 Home Premium 64Bit FPP 
MonitorKeyboardPowerCase
HP X2301 SWORD CM Quickfire TK mx blue FSP Aurum 600w 80+Gold NZXT Vulcan 
MouseMouse PadAudioOther
TT Theron DragonWar ASUS Xonar DSX Aerocool Shark 120mm Orange Led (3) 
  hide details  
Reply
post #7 of 14
Thread Starter 
I tried that frown.gif
post #8 of 14
since your mobo is Z77...have you tried putting the card on another PCI lane? maybe the PCI the card was in is broken...

another question...

what's your entire PC Spec? are you using a true rated PSU or a generic one? it could also be a power supply issue.
also...could you try using the IGP for a moment just to see if your motherboard works or not...
Rievhardt Vulcan
(16 items)
 
  
CPUMotherboardGraphicsRAM
i5-2400 ASUS P8H61-MLE-USB3 Sapphire HD 7870 Corsair Vengeance LP 2x4GB 
Hard DriveOptical DriveCoolingOS
WD BLUE 500GB Samsung 22x stock Windows 7 Home Premium 64Bit FPP 
MonitorKeyboardPowerCase
HP X2301 SWORD CM Quickfire TK mx blue FSP Aurum 600w 80+Gold NZXT Vulcan 
MouseMouse PadAudioOther
TT Theron DragonWar ASUS Xonar DSX Aerocool Shark 120mm Orange Led (3) 
  hide details  
Reply
Rievhardt Vulcan
(16 items)
 
  
CPUMotherboardGraphicsRAM
i5-2400 ASUS P8H61-MLE-USB3 Sapphire HD 7870 Corsair Vengeance LP 2x4GB 
Hard DriveOptical DriveCoolingOS
WD BLUE 500GB Samsung 22x stock Windows 7 Home Premium 64Bit FPP 
MonitorKeyboardPowerCase
HP X2301 SWORD CM Quickfire TK mx blue FSP Aurum 600w 80+Gold NZXT Vulcan 
MouseMouse PadAudioOther
TT Theron DragonWar ASUS Xonar DSX Aerocool Shark 120mm Orange Led (3) 
  hide details  
Reply
post #9 of 14
What PSU are you running?

Is it out of the question for you to buy a second super cheap graphics card, like an 8400GS or something, just for testing? Note, I'm talking about the CHEAPEST PCIe graphics card you can find, just something to see if your machine POST's.
 
NAStradamous
(12 items)
 
HTPC01
(16 items)
 
CPUMotherboardGraphicsGraphics
i7 2600k @ 4.5GHz, 1.35v GA-P67A-UD​7 (rev. 1.​0) Asus RX 580 8GB Dual Crossfire Asus RX 580 8GB Dual Crossfire 
RAMHard DriveCoolingOS
Kingston HyperX 16GB (4x4) DDR3-1600 Crucial MX100 512GB RAID0 (2x 256GB) CoolerMaster Liquid Pro 240mm Windows 10 x64 
MonitorMonitorKeyboardPower
(Fut.) Crossover 34" 3440x1440 Curved (Cur.) Dell 20/30/20 PLP Eyefinity Razer Chroma PC Power & Cooling Silencer MK II 950w 
CaseMouseAudioAudio
Thermaltake View 27 Snow Edition Logitech G602 Dayton MK402 Dayton DTA-120 
CPUMotherboardGraphicsRAM
Intel Core i5 3330 Asus H61 MSI GTX 750Ti Low Profile 2x4GB Hynix DDR3-1333 
Hard DriveHard DriveOptical DriveCooling
60GB Kingston SSD 1TB Seagate Samsung DVDRW CoolerMaster Gemin II 
OSMonitorKeyboardPower
Windows 8.1 + Steam Big Picture / Plex HT 50" Insignia LED 1080p Logitech Rosewill Green 530w 
CaseMouseAudioOther
Silverstone HTPC Logitech Pioneer 2.0 tower speakers + 135w RMS Rosewill MCE Remote 
  hide details  
Reply
 
NAStradamous
(12 items)
 
HTPC01
(16 items)
 
CPUMotherboardGraphicsGraphics
i7 2600k @ 4.5GHz, 1.35v GA-P67A-UD​7 (rev. 1.​0) Asus RX 580 8GB Dual Crossfire Asus RX 580 8GB Dual Crossfire 
RAMHard DriveCoolingOS
Kingston HyperX 16GB (4x4) DDR3-1600 Crucial MX100 512GB RAID0 (2x 256GB) CoolerMaster Liquid Pro 240mm Windows 10 x64 
MonitorMonitorKeyboardPower
(Fut.) Crossover 34" 3440x1440 Curved (Cur.) Dell 20/30/20 PLP Eyefinity Razer Chroma PC Power & Cooling Silencer MK II 950w 
CaseMouseAudioAudio
Thermaltake View 27 Snow Edition Logitech G602 Dayton MK402 Dayton DTA-120 
CPUMotherboardGraphicsRAM
Intel Core i5 3330 Asus H61 MSI GTX 750Ti Low Profile 2x4GB Hynix DDR3-1333 
Hard DriveHard DriveOptical DriveCooling
60GB Kingston SSD 1TB Seagate Samsung DVDRW CoolerMaster Gemin II 
OSMonitorKeyboardPower
Windows 8.1 + Steam Big Picture / Plex HT 50" Insignia LED 1080p Logitech Rosewill Green 530w 
CaseMouseAudioOther
Silverstone HTPC Logitech Pioneer 2.0 tower speakers + 135w RMS Rosewill MCE Remote 
  hide details  
Reply
post #10 of 14
Thread Starter 
I'm 14 and I spent my entire budget on this build, having been told by basically everyone that it is super simple to do. My dad works at a University and has taking it into one of the technicians there, who is kindly going to have a look at it for me! If he finds anything I will be sure to post it here to tell you guys! Thanks for your suggestions by the way, I really appreciate that you are trying to help me and anyone else who has this problem in the future! wink.gif
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: AMD/ATI
Overclock.net › Forums › Graphics Cards › AMD/ATI › No signal with 7970 (Sapphire)