Overclock.net › Forums › Graphics Cards › NVIDIA › EVGA GTX 550 Ti 2GB kicked the bucket.
New Posts  All Forums:Forum Nav:

EVGA GTX 550 Ti 2GB kicked the bucket.

post #1 of 17
Thread Starter 
well i played a few hrs of BF3 last night, then surfed the web for a bit and shut my system down and went to bed. woke up this morning to no video input to my monitors. odd it died like that, they have always went pop, or just let out the magic smoke.. never had one work fine then just not boot the next day..

I have contacted EVGA and within an hr of my email i have an RMA number, will be sending in tomorrow hoping for the best. anyone else have a card that just stopped like that?
post #2 of 17
nope guess its just the nature of the beast. EVGA will take care of u.
Queso Fresco
(16 items)
 
  
CPUMotherboardGraphicsRAM
Ryzen 5 1600 MSI B350 Bazooka ASUS Turbo GTX 1060  T-Force DDR4 3000 16gb 
Hard DriveHard DriveCoolingOS
Samsung 840 250gb Intel 320 160gb SilverStone Heligon HE01 Windows 10 
MonitorMonitorKeyboardPower
Dell S2716DG Achieva Shimian  Monoprice MX Black SeaSonic X-750 
CaseMouse
Corsair 350D Logitech G403 
  hide details  
Reply
Queso Fresco
(16 items)
 
  
CPUMotherboardGraphicsRAM
Ryzen 5 1600 MSI B350 Bazooka ASUS Turbo GTX 1060  T-Force DDR4 3000 16gb 
Hard DriveHard DriveCoolingOS
Samsung 840 250gb Intel 320 160gb SilverStone Heligon HE01 Windows 10 
MonitorMonitorKeyboardPower
Dell S2716DG Achieva Shimian  Monoprice MX Black SeaSonic X-750 
CaseMouse
Corsair 350D Logitech G403 
  hide details  
Reply
post #3 of 17
X2 on EVGA taking care of you....hopefully they say they dont have any 550's and send u a 560 ti biggrin.gif
Ov3RK11L
(15 items)
 
Project Toaster
(15 items)
 
 
CPUMotherboardGraphicsRAM
i5-661 4.2Ghz 24/7 Gigabyte H55N-USB3 Sapphire HD7950 950mhz OC Gskill Ripjaws DDR3 1333 4GB 
Hard DriveOptical DriveCoolingOS
Corsair F60 SSD + WD 500GB black LG burner Antech Kuhler 620 w/ NoiseBlocker fan Win 7 Ult. 64bit 
MonitorKeyboardPowerCase
Asus 24" LED LCD 1920X1080 Logitech G510 600W 80+ Lian Li PC-Q08B 
MouseMouse PadAudio
R.A.T 7  Frys?? lol onboard..ohh yahhhhhhh  
  hide details  
Reply
Ov3RK11L
(15 items)
 
Project Toaster
(15 items)
 
 
CPUMotherboardGraphicsRAM
i5-661 4.2Ghz 24/7 Gigabyte H55N-USB3 Sapphire HD7950 950mhz OC Gskill Ripjaws DDR3 1333 4GB 
Hard DriveOptical DriveCoolingOS
Corsair F60 SSD + WD 500GB black LG burner Antech Kuhler 620 w/ NoiseBlocker fan Win 7 Ult. 64bit 
MonitorKeyboardPowerCase
Asus 24" LED LCD 1920X1080 Logitech G510 600W 80+ Lian Li PC-Q08B 
MouseMouse PadAudio
R.A.T 7  Frys?? lol onboard..ohh yahhhhhhh  
  hide details  
Reply
post #4 of 17
Thread Starter 
Quote:
Originally Posted by tx-jose View Post

X2 on EVGA taking care of you....hopefully they say they dont have any 550's and send u a 560 ti biggrin.gif
this would be very awesome. atm i am using my roommates 460 till i get this taken care of. he has sli but he don't play games much anymore. heck i would be willing to pay them the extra to upgrade me, but i didnt go for the extras when i registerd my card.

there RMA auto response said they would get back to me within 2 days, it took less than an hr. so far i am extremely pleased with there service.
post #5 of 17
EVGA has the BEST customer service.....period. I have delt with a few companies RMA and none come close to EVGA's service.

I have fried a EVGA Classy 3way from OCing and they replaced it no questions asked.....i was only pushing 1.55V through a i7 920 @ 4.5Ghz primig for 24hrs lol biggrin.gif

And my GTX460 has been RMA'd for dying from heavy OCing....used to run it @ 920 on the core maxed out voltage.
Ov3RK11L
(15 items)
 
Project Toaster
(15 items)
 
 
CPUMotherboardGraphicsRAM
i5-661 4.2Ghz 24/7 Gigabyte H55N-USB3 Sapphire HD7950 950mhz OC Gskill Ripjaws DDR3 1333 4GB 
Hard DriveOptical DriveCoolingOS
Corsair F60 SSD + WD 500GB black LG burner Antech Kuhler 620 w/ NoiseBlocker fan Win 7 Ult. 64bit 
MonitorKeyboardPowerCase
Asus 24" LED LCD 1920X1080 Logitech G510 600W 80+ Lian Li PC-Q08B 
MouseMouse PadAudio
R.A.T 7  Frys?? lol onboard..ohh yahhhhhhh  
  hide details  
Reply
Ov3RK11L
(15 items)
 
Project Toaster
(15 items)
 
 
CPUMotherboardGraphicsRAM
i5-661 4.2Ghz 24/7 Gigabyte H55N-USB3 Sapphire HD7950 950mhz OC Gskill Ripjaws DDR3 1333 4GB 
Hard DriveOptical DriveCoolingOS
Corsair F60 SSD + WD 500GB black LG burner Antech Kuhler 620 w/ NoiseBlocker fan Win 7 Ult. 64bit 
MonitorKeyboardPowerCase
Asus 24" LED LCD 1920X1080 Logitech G510 600W 80+ Lian Li PC-Q08B 
MouseMouse PadAudio
R.A.T 7  Frys?? lol onboard..ohh yahhhhhhh  
  hide details  
Reply
post #6 of 17
Thread Starter 
UPDATE: i sent the card off, that had received it. 1 day later i receive an email. they have registered a new one to my account and sent it UPS, and it should be hear Thursday. awesome.
post #7 of 17
Thread Starter 
yaaay, installed it and everything works great. seems to work better than the original i had. was painless except for the 2 weeks of waiting for it and useing the 460. it could have been faster if i paid more but i couldn't afford the extra right now.
post #8 of 17
Glad your up and running again. Happy gaming thumb.gif
post #9 of 17
Thread Starter 
thank you. the RMA process was very smooth and was a great experience. i am also going to buy another 550ti tonight for sli, and it will be evga.
post #10 of 17
550ti sli doesnt worth its performance...

get 560ti SLI or a single HD 7950 3gb/ 660 GTX TI 2 gb
Edited by PontiacGTX - 9/28/12 at 3:05pm
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: NVIDIA
Overclock.net › Forums › Graphics Cards › NVIDIA › EVGA GTX 550 Ti 2GB kicked the bucket.