Overclock.net › Forums › Components › Mice › DeathAdder Firmware issue?
New Posts  All Forums:Forum Nav:

DeathAdder Firmware issue?

post #1 of 2
Thread Starter 
Hello, I was hoping to get a question answered in regards to a Razer DeathAdder 3.5G BE I just recently bought. It was working fine when I first got it yesterday from Amazon, some Warehouse Deal, was very pleased with it. Installed Synapse 2.0 (which from reading around now that was probably not the best idea...), and was fine for the rest of the night, goood couple hours of play. I get home from work today and go to play, and suddenly the mouse is acting up. The cursor jitters down to the bottom of the screen, and gets essentially stuck down there. I can move it left to right (only noticeable by buttons being illuminated in my Windows taskbar.) and kinda move it up if go real slowly, but it acts like good ol' fashioned online game lag where go 3 steps forward and two (or five) steps back. I've tried uninstalling/re-installing Synapse 2.0, and attempted to install the firmware from the website itself but it only gave a complaint about not the right mouse(?) and that no driver was installed. I went and found the 3.0.5 driver and installed that after uninstalling Synapse, but still no good. For good measure I plugged it into my laptop, just to see if maybe my computer was not cooperating, but same issue. Nothing physical happen to the mouse between last night and now, so thinking maybe firmware? But not sure what to do now, with the firmware updating not recognizing it, or the driver for that matter... says firmware version n/a... Is there any way to reset it back to it was, or repair the firmware somehow? Or is it completely screwed and should return it, if I even can?

It was first used and stopped working on a Windows Pro 64-bit if that may be the culprit. Laptop is 32-bit.
post #2 of 2
Try updating the Firmware:

http://www.razersupport.com/index.php?_m=downloads&_a=view&parentcategoryid=148&pcid=48&nav=0,76,168,48
TheSadFlute
(16 items)
 
DyingHeart
(17 items)
 
 
CPUMotherboardGraphicsRAM
i7-6700K TUF Sabertooth MSI 1080 Ti 16GB 2400MHz C15 
Hard DriveHard DriveHard DriveCooling
Corsair 480GB LE 3TB WD Green Sammy 500GB 850 EVO H100i 
OSMonitorKeyboardPower
Windows 7 Pro  BenQ XR3501 Logitech G710+ EVGA G2 750W 
CaseMouseAudioAudio
Cooler Master Stryker Logitech G602 Asus Strix Nakamichi 5.1 
CPUMotherboardGraphicsRAM
Phenom II X4 965BE  Sapphire 790X Zotac GTX650  4GB Corsair 1066 DDR2 (1GBx4) 
Hard DriveHard DriveCoolingCooling
G.Skill Phoenix Pro 120GB WD 2TB Green Stock 3x120mm UQ fans 
OSMonitorKeyboardPower
W7 Pro SP1 x64 LG 21' 1680x1050 Genius  Corsair CX600 
CaseMouseMouse PadAudio
Gigabyte  E-Blue Mazer XFX WarPad On-board 
Audio
Logitech G35 
  hide details  
Reply
TheSadFlute
(16 items)
 
DyingHeart
(17 items)
 
 
CPUMotherboardGraphicsRAM
i7-6700K TUF Sabertooth MSI 1080 Ti 16GB 2400MHz C15 
Hard DriveHard DriveHard DriveCooling
Corsair 480GB LE 3TB WD Green Sammy 500GB 850 EVO H100i 
OSMonitorKeyboardPower
Windows 7 Pro  BenQ XR3501 Logitech G710+ EVGA G2 750W 
CaseMouseAudioAudio
Cooler Master Stryker Logitech G602 Asus Strix Nakamichi 5.1 
CPUMotherboardGraphicsRAM
Phenom II X4 965BE  Sapphire 790X Zotac GTX650  4GB Corsair 1066 DDR2 (1GBx4) 
Hard DriveHard DriveCoolingCooling
G.Skill Phoenix Pro 120GB WD 2TB Green Stock 3x120mm UQ fans 
OSMonitorKeyboardPower
W7 Pro SP1 x64 LG 21' 1680x1050 Genius  Corsair CX600 
CaseMouseMouse PadAudio
Gigabyte  E-Blue Mazer XFX WarPad On-board 
Audio
Logitech G35 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Mice
Overclock.net › Forums › Components › Mice › DeathAdder Firmware issue?