Overclock.net › Forums › Software, Programming and Coding › Networking & Security › Network Internet Issues - Please Help
New Posts  All Forums:Forum Nav:

Network Internet Issues - Please Help

post #1 of 5
Thread Starter 
Hi All

Was working on a machine last night, after a few hours I gave up as I tried everything I knew. See below I'll run through everything.

Machine
Dell Inspiron i3 Laptop (Not that this is important in this case)
Windows 7 Home Premium 64bit

Problem
Can not use the internet on the laptop. None of the browsers work (IE9, Chrome, Firefox), and the other internet using applications also don't work (socialbox).

Wireless network connection is working perfectly. Full strength and showing internet access. In Network Center the map shows a perfect connection from the laptop to the router with internet.

Shows a "windows sockets initialization failed" error on starting

Steps I tried
- First thing I did was connect to my wireless network. Connected fine showing internet access, during the whole time I worked on the laptop, my desktop and my phone all used my internet access with no issues.

- Loaded up IE9, didn't work, either came up with the no internet connection screen, or a address invalid screen.
- Tried on Chrome and Firefox. Same issue (though their error screens are slightly different).

- Loaded up CMD as admin. Pinged yahoo.com - returned all good. Pinged google.com returned all good. No issues here.

- Double checked the IPv4 and IPv6 TCP/IP's in Network adapter. They are on obtain automatically, no random DNS or anything entered in there, its showing as internet access so I believe they are fine.

- Figured it must be the winsocks API. Ran CMD as admin. Did the following:
- netsh winsock reset catalog (enter) (reset all good)
- netsh int ip reset reset.log (enter) (reset all good)
- netsh int ipv4 reset reset.log (enter) (reset all good)
- netsh int ipv6 reset reset.log (enter) (reset all good)

- Rebooted the computer after refreshing the winsock. Tested when back up. No change. Except that it no longer shows the "windows sockets initialization failed" error on starting. None of the browsers work.

- Tried to access my router through IE9. Didn't work either.

- Uninstalled IE9, rebooted and reinstalled. Still wouldn't work.

- At this point I noticed that windows update was able to download perfectly fine (caught it updating during one of the reboots, then tested in windows, downloading fine).

- Went into registry, made a back up. Deleted the keys for Winsock and Winsock2 (thought it might do a refresh upon reboot).

- Upon reboot the system was terribly slow. Restarted in safemode and restored the backup registry.

- Back in Windows all fine again, still no fix to the problem however.

- Uninstalled Norton 360. Rebooted. Still no fix.

- Opened Windows Firewall. When through the list of exceptions, tried to add IE9, Chrome etc manually, message said they already had exceptions. Added IE9 64bit.

- (This is where its weird) Tried IE9 64bit. Works perfectly. Full internet access and everything. Sadly I didn't try this before I added it to the exception list in firewall though.

- Checked through Internet Options in IE. Nothing out of the ordinary to report. Should be fine.

- Finally I did a system restore back to the 16/08/12 (A week or so before the problem). Upon rebooting, still no change the problem was not fixed.

- Gave up and went to bed.

Next Steps Planned
I have told my mate to take the laptop home and back up onto a external HDD all his data, files etc. Getting ready for a format/reinstall of Win7.




That's about all there is to report. Are there any other steps I should try?

Thanks in advance
post #2 of 5
You could try using WinsockFix. There should be a download for it from softpedia in the top 3 links if you google it.
Sab Tower
(12 items)
 
  
CPUMotherboardGraphicsRAM
i7 3770k ASRock Z77 OC Formula HIS IceQ Radeon 7950 Corsair Dominator Platinum 
Hard DriveHard DriveCoolingOS
Samsung Samsung 830 XSPC Raystorm EX360 OpenSUSE 12.2 
MonitorPowerCaseMouse
Acer 21 Inch Flat Screen Seasonic x650 NZXT Switch 810 Logitech MX510 
  hide details  
Reply
Sab Tower
(12 items)
 
  
CPUMotherboardGraphicsRAM
i7 3770k ASRock Z77 OC Formula HIS IceQ Radeon 7950 Corsair Dominator Platinum 
Hard DriveHard DriveCoolingOS
Samsung Samsung 830 XSPC Raystorm EX360 OpenSUSE 12.2 
MonitorPowerCaseMouse
Acer 21 Inch Flat Screen Seasonic x650 NZXT Switch 810 Logitech MX510 
  hide details  
Reply
post #3 of 5
Thread Starter 
Isn't the winsockfix just the easy way to do the netsh stuff I already did?

I'll give that a go though, can't hurt.
post #4 of 5
Thread Starter 
Winsockfix thing made no difference as well unfortunately.
post #5 of 5
Usually uninstalling Norton will F up connectivity unless you use the removal tool:
https://www-secure.symantec.com/norton-support/jsp/help-solutions.jsp?docid=20080710133834EN&product=home&pvid=f-home&version=1&lg=english&ct=us
Quote:
Wireless network connection is working perfectly.
Doesn't seem to be the case.
Waiting on X399
(13 items)
 
  
CPUMotherboardGraphicsRAM
AMD Phenom II B57 @ X4 3.9 Gigabyte 790FXTA-UD5 Sapphire Radeon 290 8 GB G.Skill 2133 
Hard DriveCoolingOSKeyboard
250 GB 840 EVO Noctua NH-D14 Windows 10 Logitech K350 
PowerCaseMouseMouse Pad
Seasonic x750 Corsair 600T Logitech G100s Razer Goliathus Speed 
Audio
Plantronics Gamecom 788 
  hide details  
Reply
Waiting on X399
(13 items)
 
  
CPUMotherboardGraphicsRAM
AMD Phenom II B57 @ X4 3.9 Gigabyte 790FXTA-UD5 Sapphire Radeon 290 8 GB G.Skill 2133 
Hard DriveCoolingOSKeyboard
250 GB 840 EVO Noctua NH-D14 Windows 10 Logitech K350 
PowerCaseMouseMouse Pad
Seasonic x750 Corsair 600T Logitech G100s Razer Goliathus Speed 
Audio
Plantronics Gamecom 788 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Networking & Security
Overclock.net › Forums › Software, Programming and Coding › Networking & Security › Network Internet Issues - Please Help