Overclock.net › Forums › Components › Memory › My RAM is slow?
New Posts  All Forums:Forum Nav:

My RAM is slow?

post #1 of 4
Thread Starter 
Hey guys, is this speed supposed to look like this (it may be idling or not under load or something)? The RAM is rated to run at 1600 mhz and right now its running at 667. Both sticks are like this so I'm not sure if this is supposed to happen or if its abnormal.

post #2 of 4
Quote:
Originally Posted by AznRage View Post

Hey guys, is this speed supposed to look like this (it may be idling or not under load or something)? The RAM is rated to run at 1600 mhz and right now its running at 667. Both sticks are like this so I'm not sure if this is supposed to happen or if its abnormal.


DDR stands for ''Double Data Rate''. You have the multiply the speed here by two to get the effective speed.



Default speed for ddr3 is 1100 and 1333. Anything above is actually an overclock. So when you buy 1600 ram you only get the certification that it will run at a 1600 overclock.

Yours is running at 1333, that's perfectly normal. You need to enter your bios to overclock it at the rated speed.



EDIT : you're using a next gen intel board, try setting the profile to XMP - 1600. It will do the OC for you.
Edited by splinterize - 9/5/12 at 5:16pm
post #3 of 4
Thread Starter 
Alright - thanks a lot. I'm not quite that knowledgeable on RAM smile.gif
Everything felt like it was running smoothly but when I pulled up this window I looked at the speed and was like, "***?" so I just wanted to know what was going on.

+rep for a nice quick response.
post #4 of 4
Quote:
Originally Posted by AznRage View Post

Alright - thanks a lot. I'm not quite that knowledgeable on RAM smile.gif
+rep for a nice quick response.


Thank you, I appreciate the +rep smile.gif
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Memory
Overclock.net › Forums › Components › Memory › My RAM is slow?