Overclock.net › Forums › Intel › Intel CPUs › Help I5 3570K will not overclock on my Sabertooth Z77
New Posts  All Forums:Forum Nav:

Help I5 3570K will not overclock on my Sabertooth Z77

post #1 of 12
Thread Starter 
Hi all, I've just completed my new build and am now trying to overclock the I5 3570K on my sabertooth Z77 motherboard. Before I started I updated the bios to latest build - 1504 x64

However I seem to have a major problem ovclocking,

I've tried using OC Tuner, which Changed settings in Bios but the chip stayed at 3.40ghz.

I've tried adjusting the turbo ratio to manual and adjusting the limits to 45. Left everything else on Auto. And the chip stayed at 3.40ghz

It seems whatever I do , nothing changes it.

Can someone please explain what on earth I'm doing wrong, I spent many months reading up on this before I built the machine and thought I understood it.

Guess not. frown.gif

I know it must be me missing something, all I'm after doing is overclocking to 4.5ghz
post #2 of 12
Have you tried changing the turbo ratio in the BIOS?
:D
(15 items)
 
  
CPUMotherboardGraphicsRAM
Intel i5 3570K [4.5ghz] Asus P8Z77 V-Pro Asus GTX 760 2X4gb Corsair XMS3 1600mhz 
Hard DriveHard DriveCoolingOS
WD Blue 1TB EZEX X 2 [RAID 0] [WD Black 640GB][2 X WD Blue 1TB EZEX] Corsair H80i Windows 7 64bit 
MonitorPowerCase
Dell Ultrasharp 23" Corsair CX430W v2 Corsair Graphite 600T 
  hide details  
Reply
:D
(15 items)
 
  
CPUMotherboardGraphicsRAM
Intel i5 3570K [4.5ghz] Asus P8Z77 V-Pro Asus GTX 760 2X4gb Corsair XMS3 1600mhz 
Hard DriveHard DriveCoolingOS
WD Blue 1TB EZEX X 2 [RAID 0] [WD Black 640GB][2 X WD Blue 1TB EZEX] Corsair H80i Windows 7 64bit 
MonitorPowerCase
Dell Ultrasharp 23" Corsair CX430W v2 Corsair Graphite 600T 
  hide details  
Reply
post #3 of 12
Thread Starter 
Quote:
Originally Posted by chip94 View Post

Have you tried changing the turbo ratio in the BIOS?

Yep, everything is changed in bios, tried changing the ration at both the AI Tweaker page and the advanced CPU config / power management config.

Sadly nothing seems to work
post #4 of 12
Did you reset the CMOS?

Reset bios to defaults and update your board's firmware. I'd even suggest seating the CPU in the socket again.
:D
(15 items)
 
  
CPUMotherboardGraphicsRAM
Intel i5 3570K [4.5ghz] Asus P8Z77 V-Pro Asus GTX 760 2X4gb Corsair XMS3 1600mhz 
Hard DriveHard DriveCoolingOS
WD Blue 1TB EZEX X 2 [RAID 0] [WD Black 640GB][2 X WD Blue 1TB EZEX] Corsair H80i Windows 7 64bit 
MonitorPowerCase
Dell Ultrasharp 23" Corsair CX430W v2 Corsair Graphite 600T 
  hide details  
Reply
:D
(15 items)
 
  
CPUMotherboardGraphicsRAM
Intel i5 3570K [4.5ghz] Asus P8Z77 V-Pro Asus GTX 760 2X4gb Corsair XMS3 1600mhz 
Hard DriveHard DriveCoolingOS
WD Blue 1TB EZEX X 2 [RAID 0] [WD Black 640GB][2 X WD Blue 1TB EZEX] Corsair H80i Windows 7 64bit 
MonitorPowerCase
Dell Ultrasharp 23" Corsair CX430W v2 Corsair Graphite 600T 
  hide details  
Reply
post #5 of 12
Thread Starter 
Warning: Spoiler! (Click to show)
Quote:
Originally Posted by chip94 View Post

Did you reset the CMOS?
Reset bios to defaults and update your board's firmware. I'd even suggest seating the CPU in the socket again.

I've flashed the bios back to 1405 and reset to default settings , sadly run out of time and had to go to work, so if it still won't play when I get back, then I'll be resetting the CMOS and take it from there.

Can't believe work got in the way of my computing wink.gif
post #6 of 12
I had to reset the CMOS before I was able to OC mine. I'm at 4.5 GHz right now and it is running great.
post #7 of 12
Thread Starter 
Ok then, I've reset the CMOS by moving the jumper, and that didn't work. I'll take the battery off tomorrow, although I'm guessing that's a bugger of a job, as I'll have to remove the graphics card and the armor to get at it. Not looking forward to that.

Bought the sabertooth z77 and 3570k setup, as all I've read is how easy it is to OC, damn I must really have peed someone off in a previous life.

If that dosnt work.............................
post #8 of 12
stupid question but it happens, did you save the settings when you exited bios ?
w00t
(18 items)
 
   
CPUMotherboardGraphicsRAM
ph2 x20be asus m4a785-m sapphire vapor-x 4850  geil black dragon 1066 5-5-5-15-20 
Hard DriveOptical DriveCoolingOS
wd  asus dvd multi-write arctic cooling freezer 64 pro win 7 ultimate x64 
MonitorKeyboardPowerCase
samsung 42" lcd logitech wireless antec basic 500watt old dell crap 
MouseAudio
logitech wireless pioneer 7.1 
  hide details  
Reply
w00t
(18 items)
 
   
CPUMotherboardGraphicsRAM
ph2 x20be asus m4a785-m sapphire vapor-x 4850  geil black dragon 1066 5-5-5-15-20 
Hard DriveOptical DriveCoolingOS
wd  asus dvd multi-write arctic cooling freezer 64 pro win 7 ultimate x64 
MonitorKeyboardPowerCase
samsung 42" lcd logitech wireless antec basic 500watt old dell crap 
MouseAudio
logitech wireless pioneer 7.1 
  hide details  
Reply
post #9 of 12
Thread Starter 
Yep, not a stupid question, I checked that several times myself. smile.gif

The bios is saving my settings in AI Tweaker, it shows the speed it's aiming for is 4.5Ghz, yet the chip itself reads 3.4ghz and that never changes.

I've tried resetting CMOs by the jumper several times, I've flashed to a different bios, I've tried default settings, I've tried OC Tuner. I've even tried turboV in asus suite on windows.

Nothing I change will change the bloody chip settings, it's almost like its locked down, although it is a 3570K

The next thing is a complete strip down of the system, just so I can remove the CMOS battery, pretty poor design there for the Sabertooth. frown.gif

To say I'm annoyed is rather an understatement.
post #10 of 12
Maybe your motherboard is defective? Just a thought, after all the things you've tried.
:D
(15 items)
 
  
CPUMotherboardGraphicsRAM
Intel i5 3570K [4.5ghz] Asus P8Z77 V-Pro Asus GTX 760 2X4gb Corsair XMS3 1600mhz 
Hard DriveHard DriveCoolingOS
WD Blue 1TB EZEX X 2 [RAID 0] [WD Black 640GB][2 X WD Blue 1TB EZEX] Corsair H80i Windows 7 64bit 
MonitorPowerCase
Dell Ultrasharp 23" Corsair CX430W v2 Corsair Graphite 600T 
  hide details  
Reply
:D
(15 items)
 
  
CPUMotherboardGraphicsRAM
Intel i5 3570K [4.5ghz] Asus P8Z77 V-Pro Asus GTX 760 2X4gb Corsair XMS3 1600mhz 
Hard DriveHard DriveCoolingOS
WD Blue 1TB EZEX X 2 [RAID 0] [WD Black 640GB][2 X WD Blue 1TB EZEX] Corsair H80i Windows 7 64bit 
MonitorPowerCase
Dell Ultrasharp 23" Corsair CX430W v2 Corsair Graphite 600T 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Intel CPUs
Overclock.net › Forums › Intel › Intel CPUs › Help I5 3570K will not overclock on my Sabertooth Z77