Overclock.net › Forums › Graphics Cards › AMD/ATI › HELP! I think i bought bad Sapphire HD7950/Is it bricked or what?
New Posts  All Forums:Forum Nav:

HELP! I think i bought bad Sapphire HD7950/Is it bricked or what?

post #1 of 3
Thread Starter 
So, I bought today used Sapphire HD7950,3GB (not OC model)...
English is not my native language so please bear with me..
I have WIN7 64, they dont recognise card, no matter what I do, allways finding Standard VGA Adapter under drivers... I downloaded latest drivers,
GPU-Z is showing http://gpuz.techpowerup.com/12/09/15/5nc.png

Desktop picture is strange, cut in half, 30% of screen of the right side is on the left side, but when i press Print Screen and paste it in Paint its normal....

I think i even bricked first BIOS in panic by using Tahiti_PRO_Boost_BIOS_Jul12_2012.exe... When i put it on 1 BIOS its only black screen, and 2 BIOS ,thankfuly locked is like this...
I am not complete n00b and have some rudimentary knowlege of at least changing GPU ,CPU etc so i tried almost everything normal user would do...
My CPU is c2d E8500,mbo :Gigabyte EP-45 DS-3,PSU: ocz 650w

Please help, was ex-owner did something stupid with BIOS , I just dont know where to begin and i gave my last money for this so im pretty angry and i dont want to do anything rash now while im angry...
post #2 of 3
did you try resetting the BIOS by removing the CMOS battery (small silver round battery), waiting about a minute and replacing it?
Black Oxygen
(15 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core 2 Quad Q9450 @ 3.2GHz Intel DP45SG Extreme Series Gigabyte 6850 Windforce Edition 4Gb of Some Generic 1333Mhz 
Hard DriveHard DriveCoolingOS
320Gb Western Digital Blue 2Tb Hitachi Cooler Master Hyper 212+ Windows 7 Ultimate x64 
MonitorKeyboardPowerCase
1280x1024 Sony SteelSeries Zboard (CounterStrike 1.6 Edition) Hercules 400W PSU Generic, Modded Case 
MouseMouse PadAudio
Razer Abyssus Windows 7 Mousepad Turtle Beach X12s 
  hide details  
Reply
Black Oxygen
(15 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core 2 Quad Q9450 @ 3.2GHz Intel DP45SG Extreme Series Gigabyte 6850 Windforce Edition 4Gb of Some Generic 1333Mhz 
Hard DriveHard DriveCoolingOS
320Gb Western Digital Blue 2Tb Hitachi Cooler Master Hyper 212+ Windows 7 Ultimate x64 
MonitorKeyboardPowerCase
1280x1024 Sony SteelSeries Zboard (CounterStrike 1.6 Edition) Hercules 400W PSU Generic, Modded Case 
MouseMouse PadAudio
Razer Abyssus Windows 7 Mousepad Turtle Beach X12s 
  hide details  
Reply
post #3 of 3
Thread Starter 
Yes, I found the solution, i have forced drivers and i think I need to reinstall windows, to much installed cr*p...
Sorry on the panic post..

Lock..
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: AMD/ATI
Overclock.net › Forums › Graphics Cards › AMD/ATI › HELP! I think i bought bad Sapphire HD7950/Is it bricked or what?