Overclock.net › Forums › Graphics Cards › AMD/ATI › Borderlands 2 with Hybrid PhysX
New Posts  All Forums:Forum Nav:

Borderlands 2 with Hybrid PhysX

post #1 of 334
Thread Starter 
For those curious on setting up borderlands 2 with Hybrid Physx, here's a quick guide on getting it working.
post #2 of 334
It is actually easier than that guide.

Steps for BL2 Hybrid PhysX

  1. Download latest ForceWare from nVidia.

  2. Install Forceware.

  3. Install version 1.05ff of the Hybrid Mod (LINK)

  4. Run the PhysX-HwSelection-set-GPU.cmd file in the Extras folder of the Hybrid Mod.

  5. (Now, to force physx on, even though the option is greyed out.)
    Goto your My Documents\My Games folder, within you should see a Borderlands 2 folder.

  6. Open the Borderlands 2 folder -> WillowGame -> Config folders.
    (Path should be something like: "C:\Users\\Documents\My Games\Borderlands 2\WillowGame\Config")

  7. Find and open the WillowEngine.ini file.

  8. Find the line that reads "PhysXLevel="
    (It probably says PhysXLevel=0)

  9. Now for the magic, PhysXLevel=1 is Medium and PhysXLevel=2 is High.

  10. Save your desired value, save, and then launch.

Voila! Hybrid physx in Borderlands 2. smile.gif
Edited by M1RAG3 - 9/18/12 at 4:57am
post #3 of 334
Thread Starter 
Thanks! That's a heck of a lot easier.
post #4 of 334
Can anybody confirm if it works with 79xx series AMD cards?
Ol' Trusty
(19 items)
 
NAStradamous
(12 items)
 
 
CPUMotherboardGraphicsRAM
Intel i7 2600k @ 5GHz, 1.50v Asus P8P67 Pro HIS IceQ HD7970 @ 1200 / 1700, 1.30v 4x4GB Kingston HyperX Blu DDR3-1600 @ DDR3-1866... 
Hard DriveHard DriveCoolingCooling
Crucial MX100 256GB SSD WD Green 2TB Swiftec 360mm radiator Apogee Drive II 
CoolingCoolingOSMonitor
Heatkiller X 7970 Swiftec MCRes Windows 8.1 Dell 3007WFP 
MonitorKeyboardPowerCase
Dell 17" 1280x1024 OCN Ducky Cherry MX Blue PC P&C Silencer MKIII 950w NZXT Source 530 
MouseMouse PadAudio
Logitech MX310 Blue Cheap junk 
CPUMotherboardGraphicsRAM
Intel Core 2 Duo T7800 @ 2.6GHz Aopen MP965-D Intel GMA 950 2x2GB DDR2-800 SODIMM 
Hard DriveCoolingOSMonitor
80GB Western Digital Blue Stock Aopen MP965-D Windows 7 + Steam Big Picture / Plex HT 32" Vizio LED TV 
CaseAudioAudioOther
Aopen MP965-D Lepai TA2020 Pioneer SP-BS21-LR Rosewill MCE Remote 
  hide details  
Reply
Ol' Trusty
(19 items)
 
NAStradamous
(12 items)
 
 
CPUMotherboardGraphicsRAM
Intel i7 2600k @ 5GHz, 1.50v Asus P8P67 Pro HIS IceQ HD7970 @ 1200 / 1700, 1.30v 4x4GB Kingston HyperX Blu DDR3-1600 @ DDR3-1866... 
Hard DriveHard DriveCoolingCooling
Crucial MX100 256GB SSD WD Green 2TB Swiftec 360mm radiator Apogee Drive II 
CoolingCoolingOSMonitor
Heatkiller X 7970 Swiftec MCRes Windows 8.1 Dell 3007WFP 
MonitorKeyboardPowerCase
Dell 17" 1280x1024 OCN Ducky Cherry MX Blue PC P&C Silencer MKIII 950w NZXT Source 530 
MouseMouse PadAudio
Logitech MX310 Blue Cheap junk 
CPUMotherboardGraphicsRAM
Intel Core 2 Duo T7800 @ 2.6GHz Aopen MP965-D Intel GMA 950 2x2GB DDR2-800 SODIMM 
Hard DriveCoolingOSMonitor
80GB Western Digital Blue Stock Aopen MP965-D Windows 7 + Steam Big Picture / Plex HT 32" Vizio LED TV 
CaseAudioAudioOther
Aopen MP965-D Lepai TA2020 Pioneer SP-BS21-LR Rosewill MCE Remote 
  hide details  
Reply
post #5 of 334
Using a HD6900 and GTS 250 myself, works flawlessly. smile.gif

Also if you are feeling brave you can up the PhysX settings as well in the same WillowEngine.ini file.

Currently mine is set to:
PhysXGpuHeapSize=512
PhysXMeshCacheSize=32

(DEFAULTS)
PhysXGpuHeapSize=128
PhysXMeshCacheSize=8

* Obviously don't exceed your VRAM capacity.
Edited by M1RAG3 - 9/18/12 at 4:50am
post #6 of 334
The option is available in game. No need to do this. It is possible that this is due to having PhysX already installed software wise.
post #7 of 334
Hybrid physx still doesn't work for borderlands 2. I was able to get physx to enable, but there is no gpu load for my nvida card. I deleted physx device .dll. My physx works for batman and batman ac. Can anyone check if they get any gpu load?
post #8 of 334
Upon further investigation add this line also under the [Engine.Engine] and [SystemSettings] sections, one of those is probably redundant though.

bDisablePhysXHardwareSupport=False

Also, in case you aren't getting GPU load do the following:

Open this in new browser tab:
http://www.ngohq.com/graphic-cards/22136-how-to-fix-hybrid-physx-with-latest-physx-and-geforce-285-solved.html

Just get the newest Physx from http://nvidia.com/object/physx_system_software.html and then the hybridize program from the above also.

Install PhysX System Software, then Hybrid mod 1.05ff, then ran Hybridize, then ran the PhysX-HwSelection-set-GPU.cmd file as admin (important).

Then go into your G:\Steam\steamapps\common\Borderlands 2\Binaries\Win32 folder and move all the PhysX_____.dll files except for PhysXExtensions.dll to somewhere else.

Now when you run BL2 you should see load on the PhysX GPU.


Edited by M1RAG3 - 9/18/12 at 4:29pm
post #9 of 334
I can confirm this working. primary card is a xfx 6870 and physx gpu is a pny 8500gt 512.
what a difference it makes with the effects
post #10 of 334
Thanks a lot its working now. Before it appeared to be enabled. But upon further insptection there was no gpu load. Now it works perfectly fine! Thanks so much! i am getting load now smile.gif
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: AMD/ATI
Overclock.net › Forums › Graphics Cards › AMD/ATI › Borderlands 2 with Hybrid PhysX