Overclock.net › Forums › Graphics Cards › AMD/ATI › Borderlands 2 with Hybrid PhysX
New Posts  All Forums:Forum Nav:

Borderlands 2 with Hybrid PhysX - Page 22

post #211 of 334
Quote:
Originally Posted by Scorpion49 View Post

Just got it working on my system, using 7970 for primary and a GTX 450 for Physx, show up to 30% load on the 450 with Physx set to high. REALLY nice because it takes the heat off of my FX 8150 which was causing a lot of slowdowns with the game trying to run Physx on the CPU.

Could you please share the steps you did to get it working? I've been trying for the last 4 days with no luck....
TheSadFlute
(16 items)
 
DyingHeart
(17 items)
 
 
CPUMotherboardGraphicsRAM
i7-6700K TUF Sabertooth MSI 1080 Ti 16GB 2400MHz C15 
Hard DriveHard DriveHard DriveCooling
Corsair 480GB LE 3TB WD Green Sammy 500GB 850 EVO H100i 
OSMonitorKeyboardPower
Windows 7 Pro  BenQ XR3501 Logitech G710+ EVGA G2 750W 
CaseMouseAudioAudio
Cooler Master Stryker Logitech G602 Asus Strix Nakamichi 5.1 
CPUMotherboardGraphicsRAM
Phenom II X4 965BE  Sapphire 790X Zotac GTX650  4GB Corsair 1066 DDR2 (1GBx4) 
Hard DriveHard DriveCoolingCooling
G.Skill Phoenix Pro 120GB WD 2TB Green Stock 3x120mm UQ fans 
OSMonitorKeyboardPower
W7 Pro SP1 x64 LG 21' 1680x1050 Genius  Corsair CX600 
CaseMouseMouse PadAudio
Gigabyte  E-Blue Mazer XFX WarPad On-board 
Audio
Logitech G35 
  hide details  
Reply
TheSadFlute
(16 items)
 
DyingHeart
(17 items)
 
 
CPUMotherboardGraphicsRAM
i7-6700K TUF Sabertooth MSI 1080 Ti 16GB 2400MHz C15 
Hard DriveHard DriveHard DriveCooling
Corsair 480GB LE 3TB WD Green Sammy 500GB 850 EVO H100i 
OSMonitorKeyboardPower
Windows 7 Pro  BenQ XR3501 Logitech G710+ EVGA G2 750W 
CaseMouseAudioAudio
Cooler Master Stryker Logitech G602 Asus Strix Nakamichi 5.1 
CPUMotherboardGraphicsRAM
Phenom II X4 965BE  Sapphire 790X Zotac GTX650  4GB Corsair 1066 DDR2 (1GBx4) 
Hard DriveHard DriveCoolingCooling
G.Skill Phoenix Pro 120GB WD 2TB Green Stock 3x120mm UQ fans 
OSMonitorKeyboardPower
W7 Pro SP1 x64 LG 21' 1680x1050 Genius  Corsair CX600 
CaseMouseMouse PadAudio
Gigabyte  E-Blue Mazer XFX WarPad On-board 
Audio
Logitech G35 
  hide details  
Reply
post #212 of 334
Quote:
Originally Posted by eXXon View Post

Could you please share the steps you did to get it working? I've been trying for the last 4 days with no luck....

Sure, the guides confused the crap out of me and I basically just tried stuff till it worked. I tried to follow these steps at first.
Quote:
Originally Posted by M1RAG3 View Post

It is actually easier than that guide.
Steps for BL2 Hybrid PhysX
  1. Download latest ForceWare from nVidia.
  2. Install Forceware.
  3. Install version 1.05ff of the Hybrid Mod (LINK)
  4. Run the PhysX-HwSelection-set-GPU.cmd file in the Extras folder of the Hybrid Mod.
  5. (Now, to force physx on, even though the option is greyed out.)
    Goto your My Documents\My Games folder, within you should see a Borderlands 2 folder.
  6. Open the Borderlands 2 folder -> WillowGame -> Config folders.
    (Path should be something like: "C:\Users\\Documents\My Games\Borderlands 2\WillowGame\Config")
  7. Find and open the WillowEngine.ini file.
  8. Find the line that reads "PhysXLevel="
    (It probably says PhysXLevel=0)
  9. Now for the magic, PhysXLevel=1 is Medium and PhysXLevel=2 is High.
  10. Save your desired value, save, and then launch.
Voila! Hybrid physx in Borderlands 2. smile.gif

It didn't quite work for me, so here is what I did in order.

1) Installed 310.54 Nvidia drivers with the GTS 450 as my ONLY card.
2) Added HD 7970 and installed 12.11b drivers.
3) Install version 1.05ff of the Hybrid Mod as above. Download it, run it as admininstrator, click "apply" and let it do its thing, exit when it says its done.
4) Run the PhysX-HwSelection-set-GPU.cmd file in the Extras folder of the Hybrid Mod as above, right click run it as administrator. For me it popped up and was gone so fast I can't tell if it did anything at all.
5) Downloaded Hybridiz (I tried to get you the link but the site seems to be down right now, just google hybridiz and find the ngoc page for it).
6) Run Hybridiz as administrator, should say that its applied.
7) Go to BL2 config (mine looks like this): X:\Users\Yourname\Documents\my games\borderlands 2\willowgame\Config and do this:
Quote:
Originally Posted by M1RAG3 View Post

Upon further investigation add this line also under the [Engine.Engine] and [SystemSettings] sections, one of those is probably redundant though.
bDisablePhysXHardwareSupport=False

8) Go to BL2 .dll files (mine are here): X:\Steam\steamapps\common\Borderlands 2\Binaries\Win32 and move everything that says "Physx" in front of it EXCEPT PhysXExtensions.dll out of the folder, I cut and pasted them to the desktop for the time being.
9) Run BL2 games, if all went well you should be able to change the PhysX level and see that it does load your Nvidia GPU.

EDIT: you might notice once its running that the first time an effect happens there is a stutter, if you create a profile in afterburner to use 3D clocks in 2D mode and apply that while playing it should fix this, as the card seems to drop to idle when its not being used for any Physx calculations.
Edited by Scorpion49 - 11/17/12 at 7:21pm
post #213 of 334
HAHA it worked...You're da man
up to 50% usage in that dragon ship with frames in the high 70s, before it would fall into the 20s when everyone starts shooting at me.

I thank you soooo much Scorpion49 for your help +rep
TheSadFlute
(16 items)
 
DyingHeart
(17 items)
 
 
CPUMotherboardGraphicsRAM
i7-6700K TUF Sabertooth MSI 1080 Ti 16GB 2400MHz C15 
Hard DriveHard DriveHard DriveCooling
Corsair 480GB LE 3TB WD Green Sammy 500GB 850 EVO H100i 
OSMonitorKeyboardPower
Windows 7 Pro  BenQ XR3501 Logitech G710+ EVGA G2 750W 
CaseMouseAudioAudio
Cooler Master Stryker Logitech G602 Asus Strix Nakamichi 5.1 
CPUMotherboardGraphicsRAM
Phenom II X4 965BE  Sapphire 790X Zotac GTX650  4GB Corsair 1066 DDR2 (1GBx4) 
Hard DriveHard DriveCoolingCooling
G.Skill Phoenix Pro 120GB WD 2TB Green Stock 3x120mm UQ fans 
OSMonitorKeyboardPower
W7 Pro SP1 x64 LG 21' 1680x1050 Genius  Corsair CX600 
CaseMouseMouse PadAudio
Gigabyte  E-Blue Mazer XFX WarPad On-board 
Audio
Logitech G35 
  hide details  
Reply
TheSadFlute
(16 items)
 
DyingHeart
(17 items)
 
 
CPUMotherboardGraphicsRAM
i7-6700K TUF Sabertooth MSI 1080 Ti 16GB 2400MHz C15 
Hard DriveHard DriveHard DriveCooling
Corsair 480GB LE 3TB WD Green Sammy 500GB 850 EVO H100i 
OSMonitorKeyboardPower
Windows 7 Pro  BenQ XR3501 Logitech G710+ EVGA G2 750W 
CaseMouseAudioAudio
Cooler Master Stryker Logitech G602 Asus Strix Nakamichi 5.1 
CPUMotherboardGraphicsRAM
Phenom II X4 965BE  Sapphire 790X Zotac GTX650  4GB Corsair 1066 DDR2 (1GBx4) 
Hard DriveHard DriveCoolingCooling
G.Skill Phoenix Pro 120GB WD 2TB Green Stock 3x120mm UQ fans 
OSMonitorKeyboardPower
W7 Pro SP1 x64 LG 21' 1680x1050 Genius  Corsair CX600 
CaseMouseMouse PadAudio
Gigabyte  E-Blue Mazer XFX WarPad On-board 
Audio
Logitech G35 
  hide details  
Reply
post #214 of 334
Quote:
Originally Posted by eXXon View Post

HAHA it worked...You're da man
up to 50% usage in that dragon ship with frames in the high 70s, before it would fall into the 20s when everyone starts shooting at me.
I thank you soooo much Scorpion49 for your help +rep

Glad to see it worked for you. I'm enjoying it but my 7970 is not, keeps hitting 95*C and throttling. Time to take it apart and re-TIM I think.
post #215 of 334
Quote:
Originally Posted by eXXon View Post

Could you please share the steps you did to get it working? I've been trying for the last 4 days with no luck....
What I did was I installed the 2nd card. Then, installed the nvidia graphics drive 285.62 and ONLY THAT because the internet told me to. Make sure you do a custom installation and uncheck everything else. The program installation required a restart so I restarted it. Then I installed physx 9.12.0613 " the latest one". Then I ran hybridz.exe as an administrator after running 1.05ff as administrator (can't hurt right?). I restarted computer and both cards showed lowed and I kept above 30 fps instead of going down to 10.
Quote:
Originally Posted by Scorpion49 View Post

Glad to see it worked for you. I'm enjoying it but my 7970 is not, keeps hitting 95*C and throttling. Time to take it apart and re-TIM I think.
What case do you have? I have antec 900 and both gpus stay at around 60. The nvidia 9800gt maxes at like 60% and the 6850 maxes at 65%
Edited by HBTechnoDude - 11/18/12 at 12:28am
post #216 of 334
Quote:
Originally Posted by HBTechnoDude View Post

What case do you have? I have antec 900 and both gpus stay at around 60. The nvidia 9800gt maxes at like 60% and the 6850 maxes at 65%

Its definitely the card, not the case. I have a Switch 810 with 10 fans in it, it keeps every other GPU on the planet nice and cool but this one is really hot no matter what. The 7950 I had earlier in the day was nice and cool as well, but its mini display ports did not work so I had to return it.
post #217 of 334
Well, although physx is working (BL2 looks really good) and frames are always above 70 with everything maxed out, the game stutters like craaazy.
(every 5-10 sec, 3-4 half a sec freezes in a row). Without the 580 with the same settings, no stutter happens but fps go down to mid 20s in same conditions.
I've installed/removed several physx drivers, would that be the cause of the stutter? I know the 500 series is not good at physx, but I thought a 580 for physx would do great...
Anyone else facing this poblem? Any suggestions on how to solve it are much appreciated, I'll try anything..
Thanks again.
TheSadFlute
(16 items)
 
DyingHeart
(17 items)
 
 
CPUMotherboardGraphicsRAM
i7-6700K TUF Sabertooth MSI 1080 Ti 16GB 2400MHz C15 
Hard DriveHard DriveHard DriveCooling
Corsair 480GB LE 3TB WD Green Sammy 500GB 850 EVO H100i 
OSMonitorKeyboardPower
Windows 7 Pro  BenQ XR3501 Logitech G710+ EVGA G2 750W 
CaseMouseAudioAudio
Cooler Master Stryker Logitech G602 Asus Strix Nakamichi 5.1 
CPUMotherboardGraphicsRAM
Phenom II X4 965BE  Sapphire 790X Zotac GTX650  4GB Corsair 1066 DDR2 (1GBx4) 
Hard DriveHard DriveCoolingCooling
G.Skill Phoenix Pro 120GB WD 2TB Green Stock 3x120mm UQ fans 
OSMonitorKeyboardPower
W7 Pro SP1 x64 LG 21' 1680x1050 Genius  Corsair CX600 
CaseMouseMouse PadAudio
Gigabyte  E-Blue Mazer XFX WarPad On-board 
Audio
Logitech G35 
  hide details  
Reply
TheSadFlute
(16 items)
 
DyingHeart
(17 items)
 
 
CPUMotherboardGraphicsRAM
i7-6700K TUF Sabertooth MSI 1080 Ti 16GB 2400MHz C15 
Hard DriveHard DriveHard DriveCooling
Corsair 480GB LE 3TB WD Green Sammy 500GB 850 EVO H100i 
OSMonitorKeyboardPower
Windows 7 Pro  BenQ XR3501 Logitech G710+ EVGA G2 750W 
CaseMouseAudioAudio
Cooler Master Stryker Logitech G602 Asus Strix Nakamichi 5.1 
CPUMotherboardGraphicsRAM
Phenom II X4 965BE  Sapphire 790X Zotac GTX650  4GB Corsair 1066 DDR2 (1GBx4) 
Hard DriveHard DriveCoolingCooling
G.Skill Phoenix Pro 120GB WD 2TB Green Stock 3x120mm UQ fans 
OSMonitorKeyboardPower
W7 Pro SP1 x64 LG 21' 1680x1050 Genius  Corsair CX600 
CaseMouseMouse PadAudio
Gigabyte  E-Blue Mazer XFX WarPad On-board 
Audio
Logitech G35 
  hide details  
Reply
post #218 of 334
Quote:
Originally Posted by eXXon View Post

Well, although physx is working (BL2 looks really good) and frames are always above 70 with everything maxed out, the game stutters like craaazy.
(every 5-10 sec, 3-4 half a sec freezes in a row). Without the 580 with the same settings, no stutter happens but fps go down to mid 20s in same conditions.
I've installed/removed several physx drivers, would that be the cause of the stutter? I know the 500 series is not good at physx, but I thought a 580 for physx would do great...
Anyone else facing this poblem? Any suggestions on how to solve it are much appreciated, I'll try anything..
Thanks again.

I had some stuttering, I solved it by doing a few things.

1) vsync off
2) frame rate to capped 30 (my card can only do ~45 fps at 5760x1200 but you can try 60 or 120)
3) go in the WillowEngine.ini config file, scroll way down to system settings and change DynamicShadows=True to False this one improved my smoothness by a lot, no more stuttering and jumping frame rates. YMMV.
post #219 of 334
Quote:
Originally Posted by Scorpion49 View Post

I had some stuttering, I solved it by doing a few things.
1) vsync off
2) frame rate to capped 30 (my card can only do ~45 fps at 5760x1200 but you can try 60 or 120)
3) go in the WillowEngine.ini config file, scroll way down to system settings and change DynamicShadows=True to False this one improved my smoothness by a lot, no more stuttering and jumping frame rates. YMMV.

Tried the vsunc & fps capper with no luck.
Will report back on the dynamicshadows (found 2 true)....
What about these?
PhysXGpuHeapSize=256
PhysXMeshCacheSize=16

Thanks mate thumb.gif
TheSadFlute
(16 items)
 
DyingHeart
(17 items)
 
 
CPUMotherboardGraphicsRAM
i7-6700K TUF Sabertooth MSI 1080 Ti 16GB 2400MHz C15 
Hard DriveHard DriveHard DriveCooling
Corsair 480GB LE 3TB WD Green Sammy 500GB 850 EVO H100i 
OSMonitorKeyboardPower
Windows 7 Pro  BenQ XR3501 Logitech G710+ EVGA G2 750W 
CaseMouseAudioAudio
Cooler Master Stryker Logitech G602 Asus Strix Nakamichi 5.1 
CPUMotherboardGraphicsRAM
Phenom II X4 965BE  Sapphire 790X Zotac GTX650  4GB Corsair 1066 DDR2 (1GBx4) 
Hard DriveHard DriveCoolingCooling
G.Skill Phoenix Pro 120GB WD 2TB Green Stock 3x120mm UQ fans 
OSMonitorKeyboardPower
W7 Pro SP1 x64 LG 21' 1680x1050 Genius  Corsair CX600 
CaseMouseMouse PadAudio
Gigabyte  E-Blue Mazer XFX WarPad On-board 
Audio
Logitech G35 
  hide details  
Reply
TheSadFlute
(16 items)
 
DyingHeart
(17 items)
 
 
CPUMotherboardGraphicsRAM
i7-6700K TUF Sabertooth MSI 1080 Ti 16GB 2400MHz C15 
Hard DriveHard DriveHard DriveCooling
Corsair 480GB LE 3TB WD Green Sammy 500GB 850 EVO H100i 
OSMonitorKeyboardPower
Windows 7 Pro  BenQ XR3501 Logitech G710+ EVGA G2 750W 
CaseMouseAudioAudio
Cooler Master Stryker Logitech G602 Asus Strix Nakamichi 5.1 
CPUMotherboardGraphicsRAM
Phenom II X4 965BE  Sapphire 790X Zotac GTX650  4GB Corsair 1066 DDR2 (1GBx4) 
Hard DriveHard DriveCoolingCooling
G.Skill Phoenix Pro 120GB WD 2TB Green Stock 3x120mm UQ fans 
OSMonitorKeyboardPower
W7 Pro SP1 x64 LG 21' 1680x1050 Genius  Corsair CX600 
CaseMouseMouse PadAudio
Gigabyte  E-Blue Mazer XFX WarPad On-board 
Audio
Logitech G35 
  hide details  
Reply
post #220 of 334
Quote:
Originally Posted by eXXon View Post

Tried the vsunc & fps capper with no luck.
Will report back on the dynamicshadows (found 2 true)....
What about these?
PhysXGpuHeapSize=256
PhysXMeshCacheSize=16
Thanks mate thumb.gif

I think those just adjust how many PhysX effects you can have on the screen, I found that the stuttering had nothing in particular to do with the Physx after I stopped the Nvidia card from idling.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: AMD/ATI
Overclock.net › Forums › Graphics Cards › AMD/ATI › Borderlands 2 with Hybrid PhysX