Overclock.net › Forums › Graphics Cards › AMD/ATI › Borderlands 2 with Hybrid PhysX
New Posts  All Forums:Forum Nav:

Borderlands 2 with Hybrid PhysX - Page 26

post #251 of 334
Quote:
Originally Posted by Acid Reaper View Post

First off would like to say THANK YOU! to everyone on this Thread, you guys are solely responsible for getting my hybrid to work, where others failed you succeded biggrin.gif
Spent about 2.5 hours last night trying to configure new 9800GT I bought. 1st ran into Physx drivers out of date issue, downgraded to older version of Physx and seems to have fixed it, think the newest drivers aren't compatible with hybridize? My main issue is the 9800GT only seems to be carrying a 10-20% load, like 30% tops during physx events (at 0% while nothing happening) and spikes wildly, I seem to be running into same issue as eXXon where GPU load on nvidia card is really inconsistent and causing stuttering (GPU load drops=FPS drops). Fluidmark puts on a consistent 60% to 80% load and improves my frames about 80-90% over CPU load tests.
Is there any way to boost borderlands use of physx GPU or is it just broken atm mad.gif I've already adjusted the Heap size to 512 (to match 1gb card), turned off dynamic shadows are forced hardware via willowengine.ini
Sorry for the TLDR but ive been reading on other forums about restricting particle counts and adding a timer to make them eventually disappear, think im going to experiment a bit when i get home (at work right now) and will post my findings if it seems to help any. I would think its going to make a huge difference on at least some of the lower end dedicated cards people are using like mine.
I saw someone on a different forum say every vid card they tried a gt 430 and 460 wouldn't go past 80%. I personally don't go past 30% on my 9800gt. It crashs my computer a lot having hybrid physx unless I disable the card and then do a cold boot when I want to play physx. I use latest physx drivers and have found it to work with 285.02 and 302.67. If you get a weird floating point error when doing hybrid physx don't google it just reinstall catalyst.
post #252 of 334
Quote:
Originally Posted by HBTechnoDude View Post

I saw someone on a different forum say every vid card they tried a gt 430 and 460 wouldn't go past 80%. I personally don't go past 30% on my 9800gt. It crashs my computer a lot having hybrid physx unless I disable the card and then do a cold boot when I want to play physx. I use latest physx drivers and have found it to work with 285.02 and 302.67. If you get a weird floating point error when doing hybrid physx don't google it just reinstall catalyst.

Yeah with further testing the 9800GT seems to just run at about 30% most the time, going up to about 70% to 80% in like the whirlpool area and caverns. 9800GT just doesnt seem powerful enough to handle High settings but does ok on medium, can maintain about 35 40 frames on medium in whirlpool room. Using the Afterburner profiles (2D and 3D) i was able to get the card to stop idleing which helped with the stuttering.

Also messed around with some of the physics settings and I found limited particles to dramatically increase long term and intense firefight performance. I found that as i progressed through a level all the built up particles were just slowly draining system performance and started causing pretty bad FPS drops about 20 to 30 min into a zone, or rapidly deteriorate during a big battle (especially with 4 players). ]

Modifying the MaxParticleResize=0 line in the willowengine.ini will change the max number of physx particles allowed in game. 0 being default which is infinite.

On lower end cards like the 9800GT once these particles seem to hit a certain number the game poops itself. I am currently playing around with different numbers but 100,000 seems to be working pretty well. There's enough particles that you dont really notice anything disappearing around you but the count never gets high enough to start causing slowdown. 10,000 i found to be way too low, you can quickly see particles disappearing off the ground even just shooting at a single enemy. But try that out should fix the crashing issue your experiencing from your card overloading HTTechnoDude.
post #253 of 334
I'll try that thanks acid reaper
post #254 of 334
I'll try it as well and report back - set mine to 90k.

EDIT: reporting back - that seems to prevent the random crashing, at least so far (played for a few hours, no fail).

EDIT EDIT:
just crashed twice within 2 minutes of loading. humbug.
Edited by u3b3rg33k - 12/3/12 at 5:53pm
 
Reginald
(14 items)
 
GLaDOS (v3)
(12 items)
 
CPUMotherboardGraphicsGraphics
i7-970 @ 4.14GHz 1.350v P6T7 WS Supercomputer MSI 7970 GHz Edition HIS 6950 
RAMHard DriveHard DriveCooling
48GB Crucial Ballistix @1660MHz 9-9-9-27 Momentus XT intel 480GB 520 series INX-720 
OSMonitorMonitorMonitor
win7pro Soyo P-MVA 1200p 24" Dell 24" 1200p Dell 17" 4:3 (market tickers) 
KeyboardPowerCaseMouse
Dell Quietkey AX850 PC-Z60 Logitech G5 
CPUMotherboardGraphicsRAM
Q6700 @ 3.0 (stock volts) ASUS P5WDG2-WS PRO HIS 6950 2GB turbo (unlocked) 8GB DDR2 800 
Hard DriveOptical DriveOSMonitor
9550SX w/BBU + 4x 250GB 7.2k Raid 5 HL-DT-ST DVDRW GSA-H30L Kali Linux VNC (TC Rig, baby) 
KeyboardPowerCaseMouse
Dell QuietKey (PS2) Truepower Trio 650 Koolance PC3-420SL Logitech G5 
  hide details  
Reply
 
Reginald
(14 items)
 
GLaDOS (v3)
(12 items)
 
CPUMotherboardGraphicsGraphics
i7-970 @ 4.14GHz 1.350v P6T7 WS Supercomputer MSI 7970 GHz Edition HIS 6950 
RAMHard DriveHard DriveCooling
48GB Crucial Ballistix @1660MHz 9-9-9-27 Momentus XT intel 480GB 520 series INX-720 
OSMonitorMonitorMonitor
win7pro Soyo P-MVA 1200p 24" Dell 24" 1200p Dell 17" 4:3 (market tickers) 
KeyboardPowerCaseMouse
Dell Quietkey AX850 PC-Z60 Logitech G5 
CPUMotherboardGraphicsRAM
Q6700 @ 3.0 (stock volts) ASUS P5WDG2-WS PRO HIS 6950 2GB turbo (unlocked) 8GB DDR2 800 
Hard DriveOptical DriveOSMonitor
9550SX w/BBU + 4x 250GB 7.2k Raid 5 HL-DT-ST DVDRW GSA-H30L Kali Linux VNC (TC Rig, baby) 
KeyboardPowerCaseMouse
Dell QuietKey (PS2) Truepower Trio 650 Koolance PC3-420SL Logitech G5 
  hide details  
Reply
post #255 of 334
Thanks to Scorpion49 instructions I was finally able to get hybrid physx working along with ~30% load on my 650 ti.
At first the instructions by M1RAG3 which didn't work. Then I tried his second set of instructions with hybridiz which also failed.
Someone should really modify the first couple of posts so that noobs like myself who don't read through the entire thread won't all into the very first pothole.
Here's a couple notes in (*) that would hopefully help someone not freak out like I did:
Quote:
Originally Posted by Scorpion49 View Post


*When uninstall drivers, my screen went off and would keep flashing blankly. After freaking out, I eventually figured out that I needed to use the other ports from the other display devices (other HDMI from nvidia/ati or VGA via mobo.)

*After uninstalling all drivers, I removed my ati card from mobo.

*I installed the nvida's drivers while plugged through VGA port of the mobo.


1) Installed 310.54 Nvidia drivers with the GTS 450 as my ONLY card.

*I did the custom clean re-install option of nvida's drivers.
*I only left the drivers, physx, nvidia update options checked.

*Restarted when prompted.

*After restarting, I had to use nvida's ports. I did the rest of Scorpion49's instructions on the nvida's ports.

*After I installed the nvida drivers I was able to go to the nvida control panel (for the first time). I went to the physx tab and selected physx to render on GPU. This step was probably useless but I happened to run into it.


2) Added HD 7970 and installed 12.11b drivers.
3) Install version 1.05ff of the Hybrid Mod as above. Download it, run it as admininstrator, click "apply" and let it do its thing, exit when it says its done.
4) Run the PhysX-HwSelection-set-GPU.cmd file in the Extras folder of the Hybrid Mod as above, right click run it as administrator. For me it popped up and was gone so fast I can't tell if it did anything at all.
5) Downloaded Hybridiz (I tried to get you the link but the site seems to be down right now, just google hybridiz and find the ngoc page for it).
6) Run Hybridiz as administrator, should say that its applied.
7) Go to BL2 config (mine looks like this): X:\Users\Yourname\Documents\my games\borderlands 2\willowgame\Config and do this:
8) Go to BL2 .dll files (mine are here): X:\Steam\steamapps\common\Borderlands 2\Binaries\Win32 and move everything that says "Physx" in front of it EXCEPT PhysXExtensions.dll out of the folder, I cut and pasted them to the desktop for the time being.
9) Run BL2 games, if all went well you should be able to change the PhysX level and see that it does load your Nvidia GPU.
EDIT: you might notice once its running that the first time an effect happens there is a stutter, if you create a profile in afterburner to use 3D clocks in 2D mode and apply that while playing it should fix this, as the card seems to drop to idle when its not being used for any Physx calculations.

Hopefully this helps someone!
post #256 of 334
Quote:
Originally Posted by M1RAG3 View Post

Upon further investigation add this line also under the [Engine.Engine] and [SystemSettings] sections, one of those is probably redundant though.
bDisablePhysXHardwareSupport=False
Also, in case you aren't getting GPU load do the following:
Open this in new browser tab:
http://www.ngohq.com/graphic-cards/22136-how-to-fix-hybrid-physx-with-latest-physx-and-geforce-285-solved.html
Just get the newest Physx from http://nvidia.com/object/physx_system_software.html and then the hybridize program from the above also.
Install PhysX System Software, then Hybrid mod 1.05ff, then ran Hybridize, then ran the PhysX-HwSelection-set-GPU.cmd file as admin (important).
Then go into your G:\Steam\steamapps\common\Borderlands 2\Binaries\Win32 folder and move all the PhysX_____.dll files except for PhysXExtensions.dll to somewhere else.
Now when you run BL2 you should see load on the PhysX GPU.
Remove all cuda****.dll files
post #257 of 334
what if i want to use physx in many games and can cuda still work?
post #258 of 334
Quote:
Originally Posted by kimaniking View Post

what if i want to use physx in many games and can cuda still work?

Yes. Cuda files are removed from the game's directory and has nothing to do with Physx drivers.
TheSadFlute
(16 items)
 
DyingHeart
(17 items)
 
 
CPUMotherboardGraphicsRAM
i7-6700K TUF Sabertooth MSI 1080 Ti 16GB 2400MHz C15 
Hard DriveHard DriveHard DriveCooling
Corsair 480GB LE 3TB WD Green Sammy 500GB 850 EVO H100i 
OSMonitorKeyboardPower
Windows 7 Pro  BenQ XR3501 Logitech G710+ EVGA G2 750W 
CaseMouseAudioAudio
Cooler Master Stryker Logitech G602 Asus Strix Nakamichi 5.1 
CPUMotherboardGraphicsRAM
Phenom II X4 965BE  Sapphire 790X Zotac GTX650  4GB Corsair 1066 DDR2 (1GBx4) 
Hard DriveHard DriveCoolingCooling
G.Skill Phoenix Pro 120GB WD 2TB Green Stock 3x120mm UQ fans 
OSMonitorKeyboardPower
W7 Pro SP1 x64 LG 21' 1680x1050 Genius  Corsair CX600 
CaseMouseMouse PadAudio
Gigabyte  E-Blue Mazer XFX WarPad On-board 
Audio
Logitech G35 
  hide details  
Reply
TheSadFlute
(16 items)
 
DyingHeart
(17 items)
 
 
CPUMotherboardGraphicsRAM
i7-6700K TUF Sabertooth MSI 1080 Ti 16GB 2400MHz C15 
Hard DriveHard DriveHard DriveCooling
Corsair 480GB LE 3TB WD Green Sammy 500GB 850 EVO H100i 
OSMonitorKeyboardPower
Windows 7 Pro  BenQ XR3501 Logitech G710+ EVGA G2 750W 
CaseMouseAudioAudio
Cooler Master Stryker Logitech G602 Asus Strix Nakamichi 5.1 
CPUMotherboardGraphicsRAM
Phenom II X4 965BE  Sapphire 790X Zotac GTX650  4GB Corsair 1066 DDR2 (1GBx4) 
Hard DriveHard DriveCoolingCooling
G.Skill Phoenix Pro 120GB WD 2TB Green Stock 3x120mm UQ fans 
OSMonitorKeyboardPower
W7 Pro SP1 x64 LG 21' 1680x1050 Genius  Corsair CX600 
CaseMouseMouse PadAudio
Gigabyte  E-Blue Mazer XFX WarPad On-board 
Audio
Logitech G35 
  hide details  
Reply
post #259 of 334
Hello: D

I'm a user with an ATI 6950 as main plots and a Nvidia GT430 to Physx/Nvidia3DVision.

I recently purchased it and Boderlands2 ye done this:

1-formatted hard drive, had windows 8

2-Installed drivers from ATI

3-Restart

4-installed the Nvidia 285.62 drivers. They are putting on the page that works with version 1.05ff

5-installed version Hybrid-PhysX-mod-1.05ff

6-I go to the extras folder and run: PhysX-HwSelection-set-GPU

7 - Reboot

8 - plug the monitor to the graphics Nvidia 430, go into your control panel and select GPU for PhysX.

9-Again I plug the monitor to the ATI

10 - and put WillowEngine edited by PhysXLevel = 2, unless the file

11-released the game and voila: D I have Physx, but physx managed by the CPU instead of the GPU: (


Help please: (

Greetings and thanks
Edited by alkonreal - 12/23/12 at 9:05am
post #260 of 334
Quote:
Originally Posted by alkonreal View Post

Hello: D
I'm a user with an ATI 6950 as main plots and a Nvidia GT430 to Physx/Nvidia3DVision.
I recently purchased it and Boderlands2 ye done this:
1-formatted hard drive, had windows 8
2-Installed drivers from ATI
3-Restart
4-installed the Nvidia 285.62 drivers. They are putting on the page that works with version 1.05ff
5-installed version Hybrid-PhysX-mod-1.05ff
6-I go to the extras folder and run: PhysX-HwSelection-set-GPU
7 - Reboot
8 - plug the monitor to the graphics Nvidia 430, go into your control panel and select GPU for PhysX.
9-Again I plug the monitor to the ATI
10 - and put WillowEngine edited by PhysXLevel = 2, unless the file
11-released the game and voila: D I have Physx, but physx managed by the CPU instead of the GPU: (
Help please: (
Greetings and thanks

You have to add a line to the willowengine. look at post 256 a few posts above you.
TheSadFlute
(16 items)
 
DyingHeart
(17 items)
 
 
CPUMotherboardGraphicsRAM
i7-6700K TUF Sabertooth MSI 1080 Ti 16GB 2400MHz C15 
Hard DriveHard DriveHard DriveCooling
Corsair 480GB LE 3TB WD Green Sammy 500GB 850 EVO H100i 
OSMonitorKeyboardPower
Windows 7 Pro  BenQ XR3501 Logitech G710+ EVGA G2 750W 
CaseMouseAudioAudio
Cooler Master Stryker Logitech G602 Asus Strix Nakamichi 5.1 
CPUMotherboardGraphicsRAM
Phenom II X4 965BE  Sapphire 790X Zotac GTX650  4GB Corsair 1066 DDR2 (1GBx4) 
Hard DriveHard DriveCoolingCooling
G.Skill Phoenix Pro 120GB WD 2TB Green Stock 3x120mm UQ fans 
OSMonitorKeyboardPower
W7 Pro SP1 x64 LG 21' 1680x1050 Genius  Corsair CX600 
CaseMouseMouse PadAudio
Gigabyte  E-Blue Mazer XFX WarPad On-board 
Audio
Logitech G35 
  hide details  
Reply
TheSadFlute
(16 items)
 
DyingHeart
(17 items)
 
 
CPUMotherboardGraphicsRAM
i7-6700K TUF Sabertooth MSI 1080 Ti 16GB 2400MHz C15 
Hard DriveHard DriveHard DriveCooling
Corsair 480GB LE 3TB WD Green Sammy 500GB 850 EVO H100i 
OSMonitorKeyboardPower
Windows 7 Pro  BenQ XR3501 Logitech G710+ EVGA G2 750W 
CaseMouseAudioAudio
Cooler Master Stryker Logitech G602 Asus Strix Nakamichi 5.1 
CPUMotherboardGraphicsRAM
Phenom II X4 965BE  Sapphire 790X Zotac GTX650  4GB Corsair 1066 DDR2 (1GBx4) 
Hard DriveHard DriveCoolingCooling
G.Skill Phoenix Pro 120GB WD 2TB Green Stock 3x120mm UQ fans 
OSMonitorKeyboardPower
W7 Pro SP1 x64 LG 21' 1680x1050 Genius  Corsair CX600 
CaseMouseMouse PadAudio
Gigabyte  E-Blue Mazer XFX WarPad On-board 
Audio
Logitech G35 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: AMD/ATI
Overclock.net › Forums › Graphics Cards › AMD/ATI › Borderlands 2 with Hybrid PhysX