Overclock.net › Forums › Components › Power Supplies › Another dead PSU thread
New Posts  All Forums:Forum Nav:

Another dead PSU thread

post #1 of 5
Thread Starter 
So I have a PSU that I think is likely a little fried. I had it plugged in for a few days and then i think a power serge happened and it started smoking so I shut it off and later I decided to test it. it worked and all nothing really seemed to be wrong.

now I'm having a problem that I was having when before I RMAed my PSU. which was, it would crap out (black out restart no bsod) whenever I had SLI on and I was running a high usage game.
That is the only time i can get it to crash in sli. though not necessarily if the game is pushing my cards even 80% but mostly it crashes when its above 50% usage anyways its hard to say since i cant chek what it was at when it crashed. if i take out my other GPU however nothing I do can get it to crash. I up my voltage on my cpu and gpu to my highest overclocks and no crash. Then I lowered them all to my clocks to stock with optimized voltage. stable tested or coarse. and I still get crashes with SLI. so I'm stumped.

It could be my MoBO which also smoked at one time when i plugged a fan into my cpu alt fan slot which has 4 pins then 2-3 more pins lined up next to it but with no plastic piece over top of them. so i must have hit those extra pins. but how would that cause the problems I'm having and why not all the time why only in sli at high usage.

I just want to know if RMAing the psu is the thing to do. I do have a serge protector now so it shouldn't happen again is it is the psu.
I just don't want RMA too may times because it costs like $30 something ever time and i might as well just buy new parts and a better brand of psu than thermaltake if im going to have to RMA more than this last time.

I'm not the best typeset so excuse any errors please.
post #2 of 5

Which Thermaltake PSU do you have?

 

Which video cards do you have?

It's a computer!
(19 items)
 
  
CPUMotherboardGraphicsRAM
i5-2500K @ 4.5GHz (1.368-1.384V fixed voltage) ASUS P8P67 EVO B3 (UEFI ver. 1850) GTX 780 ASUS DirectCU II (1228 / 6300, 1.180V) G.SKILL Ripjaws X 8GB (2 x 4GB) 1866MHz, CL9 
Hard DriveHard DriveHard DriveOptical Drive
250 GB Samsung 840 EVO (C:\) 250 GB Samsung 840 EVO (D:\) 150 GB WD VelociRaptor Samsung SH-S243N 24x DVD Burner 
Optical DriveCoolingOSMonitor
Samsung SH-S203N 20X DVD Burner Thermaltake Frio Win 7 Home Premium x64 SP1 Retail AOC G2460PG (24" 1920 x 1080 144Hz G-SYNC) 
KeyboardPowerCaseMouse
Filco Majestouch 104-key Cherry MX Blues w/NKRO Corsair HX650 (Bronze, ordered on 12-12-2009) CM 690 Intellimouse Optical (1.1A) 1000Hz polling rate 
Mouse PadAudioAudio
Basic, but premium round X-Fi Titanium HD Klipsch ProMedia 2.1 (with 16 AWG Monster Cable... 
  hide details  
Reply
It's a computer!
(19 items)
 
  
CPUMotherboardGraphicsRAM
i5-2500K @ 4.5GHz (1.368-1.384V fixed voltage) ASUS P8P67 EVO B3 (UEFI ver. 1850) GTX 780 ASUS DirectCU II (1228 / 6300, 1.180V) G.SKILL Ripjaws X 8GB (2 x 4GB) 1866MHz, CL9 
Hard DriveHard DriveHard DriveOptical Drive
250 GB Samsung 840 EVO (C:\) 250 GB Samsung 840 EVO (D:\) 150 GB WD VelociRaptor Samsung SH-S243N 24x DVD Burner 
Optical DriveCoolingOSMonitor
Samsung SH-S203N 20X DVD Burner Thermaltake Frio Win 7 Home Premium x64 SP1 Retail AOC G2460PG (24" 1920 x 1080 144Hz G-SYNC) 
KeyboardPowerCaseMouse
Filco Majestouch 104-key Cherry MX Blues w/NKRO Corsair HX650 (Bronze, ordered on 12-12-2009) CM 690 Intellimouse Optical (1.1A) 1000Hz polling rate 
Mouse PadAudioAudio
Basic, but premium round X-Fi Titanium HD Klipsch ProMedia 2.1 (with 16 AWG Monster Cable... 
  hide details  
Reply
post #3 of 5
Thread Starter 
2 x 560 ti 2gb evga

1200 Watt - Thermaltake TR2 TRX-1200M1 x
post #4 of 5
Quote:
Originally Posted by TimmyG View Post

2 x 560 ti 2gb evga
1200 Watt - Thermaltake TR2 TRX-1200M1 x

PSU is garbage. IDC if you use half of the "claimed" wattage, it's still crap.

RMA unit (if worth it), sell it, buy Seasonic X 650 (if in USA) for $100 or something.

- Also, make it clear you have RMA'd the PSU before, and can't flip the cost to once again go through with it. They might help you out.
Simplicity
(16 items)
 
#2 PC
(12 items)
 
 
CPUMotherboardGraphicsRAM
i5 6600k MSI Gaming Z170A EVGA GTX 980 Classified Crucial Ballistix Tactical (2 x 8GB) DDR4 2666 
Hard DriveCoolingOSMonitor
Samsung Pro 950 Cryorig H7 Windows 7 Ultimate x64 CrossOver 2560x1440 IPS 
PowerCaseMouseMouse Pad
Rosewill Capstone 550-M Phanteks Enthoo Pro RAZER Abyssus Mirror Special Edition XTRAC Ripper 
AudioAudioAudioAudio
Asus Xonar Essence STX Dayton Audio B652 Lepai Tripath Class-T Hi-Fi Audio Mini Amplifier 8 Inch 60-Watt Powered Subwoofer 
CPUMotherboardGraphicsRAM
Intel q9300 Intel DP45SG MSI TFII GTX 660 Corsair Dominator 1333 
Hard DriveCoolingOSMonitor
Corsair Force 3 90gb Deepcool Gammaxx 300 Windows 7 Samsung SyncMaster 932bw 
KeyboardPowerCaseMouse
Dell Rosewill Lightning 800w CM Stryker Dell 
  hide details  
Reply
Simplicity
(16 items)
 
#2 PC
(12 items)
 
 
CPUMotherboardGraphicsRAM
i5 6600k MSI Gaming Z170A EVGA GTX 980 Classified Crucial Ballistix Tactical (2 x 8GB) DDR4 2666 
Hard DriveCoolingOSMonitor
Samsung Pro 950 Cryorig H7 Windows 7 Ultimate x64 CrossOver 2560x1440 IPS 
PowerCaseMouseMouse Pad
Rosewill Capstone 550-M Phanteks Enthoo Pro RAZER Abyssus Mirror Special Edition XTRAC Ripper 
AudioAudioAudioAudio
Asus Xonar Essence STX Dayton Audio B652 Lepai Tripath Class-T Hi-Fi Audio Mini Amplifier 8 Inch 60-Watt Powered Subwoofer 
CPUMotherboardGraphicsRAM
Intel q9300 Intel DP45SG MSI TFII GTX 660 Corsair Dominator 1333 
Hard DriveCoolingOSMonitor
Corsair Force 3 90gb Deepcool Gammaxx 300 Windows 7 Samsung SyncMaster 932bw 
KeyboardPowerCaseMouse
Dell Rosewill Lightning 800w CM Stryker Dell 
  hide details  
Reply
post #5 of 5
Thread Starter 
I'll call and see what i can get out of them, thanks

I would rather replace it at this point and if they won't work with me ill just deal i guess. since it really is that crappy.

Also can run my games fine with both GPUs in but with SLI off if that makes any difference.
I just played Borderlands 2 but my second GPU was just set to phys x never went above 20% usage for more than a few seconds.
so its just the SLI? or still the amount of voltage 2 GPU at above 50% pull.
IDK its confusing trying to nail down my symptoms
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Power Supplies
Overclock.net › Forums › Components › Power Supplies › Another dead PSU thread