Overclock.net › Forums › Components › Power Supplies › Problem with PSU (possible rma)
New Posts  All Forums:Forum Nav:

Problem with PSU (possible rma)

post #1 of 34
Thread Starter 
my PSU http://www.ncix.com/products/?sku=50802

I tried installing a Logisys LED http://www.ncix.com/products/?sku=56183
I installed the lights correctly using the 4 pin molex (provided with the lights) and the 6 pin peripheral connector (provided with the PSU)

Upon powering up the computer; the LEDs,the computer fan, the mobo LEDs and the GPU flickered on, then off after a split second.

SO i uninstall the lights and boot the computer up, the CPU runs and the fans are spinning. But the gpu has no signal.
upon further inspection, the GPU fans spin for a split second then stop when booting.
There are no beeps when it boots and the Mobos LEDs light up 1 out of 4 meaning very little power is reaching the extremities
mobo: http://www.ncix.com/products/?sku=69231
CPU http://www.ncix.com/products/?sku=70541

RMA my psu?
Did the logisys LEDs cause the problem or do you think it was something else?
Edited by lllooo222 - 10/5/12 at 5:23pm
post #2 of 34
I'm not sure I understand.... what 6pin peripheral connector?.... did you connect the LED to a PCIe connector?
post #3 of 34
Thread Starter 
oh god no.

I'm not sure what the cable is called.
But its a 6 pin with 1 missing (thought it was 6 but its a 5 pin) with 3 different 4 pin peripherals
plugs in next to the pcie.

edit:
I think they are just Sata cables?
Edited by lllooo222 - 10/5/12 at 5:25pm
post #4 of 34
Thread Starter 
Posted the non modular psu instead of the one I have
my bad
post #5 of 34
smile.gif
I understand, you were talking about the modular connector board of the PSU..... well, the symptomatology is strange... do you happen to have another PSU in the house to test the system with?
post #6 of 34
Thread Starter 
The last computer I had was a prebuilt acer.
I don't even want to look inside of it tongue.gif
But I imagine it couldn't run my maching, the prebuilt is over 3 years old.
post #7 of 34
Thread Starter 
I'm gonna unplug all the cables from my system and psu then plug back in when I get back home.

I'm also not sure of how to boot my system with onboard graphics without the use of a monitor.
I can't look at my bios settings because of the non exsistent graphics card atm
post #8 of 34
Remove your video card and connect your monitor to one of the onboard video ports since your CPU has iGPU capabilities. If it doesn't POST then the PSU is probably dead. I would try clearing the CMOS (remove the battery) as well.
post #9 of 34
Thread Starter 
When I first tried to install my GPU I went full derp and tried to start it wih the vga cable still in the mobo slot,
When I did I had no signal,
wouldn't it be the same?
post #10 of 34
smile.gif
Exactly, remove the VGA and clear CMOS... and let us know what PSU you find inside the Acer in question. wink.gif
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Power Supplies
Overclock.net › Forums › Components › Power Supplies › Problem with PSU (possible rma)