Overclock.net › Forums › Industry News › Software News › [TPU] AMD Announces Never Settle Catalyst 12.11 Driver Update
New Posts  All Forums:Forum Nav:

[TPU] AMD Announces Never Settle Catalyst 12.11 Driver Update - Page 30

post #291 of 332
Quote:
Originally Posted by SectorNine50 View Post

It is interesting, that is no doubt. I wouldn't really be so quick to blame AMD; it seems that you might have a one-off issue. Is returning the card to a retailer out of the question if it comes down to it?
I'm not sure what it would be with your particular set-up that causes this issue. If it comes down to it, you may need to contact the card maker and set up an RMA. Mass Effect 3 may be doing something that's exposing a flaw in this particular card.
The good news is that you haven't run into issues with the other games you play, so it's not a total loss.
But lets not give up just yet; does the issue occur only in the ME3 menu, or the entire time the game is running? Can you give us some info on your setup, ie. screen resolution, DVI/VGA/HDMI/DP, accessories, running software? Furthermore, you aren't installing any application profiles with the drivers, correct? Just plain Jane drivers?
Also, if you could install some tools that will graph out CPU and GPU usage as well as their clock speeds when the issue is occuring, we might be able to help you either fix the issue, or supply more information should you choose to RMA it.

My sig rig is accurate for my setup on hardware, and I just downloaded the plain jane drivers. I tried uninstalling and reinstalling different version, no change in each. I don't believe I installed any application profile since i'm not doing CF.

What tools should I use to monitor those things? It runs the same fullscreen or windowed, so i could just run it windowed and see exactly what's happening. I have cpuz and another diagnostic from when I oc'd my cpu last month, but the name escapes me for the program. I 'could' return and exchange the card to Microcenter, a benefit of buying local lol, but want to avoid that if possible since it's ~15mile drive each way.

I'll keep testing and trying new settings, but this is infuriating I could have such a weird issue. I've played all sorts of games to try them out, and everything is soo smooth, except ME3. As for the rest of ME3, I wouldn't know, I can't get past the menu. I saw a post in the Bioware forum that a guy with a 670 was having the exact same issue, but his went away after he reinstalled his drivers without rebooting. No other explanation. Weird...
Malice
(18 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i5 2500K ASUS P8Z68-V GEN3 Gigabyte 7950 Windforce 3 G Skill Ripjaw X 8GB 
Hard DriveHard DriveHard DriveHard Drive
Corsair Force Series 3 SSD 240GB Samsung 500gb HDD  Samsung 300gb HDD Seagate 500gb HDD 
Hard DriveOptical DriveCoolingOS
Seagate 1TB HDD LG DVD Super-Multi Zalman CNPS9900MAX-B CPU cooler Windows 7 64 Pro 
MonitorKeyboardPowerCase
ASUS VH236H 23" HD Saitek Eclipse I Backlit - Blue Cooler Master Silent Pro 800W Gold Cooler Master HAF932 Advanced 
MouseAudio
Roccat Kone+ Razer Carcharias 
  hide details  
Reply
Malice
(18 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i5 2500K ASUS P8Z68-V GEN3 Gigabyte 7950 Windforce 3 G Skill Ripjaw X 8GB 
Hard DriveHard DriveHard DriveHard Drive
Corsair Force Series 3 SSD 240GB Samsung 500gb HDD  Samsung 300gb HDD Seagate 500gb HDD 
Hard DriveOptical DriveCoolingOS
Seagate 1TB HDD LG DVD Super-Multi Zalman CNPS9900MAX-B CPU cooler Windows 7 64 Pro 
MonitorKeyboardPowerCase
ASUS VH236H 23" HD Saitek Eclipse I Backlit - Blue Cooler Master Silent Pro 800W Gold Cooler Master HAF932 Advanced 
MouseAudio
Roccat Kone+ Razer Carcharias 
  hide details  
Reply
post #292 of 332
May seem like a silly question, and it very well could be unrelated, but you uninstalled the nVidia drivers before you installed the AMD ones, right?

For watching the GPU, there are tons of different tools. GPU-Z would probably work fine, if you are running in windowed mode. As long as we can watch CPU and GPU usage while it's happening, anything works! smile.gif

This feels like a software issue of some sort to me... I can't imagine a hardware issue that would cause a problem in just one game.
Perpetual Upgrade
(17 items)
 
Server
(17 items)
 
Galago UltraPro
(9 items)
 
CPUMotherboardGraphicsRAM
i7-4770K MSI Z97M Gaming Zotac GTX 1080 AMP! Edition (2x4GB) Corsair DDR3-2000 
Hard DriveHard DriveCoolingCooling
128GB Crucial M4 (2x) 500GB RAID 0 Swiftech Apogee Black Ice GT Stealth 240 
OSKeyboardPowerCase
Windows 10 Pro 64bit Corsair K70 Vengence Seasonic X650 Aerocool DS Cube 
MouseAudio
Logitech G500 ASUS Xonar DX 
CPUMotherboardGraphicsRAM
Phenom II X4 965 MSI 870A-G54 nVidia 8400GS (2x2GB) Patriot DDR3-1600 
RAMHard DriveHard DriveCooling
(2x4GB) Patriot DDR3-1600 (3x) 320GB RAID 5 (1x) 1TB Backup Storage Coolermaster TX3 
OSPowerOther
Proxmox Hypervisor Antec TruePower 430W HP Smart Array P400 
CPUGraphicsRAMHard Drive
Intel i7-4750HQ Intel Iris Pro Graphics 5200  (2 x 4GB) DDR3-1600 90GB Intel mSATA SSD 
Hard DriveOSOSMonitor
500GB 5400RPM HDD Ubuntu Gnome 15.10 Windows 10 14" 1080p ColorPro IPS 
Case
Galago UltraPro 
  hide details  
Reply
Perpetual Upgrade
(17 items)
 
Server
(17 items)
 
Galago UltraPro
(9 items)
 
CPUMotherboardGraphicsRAM
i7-4770K MSI Z97M Gaming Zotac GTX 1080 AMP! Edition (2x4GB) Corsair DDR3-2000 
Hard DriveHard DriveCoolingCooling
128GB Crucial M4 (2x) 500GB RAID 0 Swiftech Apogee Black Ice GT Stealth 240 
OSKeyboardPowerCase
Windows 10 Pro 64bit Corsair K70 Vengence Seasonic X650 Aerocool DS Cube 
MouseAudio
Logitech G500 ASUS Xonar DX 
CPUMotherboardGraphicsRAM
Phenom II X4 965 MSI 870A-G54 nVidia 8400GS (2x2GB) Patriot DDR3-1600 
RAMHard DriveHard DriveCooling
(2x4GB) Patriot DDR3-1600 (3x) 320GB RAID 5 (1x) 1TB Backup Storage Coolermaster TX3 
OSPowerOther
Proxmox Hypervisor Antec TruePower 430W HP Smart Array P400 
CPUGraphicsRAMHard Drive
Intel i7-4750HQ Intel Iris Pro Graphics 5200  (2 x 4GB) DDR3-1600 90GB Intel mSATA SSD 
Hard DriveOSOSMonitor
500GB 5400RPM HDD Ubuntu Gnome 15.10 Windows 10 14" 1080p ColorPro IPS 
Case
Galago UltraPro 
  hide details  
Reply
post #293 of 332
Quote:
Originally Posted by SectorNine50 View Post

May seem like a silly question, and it very well could be unrelated, but you uninstalled the nVidia drivers before you installed the AMD ones, right?
For watching the GPU, there are tons of different tools. GPU-Z would probably work fine, if you are running in windowed mode. As long as we can watch CPU and GPU usage while it's happening, anything works! smile.gif
This feels like a software issue of some sort to me... I can't imagine a hardware issue that would cause a problem in just one game.

Its definitely a software/driver issue for that reason, and yes I completely uninstalled all nVidia drivers before installing AMD. Regedit and all.
The only nVidia thing I have is the physx since a few games require it.

- physx is showing installed as well... do I maybe not have it enabled? How would I check?
Edited by Valor958 - 11/29/12 at 3:01pm
Malice
(18 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i5 2500K ASUS P8Z68-V GEN3 Gigabyte 7950 Windforce 3 G Skill Ripjaw X 8GB 
Hard DriveHard DriveHard DriveHard Drive
Corsair Force Series 3 SSD 240GB Samsung 500gb HDD  Samsung 300gb HDD Seagate 500gb HDD 
Hard DriveOptical DriveCoolingOS
Seagate 1TB HDD LG DVD Super-Multi Zalman CNPS9900MAX-B CPU cooler Windows 7 64 Pro 
MonitorKeyboardPowerCase
ASUS VH236H 23" HD Saitek Eclipse I Backlit - Blue Cooler Master Silent Pro 800W Gold Cooler Master HAF932 Advanced 
MouseAudio
Roccat Kone+ Razer Carcharias 
  hide details  
Reply
Malice
(18 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i5 2500K ASUS P8Z68-V GEN3 Gigabyte 7950 Windforce 3 G Skill Ripjaw X 8GB 
Hard DriveHard DriveHard DriveHard Drive
Corsair Force Series 3 SSD 240GB Samsung 500gb HDD  Samsung 300gb HDD Seagate 500gb HDD 
Hard DriveOptical DriveCoolingOS
Seagate 1TB HDD LG DVD Super-Multi Zalman CNPS9900MAX-B CPU cooler Windows 7 64 Pro 
MonitorKeyboardPowerCase
ASUS VH236H 23" HD Saitek Eclipse I Backlit - Blue Cooler Master Silent Pro 800W Gold Cooler Master HAF932 Advanced 
MouseAudio
Roccat Kone+ Razer Carcharias 
  hide details  
Reply
post #294 of 332
Quote:
Originally Posted by Valor958 View Post

Its definitely a software/driver issue for that reason, and yes I completely uninstalled all nVidia drivers before installing AMD. Regedit and all.
The only nVidia thing I have is the physx since a few games require it.
- physx is showing installed as well... do I maybe not have it enabled? How would I check?

I don't think any game literally requires PhysX, since it only actually operates when an nVidia card is installed. It could be worth uninstalling for forensic purposes.

Although, honestly I'd be a little surprised if it made a difference since I don't believe ME3 takes advantage of PhysX.
Perpetual Upgrade
(17 items)
 
Server
(17 items)
 
Galago UltraPro
(9 items)
 
CPUMotherboardGraphicsRAM
i7-4770K MSI Z97M Gaming Zotac GTX 1080 AMP! Edition (2x4GB) Corsair DDR3-2000 
Hard DriveHard DriveCoolingCooling
128GB Crucial M4 (2x) 500GB RAID 0 Swiftech Apogee Black Ice GT Stealth 240 
OSKeyboardPowerCase
Windows 10 Pro 64bit Corsair K70 Vengence Seasonic X650 Aerocool DS Cube 
MouseAudio
Logitech G500 ASUS Xonar DX 
CPUMotherboardGraphicsRAM
Phenom II X4 965 MSI 870A-G54 nVidia 8400GS (2x2GB) Patriot DDR3-1600 
RAMHard DriveHard DriveCooling
(2x4GB) Patriot DDR3-1600 (3x) 320GB RAID 5 (1x) 1TB Backup Storage Coolermaster TX3 
OSPowerOther
Proxmox Hypervisor Antec TruePower 430W HP Smart Array P400 
CPUGraphicsRAMHard Drive
Intel i7-4750HQ Intel Iris Pro Graphics 5200  (2 x 4GB) DDR3-1600 90GB Intel mSATA SSD 
Hard DriveOSOSMonitor
500GB 5400RPM HDD Ubuntu Gnome 15.10 Windows 10 14" 1080p ColorPro IPS 
Case
Galago UltraPro 
  hide details  
Reply
Perpetual Upgrade
(17 items)
 
Server
(17 items)
 
Galago UltraPro
(9 items)
 
CPUMotherboardGraphicsRAM
i7-4770K MSI Z97M Gaming Zotac GTX 1080 AMP! Edition (2x4GB) Corsair DDR3-2000 
Hard DriveHard DriveCoolingCooling
128GB Crucial M4 (2x) 500GB RAID 0 Swiftech Apogee Black Ice GT Stealth 240 
OSKeyboardPowerCase
Windows 10 Pro 64bit Corsair K70 Vengence Seasonic X650 Aerocool DS Cube 
MouseAudio
Logitech G500 ASUS Xonar DX 
CPUMotherboardGraphicsRAM
Phenom II X4 965 MSI 870A-G54 nVidia 8400GS (2x2GB) Patriot DDR3-1600 
RAMHard DriveHard DriveCooling
(2x4GB) Patriot DDR3-1600 (3x) 320GB RAID 5 (1x) 1TB Backup Storage Coolermaster TX3 
OSPowerOther
Proxmox Hypervisor Antec TruePower 430W HP Smart Array P400 
CPUGraphicsRAMHard Drive
Intel i7-4750HQ Intel Iris Pro Graphics 5200  (2 x 4GB) DDR3-1600 90GB Intel mSATA SSD 
Hard DriveOSOSMonitor
500GB 5400RPM HDD Ubuntu Gnome 15.10 Windows 10 14" 1080p ColorPro IPS 
Case
Galago UltraPro 
  hide details  
Reply
post #295 of 332
Quote:
Originally Posted by SectorNine50 View Post

I don't think any game literally requires PhysX, since it only actually operates when an nVidia card is installed. It could be worth uninstalling for forensic purposes.
Although, honestly I'd be a little surprised if it made a difference since I don't believe ME3 takes advantage of PhysX.

ME3 gives you an error if you don't have physx installed and included an installer for it.


Also, gpu usage is 0-2% during the choppy areas. frown.gif
- watching it more, my core and mem clock maxed with fans @30, but still 2% usage... ??
Edited by Valor958 - 11/29/12 at 3:42pm
Malice
(18 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i5 2500K ASUS P8Z68-V GEN3 Gigabyte 7950 Windforce 3 G Skill Ripjaw X 8GB 
Hard DriveHard DriveHard DriveHard Drive
Corsair Force Series 3 SSD 240GB Samsung 500gb HDD  Samsung 300gb HDD Seagate 500gb HDD 
Hard DriveOptical DriveCoolingOS
Seagate 1TB HDD LG DVD Super-Multi Zalman CNPS9900MAX-B CPU cooler Windows 7 64 Pro 
MonitorKeyboardPowerCase
ASUS VH236H 23" HD Saitek Eclipse I Backlit - Blue Cooler Master Silent Pro 800W Gold Cooler Master HAF932 Advanced 
MouseAudio
Roccat Kone+ Razer Carcharias 
  hide details  
Reply
Malice
(18 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i5 2500K ASUS P8Z68-V GEN3 Gigabyte 7950 Windforce 3 G Skill Ripjaw X 8GB 
Hard DriveHard DriveHard DriveHard Drive
Corsair Force Series 3 SSD 240GB Samsung 500gb HDD  Samsung 300gb HDD Seagate 500gb HDD 
Hard DriveOptical DriveCoolingOS
Seagate 1TB HDD LG DVD Super-Multi Zalman CNPS9900MAX-B CPU cooler Windows 7 64 Pro 
MonitorKeyboardPowerCase
ASUS VH236H 23" HD Saitek Eclipse I Backlit - Blue Cooler Master Silent Pro 800W Gold Cooler Master HAF932 Advanced 
MouseAudio
Roccat Kone+ Razer Carcharias 
  hide details  
Reply
post #296 of 332
Grrrr, guess I should return my 680 GTX's !
post #297 of 332
Quote:
Originally Posted by Valor958 View Post

ME3 gives you an error if you don't have physx installed and included an installer for it.
Also, gpu usage is 0-2% during the choppy areas. frown.gif
- watching it more, my core and mem clock maxed with fans @30, but still 2% usage... ??

Weird... My ME3 install didn't do that (maybe I didn't pay close enough attention?). Wonder if that's related somehow. Did it give you the error on install, or when you tried to run the game?

The GPU usage is interesting. It's obviously making the jump into 3D mode, but something is holding it up...

Perhaps try a newer version of PhysX? (Uninstall existing, reinstall this)
http://www.nvidia.com/object/physx-9.12.1031-driver.html

I found this thread, which I thought was interesting...
http://social.bioware.com/primevalrpg.freeforums.org/forum/1/topic/344/index/9334997/1#12152807

People that used to have nVidia cards, but switched to AMD were having issues.
Edited by SectorNine50 - 11/29/12 at 3:57pm
Perpetual Upgrade
(17 items)
 
Server
(17 items)
 
Galago UltraPro
(9 items)
 
CPUMotherboardGraphicsRAM
i7-4770K MSI Z97M Gaming Zotac GTX 1080 AMP! Edition (2x4GB) Corsair DDR3-2000 
Hard DriveHard DriveCoolingCooling
128GB Crucial M4 (2x) 500GB RAID 0 Swiftech Apogee Black Ice GT Stealth 240 
OSKeyboardPowerCase
Windows 10 Pro 64bit Corsair K70 Vengence Seasonic X650 Aerocool DS Cube 
MouseAudio
Logitech G500 ASUS Xonar DX 
CPUMotherboardGraphicsRAM
Phenom II X4 965 MSI 870A-G54 nVidia 8400GS (2x2GB) Patriot DDR3-1600 
RAMHard DriveHard DriveCooling
(2x4GB) Patriot DDR3-1600 (3x) 320GB RAID 5 (1x) 1TB Backup Storage Coolermaster TX3 
OSPowerOther
Proxmox Hypervisor Antec TruePower 430W HP Smart Array P400 
CPUGraphicsRAMHard Drive
Intel i7-4750HQ Intel Iris Pro Graphics 5200  (2 x 4GB) DDR3-1600 90GB Intel mSATA SSD 
Hard DriveOSOSMonitor
500GB 5400RPM HDD Ubuntu Gnome 15.10 Windows 10 14" 1080p ColorPro IPS 
Case
Galago UltraPro 
  hide details  
Reply
Perpetual Upgrade
(17 items)
 
Server
(17 items)
 
Galago UltraPro
(9 items)
 
CPUMotherboardGraphicsRAM
i7-4770K MSI Z97M Gaming Zotac GTX 1080 AMP! Edition (2x4GB) Corsair DDR3-2000 
Hard DriveHard DriveCoolingCooling
128GB Crucial M4 (2x) 500GB RAID 0 Swiftech Apogee Black Ice GT Stealth 240 
OSKeyboardPowerCase
Windows 10 Pro 64bit Corsair K70 Vengence Seasonic X650 Aerocool DS Cube 
MouseAudio
Logitech G500 ASUS Xonar DX 
CPUMotherboardGraphicsRAM
Phenom II X4 965 MSI 870A-G54 nVidia 8400GS (2x2GB) Patriot DDR3-1600 
RAMHard DriveHard DriveCooling
(2x4GB) Patriot DDR3-1600 (3x) 320GB RAID 5 (1x) 1TB Backup Storage Coolermaster TX3 
OSPowerOther
Proxmox Hypervisor Antec TruePower 430W HP Smart Array P400 
CPUGraphicsRAMHard Drive
Intel i7-4750HQ Intel Iris Pro Graphics 5200  (2 x 4GB) DDR3-1600 90GB Intel mSATA SSD 
Hard DriveOSOSMonitor
500GB 5400RPM HDD Ubuntu Gnome 15.10 Windows 10 14" 1080p ColorPro IPS 
Case
Galago UltraPro 
  hide details  
Reply
post #298 of 332
Quote:
Originally Posted by Valor958 View Post

ME3 gives you an error if you don't have physx installed and included an installer for it.
Also, gpu usage is 0-2% during the choppy areas. frown.gif
- watching it more, my core and mem clock maxed with fans @30, but still 2% usage... ??

Same with Metro 2033.
Just "PC"
(20 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i5 3570K @ 4.3GHz - 1.15v GIGABYTE GA-Z77X-UD3H Zotac GTX 970 AMP! Extreme Core @ 1430+/7500 MHz Corsair Vengeance 16GB(4x4) @ 1600MHz 
Hard DriveHard DriveOptical DriveCooling
SanDisk Ultra II 480GB WD CB 1TB 7200RPM DVD-RW CM Hyper 212 Evo 
OSMonitorKeyboardPower
Windows 10 Pro x64 AOC 22" 1080p + SONY TV 32" 1080p CM Storm QuickFire Pro (Brown switches) Corsair TX 650 V2 650W 
CaseMouseMouse PadAudio
CM Storm Enforcer Roccat KPM SteelSeries QCK+ Fiio E10K 
AudioAudioAudioOther
ASUS Xonar DG Samson SR850 Headphones Logitech LS11 2.0 Speakers CyberPower CP1500PFCLCD UPS 
  hide details  
Reply
Just "PC"
(20 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i5 3570K @ 4.3GHz - 1.15v GIGABYTE GA-Z77X-UD3H Zotac GTX 970 AMP! Extreme Core @ 1430+/7500 MHz Corsair Vengeance 16GB(4x4) @ 1600MHz 
Hard DriveHard DriveOptical DriveCooling
SanDisk Ultra II 480GB WD CB 1TB 7200RPM DVD-RW CM Hyper 212 Evo 
OSMonitorKeyboardPower
Windows 10 Pro x64 AOC 22" 1080p + SONY TV 32" 1080p CM Storm QuickFire Pro (Brown switches) Corsair TX 650 V2 650W 
CaseMouseMouse PadAudio
CM Storm Enforcer Roccat KPM SteelSeries QCK+ Fiio E10K 
AudioAudioAudioOther
ASUS Xonar DG Samson SR850 Headphones Logitech LS11 2.0 Speakers CyberPower CP1500PFCLCD UPS 
  hide details  
Reply
post #299 of 332
Quote:
Originally Posted by Valor958 View Post

ME3 gives you an error if you don't have physx installed and included an installer for it.
Also, gpu usage is 0-2% during the choppy areas. frown.gif
- watching it more, my core and mem clock maxed with fans @30, but still 2% usage... ??

Edit: same message twice.


Can you delete posts btw?
Edited by xutnubu - 12/1/12 at 7:21am
Just "PC"
(20 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i5 3570K @ 4.3GHz - 1.15v GIGABYTE GA-Z77X-UD3H Zotac GTX 970 AMP! Extreme Core @ 1430+/7500 MHz Corsair Vengeance 16GB(4x4) @ 1600MHz 
Hard DriveHard DriveOptical DriveCooling
SanDisk Ultra II 480GB WD CB 1TB 7200RPM DVD-RW CM Hyper 212 Evo 
OSMonitorKeyboardPower
Windows 10 Pro x64 AOC 22" 1080p + SONY TV 32" 1080p CM Storm QuickFire Pro (Brown switches) Corsair TX 650 V2 650W 
CaseMouseMouse PadAudio
CM Storm Enforcer Roccat KPM SteelSeries QCK+ Fiio E10K 
AudioAudioAudioOther
ASUS Xonar DG Samson SR850 Headphones Logitech LS11 2.0 Speakers CyberPower CP1500PFCLCD UPS 
  hide details  
Reply
Just "PC"
(20 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i5 3570K @ 4.3GHz - 1.15v GIGABYTE GA-Z77X-UD3H Zotac GTX 970 AMP! Extreme Core @ 1430+/7500 MHz Corsair Vengeance 16GB(4x4) @ 1600MHz 
Hard DriveHard DriveOptical DriveCooling
SanDisk Ultra II 480GB WD CB 1TB 7200RPM DVD-RW CM Hyper 212 Evo 
OSMonitorKeyboardPower
Windows 10 Pro x64 AOC 22" 1080p + SONY TV 32" 1080p CM Storm QuickFire Pro (Brown switches) Corsair TX 650 V2 650W 
CaseMouseMouse PadAudio
CM Storm Enforcer Roccat KPM SteelSeries QCK+ Fiio E10K 
AudioAudioAudioOther
ASUS Xonar DG Samson SR850 Headphones Logitech LS11 2.0 Speakers CyberPower CP1500PFCLCD UPS 
  hide details  
Reply
post #300 of 332
Ok, I've tried literally EVERYTHING I can think of... even set an application profile with Catalyst, no change at all. No response on Bioware forums either... how the heck am i the only person who seems to be experiencing this?
Malice
(18 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i5 2500K ASUS P8Z68-V GEN3 Gigabyte 7950 Windforce 3 G Skill Ripjaw X 8GB 
Hard DriveHard DriveHard DriveHard Drive
Corsair Force Series 3 SSD 240GB Samsung 500gb HDD  Samsung 300gb HDD Seagate 500gb HDD 
Hard DriveOptical DriveCoolingOS
Seagate 1TB HDD LG DVD Super-Multi Zalman CNPS9900MAX-B CPU cooler Windows 7 64 Pro 
MonitorKeyboardPowerCase
ASUS VH236H 23" HD Saitek Eclipse I Backlit - Blue Cooler Master Silent Pro 800W Gold Cooler Master HAF932 Advanced 
MouseAudio
Roccat Kone+ Razer Carcharias 
  hide details  
Reply
Malice
(18 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i5 2500K ASUS P8Z68-V GEN3 Gigabyte 7950 Windforce 3 G Skill Ripjaw X 8GB 
Hard DriveHard DriveHard DriveHard Drive
Corsair Force Series 3 SSD 240GB Samsung 500gb HDD  Samsung 300gb HDD Seagate 500gb HDD 
Hard DriveOptical DriveCoolingOS
Seagate 1TB HDD LG DVD Super-Multi Zalman CNPS9900MAX-B CPU cooler Windows 7 64 Pro 
MonitorKeyboardPowerCase
ASUS VH236H 23" HD Saitek Eclipse I Backlit - Blue Cooler Master Silent Pro 800W Gold Cooler Master HAF932 Advanced 
MouseAudio
Roccat Kone+ Razer Carcharias 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Software News
Overclock.net › Forums › Industry News › Software News › [TPU] AMD Announces Never Settle Catalyst 12.11 Driver Update