Overclock.net › Forums › Graphics Cards › NVIDIA › Nvidia GTX 660 Ti Not Working Properly?
New Posts  All Forums:Forum Nav:

Nvidia GTX 660 Ti Not Working Properly? - Page 2

post #11 of 15
Thread Starter 
Here's some pictures, drivers seem to be good.

http://imgur.com/a/aBmcE
post #12 of 15
Looks really good. I wonder if your cpu could be bottlenecking your gpu's fps? You might want to ask that question in the AMD cpu area. You may have to overclock that proc a little. It looks all good from what i can tell. Check the site out for that game also. There are alot of people saying it is real buggy. There are patches on that site also for some of the problems.
jeffro37
(14 items)
 
755 websurfer
(9 items)
 
 
CPUMotherboardGraphicsRAM
I5-2500k MSI Z77A-G45 MSI TFIII 7870 ghz ed. (oc) Kingston Hyper X Genises 1600mhz 
Hard DriveHard DriveOptical DriveCooling
Samsung 840  Seagate 750gb sata III Samsung 24x DVD-RW Corsair H100 
OSMonitorKeyboardPower
Windows 7 ultimate Samsung 26" LCD Logitec 520 (wireless) Corsair TX 750 
CaseMouse
Coolermaster HAF X Logitec laser 
CPUMotherboardGraphicsRAM
Intel c2d e7400 xFx 750i sli ext. Evga 660 sc Kingston ddr2 800 
Hard DriveCoolingOSPower
WD 250 gb  hyper 212+ Windows 7 64 ultimate/ Ubuntu 13.04 Ultra X3 600w / full modular 
Case
Coolermaster Storm Enforcer 
  hide details  
Reply
jeffro37
(14 items)
 
755 websurfer
(9 items)
 
 
CPUMotherboardGraphicsRAM
I5-2500k MSI Z77A-G45 MSI TFIII 7870 ghz ed. (oc) Kingston Hyper X Genises 1600mhz 
Hard DriveHard DriveOptical DriveCooling
Samsung 840  Seagate 750gb sata III Samsung 24x DVD-RW Corsair H100 
OSMonitorKeyboardPower
Windows 7 ultimate Samsung 26" LCD Logitec 520 (wireless) Corsair TX 750 
CaseMouse
Coolermaster HAF X Logitec laser 
CPUMotherboardGraphicsRAM
Intel c2d e7400 xFx 750i sli ext. Evga 660 sc Kingston ddr2 800 
Hard DriveCoolingOSPower
WD 250 gb  hyper 212+ Windows 7 64 ultimate/ Ubuntu 13.04 Ultra X3 600w / full modular 
Case
Coolermaster Storm Enforcer 
  hide details  
Reply
post #13 of 15
Thread Starter 
Alright thanks a lot for your help, much appreciated.
post #14 of 15
Highly doubt it's a bottleneck, If anything follow Jeffro37's advice with a clean driver install. Do you have massive amounts of Anti-Aliasing set? It probably wouldn't affect that much in terms of performance but maybe it could.
SG09
(13 items)
 
 
CPUMotherboardGraphicsRAM
i5 3570k Asus Maximus V gene mATX Asus GTX 670 DCII Corsair Dominator Platinum 
Hard DriveCoolingOSMonitor
Seagate CoolerMaster Hyper 212 Evo win7 Dell 24" 
KeyboardPowerCaseMouse
Gigabyte Osmium Silverstone Strider 1000w Silverstone SG09 Logitech 
Audio
Razer Tiamat 7.1 
  hide details  
Reply
SG09
(13 items)
 
 
CPUMotherboardGraphicsRAM
i5 3570k Asus Maximus V gene mATX Asus GTX 670 DCII Corsair Dominator Platinum 
Hard DriveCoolingOSMonitor
Seagate CoolerMaster Hyper 212 Evo win7 Dell 24" 
KeyboardPowerCaseMouse
Gigabyte Osmium Silverstone Strider 1000w Silverstone SG09 Logitech 
Audio
Razer Tiamat 7.1 
  hide details  
Reply
post #15 of 15
Thread Starter 
I tried the clean driver install and it shut my monitors down (removed drivers I believe) and they didn't come back up, had to shut down and put in the disk that came with the gpu and reinstall the drivers. Is that supposed to happen?
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: NVIDIA
Overclock.net › Forums › Graphics Cards › NVIDIA › Nvidia GTX 660 Ti Not Working Properly?