Overclock.net › Forums › Graphics Cards › AMD/ATI › bad performance on new Sapphire 7950
New Posts  All Forums:Forum Nav:

bad performance on new Sapphire 7950

post #1 of 19
Thread Starter 
Here is the card I just received today for reference: http://www.newegg.com/Product/Product.aspx?Item=N82E16814202006

I followed the driver uninstall procedures listed on a post from this site, detailing removal of drivers through express uninstall, followed by specific AMD/ATI folders and registry keys to delete. I did all the reboots at the specified places, etc

Anyhow, now with my new 7950 installed, I am getting barely 10fps in WoW in outdoor areas at stock settings. I even boosted the clock through Trixx (screenshot below) to 1100/1500 with the 20% board power Li, and still there was no performance improvement. Both GPU-z and AMD CCC show the GPU usage at 100%, the clocks at the correct 1100/1500 speeds, and yet the performance is terrible. I originally tried the 12.11 beta drivers, but uninstalled those and switched to the 12.10 current drivers with no change of performance.

My previous setup was xfx 6870 oc edition in crossfire setup. I was pulling 30-40fps at ultra settings in WoW in outdoor areas.

I am hoping someone can please help me understand why a superior card (7950 oc'd to 1100/1500) is significantly underperforming 2x 6870 (factory oc) in crossfire.

My graphic settings in CCC:
1920x1080 60hz
AA mode = use app settings
Morph Filtering = off
Filter = Standard
Anisotropic Filtering = use app settings
Tessellation = use app settings
Texture Filtering quality = high quality
Enable Surface Format Optimization = true
Wait for vertical refresh = on, unless app specifies
AA mode = SSAA
Triple Buffering = On

Here is a screenshot of my second monitor while I was flying around WoW in Valley of the Four Winds, full ultra settings except for Multisampling set to 2x. Pulling 10fps when my old rig was pulling 30-40 in the same spot


note: even though I have CCC opened to view current speeds, I have overdrive disabled. I OC'd through Trixx.
Edited by sdahlbe - 10/29/12 at 8:13pm
post #2 of 19
Thread Starter 
Is there anyone else with this similar card that can give me a 3dmark or cinebench score to compare to?
post #3 of 19
sounds like a driver issue uninstall using atiman ( google is your friend ) then reinstall drivers. Atiman is the best for uninstalling well for me atleast.

also scroll down on trixx there is a voltage control if its not locked. you might need to bump it alil higher
Edited by jay2nice000 - 10/29/12 at 8:22pm
    
CPUMotherboardGraphicsRAM
3770k  AsRock Z77 SAPPHIRE Radeon HD 7950 3GB 1270/1820 SAMSUNG 8GB MV-3V4G3D/US 
Hard DriveHard DriveOptical DriveCooling
OCZ Agility 3  Western Digtial Samsung Custom water loop 
OSMonitorKeyboardPower
Windows 7 Ultimate  ASUS VW246H Sidewinder x4 SeaSonic X750 Gold 750W 
CaseMouseAudioAudio
COOLER MASTER Storm Sniper  Corsair m60 Logitech S-220  Tritton 720 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
3770k  AsRock Z77 SAPPHIRE Radeon HD 7950 3GB 1270/1820 SAMSUNG 8GB MV-3V4G3D/US 
Hard DriveHard DriveOptical DriveCooling
OCZ Agility 3  Western Digtial Samsung Custom water loop 
OSMonitorKeyboardPower
Windows 7 Ultimate  ASUS VW246H Sidewinder x4 SeaSonic X750 Gold 750W 
CaseMouseAudioAudio
COOLER MASTER Storm Sniper  Corsair m60 Logitech S-220  Tritton 720 
  hide details  
Reply
post #4 of 19
Where did you get the idea a single 7950 would be faster than two 6870's anyway?

fairly sure performance is basically identical, other than having more memory bandwidth etc.

But anyway does sound like a driver issue, i simply use driver sweeper i'm not sure what method you used exactly.
Another 3570K
(14 items)
 
  
CPUMotherboardGraphicsRAM
i5 3570K @ 4.6ghz Gigabyte Z77X-D3H  GB 7970 @ 1100/1500 8GB Corsair V LP 1600mhz  
Hard DriveCoolingMonitorPower
Intel 330 series 240GB Noctua NH-D14 1080p 24" + 27" Antec HCG 620W 
CaseAudioAudioAudio
HAF XM Yamaha RX-V373 Accusound 8.8XD 180W Signature 8" 3-way  Auzentech meridian 7.1 2G 
Audio
Audio Technica AD700X 
  hide details  
Reply
Another 3570K
(14 items)
 
  
CPUMotherboardGraphicsRAM
i5 3570K @ 4.6ghz Gigabyte Z77X-D3H  GB 7970 @ 1100/1500 8GB Corsair V LP 1600mhz  
Hard DriveCoolingMonitorPower
Intel 330 series 240GB Noctua NH-D14 1080p 24" + 27" Antec HCG 620W 
CaseAudioAudioAudio
HAF XM Yamaha RX-V373 Accusound 8.8XD 180W Signature 8" 3-way  Auzentech meridian 7.1 2G 
Audio
Audio Technica AD700X 
  hide details  
Reply
post #5 of 19
here is my score on 3dmark with new drivers, fyi im using a waterblock

    
CPUMotherboardGraphicsRAM
3770k  AsRock Z77 SAPPHIRE Radeon HD 7950 3GB 1270/1820 SAMSUNG 8GB MV-3V4G3D/US 
Hard DriveHard DriveOptical DriveCooling
OCZ Agility 3  Western Digtial Samsung Custom water loop 
OSMonitorKeyboardPower
Windows 7 Ultimate  ASUS VW246H Sidewinder x4 SeaSonic X750 Gold 750W 
CaseMouseAudioAudio
COOLER MASTER Storm Sniper  Corsair m60 Logitech S-220  Tritton 720 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
3770k  AsRock Z77 SAPPHIRE Radeon HD 7950 3GB 1270/1820 SAMSUNG 8GB MV-3V4G3D/US 
Hard DriveHard DriveOptical DriveCooling
OCZ Agility 3  Western Digtial Samsung Custom water loop 
OSMonitorKeyboardPower
Windows 7 Ultimate  ASUS VW246H Sidewinder x4 SeaSonic X750 Gold 750W 
CaseMouseAudioAudio
COOLER MASTER Storm Sniper  Corsair m60 Logitech S-220  Tritton 720 
  hide details  
Reply
post #6 of 19
Quote:
Originally Posted by Casey Ryback View Post

Where did you get the idea a single 7950 would be faster than two 6870's anyway?
fairly sure performance is basically identical, other than having more memory bandwidth etc.
But anyway does sound like a driver issue, i simply use driver sweeper i'm not sure what method you used exactly.

I bet in my house that oc 7950 will destroy 6870 CF.

@sdahlbe, restart the drivers to defaults, put the fan manually on 60% and try again.
Edited by psyside - 10/29/12 at 9:15pm
My System
(15 items)
 
  
CPUMotherboardGraphicsRAM
i5 2500K @4.7ghz(1.39v) 24/7 +D14 Asus P8Z77-V Sapphire R9 290 Tri X @1160/1600 8GB HyperX @2133 
Hard DriveOptical DriveCoolingOS
WD Blue EZEX 1TB & Samsung 840 Pro 256GB (OS) Asus Nocuta NH D14 WIN 7 64 Ultimate 
MonitorKeyboardPowerCase
NEC 2490wuxi (rev 1) Logitech Wave Cooler Master Vanguard 850W Cooler Master HAF 932 
MouseMouse PadAudio
Logitech G5 Cooler Master Xonar STX+ HD595 
  hide details  
Reply
My System
(15 items)
 
  
CPUMotherboardGraphicsRAM
i5 2500K @4.7ghz(1.39v) 24/7 +D14 Asus P8Z77-V Sapphire R9 290 Tri X @1160/1600 8GB HyperX @2133 
Hard DriveOptical DriveCoolingOS
WD Blue EZEX 1TB & Samsung 840 Pro 256GB (OS) Asus Nocuta NH D14 WIN 7 64 Ultimate 
MonitorKeyboardPowerCase
NEC 2490wuxi (rev 1) Logitech Wave Cooler Master Vanguard 850W Cooler Master HAF 932 
MouseMouse PadAudio
Logitech G5 Cooler Master Xonar STX+ HD595 
  hide details  
Reply
post #7 of 19
Thread Starter 
I used the atiman 7.0.2 tool to thoroughly uninstall the old drivers. I then reinstalled the 12.10 drivers (which I downloaded fresh from the AMD site). Nothing changed at all. I am still getting 10fps in an area where I used to get 30-40fps on my 6870 CF. My girlfriend has a 7770 GHZ edition that gets 20-30fps with these settings...

My 2600K is OC'd to 4.5ghz + 7950 overclocked moderately should be giving me FAR more that 10fps. Something is terribly wrong. I'm feeling like I need to RMA this card but I dont know how to prove it.

Quote:
@sdahlbe, restart the drivers to defaults, put the fan manually on 60% and try again.
Yes I reinstalled the drivers after using atiman. I dont see how turning the fan manually to 60% would fix my terrible performance, but I tried it anyways. Nothing changed, the temps were never too high.
post #8 of 19
Quote:
Originally Posted by sdahlbe View Post

I used the atiman 7.0.2 tool to thoroughly uninstall the old drivers. I then reinstalled the 12.10 drivers (which I downloaded fresh from the AMD site). Nothing changed at all. I am still getting 10fps in an area where I used to get 30-40fps on my 6870 CF. My girlfriend has a 7770 GHZ edition that gets 20-30fps with these settings...
My 2600K is OC'd to 4.5ghz + 7950 overclocked moderately should be giving me FAR more that 10fps. Something is terribly wrong. I'm feeling like I need to RMA this card but I dont know how to prove it.
Yes I reinstalled the drivers after using atiman. I dont see how turning the fan manually to 60% would fix my terrible performance, but I tried it anyways. Nothing changed, the temps were never too high.

Do some other benchmarks first, like Heaven 3.0. You definitely should not be getting such low fps with that card at those settings. Are you by chance playing with 2D/3D clock profiles, and could it be that your card gets stuck in 2D clocks in the game?
   
CPUMotherboardGraphicsRAM
i7 3770 @ 4.3 GHz ASRock Z77E-ITX GTX 660 Ti + Accelero Mono Plus, 1.875V G.Skill Ripjaws X 16GB at 2133MHz 9-10-11-28-1T... 
Hard DriveHard DriveHard DriveCooling
Crucial m4 Hitachi TravelStar 2.5" SATA III Intel 330  BitFenix Recon fan controller 
CoolingCoolingCoolingCooling
Corsair H100i Scythe Gentle Typhoon AP-14 x 4 (radiator front... Phanteks 140mm fan (exhaust) Fractal Design R2 Silent 140mm fan (bottom intake) 
OSOSOSMonitor
Windows 7 Professional 64-bit Windows 8 Professional 64-bit (trying it out) Linux Mint Achieva ShiMian 27" IPSB (tempered glass) 
MonitorKeyboardPowerCase
Dell U2412M 24" LZ-GH aluminum/steel TKL keyboard Seasonic G-550 80+ Gold Fractal Design Define R4 
MouseMouse PadOtherOther
Logitech MX518 Monoprice dual-surface aluminum IKEA Dioder light-changing LED strip on the roof Monoprice 10 x 6.25" drawing tablet 
CPUMotherboardGraphicsRAM
Intel i5 2400 3.8GHz turbo boost Gigabyte z68x-ud3h-b3 Sapphire Dual-X 7970 OC Samsung 30nm ULP  
Hard DriveOptical DriveCoolingCooling
Corsair Force 3 LG DVD-RW Zalman CNPS9900MAX-B Noctua NF-S12B ULN 
CoolingCoolingCoolingOS
Scythe Gentle Typhoon AP-14 Fractal Design R2 Silent 140mm fan Bitfenix Spectre 200mm fan Windows 7 Professional 64-bit 
MonitorKeyboardPowerCase
Achieva ShiMian 27" IPSB (tempered glass) Ducky Shine II MX Clears Corsair AX750 BitFenix Survivor in White 
MouseMouse PadOtherOther
Logitech MX518 Ikea circle! NZXT Hue Lamptron FC-9 
  hide details  
Reply
   
CPUMotherboardGraphicsRAM
i7 3770 @ 4.3 GHz ASRock Z77E-ITX GTX 660 Ti + Accelero Mono Plus, 1.875V G.Skill Ripjaws X 16GB at 2133MHz 9-10-11-28-1T... 
Hard DriveHard DriveHard DriveCooling
Crucial m4 Hitachi TravelStar 2.5" SATA III Intel 330  BitFenix Recon fan controller 
CoolingCoolingCoolingCooling
Corsair H100i Scythe Gentle Typhoon AP-14 x 4 (radiator front... Phanteks 140mm fan (exhaust) Fractal Design R2 Silent 140mm fan (bottom intake) 
OSOSOSMonitor
Windows 7 Professional 64-bit Windows 8 Professional 64-bit (trying it out) Linux Mint Achieva ShiMian 27" IPSB (tempered glass) 
MonitorKeyboardPowerCase
Dell U2412M 24" LZ-GH aluminum/steel TKL keyboard Seasonic G-550 80+ Gold Fractal Design Define R4 
MouseMouse PadOtherOther
Logitech MX518 Monoprice dual-surface aluminum IKEA Dioder light-changing LED strip on the roof Monoprice 10 x 6.25" drawing tablet 
CPUMotherboardGraphicsRAM
Intel i5 2400 3.8GHz turbo boost Gigabyte z68x-ud3h-b3 Sapphire Dual-X 7970 OC Samsung 30nm ULP  
Hard DriveOptical DriveCoolingCooling
Corsair Force 3 LG DVD-RW Zalman CNPS9900MAX-B Noctua NF-S12B ULN 
CoolingCoolingCoolingOS
Scythe Gentle Typhoon AP-14 Fractal Design R2 Silent 140mm fan Bitfenix Spectre 200mm fan Windows 7 Professional 64-bit 
MonitorKeyboardPowerCase
Achieva ShiMian 27" IPSB (tempered glass) Ducky Shine II MX Clears Corsair AX750 BitFenix Survivor in White 
MouseMouse PadOtherOther
Logitech MX518 Ikea circle! NZXT Hue Lamptron FC-9 
  hide details  
Reply
post #9 of 19
Have you ran 3dmark 11 to see what your score is? I dont play wow but I have the same card and an inferior system to yours as mine is just an amd 960t unlocked to an x6 on a sabertooth and Im hitting 9k scores on 3dmark. BF3 on ultra maxed out everything and I still cruise at a solid 60fps. I run my card @ 1100 1500 with the +20% voltage boost.

Oh by the way I also had a 6870 but just a single card and didnt use the atiman uninstaller. I just used the normal uninstall method from AMD
 
Intel Rig
(24 items)
 
 
CPUMotherboardGraphicsRAM
Intel i7-4930k Asus Rampage IV Black Edition EVGA GTX 1080ti SC Black Gskill Trident X 2400mhz 
Hard DriveHard DriveHard DriveOptical Drive
Kingston hyperx 3k  WD  Crucial M500 Asus dvd rw 
CoolingCoolingCoolingCooling
XSPC RX480 XSPC RX480 XSPC RX240 XSPC EX240 
CoolingCoolingOSMonitor
EK GTX 1080ti water block Mcp35x Windows 10 Xstar 
KeyboardPowerCaseMouse
Corsair K70 Corsair AX1200 Corsair 900D Corsair M65 
Mouse PadAudioAudioAudio
Corsair MM200 Creative Sound Blaster Z M-Audio AV40 Sennheiser PC360 
  hide details  
Reply
 
Intel Rig
(24 items)
 
 
CPUMotherboardGraphicsRAM
Intel i7-4930k Asus Rampage IV Black Edition EVGA GTX 1080ti SC Black Gskill Trident X 2400mhz 
Hard DriveHard DriveHard DriveOptical Drive
Kingston hyperx 3k  WD  Crucial M500 Asus dvd rw 
CoolingCoolingCoolingCooling
XSPC RX480 XSPC RX480 XSPC RX240 XSPC EX240 
CoolingCoolingOSMonitor
EK GTX 1080ti water block Mcp35x Windows 10 Xstar 
KeyboardPowerCaseMouse
Corsair K70 Corsair AX1200 Corsair 900D Corsair M65 
Mouse PadAudioAudioAudio
Corsair MM200 Creative Sound Blaster Z M-Audio AV40 Sennheiser PC360 
  hide details  
Reply
post #10 of 19
Quote:
Originally Posted by jay2nice000 View Post

here is my score on 3dmark with new drivers, fyi im using a waterblock

Don't get me wrong, much nicer using one card less hassles, better Ocing obviously.

It's about equal to OC'd 6950's in CF, but as stated much better in many ways.

I guess what i should've said is you may not notice any difference between the two setups running most games.

Also no, changing the fan speed will not do anything.

I'm guessing you have the power saving feature disabled etc to stop throttling? (ULPS)
Edited by Casey Ryback - 10/29/12 at 9:50pm
Another 3570K
(14 items)
 
  
CPUMotherboardGraphicsRAM
i5 3570K @ 4.6ghz Gigabyte Z77X-D3H  GB 7970 @ 1100/1500 8GB Corsair V LP 1600mhz  
Hard DriveCoolingMonitorPower
Intel 330 series 240GB Noctua NH-D14 1080p 24" + 27" Antec HCG 620W 
CaseAudioAudioAudio
HAF XM Yamaha RX-V373 Accusound 8.8XD 180W Signature 8" 3-way  Auzentech meridian 7.1 2G 
Audio
Audio Technica AD700X 
  hide details  
Reply
Another 3570K
(14 items)
 
  
CPUMotherboardGraphicsRAM
i5 3570K @ 4.6ghz Gigabyte Z77X-D3H  GB 7970 @ 1100/1500 8GB Corsair V LP 1600mhz  
Hard DriveCoolingMonitorPower
Intel 330 series 240GB Noctua NH-D14 1080p 24" + 27" Antec HCG 620W 
CaseAudioAudioAudio
HAF XM Yamaha RX-V373 Accusound 8.8XD 180W Signature 8" 3-way  Auzentech meridian 7.1 2G 
Audio
Audio Technica AD700X 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: AMD/ATI
Overclock.net › Forums › Graphics Cards › AMD/ATI › bad performance on new Sapphire 7950