Overclock.net › Forums › Intel › Intel Motherboards › Help with Asrock UEFI and and SSD boot
New Posts  All Forums:Forum Nav:

Help with Asrock UEFI and and SSD boot

post #1 of 7
Thread Starter 
Hello guys i have a problem hopefully i can resolve from here.
I installed a new SSD today ( Kingston HyperX 120GB) and got everything to work but one problem.
Every time i turn on the PC, i have to wait like 20 sec for the SSD to boot Windows. The screen stays in my UEFI ( Where it shows you to press F2 for this and that) and I have to wait around 20 sec until the Windows logo even shows up.
I set the booth priorities to my SSD and then to my Optical Drive, I have also disable my optical drive and just had SSD in booth prioritie #1 but still i have to wait 20 for the UEFI screen to go away until windows loads. This is on a Asrock Z77 Extreme4
How do i fix this problem?
post #2 of 7
Unplug all your USB devices and only leave it in the keyboard.

I found my Bluetooth USB dongle caused the same for me on my new motherboard. Old one had no such issue.
SIXFOUR
(15 items)
 
  
CPUMotherboardGraphicsRAM
Core i7 3770K (4500 @ 1.250v) ASRock Z77 OC Formula EVGA GTX460 SOC G-Skill F3-10666CL9-4GBXL 4x4GB 
Hard DriveOptical DriveCoolingOS
2 x Crucial M4 128GB + 4 others none Apogee XT, MCR220, MCP655B, EK full-cover GPU b... Windows 7 Ultimate 64-bit 
MonitorMonitorKeyboardPower
Dell U2713HM Dell 2407WFP 9 year old el cheapo Seasonic X Series 750W PSU 
CaseMouseMouse Pad
Corsair Carbide 540 7 year old el cheapo piece of wetsuit 
  hide details  
Reply
SIXFOUR
(15 items)
 
  
CPUMotherboardGraphicsRAM
Core i7 3770K (4500 @ 1.250v) ASRock Z77 OC Formula EVGA GTX460 SOC G-Skill F3-10666CL9-4GBXL 4x4GB 
Hard DriveOptical DriveCoolingOS
2 x Crucial M4 128GB + 4 others none Apogee XT, MCR220, MCP655B, EK full-cover GPU b... Windows 7 Ultimate 64-bit 
MonitorMonitorKeyboardPower
Dell U2713HM Dell 2407WFP 9 year old el cheapo Seasonic X Series 750W PSU 
CaseMouseMouse Pad
Corsair Carbide 540 7 year old el cheapo piece of wetsuit 
  hide details  
Reply
post #3 of 7
Yeah, I have heard xbox controllers can add 20-30 seconds to post times, and on the extreme side, no booting at all. Unplug everything.
 
Philip J. Fry
(6 items)
 
Turanga Leela
(1 item)
 
CPUMotherboardGraphicsRAM
i5 4690K 4.2ghz 1.15v Asus Z97I-Plus EVGA GTX1070 ACX 3.0 HyperX 16gb 1866mhz 
Hard DriveHard DriveCoolingOS
Samsung 850 Evo 250GB Western Digital Caviar Black1TB NZXT Kraken X41 Windows 7 Ultimate 
MonitorMonitorMonitorPower
ASUS VN247H-P ASUS VN247H-P ASUS VN247H-P SPI Magna Gold 750w 
CaseMouseMouse PadAudio
Corsair Obsidian 250D Zowie EC1-A Steelseries QCK XXL Fostex TH-X00 Mahogany 
AudioAudioAudio
Fiio E10 Olympus Modmic 4.0 Beyerdynamic DT770 80ohm Removable Cable Mod 
CPUGraphicsRAMHard Drive
Intel Core i5 M 480 Nvidia GeForce 310M 4gb Samsung ram 640gb Samsung HM641JI 
OSOther
Windows 7 Home Premium Samsung QX410 Laptop 
Keyboard
Which one? :P 
  hide details  
Reply
 
Philip J. Fry
(6 items)
 
Turanga Leela
(1 item)
 
CPUMotherboardGraphicsRAM
i5 4690K 4.2ghz 1.15v Asus Z97I-Plus EVGA GTX1070 ACX 3.0 HyperX 16gb 1866mhz 
Hard DriveHard DriveCoolingOS
Samsung 850 Evo 250GB Western Digital Caviar Black1TB NZXT Kraken X41 Windows 7 Ultimate 
MonitorMonitorMonitorPower
ASUS VN247H-P ASUS VN247H-P ASUS VN247H-P SPI Magna Gold 750w 
CaseMouseMouse PadAudio
Corsair Obsidian 250D Zowie EC1-A Steelseries QCK XXL Fostex TH-X00 Mahogany 
AudioAudioAudio
Fiio E10 Olympus Modmic 4.0 Beyerdynamic DT770 80ohm Removable Cable Mod 
CPUGraphicsRAMHard Drive
Intel Core i5 M 480 Nvidia GeForce 310M 4gb Samsung ram 640gb Samsung HM641JI 
OSOther
Windows 7 Home Premium Samsung QX410 Laptop 
Keyboard
Which one? :P 
  hide details  
Reply
post #4 of 7
Thread Starter 
I unplugged all the USB, Audio, ect and only left the Keyboard (Uses USB), HDMI, and Ethernet cable on and it still shows the UEFI screen for like 20 secs...
I tired to reset everything to default under the UEFI, but no luck.
post #5 of 7
Thread Starter 
I got it fixed. For anyone wondering how, It was caused by my Optical Drive. I took it off and now the booth time is back to normal biggrin.gif Sucks i need a new drive frown.gif
post #6 of 7
Try different sata ports before replacing the drive
Smoke
(13 items)
 
Sektor
(12 items)
 
Sub-Zero
(9 items)
 
CPUMotherboardGraphicsRAM
Ryzen 7 1700x 4.0Ghz 1.4v Asus X370 Asus GTX 1080 Gskill Trident Z 2933 
Hard DriveHard DriveCoolingOS
Crucial MX300 1TB Raid 0 Crucial MX300 1TB Raid 0 Corsair H100i Windows 10 Pro 
KeyboardPowerCaseMouse
Realforce 87U 55 Gram EVGA G2 850W Phanteks P400S Gray Cooler Master Xornet 2 
CPUMotherboardGraphicsRAM
G4400 4.8Ghz 1.3v Asrock B150 Gaming K4/Hyper MSI GTX 970 Kingston HyperX Fury Black 
Hard DriveCoolingOSMonitor
Crucial BX200 Cooler Master Hyper 212 LED Windows 10 Pro Monoprice 30" 2560x1600 
KeyboardPowerCaseMouse
Mpow Blue switches Corsair CXM 450W Bitfenix Comrade ATX Mid tower Cooler Master Xornet 2 
CPUMotherboardGraphicsRAM
Pentium G4620 3.7Ghz MSI B150M Bazooka EVGA GTX 980ti Corsair Vengeance LPX 8GB 
Hard DriveCoolingOSPower
Crucial MX300 1TB Enermax ETS-T50 AXE Windows 10 Pro EVGA BV 450W 
Case
Bitfenix Prodigy M Cobalt Blue 
  hide details  
Reply
Smoke
(13 items)
 
Sektor
(12 items)
 
Sub-Zero
(9 items)
 
CPUMotherboardGraphicsRAM
Ryzen 7 1700x 4.0Ghz 1.4v Asus X370 Asus GTX 1080 Gskill Trident Z 2933 
Hard DriveHard DriveCoolingOS
Crucial MX300 1TB Raid 0 Crucial MX300 1TB Raid 0 Corsair H100i Windows 10 Pro 
KeyboardPowerCaseMouse
Realforce 87U 55 Gram EVGA G2 850W Phanteks P400S Gray Cooler Master Xornet 2 
CPUMotherboardGraphicsRAM
G4400 4.8Ghz 1.3v Asrock B150 Gaming K4/Hyper MSI GTX 970 Kingston HyperX Fury Black 
Hard DriveCoolingOSMonitor
Crucial BX200 Cooler Master Hyper 212 LED Windows 10 Pro Monoprice 30" 2560x1600 
KeyboardPowerCaseMouse
Mpow Blue switches Corsair CXM 450W Bitfenix Comrade ATX Mid tower Cooler Master Xornet 2 
CPUMotherboardGraphicsRAM
Pentium G4620 3.7Ghz MSI B150M Bazooka EVGA GTX 980ti Corsair Vengeance LPX 8GB 
Hard DriveCoolingOSPower
Crucial MX300 1TB Enermax ETS-T50 AXE Windows 10 Pro EVGA BV 450W 
Case
Bitfenix Prodigy M Cobalt Blue 
  hide details  
Reply
post #7 of 7
Thread Starter 
I did, it worked (kinda). Now the UEFI screen goes away after 2-3 sec but gets stuck on windows screen. Really weird because this optical drive worked perfectly 3 week ago.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Intel Motherboards
Overclock.net › Forums › Intel › Intel Motherboards › Help with Asrock UEFI and and SSD boot