Overclock.net › Forums › Software, Programming and Coding › Operating Systems › Problem with Windows 8 and a few games
New Posts  All Forums:Forum Nav:

Problem with Windows 8 and a few games

post #1 of 6
Thread Starter 
This is a new build except the video card which I pulled from my old system (Radeon 4850) Asrock Z77e-itx MB with I5 3570k & Windows 8 pro. Drivers are all up to date. I don't have a lot of stuff installed yet, but 2 games already aren't working. Doom 3 BFG & GTA IV. I bought them on Steam. Both give me a "has stopped responding" message as soon as I run them. I have the latest DirectX, Net Framework & VC++ redistribution installed. The only advice I found Googling this was to try installing older drivers, but the HD 4xxxx cards don't have W8 drivers from AMD. So the built in drivers from MS seem to be my only option here. I did remove them and tried installing the latest AMD Windows 7 ones, I didn't get an error. But when I rebooted my resolution was stuck @ 1024x768 and nothing was listed in the device manager for video card.

Any ideas here? Googling either of these games + W8 I'm not seeing anyone with the same problem. I have some other games installed and outside of these 2 games everything else runs fine.
Edited by quebert - 11/10/12 at 8:45am
post #2 of 6
Download this: http://www.microsoft.com/en-us/download/details.aspx?id=5549
Should solve the GTAIV issue.
hyp3
(11 items)
 
  
CPUMotherboardRAMHard Drive
Core i5 6600k Asus Maximus VIII Ranger G.Skill Ripjaws V 2x8GB DDR4 2400MHz Samsung 830 128GB 
Hard DriveCoolingMonitorKeyboard
Crucial M500 960GB Thermaltake Water 3.0 Performer C Dell S2216H Cooler Master Quick Fire Rapid-i Cherry MX Brown 
PowerCaseMouse
Cooler Master V650 Gold NZXT S340 White Cooler Master MasterKeys Lite L 
  hide details  
Reply
hyp3
(11 items)
 
  
CPUMotherboardRAMHard Drive
Core i5 6600k Asus Maximus VIII Ranger G.Skill Ripjaws V 2x8GB DDR4 2400MHz Samsung 830 128GB 
Hard DriveCoolingMonitorKeyboard
Crucial M500 960GB Thermaltake Water 3.0 Performer C Dell S2216H Cooler Master Quick Fire Rapid-i Cherry MX Brown 
PowerCaseMouse
Cooler Master V650 Gold NZXT S340 White Cooler Master MasterKeys Lite L 
  hide details  
Reply
post #3 of 6
Thread Starter 
Quote:
Originally Posted by strych9 View Post

Download this: http://www.microsoft.com/en-us/download/details.aspx?id=5549
Should solve the GTAIV issue.

Thanks for the reply, I should have mentioned I already removed and reinstalled the latest GFWL, nothing happened.
post #4 of 6
Quote:
Originally Posted by quebert View Post

Quote:
Originally Posted by strych9 View Post

Download this: http://www.microsoft.com/en-us/download/details.aspx?id=5549
Should solve the GTAIV issue.

Thanks for the reply, I should have mentioned I already removed and reinstalled the latest GFWL, nothing happened.
No idea then, I had the same problem and reinstalling the latest GFLW solved it.
hyp3
(11 items)
 
  
CPUMotherboardRAMHard Drive
Core i5 6600k Asus Maximus VIII Ranger G.Skill Ripjaws V 2x8GB DDR4 2400MHz Samsung 830 128GB 
Hard DriveCoolingMonitorKeyboard
Crucial M500 960GB Thermaltake Water 3.0 Performer C Dell S2216H Cooler Master Quick Fire Rapid-i Cherry MX Brown 
PowerCaseMouse
Cooler Master V650 Gold NZXT S340 White Cooler Master MasterKeys Lite L 
  hide details  
Reply
hyp3
(11 items)
 
  
CPUMotherboardRAMHard Drive
Core i5 6600k Asus Maximus VIII Ranger G.Skill Ripjaws V 2x8GB DDR4 2400MHz Samsung 830 128GB 
Hard DriveCoolingMonitorKeyboard
Crucial M500 960GB Thermaltake Water 3.0 Performer C Dell S2216H Cooler Master Quick Fire Rapid-i Cherry MX Brown 
PowerCaseMouse
Cooler Master V650 Gold NZXT S340 White Cooler Master MasterKeys Lite L 
  hide details  
Reply
post #5 of 6
Do you use a EVGA Precision-X, MSI Afterburner etc?

I also had this problem running games after upgrading to Windows 8 but they started running properly after I uninstalled Precision-X?

I think it is the built-in FPS monitor that causes the crash.
Black Z170
(15 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i5 6600K MSI Z170A GAMING PRO CARBON MSI GeForce GTX 1080 SEA HAWK X 8GB 16GB (4x4GB) Corsair DDR4 Vengeance LPX Black P... 
Hard DriveHard DriveCoolingCooling
120GB Samsung 750 EVO 500GB Samsung 750 EVO Corsair Hydro Series H100i V2 6x 20mm EK Vardar F4-120ER Cooling Fans in Black 
CoolingOSKeyboardPower
Thermaltake Commander FP Windows 10 Pro 64-bit QPAD MK-90 RGB Pro 850W EVGA Supernova P2 with EVGA Black Braided ... 
CaseMouseOther
Fractal Design Define C QPAD 8K Pro 3x 30cm Silverstone Ultra Slim SATA cables 
  hide details  
Reply
Black Z170
(15 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i5 6600K MSI Z170A GAMING PRO CARBON MSI GeForce GTX 1080 SEA HAWK X 8GB 16GB (4x4GB) Corsair DDR4 Vengeance LPX Black P... 
Hard DriveHard DriveCoolingCooling
120GB Samsung 750 EVO 500GB Samsung 750 EVO Corsair Hydro Series H100i V2 6x 20mm EK Vardar F4-120ER Cooling Fans in Black 
CoolingOSKeyboardPower
Thermaltake Commander FP Windows 10 Pro 64-bit QPAD MK-90 RGB Pro 850W EVGA Supernova P2 with EVGA Black Braided ... 
CaseMouseOther
Fractal Design Define C QPAD 8K Pro 3x 30cm Silverstone Ultra Slim SATA cables 
  hide details  
Reply
post #6 of 6
Thread Starter 
Quote:
Originally Posted by VulgarDisplay88 View Post

Do you use a EVGA Precision-X, MSI Afterburner etc?
I also had this problem running games after upgrading to Windows 8 but they started running properly after I uninstalled Precision-X?
I think it is the built-in FPS monitor that causes the crash.

No, I tried installing Aftewrburner since to set my fan speed, but it doesn't work with my card, I think because the HD 4xxx's don't have ATI CCC drivers for Windows 8, I don't know though. This is a pretty vanilla Windows 8 install. In fact the 1st thing I installed after all the drivers was Doom 3 and it wouldn't work. I even reinstalled Windows again just to see, and even after a 2nd clean install the game still wouldn't launch.

I'm hoping it's my video card, I'll pick up a 7950 or something in a few weeks and keep my fingers crossed.

should have probably mentioned in the OP, nothing's overclocked and my memory's running @ 1866 (stock)
Edited by quebert - 11/10/12 at 9:40am
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Operating Systems
Overclock.net › Forums › Software, Programming and Coding › Operating Systems › Problem with Windows 8 and a few games