Overclock.net › Forums › Graphics Cards › AMD/ATI › ATI Drivers and Overclocking Software › Gigabyte 7970 OC REV 2.0 issues after bios flash
New Posts  All Forums:Forum Nav:

Gigabyte 7970 OC REV 2.0 issues after bios flash

post #1 of 15
Thread Starter 
Hello,

Recently bought a 7970 GV-R797OC-3GD, started out oc'ing and managed to get it to about 1060/1500 clocks which seemed to be pretty stable after a few hours of gaming, but I wanted to flash the bios to allow me increase the voltage above stock (1.170V).

Unable to find just a bios that allowed voltage modification, I flashed my bios (switch position 2) to the GHZ edition. After rebooting, basically every game I played instantly resulted in the game locking up and me having to force quit the game. Thinking maybe the clocks were too high for my card I reset clocks to my stock (1000/1375) and had the same result. Any 3D app would lock up and give me the display driver crashed error.

Here's the kicker. Long story short I ended up using this "stock" BIOS on both bios 1 and 2. I know I know, I screwed that up. http://www.techpowerup.com/vgabios/122736/Gigabyte.HD7970.3072.120426.html

Sounds good right? Nope. Games now sometimes give me the display driver crashed error even on stock bios and stock clocks (1000/1375) after a few minutes of gameplay. Raising my OC back to my initial 1060/1500 results in instant lockup in-game. So I am forced to slightly underclock my card to be stable.
I used atiflash with the cmd - "atiflash -p 0 file.rom -fs -fp" to flash my bios every time.

Wondering if there's anything I can do. Maybe someone has my card and can upload their stock bios? Just to be sure the "stock" ones im using are actually stock.

Thanks
post #2 of 15
is this your card? (Rev 2.0)
TheSadFlute
(16 items)
 
DyingHeart
(17 items)
 
 
CPUMotherboardGraphicsRAM
i7-6700K TUF Sabertooth MSI 1080 Ti 16GB 2400MHz C15 
Hard DriveHard DriveHard DriveCooling
Corsair 480GB LE 3TB WD Green Sammy 500GB 850 EVO H100i 
OSMonitorKeyboardPower
Windows 7 Pro  BenQ XR3501 Logitech G710+ EVGA G2 750W 
CaseMouseAudioAudio
Cooler Master Stryker Logitech G602 Asus Strix Nakamichi 5.1 
CPUMotherboardGraphicsRAM
Phenom II X4 965BE  Sapphire 790X Zotac GTX650  4GB Corsair 1066 DDR2 (1GBx4) 
Hard DriveHard DriveCoolingCooling
G.Skill Phoenix Pro 120GB WD 2TB Green Stock 3x120mm UQ fans 
OSMonitorKeyboardPower
W7 Pro SP1 x64 LG 21' 1680x1050 Genius  Corsair CX600 
CaseMouseMouse PadAudio
Gigabyte  E-Blue Mazer XFX WarPad On-board 
Audio
Logitech G35 
  hide details  
Reply
TheSadFlute
(16 items)
 
DyingHeart
(17 items)
 
 
CPUMotherboardGraphicsRAM
i7-6700K TUF Sabertooth MSI 1080 Ti 16GB 2400MHz C15 
Hard DriveHard DriveHard DriveCooling
Corsair 480GB LE 3TB WD Green Sammy 500GB 850 EVO H100i 
OSMonitorKeyboardPower
Windows 7 Pro  BenQ XR3501 Logitech G710+ EVGA G2 750W 
CaseMouseAudioAudio
Cooler Master Stryker Logitech G602 Asus Strix Nakamichi 5.1 
CPUMotherboardGraphicsRAM
Phenom II X4 965BE  Sapphire 790X Zotac GTX650  4GB Corsair 1066 DDR2 (1GBx4) 
Hard DriveHard DriveCoolingCooling
G.Skill Phoenix Pro 120GB WD 2TB Green Stock 3x120mm UQ fans 
OSMonitorKeyboardPower
W7 Pro SP1 x64 LG 21' 1680x1050 Genius  Corsair CX600 
CaseMouseMouse PadAudio
Gigabyte  E-Blue Mazer XFX WarPad On-board 
Audio
Logitech G35 
  hide details  
Reply
post #3 of 15
Thread Starter 
Yes, exactly. Is this your card? if so, anyway you could upload your stock bios for me via GPUZ?
post #4 of 15
Quote:
Originally Posted by Cainabob View Post

Yes, exactly. Is this your card? if so, anyway you could upload your stock bios for me via GPUZ?

here you go smile.gif
TahitiGigabyte7970OCrev2.zip 41k .zip file
TheSadFlute
(16 items)
 
DyingHeart
(17 items)
 
 
CPUMotherboardGraphicsRAM
i7-6700K TUF Sabertooth MSI 1080 Ti 16GB 2400MHz C15 
Hard DriveHard DriveHard DriveCooling
Corsair 480GB LE 3TB WD Green Sammy 500GB 850 EVO H100i 
OSMonitorKeyboardPower
Windows 7 Pro  BenQ XR3501 Logitech G710+ EVGA G2 750W 
CaseMouseAudioAudio
Cooler Master Stryker Logitech G602 Asus Strix Nakamichi 5.1 
CPUMotherboardGraphicsRAM
Phenom II X4 965BE  Sapphire 790X Zotac GTX650  4GB Corsair 1066 DDR2 (1GBx4) 
Hard DriveHard DriveCoolingCooling
G.Skill Phoenix Pro 120GB WD 2TB Green Stock 3x120mm UQ fans 
OSMonitorKeyboardPower
W7 Pro SP1 x64 LG 21' 1680x1050 Genius  Corsair CX600 
CaseMouseMouse PadAudio
Gigabyte  E-Blue Mazer XFX WarPad On-board 
Audio
Logitech G35 
  hide details  
Reply
TheSadFlute
(16 items)
 
DyingHeart
(17 items)
 
 
CPUMotherboardGraphicsRAM
i7-6700K TUF Sabertooth MSI 1080 Ti 16GB 2400MHz C15 
Hard DriveHard DriveHard DriveCooling
Corsair 480GB LE 3TB WD Green Sammy 500GB 850 EVO H100i 
OSMonitorKeyboardPower
Windows 7 Pro  BenQ XR3501 Logitech G710+ EVGA G2 750W 
CaseMouseAudioAudio
Cooler Master Stryker Logitech G602 Asus Strix Nakamichi 5.1 
CPUMotherboardGraphicsRAM
Phenom II X4 965BE  Sapphire 790X Zotac GTX650  4GB Corsair 1066 DDR2 (1GBx4) 
Hard DriveHard DriveCoolingCooling
G.Skill Phoenix Pro 120GB WD 2TB Green Stock 3x120mm UQ fans 
OSMonitorKeyboardPower
W7 Pro SP1 x64 LG 21' 1680x1050 Genius  Corsair CX600 
CaseMouseMouse PadAudio
Gigabyte  E-Blue Mazer XFX WarPad On-board 
Audio
Logitech G35 
  hide details  
Reply
post #5 of 15
Thread Starter 
THANK YOU!

I have literally been trying different bios all day and all with the same result. The one you just uploaded fixed my problem.

A million thanks!
post #6 of 15
Quote:
Originally Posted by Cainabob View Post

THANK YOU!
I have literally been trying different bios all day and all with the same result. The one you just uploaded fixed my problem.
A million thanks!

thumb.gif

If you want your rig in your sig, here's how:
http://www.overclock.net/t/1258253/how-to-put-your-rig-in-your-sig
TheSadFlute
(16 items)
 
DyingHeart
(17 items)
 
 
CPUMotherboardGraphicsRAM
i7-6700K TUF Sabertooth MSI 1080 Ti 16GB 2400MHz C15 
Hard DriveHard DriveHard DriveCooling
Corsair 480GB LE 3TB WD Green Sammy 500GB 850 EVO H100i 
OSMonitorKeyboardPower
Windows 7 Pro  BenQ XR3501 Logitech G710+ EVGA G2 750W 
CaseMouseAudioAudio
Cooler Master Stryker Logitech G602 Asus Strix Nakamichi 5.1 
CPUMotherboardGraphicsRAM
Phenom II X4 965BE  Sapphire 790X Zotac GTX650  4GB Corsair 1066 DDR2 (1GBx4) 
Hard DriveHard DriveCoolingCooling
G.Skill Phoenix Pro 120GB WD 2TB Green Stock 3x120mm UQ fans 
OSMonitorKeyboardPower
W7 Pro SP1 x64 LG 21' 1680x1050 Genius  Corsair CX600 
CaseMouseMouse PadAudio
Gigabyte  E-Blue Mazer XFX WarPad On-board 
Audio
Logitech G35 
  hide details  
Reply
TheSadFlute
(16 items)
 
DyingHeart
(17 items)
 
 
CPUMotherboardGraphicsRAM
i7-6700K TUF Sabertooth MSI 1080 Ti 16GB 2400MHz C15 
Hard DriveHard DriveHard DriveCooling
Corsair 480GB LE 3TB WD Green Sammy 500GB 850 EVO H100i 
OSMonitorKeyboardPower
Windows 7 Pro  BenQ XR3501 Logitech G710+ EVGA G2 750W 
CaseMouseAudioAudio
Cooler Master Stryker Logitech G602 Asus Strix Nakamichi 5.1 
CPUMotherboardGraphicsRAM
Phenom II X4 965BE  Sapphire 790X Zotac GTX650  4GB Corsair 1066 DDR2 (1GBx4) 
Hard DriveHard DriveCoolingCooling
G.Skill Phoenix Pro 120GB WD 2TB Green Stock 3x120mm UQ fans 
OSMonitorKeyboardPower
W7 Pro SP1 x64 LG 21' 1680x1050 Genius  Corsair CX600 
CaseMouseMouse PadAudio
Gigabyte  E-Blue Mazer XFX WarPad On-board 
Audio
Logitech G35 
  hide details  
Reply
post #7 of 15
GUYS,
NEVER, EVER EVER FLASH A 7970 WITH A GHZ BIOS WITH ATIFLASH/AtiWINFLASH! EVER !!!

The card WILL NOT WORK.

The ghz cards have some changes which REQUIRE that you use the AMD supplied (unofficial flasher). There should be a link on the guru3d forums.
Just set the card back to stock, run the AMD supplied ghz edition flasher, then uninstall and reinstall the drivers. (some said that you can run the flasher after uninstalling the drivers first).
SB Rig
(13 items)
 
  
CPUMotherboardGraphicsRAM
i7-2600k Gigabyte P67A-UD5 B3 R9 290X 16GB 
Hard DriveOptical DriveOSMonitor
WD 2 TB, WD 1 TB, 250gb Liteon ihbs212 blu-ray burner/reader XP+W7 Benq XL2720Z 
KeyboardPowerCaseMouse
Ducky Shine 69/Year of the Goat/Shine 5 Seasonic Platinum X1000 Corsair 760T Logitech G502 with r0ach approved ™ sensor 
Mouse Pad
Puretrak Talent 
  hide details  
Reply
SB Rig
(13 items)
 
  
CPUMotherboardGraphicsRAM
i7-2600k Gigabyte P67A-UD5 B3 R9 290X 16GB 
Hard DriveOptical DriveOSMonitor
WD 2 TB, WD 1 TB, 250gb Liteon ihbs212 blu-ray burner/reader XP+W7 Benq XL2720Z 
KeyboardPowerCaseMouse
Ducky Shine 69/Year of the Goat/Shine 5 Seasonic Platinum X1000 Corsair 760T Logitech G502 with r0ach approved ™ sensor 
Mouse Pad
Puretrak Talent 
  hide details  
Reply
post #8 of 15
Quote:
Originally Posted by Falkentyne View Post

GUYS,
NEVER, EVER EVER FLASH A 7970 WITH A GHZ BIOS WITH ATIFLASH/AtiWINFLASH! EVER !!!
The card WILL NOT WORK.
The ghz cards have some changes which REQUIRE that you use the AMD supplied (unofficial flasher). There should be a link on the guru3d forums.
Just set the card back to stock, run the AMD supplied ghz edition flasher, then uninstall and reinstall the drivers. (some said that you can run the flasher after uninstalling the drivers first).

if it´s the same card i have, thers no problem and second if it is the same card you have a bioswitch(dual bios chip) Look post down under

http://www.overclock.net/t/1294856/cant-increase-voltage-gigabyte-7970-windforce-3x-gv-r797oc-3gd/80#post_18589897
post #9 of 15
Quote:
Originally Posted by Falkentyne View Post

GUYS,
NEVER, EVER EVER FLASH A 7970 WITH A GHZ BIOS WITH ATIFLASH/AtiWINFLASH! EVER !!!
The card WILL NOT WORK.
The ghz cards have some changes which REQUIRE that you use the AMD supplied (unofficial flasher). There should be a link on the guru3d forums.
Just set the card back to stock, run the AMD supplied ghz edition flasher, then uninstall and reinstall the drivers. (some said that you can run the flasher after uninstalling the drivers first).

Can you link me to which one you mean? The only AMD supplied flasher I can find is for reference GHZ cards which failed to flash for me.


Thanks!
post #10 of 15
sorry i'am italien ^_^ my vga http://www.overclock.net/content/type/61/id/1125716/ http://www.gigabyte.com/products/product-page.aspx?pid=4102#ov

bios?? unlock voltage?? frown.gif
New Posts  All Forums:Forum Nav:
  Return Home
Overclock.net › Forums › Graphics Cards › AMD/ATI › ATI Drivers and Overclocking Software › Gigabyte 7970 OC REV 2.0 issues after bios flash