Overclock.net › Forums › Software, Programming and Coding › Networking & Security › Wifi speed fluctuating like mad
New Posts  All Forums:Forum Nav:

Wifi speed fluctuating like mad

post #1 of 8
Thread Starter 
Hey guys, I have been having some trouble with my wifi lately. First off I have a Netgear R4500 router and an Intel Centrino Advanced-N 6205 Wifi adapter. I get 4-5 bars of signal all the time, but my speed fluctuates like crazy. It will go from ~100KB/s to ~3MB/s then drop back to ~100KB/s. I am quite a ways away from my router, but seeing that I can get 3MB/s seems to rule out this issue being caused by me being too far from the router. Do you guys have any ideas on what is going on? I have tried changing the channel on the router, but it doesn't seem to make a difference. Is there anything else I can try?
Z270
(7 items)
 
X58
(10 items)
 
Still Kickin'
(12 items)
 
CPUMotherboardGraphicsRAM
i5 7600K 4.6GHz @ 1.3v De-Lidded Asus Z270I EVGA GTX 980Ti SC Patriot Viper 3000mhz DDR4 
Hard DriveCoolingOS
a bunch of random SSD's Corsair H100i V2 Windows 10 Pro 
CPUMotherboardGraphicsRAM
Xeon X5670 @4.4GHz ASUS P6X58D-E EVGA GTX 980Ti @1455/3766 12GB Kingston HyperX 
Hard DriveCoolingOSMonitor
Samsung 850/OCZ Trion 150 Corsair H100i Windows 10 Professional  Asus PB258Q 
Power
Corsair AX650 
CPUMotherboardGraphicsRAM
Xeon X5470 (LGA 771)  ASUS PQ5 PRO TURBO EVGA GTX 980Ti Random DDR2 
Hard DriveCoolingOSMonitor
Samsung EVO 840 250GB LEPA Exllusion 240 Windows 10 Pro Asus PB258Q 
KeyboardPowerCaseMouse
Razer Blackwidow Ultimate Corsair AX650 TBD Razer Mamba TE 
  hide details  
Reply
Z270
(7 items)
 
X58
(10 items)
 
Still Kickin'
(12 items)
 
CPUMotherboardGraphicsRAM
i5 7600K 4.6GHz @ 1.3v De-Lidded Asus Z270I EVGA GTX 980Ti SC Patriot Viper 3000mhz DDR4 
Hard DriveCoolingOS
a bunch of random SSD's Corsair H100i V2 Windows 10 Pro 
CPUMotherboardGraphicsRAM
Xeon X5670 @4.4GHz ASUS P6X58D-E EVGA GTX 980Ti @1455/3766 12GB Kingston HyperX 
Hard DriveCoolingOSMonitor
Samsung 850/OCZ Trion 150 Corsair H100i Windows 10 Professional  Asus PB258Q 
Power
Corsair AX650 
CPUMotherboardGraphicsRAM
Xeon X5470 (LGA 771)  ASUS PQ5 PRO TURBO EVGA GTX 980Ti Random DDR2 
Hard DriveCoolingOSMonitor
Samsung EVO 840 250GB LEPA Exllusion 240 Windows 10 Pro Asus PB258Q 
KeyboardPowerCaseMouse
Razer Blackwidow Ultimate Corsair AX650 TBD Razer Mamba TE 
  hide details  
Reply
post #2 of 8
All of my issues went away after I switched ISP, something to think about before you pull your hair out.

The 1st thing to try would be your WiFi adapter, sometimes they can act up.
Main Rig
(19 items)
 
  
CPUMotherboardGraphicsRAM
i7 4770 ASRock Z87 Extreme4 Sapphire HD 7950 Corsair Vengeance 4 x 4GB DDR3 
Hard DriveHard DriveOptical DriveOS
Samsung 840 Pro 256 WD Caviar Black Samsung Windows 8 64 
MonitorKeyboardPowerCase
Triple LG 22EA63 IPS Cinema Screens Ducky DK9087 Dragon Antec HCG-620M (620w) Fractal R4 
MouseMouse PadAudioAudio
Sensei Raw steelseries 9HD Audioengine D1 DAC Sennheiser HD558 Cans 
AudioOtherOther
SE EL84 valve amplifier Hauppauge WinTV HVR-1800 Tuner Card Gyration remote control. 
  hide details  
Reply
Main Rig
(19 items)
 
  
CPUMotherboardGraphicsRAM
i7 4770 ASRock Z87 Extreme4 Sapphire HD 7950 Corsair Vengeance 4 x 4GB DDR3 
Hard DriveHard DriveOptical DriveOS
Samsung 840 Pro 256 WD Caviar Black Samsung Windows 8 64 
MonitorKeyboardPowerCase
Triple LG 22EA63 IPS Cinema Screens Ducky DK9087 Dragon Antec HCG-620M (620w) Fractal R4 
MouseMouse PadAudioAudio
Sensei Raw steelseries 9HD Audioengine D1 DAC Sennheiser HD558 Cans 
AudioOtherOther
SE EL84 valve amplifier Hauppauge WinTV HVR-1800 Tuner Card Gyration remote control. 
  hide details  
Reply
post #3 of 8
Thread Starter 
Quote:
Originally Posted by All3n View Post

All of my issues went away after I switched ISP, something to think about before you pull your hair out.
The 1st thing to try would be your WiFi adapter, sometimes they can act up.

Here in AZ its Cox or crappy speeds so I am going to have to stick with my ISP, my speeds from the modem are great its just the wireless speeds. I have updated my adapter drivers, but it doesn't seem to help. I might pull it out and put it in a different PCI-E slot and see if that makes any difference.
Z270
(7 items)
 
X58
(10 items)
 
Still Kickin'
(12 items)
 
CPUMotherboardGraphicsRAM
i5 7600K 4.6GHz @ 1.3v De-Lidded Asus Z270I EVGA GTX 980Ti SC Patriot Viper 3000mhz DDR4 
Hard DriveCoolingOS
a bunch of random SSD's Corsair H100i V2 Windows 10 Pro 
CPUMotherboardGraphicsRAM
Xeon X5670 @4.4GHz ASUS P6X58D-E EVGA GTX 980Ti @1455/3766 12GB Kingston HyperX 
Hard DriveCoolingOSMonitor
Samsung 850/OCZ Trion 150 Corsair H100i Windows 10 Professional  Asus PB258Q 
Power
Corsair AX650 
CPUMotherboardGraphicsRAM
Xeon X5470 (LGA 771)  ASUS PQ5 PRO TURBO EVGA GTX 980Ti Random DDR2 
Hard DriveCoolingOSMonitor
Samsung EVO 840 250GB LEPA Exllusion 240 Windows 10 Pro Asus PB258Q 
KeyboardPowerCaseMouse
Razer Blackwidow Ultimate Corsair AX650 TBD Razer Mamba TE 
  hide details  
Reply
Z270
(7 items)
 
X58
(10 items)
 
Still Kickin'
(12 items)
 
CPUMotherboardGraphicsRAM
i5 7600K 4.6GHz @ 1.3v De-Lidded Asus Z270I EVGA GTX 980Ti SC Patriot Viper 3000mhz DDR4 
Hard DriveCoolingOS
a bunch of random SSD's Corsair H100i V2 Windows 10 Pro 
CPUMotherboardGraphicsRAM
Xeon X5670 @4.4GHz ASUS P6X58D-E EVGA GTX 980Ti @1455/3766 12GB Kingston HyperX 
Hard DriveCoolingOSMonitor
Samsung 850/OCZ Trion 150 Corsair H100i Windows 10 Professional  Asus PB258Q 
Power
Corsair AX650 
CPUMotherboardGraphicsRAM
Xeon X5470 (LGA 771)  ASUS PQ5 PRO TURBO EVGA GTX 980Ti Random DDR2 
Hard DriveCoolingOSMonitor
Samsung EVO 840 250GB LEPA Exllusion 240 Windows 10 Pro Asus PB258Q 
KeyboardPowerCaseMouse
Razer Blackwidow Ultimate Corsair AX650 TBD Razer Mamba TE 
  hide details  
Reply
post #4 of 8
Quote:
Originally Posted by TB13 View Post

Here in AZ its Cox or crappy speeds so I am going to have to stick with my ISP, my speeds from the modem are great its just the wireless speeds. I have updated my adapter drivers, but it doesn't seem to help. I might pull it out and put it in a different PCI-E slot and see if that makes any difference.

Maybe you're getting a lot of interference, or the router isn't operating properly and/or the adapter. Try changing those first.
    
CPUMotherboardGraphicsRAM
INTEL ASUS XFX  SAMSUNG 
Hard DriveOptical DriveCoolingOS
WD/ST LG KUHLER WINDOWS 
MonitorKeyboardPowerCase
LG/SAMSUNG IBM MODEL M CORSAIR THERMALTAKE 
MouseMouse PadAudio
MS INTELLIMOUSE EXPLORER 3.0 REGULAR LARGE PAD ONBOARD but it USED TO BE A XONAR DG  
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
INTEL ASUS XFX  SAMSUNG 
Hard DriveOptical DriveCoolingOS
WD/ST LG KUHLER WINDOWS 
MonitorKeyboardPowerCase
LG/SAMSUNG IBM MODEL M CORSAIR THERMALTAKE 
MouseMouse PadAudio
MS INTELLIMOUSE EXPLORER 3.0 REGULAR LARGE PAD ONBOARD but it USED TO BE A XONAR DG  
  hide details  
Reply
post #5 of 8
A router is a computer too. How old is it? There might be dust in there and letting it heat up.
Make sure you're not on the same channel as other nearby networks as well.
My Scarlet Sin
(16 items)
 
  
CPUMotherboardGraphicsRAM
Core i7-3770k @ 5GHz HT ASRock Z77 Extreme6 eVGA GTX 1070 4x4GB Vengeance @ 1600 CAS7 
Hard DriveCoolingOSMonitor
120GB Plextor M3 SSD | 2x1TB RE4 RAID 1 XSPC Rasa | RX120/240 Windows 7 x64 27" Overlord | 22" U2211H | 32" CCFL Sony 
KeyboardPowerCaseMouse
Cooler Master QuickFire Rapid-i Seasonic X-760 Lian-Li PC-8FIR Logitech G502  
AudioOther
ODAC | Tascam US-366 | Adam A7X Monitors Adam A7X Studio Monitors 
  hide details  
Reply
My Scarlet Sin
(16 items)
 
  
CPUMotherboardGraphicsRAM
Core i7-3770k @ 5GHz HT ASRock Z77 Extreme6 eVGA GTX 1070 4x4GB Vengeance @ 1600 CAS7 
Hard DriveCoolingOSMonitor
120GB Plextor M3 SSD | 2x1TB RE4 RAID 1 XSPC Rasa | RX120/240 Windows 7 x64 27" Overlord | 22" U2211H | 32" CCFL Sony 
KeyboardPowerCaseMouse
Cooler Master QuickFire Rapid-i Seasonic X-760 Lian-Li PC-8FIR Logitech G502  
AudioOther
ODAC | Tascam US-366 | Adam A7X Monitors Adam A7X Studio Monitors 
  hide details  
Reply
post #6 of 8
Thread Starter 
Quote:
Originally Posted by GanjaSMK View Post

Quote:
Originally Posted by TB13 View Post

Here in AZ its Cox or crappy speeds so I am going to have to stick with my ISP, my speeds from the modem are great its just the wireless speeds. I have updated my adapter drivers, but it doesn't seem to help. I might pull it out and put it in a different PCI-E slot and see if that makes any difference.

Maybe you're getting a lot of interference, or the router isn't operating properly and/or the adapter. Try changing those first.

The thing is all of the appliances in my house are in the far side of the house, no where near the router or my PC. What else could cause interference?
Quote:
Originally Posted by Dirtyworks View Post

A router is a computer too. How old is it? There might be dust in there and letting it heat up.
Make sure you're not on the same channel as other nearby networks as well.

The router is maybe 3 months old and the adapter is about 2 months old. I have messed with channels, but none of them seem to change anything. I have tried both 2.4GHz and 5GHz but both give the same results too.

Sent from my Galaxy Nexus using Tapatalk 2
Edited by TB13 - 11/12/12 at 8:29pm
Z270
(7 items)
 
X58
(10 items)
 
Still Kickin'
(12 items)
 
CPUMotherboardGraphicsRAM
i5 7600K 4.6GHz @ 1.3v De-Lidded Asus Z270I EVGA GTX 980Ti SC Patriot Viper 3000mhz DDR4 
Hard DriveCoolingOS
a bunch of random SSD's Corsair H100i V2 Windows 10 Pro 
CPUMotherboardGraphicsRAM
Xeon X5670 @4.4GHz ASUS P6X58D-E EVGA GTX 980Ti @1455/3766 12GB Kingston HyperX 
Hard DriveCoolingOSMonitor
Samsung 850/OCZ Trion 150 Corsair H100i Windows 10 Professional  Asus PB258Q 
Power
Corsair AX650 
CPUMotherboardGraphicsRAM
Xeon X5470 (LGA 771)  ASUS PQ5 PRO TURBO EVGA GTX 980Ti Random DDR2 
Hard DriveCoolingOSMonitor
Samsung EVO 840 250GB LEPA Exllusion 240 Windows 10 Pro Asus PB258Q 
KeyboardPowerCaseMouse
Razer Blackwidow Ultimate Corsair AX650 TBD Razer Mamba TE 
  hide details  
Reply
Z270
(7 items)
 
X58
(10 items)
 
Still Kickin'
(12 items)
 
CPUMotherboardGraphicsRAM
i5 7600K 4.6GHz @ 1.3v De-Lidded Asus Z270I EVGA GTX 980Ti SC Patriot Viper 3000mhz DDR4 
Hard DriveCoolingOS
a bunch of random SSD's Corsair H100i V2 Windows 10 Pro 
CPUMotherboardGraphicsRAM
Xeon X5670 @4.4GHz ASUS P6X58D-E EVGA GTX 980Ti @1455/3766 12GB Kingston HyperX 
Hard DriveCoolingOSMonitor
Samsung 850/OCZ Trion 150 Corsair H100i Windows 10 Professional  Asus PB258Q 
Power
Corsair AX650 
CPUMotherboardGraphicsRAM
Xeon X5470 (LGA 771)  ASUS PQ5 PRO TURBO EVGA GTX 980Ti Random DDR2 
Hard DriveCoolingOSMonitor
Samsung EVO 840 250GB LEPA Exllusion 240 Windows 10 Pro Asus PB258Q 
KeyboardPowerCaseMouse
Razer Blackwidow Ultimate Corsair AX650 TBD Razer Mamba TE 
  hide details  
Reply
post #7 of 8
Not the adapter getting hot - the important computery stuff inside the router. Try aiming a fan towards it. I had this problem too and it turned out it was overheating.
My Scarlet Sin
(16 items)
 
  
CPUMotherboardGraphicsRAM
Core i7-3770k @ 5GHz HT ASRock Z77 Extreme6 eVGA GTX 1070 4x4GB Vengeance @ 1600 CAS7 
Hard DriveCoolingOSMonitor
120GB Plextor M3 SSD | 2x1TB RE4 RAID 1 XSPC Rasa | RX120/240 Windows 7 x64 27" Overlord | 22" U2211H | 32" CCFL Sony 
KeyboardPowerCaseMouse
Cooler Master QuickFire Rapid-i Seasonic X-760 Lian-Li PC-8FIR Logitech G502  
AudioOther
ODAC | Tascam US-366 | Adam A7X Monitors Adam A7X Studio Monitors 
  hide details  
Reply
My Scarlet Sin
(16 items)
 
  
CPUMotherboardGraphicsRAM
Core i7-3770k @ 5GHz HT ASRock Z77 Extreme6 eVGA GTX 1070 4x4GB Vengeance @ 1600 CAS7 
Hard DriveCoolingOSMonitor
120GB Plextor M3 SSD | 2x1TB RE4 RAID 1 XSPC Rasa | RX120/240 Windows 7 x64 27" Overlord | 22" U2211H | 32" CCFL Sony 
KeyboardPowerCaseMouse
Cooler Master QuickFire Rapid-i Seasonic X-760 Lian-Li PC-8FIR Logitech G502  
AudioOther
ODAC | Tascam US-366 | Adam A7X Monitors Adam A7X Studio Monitors 
  hide details  
Reply
post #8 of 8
Quote:
Originally Posted by TB13 View Post


The thing is all of the appliances in my house are in the far side of the house, no where near the router or my PC. What else could cause interference?

Lots of things. Power lines, radio towers, other wifi networks in the area, etc.
    
CPUMotherboardGraphicsRAM
INTEL ASUS XFX  SAMSUNG 
Hard DriveOptical DriveCoolingOS
WD/ST LG KUHLER WINDOWS 
MonitorKeyboardPowerCase
LG/SAMSUNG IBM MODEL M CORSAIR THERMALTAKE 
MouseMouse PadAudio
MS INTELLIMOUSE EXPLORER 3.0 REGULAR LARGE PAD ONBOARD but it USED TO BE A XONAR DG  
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
INTEL ASUS XFX  SAMSUNG 
Hard DriveOptical DriveCoolingOS
WD/ST LG KUHLER WINDOWS 
MonitorKeyboardPowerCase
LG/SAMSUNG IBM MODEL M CORSAIR THERMALTAKE 
MouseMouse PadAudio
MS INTELLIMOUSE EXPLORER 3.0 REGULAR LARGE PAD ONBOARD but it USED TO BE A XONAR DG  
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Networking & Security
Overclock.net › Forums › Software, Programming and Coding › Networking & Security › Wifi speed fluctuating like mad