Overclock.net › Forums › Graphics Cards › NVIDIA › NVIDIA Drivers and Overclocking Software › GTX 680 Physx not showing in GPU-z
New Posts  All Forums:Forum Nav:

GTX 680 Physx not showing in GPU-z

post #1 of 12
Thread Starter 
Has anyone else encountered this? I was checking GPU-z yesterday and I noticed that Physx is not checked on my system. In the Nvidia Control Panel I have the GTX 680 selected as the Physx device, and the Physx drivers show up in the System Information pane of the NCP, and in the Programs list in the WIndows Control Panel. I tried re-installing the latest WHQL drivers, I tried uninstalling the Physx drivers and installing both the WHQL version (can't remember the number) and the newest version via their standalone installers. No luck. The only time I ever saw the Physx box checked was right after I installed the WHQL driver package - but then after I rebooted it was gone again.

I don't know if it is just a display error with GPU-z or not, but I did notice that when I went to the options menu of Batman: AC it would give me a warning that Physx wasn't available and that selecting it could cause slowdowns - but performance seemed normal. I've also noticed before that the NCP would sometimes show the Physx device as the CPU when I open it even though it lets me switch it back to GTX 680 (and Auto puts it to the GPU as well).

Anyone have any ideas?
post #2 of 12
I had this problem with my 680 a few days ago when I got it. To fix it I just uninstalled ALL nvidia drivers and then got rid of the remains with driversweeper. After that just reinstall the latest WHQL or beta drivers and it should be fine smile.gif
Define
(21 items)
 
   
CPUMotherboardGraphicsRAM
Intel Core i7-3770K @ 4.3GHz Gigabyte GA-Z77X-UD5H ASUS GeForce GTX 980 Ti STRIX 6GB @ 1500MHz 2x8GB Kingston HyperX Fury DDR3 @ 2400MHz 
Hard DriveHard DriveCoolingCooling
Samsung 840 Pro 256GB Crucial MX100 512GB Noctua NH-U14S 3x Noctua NF-A14 FLX 
OSMonitorMonitorKeyboard
Windows 10 Pro 64-bit Dell U2713HM Dell U2312HM Ducky Shine 3 Year of the Snake (MX Brown) 
PowerCaseMouseMouse Pad
EVGA SuperNOVA P2 650W Fractal Design Define R5 Black Mionix Naos 7000 SteelSeries QcK 
AudioAudioAudioAudio
Sennheiser HD 650 (bal) Fostex TH-X00 Ebony Schiit Modi Multibit Schiit Jotunheim 
Other
TP-LINK Archer T9E  
CPUGraphicsRAMHard Drive
Intel Xeon E5-2620 v4 @ 3GHz Matrox G200eH2 4x8GB Kingston Dual Rank ECC DDR4 @ 2133MHz 2x Samsung PM863 120GB in RAID1 
Hard DriveOS
4x WD Red 3TB in RAID5 ESXi 6.5 
  hide details  
Reply
Define
(21 items)
 
   
CPUMotherboardGraphicsRAM
Intel Core i7-3770K @ 4.3GHz Gigabyte GA-Z77X-UD5H ASUS GeForce GTX 980 Ti STRIX 6GB @ 1500MHz 2x8GB Kingston HyperX Fury DDR3 @ 2400MHz 
Hard DriveHard DriveCoolingCooling
Samsung 840 Pro 256GB Crucial MX100 512GB Noctua NH-U14S 3x Noctua NF-A14 FLX 
OSMonitorMonitorKeyboard
Windows 10 Pro 64-bit Dell U2713HM Dell U2312HM Ducky Shine 3 Year of the Snake (MX Brown) 
PowerCaseMouseMouse Pad
EVGA SuperNOVA P2 650W Fractal Design Define R5 Black Mionix Naos 7000 SteelSeries QcK 
AudioAudioAudioAudio
Sennheiser HD 650 (bal) Fostex TH-X00 Ebony Schiit Modi Multibit Schiit Jotunheim 
Other
TP-LINK Archer T9E  
CPUGraphicsRAMHard Drive
Intel Xeon E5-2620 v4 @ 3GHz Matrox G200eH2 4x8GB Kingston Dual Rank ECC DDR4 @ 2133MHz 2x Samsung PM863 120GB in RAID1 
Hard DriveOS
4x WD Red 3TB in RAID5 ESXi 6.5 
  hide details  
Reply
post #3 of 12
If it's a possible GPU-Z bug, try nvidia inspector, click on the little cog/spanner sign and scroll down and turn on "Physx Indicator", save it and try a game with Physx to see if it actually says on or off. Or... reinstall drivers haha
    
CPUMotherboardGraphicsGraphics
Intel i5-2500k @Stock MSI P67A-G45 Gigabyte GTX 980 4GB WINDFORCE 3 Gigabyte GTX 980 4GB WINDFORCE 3 
RAMHard DriveOSPower
8GB DDR3 RAM Seagate 500GB 7,500RPM Windows 64-bit EVGA SuperNova P2 850W Platinum 
Case
Carbide Series® Air 540 
  hide details  
Reply
    
CPUMotherboardGraphicsGraphics
Intel i5-2500k @Stock MSI P67A-G45 Gigabyte GTX 980 4GB WINDFORCE 3 Gigabyte GTX 980 4GB WINDFORCE 3 
RAMHard DriveOSPower
8GB DDR3 RAM Seagate 500GB 7,500RPM Windows 64-bit EVGA SuperNova P2 850W Platinum 
Case
Carbide Series® Air 540 
  hide details  
Reply
post #4 of 12
Thread Starter 
Quote:
Originally Posted by AndyM95 View Post

I had this problem with my 680 a few days ago when I got it. To fix it I just uninstalled ALL nvidia drivers and then got rid of the remains with driversweeper. After that just reinstall the latest WHQL or beta drivers and it should be fine smile.gif

That's my next step, I guess, although I was hoping it was just an indication error with GPU-Z. Guess it's not worth wondering what else might be wrong, though. I haven't tried a clean install since I didn't want to lose my per-game settings, but I guess that's where I'm at.

Quote:
Originally Posted by icanhasburgers View Post

If it's a possible GPU-Z bug, try nvidia inspector, click on the little cog/spanner sign and scroll down and turn on "Physx Indicator", save it and try a game with Physx to see if it actually says on or off. Or... reinstall drivers haha

I'll give that a shot. Any idea what "Physx indicator" actually does?
post #5 of 12
edit: already tried what fixed mine, mental note: read the post very thoroughly before making a reply
    
CPUMotherboardGraphicsRAM
Intel Core i7 4770k Gigabyte GA-Z87X-UD4H GeForce GTX 680  Crucial Ballistix Elite 
Hard DriveHard DriveOptical DriveCooling
WD30EZRX x2 Intel 520 SSD LG Bluray Burner WH12LS39 x2 Fully Liquid Cooled 
OSMonitorKeyboardPower
Win 7 Pro Qnix QX2710 Razer Blackwidow Ultimate 2013 BF4 Edition Corsair AX760 
CaseMouseMouse Pad
Switch 810 Gunmetal G700s Steelseries 4HD 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
Intel Core i7 4770k Gigabyte GA-Z87X-UD4H GeForce GTX 680  Crucial Ballistix Elite 
Hard DriveHard DriveOptical DriveCooling
WD30EZRX x2 Intel 520 SSD LG Bluray Burner WH12LS39 x2 Fully Liquid Cooled 
OSMonitorKeyboardPower
Win 7 Pro Qnix QX2710 Razer Blackwidow Ultimate 2013 BF4 Edition Corsair AX760 
CaseMouseMouse Pad
Switch 810 Gunmetal G700s Steelseries 4HD 
  hide details  
Reply
post #6 of 12
Thread Starter 
Bah, still can't get this working. Anyone know a way to verify if Physx is actually working that doesn't involve me buying BL2 or re-downloading one of the Batman games? I downloaded the Supersonic Sled demo from the Nvidia Physx page and it runs the same if I select GTX 680 for Physx or CPU. I'm guessing that means Physx isn't working, but I'm not convinced that is a valid test.
post #7 of 12
Quote:
Originally Posted by Forceman View Post

Bah, still can't get this working. Anyone know a way to verify if Physx is actually working that doesn't involve me buying BL2 or re-downloading one of the Batman games? I downloaded the Supersonic Sled demo from the Nvidia Physx page and it runs the same if I select GTX 680 for Physx or CPU. I'm guessing that means Physx isn't working, but I'm not convinced that is a valid test.
It's worth just re-downloading a batman game. If it doesn't work in that then you're gonna have to do a clean re-install of your drivers smile.gif
Define
(21 items)
 
   
CPUMotherboardGraphicsRAM
Intel Core i7-3770K @ 4.3GHz Gigabyte GA-Z77X-UD5H ASUS GeForce GTX 980 Ti STRIX 6GB @ 1500MHz 2x8GB Kingston HyperX Fury DDR3 @ 2400MHz 
Hard DriveHard DriveCoolingCooling
Samsung 840 Pro 256GB Crucial MX100 512GB Noctua NH-U14S 3x Noctua NF-A14 FLX 
OSMonitorMonitorKeyboard
Windows 10 Pro 64-bit Dell U2713HM Dell U2312HM Ducky Shine 3 Year of the Snake (MX Brown) 
PowerCaseMouseMouse Pad
EVGA SuperNOVA P2 650W Fractal Design Define R5 Black Mionix Naos 7000 SteelSeries QcK 
AudioAudioAudioAudio
Sennheiser HD 650 (bal) Fostex TH-X00 Ebony Schiit Modi Multibit Schiit Jotunheim 
Other
TP-LINK Archer T9E  
CPUGraphicsRAMHard Drive
Intel Xeon E5-2620 v4 @ 3GHz Matrox G200eH2 4x8GB Kingston Dual Rank ECC DDR4 @ 2133MHz 2x Samsung PM863 120GB in RAID1 
Hard DriveOS
4x WD Red 3TB in RAID5 ESXi 6.5 
  hide details  
Reply
Define
(21 items)
 
   
CPUMotherboardGraphicsRAM
Intel Core i7-3770K @ 4.3GHz Gigabyte GA-Z77X-UD5H ASUS GeForce GTX 980 Ti STRIX 6GB @ 1500MHz 2x8GB Kingston HyperX Fury DDR3 @ 2400MHz 
Hard DriveHard DriveCoolingCooling
Samsung 840 Pro 256GB Crucial MX100 512GB Noctua NH-U14S 3x Noctua NF-A14 FLX 
OSMonitorMonitorKeyboard
Windows 10 Pro 64-bit Dell U2713HM Dell U2312HM Ducky Shine 3 Year of the Snake (MX Brown) 
PowerCaseMouseMouse Pad
EVGA SuperNOVA P2 650W Fractal Design Define R5 Black Mionix Naos 7000 SteelSeries QcK 
AudioAudioAudioAudio
Sennheiser HD 650 (bal) Fostex TH-X00 Ebony Schiit Modi Multibit Schiit Jotunheim 
Other
TP-LINK Archer T9E  
CPUGraphicsRAMHard Drive
Intel Xeon E5-2620 v4 @ 3GHz Matrox G200eH2 4x8GB Kingston Dual Rank ECC DDR4 @ 2133MHz 2x Samsung PM863 120GB in RAID1 
Hard DriveOS
4x WD Red 3TB in RAID5 ESXi 6.5 
  hide details  
Reply
post #8 of 12
Quote:
Originally Posted by Forceman View Post

That's my next step, I guess, although I was hoping it was just an indication error with GPU-Z. Guess it's not worth wondering what else might be wrong, though. I haven't tried a clean install since I didn't want to lose my per-game settings, but I guess that's where I'm at.
I'll give that a shot. Any idea what "Physx indicator" actually does?

Tells you while in-game in the corner whether physx is running or not.
    
CPUMotherboardGraphicsGraphics
Intel i5-2500k @Stock MSI P67A-G45 Gigabyte GTX 980 4GB WINDFORCE 3 Gigabyte GTX 980 4GB WINDFORCE 3 
RAMHard DriveOSPower
8GB DDR3 RAM Seagate 500GB 7,500RPM Windows 64-bit EVGA SuperNova P2 850W Platinum 
Case
Carbide Series® Air 540 
  hide details  
Reply
    
CPUMotherboardGraphicsGraphics
Intel i5-2500k @Stock MSI P67A-G45 Gigabyte GTX 980 4GB WINDFORCE 3 Gigabyte GTX 980 4GB WINDFORCE 3 
RAMHard DriveOSPower
8GB DDR3 RAM Seagate 500GB 7,500RPM Windows 64-bit EVGA SuperNova P2 850W Platinum 
Case
Carbide Series® Air 540 
  hide details  
Reply
post #9 of 12
Just download Fluidmark from Geeks3d, and check if you can use Physx from your GPU. If not download the Physx package from Nvidia and install it.
Doing that should enable GPU Physx. It did for me on my laptop tongue.gif
post #10 of 12
OP, uninstall GPU-Z, reinstall it and check....
TheSadFlute
(16 items)
 
DyingHeart
(17 items)
 
 
CPUMotherboardGraphicsRAM
i7-6700K TUF Sabertooth MSI 1080 Ti 16GB 2400MHz C15 
Hard DriveHard DriveHard DriveCooling
Corsair 480GB LE 3TB WD Green Sammy 500GB 850 EVO H100i 
OSMonitorKeyboardPower
Windows 7 Pro  BenQ XR3501 Logitech G710+ EVGA G2 750W 
CaseMouseAudioAudio
Cooler Master Stryker Logitech G602 Asus Strix Nakamichi 5.1 
CPUMotherboardGraphicsRAM
Phenom II X4 965BE  Sapphire 790X Zotac GTX650  4GB Corsair 1066 DDR2 (1GBx4) 
Hard DriveHard DriveCoolingCooling
G.Skill Phoenix Pro 120GB WD 2TB Green Stock 3x120mm UQ fans 
OSMonitorKeyboardPower
W7 Pro SP1 x64 LG 21' 1680x1050 Genius  Corsair CX600 
CaseMouseMouse PadAudio
Gigabyte  E-Blue Mazer XFX WarPad On-board 
Audio
Logitech G35 
  hide details  
Reply
TheSadFlute
(16 items)
 
DyingHeart
(17 items)
 
 
CPUMotherboardGraphicsRAM
i7-6700K TUF Sabertooth MSI 1080 Ti 16GB 2400MHz C15 
Hard DriveHard DriveHard DriveCooling
Corsair 480GB LE 3TB WD Green Sammy 500GB 850 EVO H100i 
OSMonitorKeyboardPower
Windows 7 Pro  BenQ XR3501 Logitech G710+ EVGA G2 750W 
CaseMouseAudioAudio
Cooler Master Stryker Logitech G602 Asus Strix Nakamichi 5.1 
CPUMotherboardGraphicsRAM
Phenom II X4 965BE  Sapphire 790X Zotac GTX650  4GB Corsair 1066 DDR2 (1GBx4) 
Hard DriveHard DriveCoolingCooling
G.Skill Phoenix Pro 120GB WD 2TB Green Stock 3x120mm UQ fans 
OSMonitorKeyboardPower
W7 Pro SP1 x64 LG 21' 1680x1050 Genius  Corsair CX600 
CaseMouseMouse PadAudio
Gigabyte  E-Blue Mazer XFX WarPad On-board 
Audio
Logitech G35 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
Overclock.net › Forums › Graphics Cards › NVIDIA › NVIDIA Drivers and Overclocking Software › GTX 680 Physx not showing in GPU-z