Overclock.net › Forums › Components › Mice › SteelSeries Sensei startup detection problem!
New Posts  All Forums:Forum Nav:

SteelSeries Sensei startup detection problem!

post #1 of 22
Thread Starter 
last week i upgraded to new SS engine for my SS sensei, after that, the engine itself upgraded the firmware. ok good. then the prob has started... the mouse remains undetected whenever i turn on the pc. Doesn't light up. I have to pull out and re attach the usb connector. Then it works. tried all possible ways to solve this issue, reinstalled the engine, reload the firmware... problem remains same... any solution?

-OS: Win 7 x64
-Mainboard: MSI 990FXA GD-80
-Processor: AMD Phenom II X-6
-GFX: AMD Radeon 7870

guitar.gif
post #2 of 22
Can you roll back to a previous firmware?

I have a Sensei, but I simply don't bother with SteelSeries Engine anymore. I installed it once, adjusted the settings I wanted and removed it. Whenever I need to make additional changes I just use the built-in LCD.
I don't like having these poorly programmed, memory hog utilities running on my system.

Have you tried contacting their support?
Desktop
(15 items)
 
  
CPUMotherboardGraphicsRAM
Intel i3 4170 Asrock Z97 Killer Galax Geforce GTX1060 EXOC 8GB G.SKILL Sniper Low Voltage 
Hard DriveOptical DriveOSMonitor
Seagate Barracuda 1TB (7200RPM) Some LG drive... Windows 10 LG 25UM65 
KeyboardPowerCaseMouse
Coolermaster Storm Devastator OCZ ModXStream Pro (700W) NZXT 410 Phantom Coolermaster Storm Devastator 
Mouse PadAudioOther
Steelseries QcK+ Edifier R2700 Microsoft Xbox 360 Wireless Gamepad 
  hide details  
Reply
Desktop
(15 items)
 
  
CPUMotherboardGraphicsRAM
Intel i3 4170 Asrock Z97 Killer Galax Geforce GTX1060 EXOC 8GB G.SKILL Sniper Low Voltage 
Hard DriveOptical DriveOSMonitor
Seagate Barracuda 1TB (7200RPM) Some LG drive... Windows 10 LG 25UM65 
KeyboardPowerCaseMouse
Coolermaster Storm Devastator OCZ ModXStream Pro (700W) NZXT 410 Phantom Coolermaster Storm Devastator 
Mouse PadAudioOther
Steelseries QcK+ Edifier R2700 Microsoft Xbox 360 Wireless Gamepad 
  hide details  
Reply
post #3 of 22
Thread Starter 
yeh... they gave me some sorta ticket to the support serial confused.gif and after a week, a whole week, replied suggesting upgrading my bios, fresh re install the engine and the firmware... i was like sozo.gif , I'm running an unlocked processor and a high end MB and i keep the bios backdated? weirdsmiley.gif
Quote:
Can you roll back to a previous firmware?
well, sigh, now i want to roll back to the previous firmware (yes you read my mind somehow sitting far away from me)
but there ain't any options showing roll back anywhere related to the sensei....

so if anybody knows how to roll back, please do tell, at least that'd be the best solution, getting another mouse is waste since it's serving me well... tiredsmiley.gif

ohh... thanks buddy.... i've been thinking that i'm the only 1 who thinks this engine is resource grabbing poorly programmed piece of **** cheers.gif and now i know at least another 1 also thinks such...
post #4 of 22
Have you tried that Firmware Update Tool instead of using the SteelSeries Engine to do it?
Desktop
(15 items)
 
  
CPUMotherboardGraphicsRAM
Intel i3 4170 Asrock Z97 Killer Galax Geforce GTX1060 EXOC 8GB G.SKILL Sniper Low Voltage 
Hard DriveOptical DriveOSMonitor
Seagate Barracuda 1TB (7200RPM) Some LG drive... Windows 10 LG 25UM65 
KeyboardPowerCaseMouse
Coolermaster Storm Devastator OCZ ModXStream Pro (700W) NZXT 410 Phantom Coolermaster Storm Devastator 
Mouse PadAudioOther
Steelseries QcK+ Edifier R2700 Microsoft Xbox 360 Wireless Gamepad 
  hide details  
Reply
Desktop
(15 items)
 
  
CPUMotherboardGraphicsRAM
Intel i3 4170 Asrock Z97 Killer Galax Geforce GTX1060 EXOC 8GB G.SKILL Sniper Low Voltage 
Hard DriveOptical DriveOSMonitor
Seagate Barracuda 1TB (7200RPM) Some LG drive... Windows 10 LG 25UM65 
KeyboardPowerCaseMouse
Coolermaster Storm Devastator OCZ ModXStream Pro (700W) NZXT 410 Phantom Coolermaster Storm Devastator 
Mouse PadAudioOther
Steelseries QcK+ Edifier R2700 Microsoft Xbox 360 Wireless Gamepad 
  hide details  
Reply
post #5 of 22
I have the same problem. You fixed?
post #6 of 22
Search for the ss firmware update tool. It should fix it.
post #7 of 22
Quote:
Originally Posted by curteRAmott View Post

last week i upgraded to new SS engine for my SS sensei, after that, the engine itself upgraded the firmware. ok good. then the prob has started... the mouse remains undetected whenever i turn on the pc. Doesn't light up. I have to pull out and re attach the usb connector. Then it works. tried all possible ways to solve this issue, reinstalled the engine, reload the firmware... problem remains same... any solution?

-OS: Win 7 x64
-Mainboard: MSI 990FXA GD-80
-Processor: AMD Phenom II X-6
-GFX: AMD Radeon 7870

guitar.gif

Hi there curteRAmott,

I had that problem a long time ago, but with steelseries Xai (http://www.overclock.net/t/988923/steelseries-xai-boot-problem). i also had to unplug the mouse until windows was fully loaded and then plug it.
From what i remember it has something to do with MB doesn't recognize both devices xai created..
I also have an MSI. The only solution i got for you and is 100% effective (i don't know about sensei and your motherboard), is to buy a usb 2.0 pci card.
It's the only way to get around that issue. I think you have a b4 hang up?
Try to see if you have some kind of bios update, because this was a known issue, and msi kind of released some updates, because there was a lot of costumers complaining with the exact same problem ( i thought that issue was already fixed....)
I hope i could help you smile.gif
Old but fast
(17 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i5 2500K Asus P8Z77-V LE AMD Radeon HD 7900 Series G. 
RAMHard DriveOptical DriveCooling
G. Samsung 500GB LG dvd wr arctic cooler freezer 13 
OSMonitorKeyboardPower
win 7 64 Benq XL 2411t Roccat Arvo corsair tx650 
CaseMouseMouse PadAudio
CM 690 II Advanced Zowie ec2-a SS Qck Heavy Sennheiser hd 558 & zalmann mic clip 
Audio
Asus Xonar Dx 
  hide details  
Reply
Old but fast
(17 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i5 2500K Asus P8Z77-V LE AMD Radeon HD 7900 Series G. 
RAMHard DriveOptical DriveCooling
G. Samsung 500GB LG dvd wr arctic cooler freezer 13 
OSMonitorKeyboardPower
win 7 64 Benq XL 2411t Roccat Arvo corsair tx650 
CaseMouseMouse PadAudio
CM 690 II Advanced Zowie ec2-a SS Qck Heavy Sennheiser hd 558 & zalmann mic clip 
Audio
Asus Xonar Dx 
  hide details  
Reply
post #8 of 22
Thread Starter 
nah... F/W upgrades din't solve my problem... I'm up-to-date till now... wha-smiley.png
post #9 of 22
Thread Starter 
Quote:
Originally Posted by connectwise View Post

Search for the ss firmware update tool. It should fix it.

nah... F/W upgrades din't solve my problem... I'm up-to-date till now... wha-smiley.png
post #10 of 22
Thread Starter 
Quote:
Originally Posted by Snakesoul View Post

buy a usb 2.0 pci card.
It's the only way to get around that issue. I think you have a b4 hang up?

well, i've already got 8x 2.0usb on board and 4x usb 3.0 ... so I'm not intending to get any addon interface for usb wth.gif
about my BIOS, it's also up-to-date biggrin.gif as far as i can guess this mouse is not being detected by the bios because of it's internal circuitry... the mouse remain's inactive even after getting the power via usb port first time so it's remain undetected by the MB... It's definitely F/W problem. sozo.gif
A company like SteelSeries should focus on this problem and i don't know how come they're ignoring customer complains. I post a complain too but that ******* support team gave me a support ticket which is quite useless confused.gif
Quote:
Originally Posted by Snakesoul View Post

I had that problem a long time ago, but with steelseries Xai

If xai faces the same problem, well, sigh, it's quite misuse of money getting ss mouse ... The Sensei i'm using is quite powerful since it has ARM cortex processor inside and the profiling is too good, but i think none would like to do some exercises after turning on their system by unplug and reconnect the mouse tiredsmiley.gif
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Mice
Overclock.net › Forums › Components › Mice › SteelSeries Sensei startup detection problem!