Overclock.net › Forums › Components › Memory › DDR3 1333 RAM not always detected after Processor upgrade
New Posts  All Forums:Forum Nav:

DDR3 1333 RAM not always detected after Processor upgrade

post #1 of 4
Thread Starter 
Hello everyone,
So here is the situation. I have a system which I have been slowly upgrading piece by piece over the last one year or so. Current specs.

1. CPU: AMD FX 4100
2. RAM: 2x4GB G.SKILL F3-10666CL9-4GBNT (9-9-9-24 1.5v)
3. MOBO: Gigabyte GA-78LMT-S2P
4. PSU: Corsair GS600
5. GPU: GTX 550Ti
6. OS: Win 7 Ultimate 64bits
Note: NO OVERCLOCK, everything is stock

Now here is the problem. Previously, I was using the AMD Athlon X2 CPU and everything else was the same specs. I never faced any issues or problems with my system. Recently, I got the FX 4100, installed it and that when the problem started. Windows detected only 6GB of RAM with 4GB usable. So I immediately rebooted and alas the bios only read 4097 MB of DDR3 at 1333MHz. Windows loaded and again only 6GB. No change after several reboots. I was getting sure I had fried a stick.

So, next these are what I try
I remove both sticks and reseat them - No change (By the way my mobo has only 2 memory slots)
I remove and interchange - No change
I remove one and restart - Bios posts and 4097 Mb detected, windows reads 4GB of RAM
I remove 1st stick and insert 2nd - No post

So I have isolated the faulty RAM.
Just to make sure I insert it in my brother's system, but to my shock the system boots and windows detects 4gb of ram.
I insert my brothers 2gb of ram along with my working 4gb in my system and the bios detects 6gb of DDR3 at 1333 Mhz.

Out of desperation, I finally remove my FX4100 and insert my old Athlon X2 and not to my surprise everything is PERFECT. All RAM is detected. All 8GB of it.
I then check for bent pin in my FX4100. Reseat the CPU and Cooler properly. Check is the cooler is too tight (it is not). Nothing works.

Finally, I flash the bios with the latest upgrade from Gigabyte. This is when I see some changes.
After flashing, when I restart, the bios finally sees 8192 Mb of DDR3 1333Mhz. Windows does the same. 8GB of usable RAM. I use the system for a couple of hours and shut down the system for the night.
Next morning after restart again only 4GB. What went wrong now? After several restarts no solution.
Shut down and forget! mad.gif

That night I plan to tweak the bios on a trial and error basis.
I increase the DRAM voltage 1.6v - No change - Reset to 1.5v
Changed SPD from auto to manual - timings match the RAM defaults
Finally reduced speed from 1333Mhz to 800Mhz - after restart 8192 Mb detected.
worked fine for the whole day.

Next morning on reboot again got 4gb at 800Mhz. So reduced to 667Mhz and got 8GB. Then raised to 800 and still 8GB. But on increasing to 1333 only got 4GB so reverted back to 800Mhz and got 8gb.
So now this is the only temporary solution that I have been using for a couple of days now. If on reboot all 8gb is not detected then I reduce the timing and increase again but only till 800Mhz. More than that and not all RAM is detected.

Now my question is how do I over come this problem. Is the RAM faulty? Are the BIOS settings wrong? I really dont know.

Please advice. Any help will be appreciated.

post #2 of 4

this looks to be a very very unusual BIOS fault. You'll want to report it to GIGABYTE.
You could also try increasing the IMC voltage (CPU-NB probably) to see if that might help address anything.

post #3 of 4
Thread Starter 
I dont think its a Gigabyte problem because the RAMs seem to work just fine with my old Athlon X2. Only when I install my FX4100 the problems start.

as for increasing the IMC voltage what exactly am i looking for in the BIOS. By how much can I safely increase the voltage.
post #4 of 4
Thread Starter 
OK an update.
I cleared the CMOS as you asked. I had to remove my GPU in the process. So decided not to install it for the time being. Got some screen shots of the BIOS


Ok now you can see the BIOS has detected 3582Mb (512 Mb for shared memory, since I did not install the GPU, I guess). So I save and exit. Bios and Windows now detects 7678Mb (+512Mb). Windows say 8GB ram (7.50GB usable).


So I install the GPU. Again bios gets 4096Mb.
Then I try to increase the CPU-NB volt as you suggested. Got it up by .5v at 1.25v. Booted and 8GB. shut down and reboot 8gb.
Think it might have solved the problem. Have to wait and see. Will revert in some time.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Memory
Overclock.net › Forums › Components › Memory › DDR3 1333 RAM not always detected after Processor upgrade