Overclock.net › Forums › Components › Keyboards › My left "ALT" key on my CM quickfire rapid (MX red) just stopped working....
New Posts  All Forums:Forum Nav:

My left "ALT" key on my CM quickfire rapid (MX red) just stopped working....

post #1 of 17
Thread Starter 
*** happened? How do I fix this? I didn't spill anything into it; it just stopped working for no apparent reason.
post #2 of 17
You are now the 5th one I've seen with this.

I'm beginning to think they have a PCB layout problem.
My System
(13 items)
 
  
Keyboard
Lots of them 
  hide details  
Reply
My System
(13 items)
 
  
Keyboard
Lots of them 
  hide details  
Reply
post #3 of 17
you got 2 alt keys to work with
post #4 of 17
Thread Starter 
It's kind of difficult to play my MOBAS holding down my right alt key and pressing the "QWE" keys at the same time...

And regardless, if I'm paying $90 for a keyboard, I expect for all of these to work...
post #5 of 17
its got 2 year warranty on it..
post #6 of 17
"you got 2 alt keys to work with
"

Hey, the mobile OCN app doesn't have a "troll" button!
My System
(13 items)
 
  
Keyboard
Lots of them 
  hide details  
Reply
My System
(13 items)
 
  
Keyboard
Lots of them 
  hide details  
Reply
post #7 of 17
I have to add myself to that list. The left-alt key just failed on my CM Quickfire with brown switches. Seems like a small batch of Brown, Blue and Reds have faulty left alt-keys.

From the CM rep in the Quickfire thread:
Quote:
Unfortunately, there was a very small concentrated batch Costar apparently had issues with left ALT. All issues have been fixed and it will not happen on any further board. We are able to track down the exact order these came in on, unfortunately it affects Blue, Red & Brown switches but in a very limited fashion. Also its impossible to recall the whole shipment because only about 1 out of 20 boards suffer the issue.

Please understand this was something we didnt catch, but do apologize, and assure you we have tightened up QC BIG time on our Costar boards.

Edited by TomatoBasket - 12/3/12 at 2:30pm
post #8 of 17
Hi guys,
just got another Quickfire Rapid with broken Left Alt key.
The first one amazon sent had a broken left alt.
The second one they sent was a Spanish layout with a working left alt.
The third one they sent was again a US layout with broken left alt key.
I dunno what to do.

/matt
post #9 of 17
Quote:
Originally Posted by mmontag View Post

Hi guys,
just got another Quickfire Rapid with broken Left Alt key.
The first one amazon sent had a broken left alt.
The second one they sent was a Spanish layout with a working left alt.
The third one they sent was again a US layout with broken left alt key.
I dunno what to do.
/matt

Mine arrived with a broken one too, but I remapped the Left Windows to Left Alt, and the Right Windows key to Left Windows key with KeyTweak. I will send it back 1 month before the 3 year warranty will expire -> I will have another 3 years of warranty. If they can't tests these things out in the factory then they deserve it.
Edited by tikshow - 12/11/12 at 3:20am
post #10 of 17
They COULD hALT shipments of bad keyboards.
My System
(13 items)
 
  
Keyboard
Lots of them 
  hide details  
Reply
My System
(13 items)
 
  
Keyboard
Lots of them 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Keyboards
Overclock.net › Forums › Components › Keyboards › My left "ALT" key on my CM quickfire rapid (MX red) just stopped working....