Overclock.net › Forums › Components › Other Peripherals › Blu-ray drive problems
New Posts  All Forums:Forum Nav:

Blu-ray drive problems

post #1 of 3
Thread Starter 
I just built a new computer for my dad, and one of the things he wanted was a Blu-ray burner (Asus BW-12B1ST). Everything went fine with the install, and the drive is recognized in BIOS, but when you go into Windows (Windows 7 Professional 64bit) it doesn't work at all. It doesn't show up in my computer, and when you look in the device manager the drive shows up with an error icon and is identified as a CD/DVD Drive not a Blu-ray drive. I have tried to uninstall the drive and let Windows re-detect it but it says it successfully installed and all the problems are still there. We tried talking to Asus tech support, and they weren't able to help. The only suggestion they had was that their was some sort of incompatibility with the motherboard (ASRock FM2A75 Pro4). I've double checked all the connections, and they are fine. I've run out of ideas on how to trouble shoot this problem. Has anyone else ever had this problem, or have any advice on how to fix it?
    
CPUMotherboardGraphicsRAM
Intel Core i5 750 Gigabyte P55-UD4P NVIDIA GeForce GTX 470 G. Skill 
Hard DriveOptical DriveOSMonitor
WD 6401AALS Samsung SH-S223B Windows 7 Professional 64 Bit Samsung SyncMaster 2232BW 
KeyboardPowerCaseMouse
Saitek Eclipse II Corsair TX750 CM 690 II Advanced Logitech G500 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
Intel Core i5 750 Gigabyte P55-UD4P NVIDIA GeForce GTX 470 G. Skill 
Hard DriveOptical DriveOSMonitor
WD 6401AALS Samsung SH-S223B Windows 7 Professional 64 Bit Samsung SyncMaster 2232BW 
KeyboardPowerCaseMouse
Saitek Eclipse II Corsair TX750 CM 690 II Advanced Logitech G500 
  hide details  
Reply
post #2 of 3
What is this error icon?If you hover the mouse over the icon does it say anything?
My System
(14 items)
 
  
CPUMotherboardGraphicsRAM
I5-750 4.3@1.375v Asus Maximus III Formula Asus ENGTX465 4gb G Skill 2000 Mhz.Trident @2133 9-9-9-27 
Hard DriveOptical DriveCoolingOS
OCZ VERTEX 2 50GB SSD/WD 500GB Blue/WD640GB Black Samsung DVD/RW Corsair H-50 Windows 10 home 64 Bit Retail 
MonitorKeyboardPowerCase
ASUS 24"1080P LED Asus VE248H Abs M1 Cooler master silent pro 600 modular M600 RS-60... Lian Li Lancool PCK-58 
MouseMouse Pad
Steelseries Kinzu no 
  hide details  
Reply
My System
(14 items)
 
  
CPUMotherboardGraphicsRAM
I5-750 4.3@1.375v Asus Maximus III Formula Asus ENGTX465 4gb G Skill 2000 Mhz.Trident @2133 9-9-9-27 
Hard DriveOptical DriveCoolingOS
OCZ VERTEX 2 50GB SSD/WD 500GB Blue/WD640GB Black Samsung DVD/RW Corsair H-50 Windows 10 home 64 Bit Retail 
MonitorKeyboardPowerCase
ASUS 24"1080P LED Asus VE248H Abs M1 Cooler master silent pro 600 modular M600 RS-60... Lian Li Lancool PCK-58 
MouseMouse Pad
Steelseries Kinzu no 
  hide details  
Reply
post #3 of 3
Thread Starter 
Of course as soon as I post and keep looking we get it figured out. Thanks for your help. For anyone else who runs into this problem, it seems to be caused by corrupted registry entries. The fix we found is located here.
    
CPUMotherboardGraphicsRAM
Intel Core i5 750 Gigabyte P55-UD4P NVIDIA GeForce GTX 470 G. Skill 
Hard DriveOptical DriveOSMonitor
WD 6401AALS Samsung SH-S223B Windows 7 Professional 64 Bit Samsung SyncMaster 2232BW 
KeyboardPowerCaseMouse
Saitek Eclipse II Corsair TX750 CM 690 II Advanced Logitech G500 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
Intel Core i5 750 Gigabyte P55-UD4P NVIDIA GeForce GTX 470 G. Skill 
Hard DriveOptical DriveOSMonitor
WD 6401AALS Samsung SH-S223B Windows 7 Professional 64 Bit Samsung SyncMaster 2232BW 
KeyboardPowerCaseMouse
Saitek Eclipse II Corsair TX750 CM 690 II Advanced Logitech G500 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Other Peripherals
Overclock.net › Forums › Components › Other Peripherals › Blu-ray drive problems