Overclock.net › Forums › Software, Programming and Coding › Networking & Security › The phantom download cap, has had me stumped for a while.
New Posts  All Forums:Forum Nav:

The phantom download cap, has had me stumped for a while.

post #1 of 7
Thread Starter 
Ok, this is a very odd one. I mean VERY odd. I am a pretty experienced in networking and it has me stumped. So here is the problem. Please read as its not as simple as it sounds.

Anything I download from a browser is capped at 20-150kps. Infact any program that uses HTTP to download something is getting those speeds, EXCEPT steam or steam games. Here is the situation.

I have verizon FIOS and my current net speed is 75Mb/s down and 50MB/s up. On my desktop I am getting full speed during a speedtest and am happily enjoying full speed on downloads. This is also true for 5 other machines in my house which can also all happily download large files at 8-10 Megabytes per second simultaneously with no issues. This is why I am sure its not my router. The computer having the Issues is a ASUS G53SW. It happens on Ethernet or wireless.

Things I have tried to solve this issue.

1. Removing the bandwith cap in the windows registry. Result = No change.
2. TCP Optimizer = No change
3. Complete fresh install of all drivers including chipset, Ethernet, and wireless drivers. = No change.
4. I tired Firefox, Chrome, IE, Opera, etc. = No change.
5. Booting into linux partition interestingly = No change!
6. Bootable linux disc = No change!?
7. Sent laptop back to ASUS for service. They told me nothing is wrong and to update my drivers. So that means, No change.
8. Checked routers QoS, firewall, static nats, bandwith limits, anything I could think off. Nothing is wrong with the router.
9. All virus scans clean including several bootable AV software, rootkit revealers not that any of that would help as it even happens on bootable media.

Then I made the oddest discovery of them all. And this is why I am stumped. Remember how I mentioned before steam would get full speed? If I start downloading a game via steam then go download something in my browser my browser magically starts to download at FULL speed. wth.gif

So....one last go at fixing this problem. I killed the steam process. No change............. Only thing I can thing of is something on the network cards them self is limiting connection.

Laptop Specs:

ASUS G53SW

CPU: Core i7 2.0 (2.6ghz)
Mem: 6GB of ram
GPU: Nvidia 460m

Wireless: Atheros AR9002WB-1NG Wireless Adapter
Ethernet: Realtek PCIe GBE Family Controller


One very stumped overclocker,

Aiden.
Pulsar
(15 items)
 
  
CPUMotherboardGraphicsRAM
Q9650 (3.0ghz) EVGA 780i FTW EVGA GTX 285 G. SKILL Pi 
Hard DriveHard DriveOptical DriveCooling
1x Kingston HyperX 120GB 1x Seagate 1TB 40x CD/DVD R/W Xigmatech Dark Knight 
OSMonitorKeyboardPower
Windows 7 64Bit Samsung T220 IBM Model M Corsair TX750w 
CaseMouseMouse Pad
Antec Nine Hundred Two Logitech 560 n/a 
  hide details  
Reply
Pulsar
(15 items)
 
  
CPUMotherboardGraphicsRAM
Q9650 (3.0ghz) EVGA 780i FTW EVGA GTX 285 G. SKILL Pi 
Hard DriveHard DriveOptical DriveCooling
1x Kingston HyperX 120GB 1x Seagate 1TB 40x CD/DVD R/W Xigmatech Dark Knight 
OSMonitorKeyboardPower
Windows 7 64Bit Samsung T220 IBM Model M Corsair TX750w 
CaseMouseMouse Pad
Antec Nine Hundred Two Logitech 560 n/a 
  hide details  
Reply
post #2 of 7
Try the Laptop at a friends house. Could there be a setting on the Router that is changing this like MAC throttling.
Just want to iron our that issue.
Maybe even try resetting the Router settings?
ESXi Home Box
(6 items)
 
The Workstation.
(16 items)
 
 
CPURAMHard DriveOS
Dual L5630 72GB DDR3 RECC 120GB VERTEX 4 + 6TB RAID5 ESXi 6.0 U2 
Other
Dell PowedgeR710  
CPUGraphicsRAMHard Drive
Intel Core i5 2.4GHZ Intel Iris Pro 16GB DDR3 256GB PCI-e x2 
OSKeyboardMouse
OSX 10.11 + Win 10 Apple Wireless Keyboard Apple Magic Trackpad 
  hide details  
Reply
ESXi Home Box
(6 items)
 
The Workstation.
(16 items)
 
 
CPURAMHard DriveOS
Dual L5630 72GB DDR3 RECC 120GB VERTEX 4 + 6TB RAID5 ESXi 6.0 U2 
Other
Dell PowedgeR710  
CPUGraphicsRAMHard Drive
Intel Core i5 2.4GHZ Intel Iris Pro 16GB DDR3 256GB PCI-e x2 
OSKeyboardMouse
OSX 10.11 + Win 10 Apple Wireless Keyboard Apple Magic Trackpad 
  hide details  
Reply
post #3 of 7
Thread Starter 
Very good idea. I didn't even think of MAC throttling. Odd thing is I have reset my router. I may have to double check that. I am getting 2 MB per second on the school network before they start throttling me. So I think now that probably is the issue. I will post as soon as I find out.

Thanks,

Aiden
Pulsar
(15 items)
 
  
CPUMotherboardGraphicsRAM
Q9650 (3.0ghz) EVGA 780i FTW EVGA GTX 285 G. SKILL Pi 
Hard DriveHard DriveOptical DriveCooling
1x Kingston HyperX 120GB 1x Seagate 1TB 40x CD/DVD R/W Xigmatech Dark Knight 
OSMonitorKeyboardPower
Windows 7 64Bit Samsung T220 IBM Model M Corsair TX750w 
CaseMouseMouse Pad
Antec Nine Hundred Two Logitech 560 n/a 
  hide details  
Reply
Pulsar
(15 items)
 
  
CPUMotherboardGraphicsRAM
Q9650 (3.0ghz) EVGA 780i FTW EVGA GTX 285 G. SKILL Pi 
Hard DriveHard DriveOptical DriveCooling
1x Kingston HyperX 120GB 1x Seagate 1TB 40x CD/DVD R/W Xigmatech Dark Knight 
OSMonitorKeyboardPower
Windows 7 64Bit Samsung T220 IBM Model M Corsair TX750w 
CaseMouseMouse Pad
Antec Nine Hundred Two Logitech 560 n/a 
  hide details  
Reply
post #4 of 7
Boot into Safe mode with networking?

Are you wireless? Do you get same results on a different network adapters running individually?

Have you tried plugging into a different interface on the LAN?


Lastly install wireshark on your local machine and see what is happening to packet transfers. A lot of SYN packet failures could point to an issue w/ the laptop.
Pwnisher
(15 items)
 
Small Hoss
(14 items)
 
 
CPUMotherboardGraphicsRAM
Intel i7 3770k GIGABYTE GA-Z77X-UP4 TH GTX 460 SE 16GB Samsung MV-3V4G3D/US 
Hard DriveHard DriveOptical DriveCooling
120GB Agility 3 1.5TB Seagate Barracuda LG 14x Blu-ray burner Corsair H100i 
OSMonitorKeyboardPower
Windows 8 Professional Dell Ultrasharp U2410 Logitech Illuminated keyboard Kingwin LZP-750 
CaseMouseMouse Pad
Corsair 650D Logitech G500 RadPadz XT 
CPUMotherboardGraphicsGraphics
Intel Core i3 540 @ 4.2GHz 1.328v Gigabyte GA-P55-UD4P EVGA GTX 460 SE SLI EVGA GTX 460 SE SLI 
RAMHard DriveOSMonitor
G.Skill 8GB 4x 2GB DDR3 OCZ Agility 3 120GB SSD Windows 7 Professional Dell Ultrasharp U2410 sRGB 
KeyboardPowerCaseMouse
Logitech Illuminated Keyboard PC Power & Cooling 750w Antec 1200 Logitech G500 
Mouse PadAudio
RatPadz OnBoard 
  hide details  
Reply
Pwnisher
(15 items)
 
Small Hoss
(14 items)
 
 
CPUMotherboardGraphicsRAM
Intel i7 3770k GIGABYTE GA-Z77X-UP4 TH GTX 460 SE 16GB Samsung MV-3V4G3D/US 
Hard DriveHard DriveOptical DriveCooling
120GB Agility 3 1.5TB Seagate Barracuda LG 14x Blu-ray burner Corsair H100i 
OSMonitorKeyboardPower
Windows 8 Professional Dell Ultrasharp U2410 Logitech Illuminated keyboard Kingwin LZP-750 
CaseMouseMouse Pad
Corsair 650D Logitech G500 RadPadz XT 
CPUMotherboardGraphicsGraphics
Intel Core i3 540 @ 4.2GHz 1.328v Gigabyte GA-P55-UD4P EVGA GTX 460 SE SLI EVGA GTX 460 SE SLI 
RAMHard DriveOSMonitor
G.Skill 8GB 4x 2GB DDR3 OCZ Agility 3 120GB SSD Windows 7 Professional Dell Ultrasharp U2410 sRGB 
KeyboardPowerCaseMouse
Logitech Illuminated Keyboard PC Power & Cooling 750w Antec 1200 Logitech G500 
Mouse PadAudio
RatPadz OnBoard 
  hide details  
Reply
post #5 of 7
Thread Starter 
Thank you for the Replies it seems I have made some progress. The problem was happening on wireless and ethernet, no matter what cable or port I was using. I even tried pluging in behind another router to see if it was MAC based QoS as suggested. However....I stumbled upon a support PDF from actiontec explaining how to properly set up QoS. It seems I found the culprit.

When you reset a Verizon Actiontec WI424WR FIOS Router it completely WIPES the quality of service rules. That means or at least I believe it means the router was not even trying to process packet prioritization at all. I followed the guide and changed the following settings.

New traffic shaping rule for Wan device (COAX). I set the Tx Value to 51200kb (50mb/s) and the TX value to 81920 (80mb/s) and saved it. I did a speed test and do my delight my laptop was getting 25 mb/s down and 15 mb/s up. Which is about normal for a wireless G router I believe? However my desktop (which also virtualizes some servers) is now only get 40mb/s down max when it used to get 80. Is this normal behavior for QoS? I honestly don't mind if it is only getting 40 as long as my laptop is working finally.

Now I am really interested in QoS and testing this further but I do not know where to begin. The Actiontec verizon gives us is way more then one could EVER ask for on a home router. I love this thing.

Now for a related question, I can make a new thread if a moderator wishes. Could someone help explain to me QoS rules? I understan the basics but I have no clue where to begin with the DSCP Hex values and what the different Class levels mean. (Class 0-7). Would anyone be able to help explain these to me? I know 0 is for link ups but that's really about all I know so far.

Thank you,

Aiden.

EDIT: I will throw Wireshark up on my Arch Linux laptop and see what I can find. I didn't think of the SYN packets. Maybe this can help me with understanding the QoS stuff more. smile.gif
Pulsar
(15 items)
 
  
CPUMotherboardGraphicsRAM
Q9650 (3.0ghz) EVGA 780i FTW EVGA GTX 285 G. SKILL Pi 
Hard DriveHard DriveOptical DriveCooling
1x Kingston HyperX 120GB 1x Seagate 1TB 40x CD/DVD R/W Xigmatech Dark Knight 
OSMonitorKeyboardPower
Windows 7 64Bit Samsung T220 IBM Model M Corsair TX750w 
CaseMouseMouse Pad
Antec Nine Hundred Two Logitech 560 n/a 
  hide details  
Reply
Pulsar
(15 items)
 
  
CPUMotherboardGraphicsRAM
Q9650 (3.0ghz) EVGA 780i FTW EVGA GTX 285 G. SKILL Pi 
Hard DriveHard DriveOptical DriveCooling
1x Kingston HyperX 120GB 1x Seagate 1TB 40x CD/DVD R/W Xigmatech Dark Knight 
OSMonitorKeyboardPower
Windows 7 64Bit Samsung T220 IBM Model M Corsair TX750w 
CaseMouseMouse Pad
Antec Nine Hundred Two Logitech 560 n/a 
  hide details  
Reply
post #6 of 7
QoS is tricky business. Either you get it right and have a very efficient network or get it wrong and everything is broken. I used to help configure a packetshaper, a $20,000 device only for QoS, for a university. The rules were absurd.

My suggestion for QoS for a house, keep it very simple. The more configuration you have, the more work you put on your device which could cause performance issues. Sounds like refining your QoS and you're good to go!


Glad you found a solution!
Pwnisher
(15 items)
 
Small Hoss
(14 items)
 
 
CPUMotherboardGraphicsRAM
Intel i7 3770k GIGABYTE GA-Z77X-UP4 TH GTX 460 SE 16GB Samsung MV-3V4G3D/US 
Hard DriveHard DriveOptical DriveCooling
120GB Agility 3 1.5TB Seagate Barracuda LG 14x Blu-ray burner Corsair H100i 
OSMonitorKeyboardPower
Windows 8 Professional Dell Ultrasharp U2410 Logitech Illuminated keyboard Kingwin LZP-750 
CaseMouseMouse Pad
Corsair 650D Logitech G500 RadPadz XT 
CPUMotherboardGraphicsGraphics
Intel Core i3 540 @ 4.2GHz 1.328v Gigabyte GA-P55-UD4P EVGA GTX 460 SE SLI EVGA GTX 460 SE SLI 
RAMHard DriveOSMonitor
G.Skill 8GB 4x 2GB DDR3 OCZ Agility 3 120GB SSD Windows 7 Professional Dell Ultrasharp U2410 sRGB 
KeyboardPowerCaseMouse
Logitech Illuminated Keyboard PC Power & Cooling 750w Antec 1200 Logitech G500 
Mouse PadAudio
RatPadz OnBoard 
  hide details  
Reply
Pwnisher
(15 items)
 
Small Hoss
(14 items)
 
 
CPUMotherboardGraphicsRAM
Intel i7 3770k GIGABYTE GA-Z77X-UP4 TH GTX 460 SE 16GB Samsung MV-3V4G3D/US 
Hard DriveHard DriveOptical DriveCooling
120GB Agility 3 1.5TB Seagate Barracuda LG 14x Blu-ray burner Corsair H100i 
OSMonitorKeyboardPower
Windows 8 Professional Dell Ultrasharp U2410 Logitech Illuminated keyboard Kingwin LZP-750 
CaseMouseMouse Pad
Corsair 650D Logitech G500 RadPadz XT 
CPUMotherboardGraphicsGraphics
Intel Core i3 540 @ 4.2GHz 1.328v Gigabyte GA-P55-UD4P EVGA GTX 460 SE SLI EVGA GTX 460 SE SLI 
RAMHard DriveOSMonitor
G.Skill 8GB 4x 2GB DDR3 OCZ Agility 3 120GB SSD Windows 7 Professional Dell Ultrasharp U2410 sRGB 
KeyboardPowerCaseMouse
Logitech Illuminated Keyboard PC Power & Cooling 750w Antec 1200 Logitech G500 
Mouse PadAudio
RatPadz OnBoard 
  hide details  
Reply
post #7 of 7
Thread Starter 
Awesome. The only thing I want to tweak at this point is priorities my Teamspeak, Minecraft, and Arma Servers. I Belive I can do that via IP and port but am not sure what level to set them at. Currently all traffic it 6, and I was thinking of setting mine craft/arma to 5, and team speak to 4. Link up's and DNS are apparently 0,1,2,3 which seem to have helped alot.
Pulsar
(15 items)
 
  
CPUMotherboardGraphicsRAM
Q9650 (3.0ghz) EVGA 780i FTW EVGA GTX 285 G. SKILL Pi 
Hard DriveHard DriveOptical DriveCooling
1x Kingston HyperX 120GB 1x Seagate 1TB 40x CD/DVD R/W Xigmatech Dark Knight 
OSMonitorKeyboardPower
Windows 7 64Bit Samsung T220 IBM Model M Corsair TX750w 
CaseMouseMouse Pad
Antec Nine Hundred Two Logitech 560 n/a 
  hide details  
Reply
Pulsar
(15 items)
 
  
CPUMotherboardGraphicsRAM
Q9650 (3.0ghz) EVGA 780i FTW EVGA GTX 285 G. SKILL Pi 
Hard DriveHard DriveOptical DriveCooling
1x Kingston HyperX 120GB 1x Seagate 1TB 40x CD/DVD R/W Xigmatech Dark Knight 
OSMonitorKeyboardPower
Windows 7 64Bit Samsung T220 IBM Model M Corsair TX750w 
CaseMouseMouse Pad
Antec Nine Hundred Two Logitech 560 n/a 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Networking & Security
Overclock.net › Forums › Software, Programming and Coding › Networking & Security › The phantom download cap, has had me stumped for a while.