post #1 of 1
Thread Starter 
Ever since I've upgraded to Windows 8, certain games limit my max resolution and refresh rate to 1920x1080 @ 59Hz. My monitor is set to 60Hz on both the Windows display properties and Catalyst Control Center. This wasn't an issue with Windows 7 using the same driver number, 12.10; same issue with the 12.11 drivers for me. Games where I can't see the refresh rate usually switch resolution after launching in the case that I used my old config files (60 Hz in Win 7.) DVI connection is being used since I know HDMI usually likes 59Hz for HD.

Here are some screenshots showing the monitor set to 60Hz in Windows but showing as 59 in game.





I can set it to 60Hz in the Sonic Generations config.


Anyone else have this issue or know what causes it?

Edit: I sent a ticket to AMD customer support since I'm getting nowhere on this and it actually caused an issue in Age of Empires 3; also including an image from Battlefield 3 which is reporting 59.94Hz which is what HDMI uses.



Update 2012, Dec. 26: I was recommended to uninstall the drivers using DriverSweeper and then to try the 12.8 drivers for Windows 8 but it did not fix the problem. I also tried reinstalling the 12.11b11 drivers with no change; had to send a report.

Update 2013, Jan. 29: I had to go back to Windows 7 to get rid of the issue, still not sure what caused it in Windows 8. The issue was getting a bit out of hand in a few games where it would get some heavy stutter, go to a black screen, then my monitor would switch input modes or so before everything returned to normal.

Sapphire Radeon HD 5850 Vapor-X 2GB
ASUS VH226H - DVI cable

Tried contacting AMD, ASUS, and Sapphire support but that didn't help. I also tried testing my Intel HD 4000 chipset but that only offers HDMI out; I'm using DVI.

Update 2013, Feb. 01: I have reverted back to a Windows 7 64-bit install after the AMD uninstall utility also messed up my Windows 8 install. The refresh rate issue is gone in Windows 7; I am able to run 60Hz fullscreen again. I have not tried the 13.2 beta drivers in Windows 8 yet because I would have to do another install.
Edited by Someguy316 - 2/1/13 at 6:24am
3570k + GTX 970
(17 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i5 3570k ASUS MAXIMUS V GENE Gigabyte GV-N970G1 G.Skill Sniper Low Voltage 1.25v 
Hard DriveCoolingOSMonitor
Western Digital 650GB Caviar Black Zalman CNPS10X Performa Windows 10 Pro (64-bit) QNIX QX2414 
KeyboardPowerCaseMouse
Ducky Shining 9800S (White LED / Black Cherry MX) EVGA Supernova 550 G2 Cooler Master CM 690 II Advanced Zowie FK1 
Mouse PadAudioAudioOther
Steelseries QcK FiiO E10 Realtek onboard audio (Microphone) M-Audio AV40 
Other
AKG K7XX 
  hide details  
Reply
3570k + GTX 970
(17 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i5 3570k ASUS MAXIMUS V GENE Gigabyte GV-N970G1 G.Skill Sniper Low Voltage 1.25v 
Hard DriveCoolingOSMonitor
Western Digital 650GB Caviar Black Zalman CNPS10X Performa Windows 10 Pro (64-bit) QNIX QX2414 
KeyboardPowerCaseMouse
Ducky Shining 9800S (White LED / Black Cherry MX) EVGA Supernova 550 G2 Cooler Master CM 690 II Advanced Zowie FK1 
Mouse PadAudioAudioOther
Steelseries QcK FiiO E10 Realtek onboard audio (Microphone) M-Audio AV40 
Other
AKG K7XX 
  hide details  
Reply