Overclock.net › Forums › Video Games › PC Gaming › Far Cry 3 Anti-Aliasing Problem
New Posts  All Forums:Forum Nav:

Far Cry 3 Anti-Aliasing Problem - Page 2

post #11 of 20
Thread Starter 
Quote:
Originally Posted by ACHILEE5 View Post

NVidia thumb.gif
In my Sig is a link to "How to put your Rig in your Sig" if you was wanting to know how smile.gif

I see that now. I've added my config to my signature. smile.gif
Quote:
Originally Posted by alawadhi3000 View Post

310.70 drivers were released.

Still the same. :/
Sabijac
(17 items)
 
  
CPUMotherboardGraphicsRAM
Core i7-2600k ASUS P8P67 DELUXE Gainward GeForce GTX 590 Kingston HyperX 16 GB 
Hard DriveHard DriveOptical DriveCooling
Kingston HyperX SSD 120GB Seagate 1TB SATA3 LG DVD-RW Writer Cooler Master Hyper 212 EVO 
OSMonitorKeyboardPower
Windows 7 Ultimate Samsung SyncMaster SA350 Logitech Illuminated Keyboard Chieftec APS-1000C 1000W 
CaseMouseMouse PadAudio
Cooler Master 690 II Basic Logitech G500 Gaming Mouse My Table Genius 5.1 SW-HF 5000 
Other
Cyborg V.5 360 Rumble Pad 
  hide details  
Reply
Sabijac
(17 items)
 
  
CPUMotherboardGraphicsRAM
Core i7-2600k ASUS P8P67 DELUXE Gainward GeForce GTX 590 Kingston HyperX 16 GB 
Hard DriveHard DriveOptical DriveCooling
Kingston HyperX SSD 120GB Seagate 1TB SATA3 LG DVD-RW Writer Cooler Master Hyper 212 EVO 
OSMonitorKeyboardPower
Windows 7 Ultimate Samsung SyncMaster SA350 Logitech Illuminated Keyboard Chieftec APS-1000C 1000W 
CaseMouseMouse PadAudio
Cooler Master 690 II Basic Logitech G500 Gaming Mouse My Table Genius 5.1 SW-HF 5000 
Other
Cyborg V.5 360 Rumble Pad 
  hide details  
Reply
post #12 of 20
I just worked out what causes this issue. It's the built in FXAA in FarCry 3.

I had the exact same jagged edges on other things like the poles under tin roofs etc.

How to disable FXAA (Thanks to aiacds on ubi forum):

http://forums.ubi.com/showthread.php/741249-How-to-completely-disable-Anti-Aliasing?p=8822580&posted=1

"put this in your gamerprofile after the :


"


Personally I left CinematicDOF on.

With MSAA and XFAA disabled I use SMAA injector ( http://mrhaandi.blogspot.com/p/injectsmaa.html ) on it's ultra preset and the game looks amazing. SMAA puts but ~7% more load on my GPU compared to zero anti-aliasing and it looks superb!
post #13 of 20
Sorry the XML was stripped from the above message but the how to disable FXAA is in the link above the broken quote
post #14 of 20
SMAA Patrol Boat Shadows: Image (Click to show)

SMAA Rubber duck Shadows: Image (Click to show)

SMAA Tin sheet and planks: Image (Click to show)

Edited by RobertE - 12/24/12 at 3:36am
post #15 of 20
How did you get yours to work? When I try with SSMA or SweetFX Far Cry just CTD, it littreally just Flashes black then bam desktop. It works when I delete the dxgi file but then the SSMA is not present within the game. Does anyone have any idea?
post #16 of 20
I just replied to your post on the Ubi forum smile.gif

All I did was use the injector from here: http://mrhaandi.blogspot.com/p/injectsmaa.html

And I run the game in DX9.

Have you tried setting weird_steam_hack = 1 in the injector.ini?
post #17 of 20
Also from my experience with Skyrim and ENB's I know some of these injectors and other overlay programs like Fraps or MSI Afterburner's OSD don't get along well. If you have something like that running disable it and see if the game starts.

I haven't had an issue with MSI Afterburner and SMAA though.
post #18 of 20
to OP: Set PostFx on Ultra (or High), and see if it got smoother.

EDIT: And for shadow, try set it on high (not Ultra or Very High). It's blocky because of the shadowing technique on Ultra and Very High setting.
Edited by ismanto - 12/26/12 at 3:09am
post #19 of 20
Hi guys,

I don't know if I should post this here since I'm new but for some reason I cannot get the anti aliasing to work through the NVIDIA inspector panel in Far Cry 3. Whatever the setting I choose nothing changes in the game.

Here are my settings:

- Antialiasing compatibility (DX1x): 0x00100000 (Far Cry 2)
- Antialiasing - Mode: Override any application setting
- Antialiasing - Setting: 8xQ
- Antialiasing - Transparency Supersampling: 8x Sparse Grid Supersampling

Your help would be greatly appreciated since my eyes burn without antialiasing and with the built-in MSAA I get awful performance with my GTX 580 / 310.70
post #20 of 20
Well I've managed to get a good image quality while keeping a steady 55-60 fps by lowering the shadows to medium and setting the postfx setting to 'false' in the gamerprofile.xml file, in-game MSAA set to 2 and alpha to coverage to enhanced.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: PC Gaming
Overclock.net › Forums › Video Games › PC Gaming › Far Cry 3 Anti-Aliasing Problem