Overclock.net › Forums › Components › Sound Cards and Computer Audio › Titanium HD no Mic boost
New Posts  All Forums:Forum Nav:

Titanium HD no Mic boost

post #1 of 10
Thread Starter 
I am having problems boosting my mic volume up after installing a Titanium HD sound card. Before, there was options in the recording device for up to 30DB boost, now its gone. Also, theres no mic boost in the sound card options either.

My friends have very hard time hearing me in ventrillo, and ventrillo will not allow me to boost the outgoing signal unless there is already a 20DB boost in the recording device options.
I have tried two microphones now and both are too quiet. Also tried using the onboard mic input and it no longer functions with the sound card enabled.

Any way to mic boost or other fixes?
post #2 of 10
Thread Starter 
Had to install my realtek drivers and use onboard mic input, which gets a boost like normal.

Is this going to cause any conflicts having two different audio drivers at same time?
post #3 of 10
No, not with the Realtek and the Titanium HD.

I regularly run a Titanium HD and an Auzentech X-Meridian 2G sound card in my machine with absolutely no issues. The X-Meridian uses a C-Media chipset and the two do not conflict.

For a while, I used a Corsair Vengeance 2000 USB headset with C-Media drivers, the Realtek for its HDMI output and my Titanium HD from Creative all at the same time. No problems.
post #4 of 10
Thread Starter 
Quote:
Originally Posted by chalkbluffgrown View Post

No, not with the Realtek and the Titanium HD.
I regularly run a Titanium HD and an Auzentech X-Meridian 2G sound card in my machine with absolutely no issues. The X-Meridian uses a C-Media chipset and the two do not conflict.
For a while, I used a Corsair Vengeance 2000 USB headset with C-Media drivers, the Realtek for its HDMI output and my Titanium HD from Creative all at the same time. No problems.

Ok thanks for the info. I cant believe Creative left out a mic boost function, even though it seems to have everything else and then some.
post #5 of 10
Have you increased your level here?

post #6 of 10
Thread Starter 
Quote:
Originally Posted by chalkbluffgrown View Post

Have you increased your level here?

For the onboard I did, but on the Titanium HD that option isnt there.
post #7 of 10
Well I have the same sound card that you do. So you should be able to go to the Creative microphone in the control panel like in the picture and increase your recording level.
post #8 of 10
Thread Starter 
Quote:
Originally Posted by chalkbluffgrown View Post

Well I have the same sound card that you do. So you should be able to go to the Creative microphone in the control panel like in the picture and increase your recording level.

Yes that isnt the problem. I needed mic boost. It is already at 100% recording level but it isn't enough for people to hear me in vent. Problem is fixed anyways since I just use the onboard for it, but its still anoying that my sound card didnt have mic boost.
post #9 of 10
What kind of mic do you have?
Gaming rig
(13 items)
 
  
CPUMotherboardGraphicsRAM
i7 920 @ 3.8GHz GIGABYTE GA-EX58-UD5 EVGA GTX 780 SC w/ACX CORSAIR DOMINATOR 12GB 
Hard DriveOptical DriveOSMonitor
Samsung 840 Pro 256GB, SSD Western Digital VelociRaptor 300GB Windows 8 Pro QNIX QX2710 LED Evolution ll 27" 
KeyboardPowerCaseMouse
Corsair K70 CORSAIR-HX 1050W Antec 1200 Razar Deathadder 3.5G 
Audio
Creative Sound Blaster X-Fi Titanium HD 
  hide details  
Reply
Gaming rig
(13 items)
 
  
CPUMotherboardGraphicsRAM
i7 920 @ 3.8GHz GIGABYTE GA-EX58-UD5 EVGA GTX 780 SC w/ACX CORSAIR DOMINATOR 12GB 
Hard DriveOptical DriveOSMonitor
Samsung 840 Pro 256GB, SSD Western Digital VelociRaptor 300GB Windows 8 Pro QNIX QX2710 LED Evolution ll 27" 
KeyboardPowerCaseMouse
Corsair K70 CORSAIR-HX 1050W Antec 1200 Razar Deathadder 3.5G 
Audio
Creative Sound Blaster X-Fi Titanium HD 
  hide details  
Reply
post #10 of 10
Quote:
Originally Posted by Shaded War View Post

and ventrillo will not allow me to boost the outgoing signal unless there is already a 20DB boost


That isn't true at all, ACTUALLY. I have a Titanium HD and there's no way I found yet to boost the mic, but there IS a way to do it in Vent.



Use those exact settings and it WILL be louder
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Sound Cards and Computer Audio
Overclock.net › Forums › Components › Sound Cards and Computer Audio › Titanium HD no Mic boost