Overclock.net › Forums › Graphics Cards › AMD/ATI › New Sapphire 7950 HD, weird issues with it and FPS
New Posts  All Forums:Forum Nav:

New Sapphire 7950 HD, weird issues with it and FPS - Page 2

post #11 of 20
Thread Starter 
Quote:
Originally Posted by sugarhell View Post

Probably at this resolution your cpu is a big problem for your card.Try to lower a bit your details in lol because its cpu dependent
Also try to increase your power limit to 20% in AB

Fair enough. I'll try while I play next game to see if there's much of a difference.

It just makes no sense; I ran full settings with a 550Ti though, and never experienced anywhere near the same amount of change in performance. The CPU is pretty weak, but I have played other games at high resolutions with it just fine, and the usage stays around 33% on all cores or so during gameplay.

What would you suggest?
post #12 of 20
Quote:
Originally Posted by Barnacles View Post

Fair enough. I'll try while I play next game to see if there's much of a difference.
It just makes no sense; I ran full settings with a 550Ti though, and never experienced anywhere near the same amount of change in performance. The CPU is pretty weak, but I have played other games at high resolutions with it just fine, and the usage stays around 33% on all cores or so during gameplay.
What would you suggest?

Maybe somewhere conflict with your nvidia driver. Try to run 3dmark 11
Workstation
(4 items)
 
  
CPUMotherboardGraphicsMonitor
Xeon E5-2690 Supermicro 2011 Nvidia GP100/ Vega FE Dell ultrasharp 4k 
  hide details  
Reply
Workstation
(4 items)
 
  
CPUMotherboardGraphicsMonitor
Xeon E5-2690 Supermicro 2011 Nvidia GP100/ Vega FE Dell ultrasharp 4k 
  hide details  
Reply
post #13 of 20
Quote:
Originally Posted by Barnacles View Post

But... it's worse gameplay than a cheap 550Ti? Why is that? >_> Same with Saints Row, etc... It's all actually worse off than a cheap Nvidia card. That makes no sense to me.

Quote:
Originally Posted by sugarhell View Post

Probably at this resolution your cpu is a big problem for your card.Try to lower a bit your details in lol because its cpu dependent
Also try to increase your power limit to 20% in AB

NAh I had a 2.9Gh'z Athlon x3 with the 4th unlocked @ 3.0 @ same resolution and it's perfectly fine on a 4890 and a PH II 555 BE unlocked @ 3.4 with a 5870 on a 1440x900 that also runs LoL perfectly fine. What kind of PSU do you have? Maybe the new 7950 is taking too much juice.

*edit* just noticed you had a CX600....... it should be enough but maybe could be that, I would swap out the card first and try another 7950. If not return it and go back to the 550ti if you're happy with it or a nice 660/670.
Edited by Junkboy - 1/6/13 at 5:13pm
Ada
(24 items)
 
Aegis
(9 items)
 
 
CPUMotherboardGraphicsRAM
AMD 1700 Gigabyte AB350 Gaming 3 EVGA GTX 980 ti Classified F4-3600C16D-16GTZ @3200 
Hard DriveHard DriveHard DriveHard Drive
Intel 520 120GB SSD Samsung F2 1TB X2 Samsung F4 2TB Hitachi 1TB X2 
Hard DriveOptical DriveCoolingCooling
Seagate 3 TB Pioneer BDR 2207 Noctua NH D14 Sunbeam Rheobus Extreme 
CoolingOSMonitorMonitor
Enermax 140mm T.B. Vegas Duo x2 Win 10 Pro Extreme Edition Catleap 2B  ASUS VH242H  
KeyboardPowerCaseMouse
Logitech mk260 NZXT Hale90 750 Fractal Design Arc Midi Logitech G9x 
Mouse PadAudioAudioAudio
Steelseries QcK Denon AH D2000 Harman Kardon AVR 2600 Polk RTi8s, Rti4s and CSi3 
CPUMotherboardGraphicsRAM
Intel G645 Asrock z77 Extreme 4 Nvidia Branded GTX 460 SLI 8GB Corsair Vengeance Low profile DDR3 1600 
Hard DriveOSPowerCase
Hitachi 1TB Windows 7 Antec HCG 750 Bitfenix Shinobi Window 
Mouse Pad
Diablo 3 Steel Series.  
  hide details  
Reply
Ada
(24 items)
 
Aegis
(9 items)
 
 
CPUMotherboardGraphicsRAM
AMD 1700 Gigabyte AB350 Gaming 3 EVGA GTX 980 ti Classified F4-3600C16D-16GTZ @3200 
Hard DriveHard DriveHard DriveHard Drive
Intel 520 120GB SSD Samsung F2 1TB X2 Samsung F4 2TB Hitachi 1TB X2 
Hard DriveOptical DriveCoolingCooling
Seagate 3 TB Pioneer BDR 2207 Noctua NH D14 Sunbeam Rheobus Extreme 
CoolingOSMonitorMonitor
Enermax 140mm T.B. Vegas Duo x2 Win 10 Pro Extreme Edition Catleap 2B  ASUS VH242H  
KeyboardPowerCaseMouse
Logitech mk260 NZXT Hale90 750 Fractal Design Arc Midi Logitech G9x 
Mouse PadAudioAudioAudio
Steelseries QcK Denon AH D2000 Harman Kardon AVR 2600 Polk RTi8s, Rti4s and CSi3 
CPUMotherboardGraphicsRAM
Intel G645 Asrock z77 Extreme 4 Nvidia Branded GTX 460 SLI 8GB Corsair Vengeance Low profile DDR3 1600 
Hard DriveOSPowerCase
Hitachi 1TB Windows 7 Antec HCG 750 Bitfenix Shinobi Window 
Mouse Pad
Diablo 3 Steel Series.  
  hide details  
Reply
post #14 of 20
Quote:
Originally Posted by Junkboy View Post

NAh I had a 2.9Gh'z Athlon x3 with the 4th unlocked @ 3.0 @ same resolution and it's perfectly fine on a 4890 and a PH II 555 BE unlocked @ 3.4 with a 5870 on a 1440x900 that also runs LoL perfectly fine. What kind of PSU do you have? Maybe the new 7950 is taking too much juice.

He said he had a cx600w.
Space Heater
(11 items)
 
  
CPUMotherboardGraphicsRAM
i7 870 Some Dell Mobo 6950 2gb 8(4x2)GB DDR3 @ 1333mhz 
Hard DriveOSPowerCase
Seagate Barracuda 1 Terabyte Win7 Home Premium 64bits Hx750 Corsair 800D 
MouseAudioAudio
Logitech G500 Asus xonar dg Beyerdynamic dt770 pro 80 
  hide details  
Reply
Space Heater
(11 items)
 
  
CPUMotherboardGraphicsRAM
i7 870 Some Dell Mobo 6950 2gb 8(4x2)GB DDR3 @ 1333mhz 
Hard DriveOSPowerCase
Seagate Barracuda 1 Terabyte Win7 Home Premium 64bits Hx750 Corsair 800D 
MouseAudioAudio
Logitech G500 Asus xonar dg Beyerdynamic dt770 pro 80 
  hide details  
Reply
post #15 of 20
When you uninstall both the drivers run CCleaner and clean the registry. Then reinstall AMD's 12.11b drivers. Could be some cobwebbs left in your system from switching from nvidia to AMD. Also what is the Power Supply?

Here is a download link for CCleaner...
http://www.piriform.com/ccleaner/download
Edited by stickg1 - 1/6/13 at 5:36pm
post #16 of 20
Quote:
Originally Posted by Junkboy View Post

NAh I had a 2.9Gh'z Athlon x3 with the 4th unlocked @ 3.0 @ same resolution and it's perfectly fine on a 4890 and a PH II 555 BE unlocked @ 3.4 with a 5870 on a 1440x900 that also runs LoL perfectly fine. What kind of PSU do you have? Maybe the new 7950 is taking too much juice.
*edit* just noticed you had a CX600....... it should be enough but maybe could be that, I would swap out the card first and try another 7950. If not return it and go back to the 550ti if you're happy with it or a nice 660/670.

Yeah i thought i have a athlon x2 for my htpc and it runs lol just fine. Probably is leftovers from nvidia drivers that conflict with the amd
Workstation
(4 items)
 
  
CPUMotherboardGraphicsMonitor
Xeon E5-2690 Supermicro 2011 Nvidia GP100/ Vega FE Dell ultrasharp 4k 
  hide details  
Reply
Workstation
(4 items)
 
  
CPUMotherboardGraphicsMonitor
Xeon E5-2690 Supermicro 2011 Nvidia GP100/ Vega FE Dell ultrasharp 4k 
  hide details  
Reply
post #17 of 20
If CCleaner doesn't work I'm bit partial to driver fusion as that seemed to work best for me.
Ada
(24 items)
 
Aegis
(9 items)
 
 
CPUMotherboardGraphicsRAM
AMD 1700 Gigabyte AB350 Gaming 3 EVGA GTX 980 ti Classified F4-3600C16D-16GTZ @3200 
Hard DriveHard DriveHard DriveHard Drive
Intel 520 120GB SSD Samsung F2 1TB X2 Samsung F4 2TB Hitachi 1TB X2 
Hard DriveOptical DriveCoolingCooling
Seagate 3 TB Pioneer BDR 2207 Noctua NH D14 Sunbeam Rheobus Extreme 
CoolingOSMonitorMonitor
Enermax 140mm T.B. Vegas Duo x2 Win 10 Pro Extreme Edition Catleap 2B  ASUS VH242H  
KeyboardPowerCaseMouse
Logitech mk260 NZXT Hale90 750 Fractal Design Arc Midi Logitech G9x 
Mouse PadAudioAudioAudio
Steelseries QcK Denon AH D2000 Harman Kardon AVR 2600 Polk RTi8s, Rti4s and CSi3 
CPUMotherboardGraphicsRAM
Intel G645 Asrock z77 Extreme 4 Nvidia Branded GTX 460 SLI 8GB Corsair Vengeance Low profile DDR3 1600 
Hard DriveOSPowerCase
Hitachi 1TB Windows 7 Antec HCG 750 Bitfenix Shinobi Window 
Mouse Pad
Diablo 3 Steel Series.  
  hide details  
Reply
Ada
(24 items)
 
Aegis
(9 items)
 
 
CPUMotherboardGraphicsRAM
AMD 1700 Gigabyte AB350 Gaming 3 EVGA GTX 980 ti Classified F4-3600C16D-16GTZ @3200 
Hard DriveHard DriveHard DriveHard Drive
Intel 520 120GB SSD Samsung F2 1TB X2 Samsung F4 2TB Hitachi 1TB X2 
Hard DriveOptical DriveCoolingCooling
Seagate 3 TB Pioneer BDR 2207 Noctua NH D14 Sunbeam Rheobus Extreme 
CoolingOSMonitorMonitor
Enermax 140mm T.B. Vegas Duo x2 Win 10 Pro Extreme Edition Catleap 2B  ASUS VH242H  
KeyboardPowerCaseMouse
Logitech mk260 NZXT Hale90 750 Fractal Design Arc Midi Logitech G9x 
Mouse PadAudioAudioAudio
Steelseries QcK Denon AH D2000 Harman Kardon AVR 2600 Polk RTi8s, Rti4s and CSi3 
CPUMotherboardGraphicsRAM
Intel G645 Asrock z77 Extreme 4 Nvidia Branded GTX 460 SLI 8GB Corsair Vengeance Low profile DDR3 1600 
Hard DriveOSPowerCase
Hitachi 1TB Windows 7 Antec HCG 750 Bitfenix Shinobi Window 
Mouse Pad
Diablo 3 Steel Series.  
  hide details  
Reply
post #18 of 20
Thread Starter 
Yeah, it's still just spiking and lagging. Seems to be getting worse as the night goes on. It's pretty frustrating. Just going to return it.
post #19 of 20
Hey, I know I'm kinda reviving an old thread here, but I'm suffering from the same issues.
I recently upgraded my Sapphire Radeon 6950 2GB to the Sapphire Radeon 7950 3GB hyper-x boost. I was able to run LoL at 200 FPS without vsync on max settings, and without vsync it would never drop below 60 FPS.

Now that i have the new Radeon 7950 I'm getting weird lag drops to 30-40 fps (really stuttery) randomly. It doens't make any sense, also because I have never used any other drivers than the AMD catalyst. As far as I know I don't experience these lags in other games like Tombraider or Crysis 3, just on League of Legends.

Any updates on this issue?

System specs:
Intel i5 2500K 3,3 ghz
Asrock P67 Pro3 mobo
750W *don't remember brand name* power supply
Radeon 7950 3gb hyper-x graphics
120 GB samsung 840 SSD
2 TB HD
My Blue Pearl
(12 items)
 
   
CPUMotherboardGraphicsRAM
Intel Core i5 2500K P67 Pro3 Sapphire Radeon HD 7950 vapor-x Kingston  
Hard DriveHard DriveCoolingOS
Samsung 840 Series SSD WDC WD20EARX-008FB0 Corsair H100i Windows 7 64 bits 
MonitorPowerCaseMouse
Samsung Syncmaster S24A300BL MS-tech 750W Corsair 500R Logitech M500 
CPUMotherboardGraphicsRAM
Core 2 duo E6850 ASrock G41MGS3 Sapphire Radeon HD 6870  Kingston 
Hard DriveCoolingOSMonitor
Seagate Hyper TX3 evo Windows 7 Ultimate 64 bit Packard Bell 21 inch 
PowerMouse
MS-tech 550W Logitech M500 
  hide details  
Reply
My Blue Pearl
(12 items)
 
   
CPUMotherboardGraphicsRAM
Intel Core i5 2500K P67 Pro3 Sapphire Radeon HD 7950 vapor-x Kingston  
Hard DriveHard DriveCoolingOS
Samsung 840 Series SSD WDC WD20EARX-008FB0 Corsair H100i Windows 7 64 bits 
MonitorPowerCaseMouse
Samsung Syncmaster S24A300BL MS-tech 750W Corsair 500R Logitech M500 
CPUMotherboardGraphicsRAM
Core 2 duo E6850 ASrock G41MGS3 Sapphire Radeon HD 6870  Kingston 
Hard DriveCoolingOSMonitor
Seagate Hyper TX3 evo Windows 7 Ultimate 64 bit Packard Bell 21 inch 
PowerMouse
MS-tech 550W Logitech M500 
  hide details  
Reply
post #20 of 20
Sorry Zyvera, I couldn't send you a PM as I have reached my limit.

In regards to my voltage, Afterburner incorrectly shows it as 1125, when it is in fact 1250. I am only able to change the voltage when using the program Sapphire Trixx.

I just finished reformatting my computer. After re-installing everything, the same issue still exists in League of Legends. However, I believe I have found a workaround. I have heard that this issue began cropping up for people after the Quinn patch. Try running the game in "Border-less Windowed Mode". I still need to test some more, but I think it may have eliminated the problem.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: AMD/ATI
Overclock.net › Forums › Graphics Cards › AMD/ATI › New Sapphire 7950 HD, weird issues with it and FPS