Overclock.net › Forums › AMD › AMD - General › Graphics Issues!!!!
New Posts  All Forums:Forum Nav:

Graphics Issues!!!!

post #1 of 17
Thread Starter 
Hello everyone, currently I'm having issues with my XFX Black Edition 7970. This is my 3rd 7970 that I believe to be defective. Before I return this, I would like to know why I'm having these issues. I'm getting a new power supply in the mail soon (Seasonic x850) and I'm wondering if that is the problem because I currently have a cheapo Raidmax PSU. I've alsoo been experiencing issues with my motherboard as now my onboard audio no longer works. I'm running the 12.10 drivers, and interestingly enough, my card under-performs when it is at default clocks (1000MHz Core, 1425MHz Memory) I'm sure the card is voltage locked, but if I bump either clock speed up by just a smidge, (1000MHz>1001MHz) I can see a humongous performance boost. It goes from 20 fps in Kombustor to 160+ fps which seems really strange to me. I've tried uninstalling and re installing drivers, installing different drivers, and different versions of overclocking. I've also noticed artifacting in a few games such as Sleeping Dogs.

Kombustor and Afterburner:
GPU at stock clocks (Click to show)
GPU with 1Mhz OC (Click to show)

PLEASE HELP ME!

EDIT: I've tried switching PCI ports. No difference. mad.gif If someone thinks I don't have enough info, what should I add? This is extremely frustrating.
Edited by CutThroat - 1/7/13 at 7:09pm
post #2 of 17
BUMP
I am having a similar issue.
post #3 of 17
If you've gone through 3 cards I bet its the psu,cheap ones cause so many issues.Then again it could also be you mobo going bad.But I doubt its 3 bad cards in a row.......
    
CPUMotherboardGraphicsRAM
AMD Phenom II X4 965 M4A785-M XFX Black Edition DD 7850 G.Skill 
RAMHard DriveOptical DriveCooling
G.Skill Hitachi Sony DVD +CM Hyper 212+ 
OSMonitorKeyboardPower
WIN864 Hannspree 25" Onn Kingwin Modular 800w sli ready 
CaseMouseMouse PadAudio
Zalman Z9 ProHT Hypersonic On board 7.1 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
AMD Phenom II X4 965 M4A785-M XFX Black Edition DD 7850 G.Skill 
RAMHard DriveOptical DriveCooling
G.Skill Hitachi Sony DVD +CM Hyper 212+ 
OSMonitorKeyboardPower
WIN864 Hannspree 25" Onn Kingwin Modular 800w sli ready 
CaseMouseMouse PadAudio
Zalman Z9 ProHT Hypersonic On board 7.1 
  hide details  
Reply
post #4 of 17
Thread Starter 
I do have reason to believe it's the motherboard. I recently took it up to Milwaukee as I'm from the Chicago area. When I came back, my onboard audio was not working, speakers weren't even getting recognized at all. Although I was having this issue before I moved my computer.
post #5 of 17
Thread Starter 
Just noticed this today. Could a screw missing be the issue?

post #6 of 17
Thread Starter 
*Sigh* XFX Support. No phone lines, just this ****ty ticket service.

post #7 of 17
Wow.
XFX has very bad support. So many companies would have a lot more consumers if they spent a little more on customer service...
post #8 of 17
Quote:
Originally Posted by CutThroat View Post

Just noticed this today. Could a screw missing be the issue? Warning: Spoiler! (Click to show)
Very unlikely, worse thing that has happened to me when a screw is missing is the motherboard shorting and not able to boot at all. I also notice fan speeds are only at 22% at 68C? Do you have a super aggressive fan profile that ramps up latter? I feel like a RMA is in order, there is really no logical reason for temps to randomly shoot up 10C and 100's of fps if the 1mhz overclock is the only thing changing.
Chuggin' along
(16 items)
 
   
CPUMotherboardGraphicsRAM
Intel Core i7 2600K@4.6GHz MAXIMUS V GENE GTX 970 STRIX@1475/8212 8gb G skill Sniper 2133 
Hard DriveHard DriveHard DriveCooling
Seagate Barracuda 1TB OCZ Agility 3 Intel 120gb 520 H100 
OSMonitorKeyboardPower
Windows 8 Pro BenQ XL2420T +2 Samsung s24d590pl  Corsair K90 OCZ ZX 850w 
CaseMouseAudio
Corsair 500R R.A.T. 7 Sennheiser HD 518 
CPUGraphicsRAMHard Drive
i7 4700 GTX 860m 12GB 120gb SSD 
Hard DriveOSMonitorMouse
1 TB  Windows 8.1 17' 1080p RAT 7 
AudioAudio
Bose quiet comfort 15 sennheiser hd 518  
  hide details  
Reply
Chuggin' along
(16 items)
 
   
CPUMotherboardGraphicsRAM
Intel Core i7 2600K@4.6GHz MAXIMUS V GENE GTX 970 STRIX@1475/8212 8gb G skill Sniper 2133 
Hard DriveHard DriveHard DriveCooling
Seagate Barracuda 1TB OCZ Agility 3 Intel 120gb 520 H100 
OSMonitorKeyboardPower
Windows 8 Pro BenQ XL2420T +2 Samsung s24d590pl  Corsair K90 OCZ ZX 850w 
CaseMouseAudio
Corsair 500R R.A.T. 7 Sennheiser HD 518 
CPUGraphicsRAMHard Drive
i7 4700 GTX 860m 12GB 120gb SSD 
Hard DriveOSMonitorMouse
1 TB  Windows 8.1 17' 1080p RAT 7 
AudioAudio
Bose quiet comfort 15 sennheiser hd 518  
  hide details  
Reply
post #9 of 17
Quote:
Originally Posted by CutThroat View Post

Just noticed this today. Could a screw missing be the issue?

Only if that screw has shorted the board out then yes.You don't have another pc to put that card in to test it do you,if you have bad components you need to find out what they are.If you have another pc or a friend with one you could see if card does the same thing.
Find out if the card is bad first.
    
CPUMotherboardGraphicsRAM
AMD Phenom II X4 965 M4A785-M XFX Black Edition DD 7850 G.Skill 
RAMHard DriveOptical DriveCooling
G.Skill Hitachi Sony DVD +CM Hyper 212+ 
OSMonitorKeyboardPower
WIN864 Hannspree 25" Onn Kingwin Modular 800w sli ready 
CaseMouseMouse PadAudio
Zalman Z9 ProHT Hypersonic On board 7.1 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
AMD Phenom II X4 965 M4A785-M XFX Black Edition DD 7850 G.Skill 
RAMHard DriveOptical DriveCooling
G.Skill Hitachi Sony DVD +CM Hyper 212+ 
OSMonitorKeyboardPower
WIN864 Hannspree 25" Onn Kingwin Modular 800w sli ready 
CaseMouseMouse PadAudio
Zalman Z9 ProHT Hypersonic On board 7.1 
  hide details  
Reply
post #10 of 17
Quote:
Originally Posted by CutThroat View Post

Just noticed this today. Could a screw missing be the issue?

Only if that screw has shorted the board out then yes.You don't have another pc to put that card in to test it do you,if you have bad components you need to find out what they are.If you have another pc or a friend with one you could see if card does the same thing.
Find out if the card is bad first.
    
CPUMotherboardGraphicsRAM
AMD Phenom II X4 965 M4A785-M XFX Black Edition DD 7850 G.Skill 
RAMHard DriveOptical DriveCooling
G.Skill Hitachi Sony DVD +CM Hyper 212+ 
OSMonitorKeyboardPower
WIN864 Hannspree 25" Onn Kingwin Modular 800w sli ready 
CaseMouseMouse PadAudio
Zalman Z9 ProHT Hypersonic On board 7.1 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
AMD Phenom II X4 965 M4A785-M XFX Black Edition DD 7850 G.Skill 
RAMHard DriveOptical DriveCooling
G.Skill Hitachi Sony DVD +CM Hyper 212+ 
OSMonitorKeyboardPower
WIN864 Hannspree 25" Onn Kingwin Modular 800w sli ready 
CaseMouseMouse PadAudio
Zalman Z9 ProHT Hypersonic On board 7.1 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: AMD - General
Overclock.net › Forums › AMD › AMD - General › Graphics Issues!!!!