Overclock.net › Forums › Graphics Cards › AMD/ATI › ATI Cooling › XFX 6870 with Accelero Twin Turbo II in a Mac pro.
New Posts  All Forums:Forum Nav:

XFX 6870 with Accelero Twin Turbo II in a Mac pro.

post #1 of 3
Thread Starter 
Hey, I installed a Accelero Twin Turbo II on my XFX 6870, and every thing was great until I found out that the ****er(the 6870) has a 2-pin connector and the cooler has a 3-pin, 4-pin or that old IDE-power harddrive connector.

I call it that old IDE connector because my Mac pro's PSU doesn't have that power-connector ;( **** Apple smile.gif

So what can I do?

1. "the hacker": Cut the old 2-pin connector from the old 6870-cooler and use only 2 of the 3 cables to power the new Accelero cooler. http://cl.ly/image/0X1D3a3s3d2B the logic thing would be to use Red and yellow (VDC and Signal). Since the standard 3 pin-Accelero-connector has the 1,2 and 3 pin and I "properly" won't need the Ground-pin:D

2. "the Almost hacker": Find an adapter to do 1.

3. "the proper way": Find an adapter from the "new" Sata-power-connector to the old IDE-power-connector. I would do this but I can't find one frown.gif



Thanks, Thanks, Thanks, Thanks, Thanks, Thanks and Thanks.
post #2 of 3
Thread Starter 
SATA-to-Molex will do smile.gif

http://www.amazon.co.uk/SATA-to-Molex-Power-Adapter/dp/B000ZMCYQG
post #3 of 3
Hi!

Googled my way to this thread as I've ordered an accelero twin turbo 2 to mod an XFX 6870 myself. Just wondering:

1. Was your card the single fan or 2-fan version?
and
2. Did you get it to work and if so how?

Thanks dude
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: ATI Cooling
Overclock.net › Forums › Graphics Cards › AMD/ATI › ATI Cooling › XFX 6870 with Accelero Twin Turbo II in a Mac pro.