Overclock.net › Forums › Graphics Cards › AMD/ATI › ATI Drivers and Overclocking Software › Driver issues with the 7970 Ghz 6gb Vapor-X ? And issues with over clocking.
New Posts  All Forums:Forum Nav:

Driver issues with the 7970 Ghz 6gb Vapor-X ? And issues with over clocking.

post #1 of 16
Thread Starter 
What drivers are you guys running? I installed my 7970 GHz Vapor-X 6gb last night and booted up Empire total war, cranked up to max setting Ultra everything, 16X 8X Ultra everything @ 2500X1400 8 armies and it lagged like crazy and looked horrible....

I'm assuming it’s a driver issue... I've only had Nvidia in the past and can’t seem to find where the latest or best driver for Empire with the 7970 is....

With Nvidia I'd just go to the website down load the latest version, remove current and just install the latest version. Simple. With the 7970 there are all these packages and what not!

So I was wondering who else plays the Total war franchise with the 7970 Ghz 6gb. And where can I down load just the latest drivers for the sapphire card.

When I download the 3gb drivers are they also for my 6gb version of the Vapor-X? Because that is all that I can find right now....

I had the Nvidia 295 GTX (dual GPU) and at firs I also had driver issues with that card as well but a couple months after launch I go drivers that worked great. granted that is why I waited so long to get the 7970, so that I can go straight to stable drivers...

All and all I am pretty new to everything computers.... So I am trying to learn everything as quick as possible and searching the forums as much as possible....

And with the over clocking I am having issues as well... It wont let me set up custom clocks and keeps telling me: (using trixx I found that's said was compatible for the 3gb version of my card... because I cant find a 6gb version, if it matters)


"AMD Ultra Low Power State is enables on this card. Overclocking a ULPS enabled card will crash the system. Go to settings, disable ULPS, then restart the system to enable overclocking"

and I do, I go over to the settings tab and it shows the "disable ULPS" checked.... So idk about that either.....


Idk if I have provided enough information.... I can Imagine you'd want my comp specs;

i7 2700k @ 4.8 water cooled by the H8
24.0 GB Ram @ 1600
Asus Maximus IV Gene-Z/Gen3 Mother board
850 corsair power supply
830 Samsung SSD
Crossover 27" 2500X1400

Help? hahah
post #2 of 16
Thread Starter 


If that helps at all!
post #3 of 16
Read my sig thread on AMD how to. Most problems arise from overclocking and "how" one overclocks.

That said, I hope you didn't expect melt your face off awesome performance from one card at that resolution.
The 3930
(26 items)
 
Junior's 3930
(22 items)
 
DATA/HTPC
(20 items)
 
  hide details  
Reply
The 3930
(26 items)
 
Junior's 3930
(22 items)
 
DATA/HTPC
(20 items)
 
  hide details  
Reply
post #4 of 16
Thread Starter 
Quote:
Originally Posted by tsm106 View Post

Read my sig thread on AMD how to. Most problems arise from overclocking and "how" one overclocks.

That said, I hope you didn't expect melt your face off awesome performance from one card at that resolution.


Well I reduced it to 1080p and was still only at about 35-40 fps... I saw some benchmarks where they where hitting 100FPS with this same card on Shogun total war 2.... and empire is older, so that leads me to believe I’m messing up somewhere ?

or am I completely wrong...?
post #5 of 16
Did you get your driver and overclocking sorted out?

Can you run a benchmark? Follow the settings in the link below and post your result. It will tell me if your card is working properly. I don't have total war so I can't compare for you. Also, you might as well fill out your sig rig info.

http://www.overclock.net/t/1235557/official-top-30-heaven-benchmark-3-0-scores/0_40#post_16829928
The 3930
(26 items)
 
Junior's 3930
(22 items)
 
DATA/HTPC
(20 items)
 
  hide details  
Reply
The 3930
(26 items)
 
Junior's 3930
(22 items)
 
DATA/HTPC
(20 items)
 
  hide details  
Reply
post #6 of 16
Thread Starter 
Quote:
Originally Posted by tsm106 View Post

Did you get your driver and overclocking sorted out?

Can you run a benchmark? Follow the settings in the link below and post your result. It will tell me if your card is working properly. I don't have total war so I can't compare for you. Also, you might as well fill out your sig rig info.

http://www.overclock.net/t/1235557/official-top-30-heaven-benchmark-3-0-scores/0_40#post_16829928

Okay sounds good as soon as I am home from work I will do so. Thanks
post #7 of 16
Thread Starter 
post #8 of 16
Thread Starter 
post #9 of 16
Thread Starter 
post #10 of 16
Quote:
Originally Posted by christianreyess View Post


your gpu score looks normal but your physics is way off for 4.8GHz - if it is at that oc. i get 11000 at that oc. your oc might not be stable and affecting your games.
Second Intel Rig
(16 items)
 
  
CPUMotherboardGraphicsRAM
2700 4.5/ 1.28 77 290 (2) 16 / 1866 
Hard DriveCoolingOSMonitor
1000 360/240 10 64 28 2160 
PowerCase
850 540 
  hide details  
Reply
Second Intel Rig
(16 items)
 
  
CPUMotherboardGraphicsRAM
2700 4.5/ 1.28 77 290 (2) 16 / 1866 
Hard DriveCoolingOSMonitor
1000 360/240 10 64 28 2160 
PowerCase
850 540 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
Overclock.net › Forums › Graphics Cards › AMD/ATI › ATI Drivers and Overclocking Software › Driver issues with the 7970 Ghz 6gb Vapor-X ? And issues with over clocking.