Overclock.net › Forums › Components › Power Supplies › NZXT Hale90 1000w psu woes
New Posts  All Forums:Forum Nav:

NZXT Hale90 1000w psu woes

post #1 of 2
Thread Starter 
Purchased one of these psus last year along with a white switch 810 and a bunch of the NZXT sleeved psu cables to build a new rig. Was really happy with the initial performance of the unit and of course it looked sweet in the 810. But then one morning the unit refused to power up. Although the hale90's are Sunflower units and have great writeups, a more thorough search revealed a scattering of similar Hale90 deaths around all with the same story when trying to go through the dreaded NZXT rma process. One guy had an outstanding rma going back 15 months. So with my rma requests and email for tech support going unanswered for 2 weeks i guess I have a long time to wait. Has anyone got any simlar experience with NZXT product support? Or to be more precise the total lack of it?

update:
NZXT finally got in touch and my psu is off to them for rma...After much whining in a number of forums by me >>

update:
3weeks after return of defective unit for rma and all they have done up to now is try to close the ticket.
Straight trash.
Edited by walsingham100 - 2/10/13 at 12:46pm
post #2 of 2
Thread Starter 
Well,I received my brand new replacement psu in the post this week. Thanks to NZXT community reps. I still thin you have issues with customer service, insofar as if I didn't complain on the forums I would still be waiting, but the reps are really good. Cheers guys
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Power Supplies
Overclock.net › Forums › Components › Power Supplies › NZXT Hale90 1000w psu woes