Overclock.net › Forums › Cooling › Water Cooling › [Help wanted] XSPC X20 750 V4
New Posts  All Forums:Forum Nav:

[Help wanted] XSPC X20 750 V4

post #1 of 4
Thread Starter 
Hello guys.

Done my first watercooling solution.

I got these items :

1x XSPC 750 Dual Bayres/Pump V4.
1x Alphacool NexXxoS UT60 Full Copper 360m
2x Alphacool NexXxoS NVXP Nvidia GTX680 - brushed stainless steel.

Everything has been flushed, cleaned and setup, I am going rad - block - block - res/pump, if this has anything to say.

The tubing has even nice curves, nothing that could restrict waterflow.

I spent around 1-1/5 hours bleeding out the system, rocking it back and forth to remove air from the rad.

My question is now, its been running 12-14 hours or so since i put it all together and was bleeding it out. My pump/res makes this most annoying sound in the world, something like a "eeeeerrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrr" sound, somehow remines of one of them pumps in a old fish tank, the sound dont change much if its in the case or if its held in my hand outside the case.

As far as I am told, there is no way to change the pump speed on this unit, as this was my first thought, someone did mention something about a lower volt molex adepter - but I dont know if this is such a good idea, since it would lower the performance and not really fix the problem, should there be one.

I am worried that the pump/res might be faulty since it makes this sound, the fluid level hasnt dropped since the bleed out, I was told to keep the cap off for about 24 hours, so that is still off the res atm.

Performance wise its great, cools my two 680 great nothing to complain about there.

So, TL;DR - Nosy XSPC X20 750 V4 - is it broken or do I just have to wait a few days for it to change the way it sounds?
Edited by Raarup - 1/16/13 at 5:33pm
post #2 of 4
I actually ran into this problem just the other day when i installed mine, after letting it just run, comp was off, for a couple hours the sound went away, i only get it now for ~.5 sec when i first turn on my computer, don't know if thats good/bad, but just let it run for a bit and see what happens.
    
CPUMotherboardGraphicsRAM
Intel Processor Z97-PRO AMD Radeon R9 290 Series G. Skill 
Hard DriveHard DriveOptical DriveCooling
OCZ 128 Vertex 3 WD 1TB black Asus drive Corsair h100i 
OSMonitorKeyboardPower
Windows 8.1 BenQ 24 inch Rosewill rk9000 EVGA 850W GS 
CaseMouseMouse PadAudio
Corsair 540 Silver edition Steel Series Rival SS Qck+ Superlux 681 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
Intel Processor Z97-PRO AMD Radeon R9 290 Series G. Skill 
Hard DriveHard DriveOptical DriveCooling
OCZ 128 Vertex 3 WD 1TB black Asus drive Corsair h100i 
OSMonitorKeyboardPower
Windows 8.1 BenQ 24 inch Rosewill rk9000 EVGA 850W GS 
CaseMouseMouse PadAudio
Corsair 540 Silver edition Steel Series Rival SS Qck+ Superlux 681 
  hide details  
Reply
post #3 of 4
This is interesting. I wonder if they are having QC issues with the new pumps as well. The non "V4" version suffered many RMA's due to faulty pumps
Main Rig
(15 items)
 
 
Living Room PC
(12 items)
 
CPUMotherboardGraphicsRAM
i7 4790K @ 4800 G1 Sniper 5 GTX 780Ti SLI @ 1300MHz 16GB DDR3 @ 2200 9-11-11-31 1T 
Hard DriveHard DriveOptical DriveCooling
2TB Hitatchi HDD 1TB Samsung 840 EVO samsung DVDRW DL Custom Water loop 
OSMonitorPowerCase
Win7 64 LG 27" 1080p EVGA 1000P Corsair 700D 
CPUMotherboardGraphicsRAM
i7 3770K @ 5000 Z77X-UP7 GTX770 2x4GB DDR3 7-8-7-21 1T 
Hard DriveHard DriveOptical DriveCooling
WD Velociraptor 250GB 840Evo DVD Burner Coolermaster hyper 212+ 
OSPowerCase
Win 7 x64 OCZ GameXtreme 700W  Dimastech mini v1 
CPUMotherboardGraphicsRAM
i7 2600 Asus P8Z77-V Pro GTX580 8GB DDR3 @ 1600 9-9-9 1T 
Hard DriveHard DriveOptical DriveCooling
2TB hitachi 500GB 850EVO Blue Ray Hyper 212+ 
OSMonitorPowerCase
Win7 64` 42" Panasonic Plasma TX650 Tuniq Tower 3 
  hide details  
Reply
Main Rig
(15 items)
 
 
Living Room PC
(12 items)
 
CPUMotherboardGraphicsRAM
i7 4790K @ 4800 G1 Sniper 5 GTX 780Ti SLI @ 1300MHz 16GB DDR3 @ 2200 9-11-11-31 1T 
Hard DriveHard DriveOptical DriveCooling
2TB Hitatchi HDD 1TB Samsung 840 EVO samsung DVDRW DL Custom Water loop 
OSMonitorPowerCase
Win7 64 LG 27" 1080p EVGA 1000P Corsair 700D 
CPUMotherboardGraphicsRAM
i7 3770K @ 5000 Z77X-UP7 GTX770 2x4GB DDR3 7-8-7-21 1T 
Hard DriveHard DriveOptical DriveCooling
WD Velociraptor 250GB 840Evo DVD Burner Coolermaster hyper 212+ 
OSPowerCase
Win 7 x64 OCZ GameXtreme 700W  Dimastech mini v1 
CPUMotherboardGraphicsRAM
i7 2600 Asus P8Z77-V Pro GTX580 8GB DDR3 @ 1600 9-9-9 1T 
Hard DriveHard DriveOptical DriveCooling
2TB hitachi 500GB 850EVO Blue Ray Hyper 212+ 
OSMonitorPowerCase
Win7 64` 42" Panasonic Plasma TX650 Tuniq Tower 3 
  hide details  
Reply
post #4 of 4
What was the outcome from this? I have the same problem.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Water Cooling
Overclock.net › Forums › Cooling › Water Cooling › [Help wanted] XSPC X20 750 V4