Overclock.net › Forums › Components › Sound Cards and Computer Audio › HELP! Can't figure out how to install my X-Fi
New Posts  All Forums:Forum Nav:

HELP! Can't figure out how to install my X-Fi

post #1 of 11
Thread Starter 
Okay the X-Fi card is notched so it looks like this.

But my three PCI slots look like this.


The PCI slot has two 'notch' things, but the card has three! When I try to stick the card into the PCI slot, it doesn't really seem to 'plug' or 'stick' in, and won't go all the way down. I don't want to try to force it anymore than I already have in fear of breaking it.

So what should I do? Do I need a new motherboard or something?
My System
(13 items)
 
  
CPUMotherboardGraphicsRAM
Pentium D 4.05GHz Asus P5WD2-E Premium BFG 7900 GTX OC 2GB Crucial Ballistix 
Hard DriveOSMonitorKeyboard
Seagate 250GB +80GB +30GB Vista Premium Dell E207WFP 20.1" Wide G15 
PowerMouse
HEC Power 475 MX518 
  hide details  
Reply
My System
(13 items)
 
  
CPUMotherboardGraphicsRAM
Pentium D 4.05GHz Asus P5WD2-E Premium BFG 7900 GTX OC 2GB Crucial Ballistix 
Hard DriveOSMonitorKeyboard
Seagate 250GB +80GB +30GB Vista Premium Dell E207WFP 20.1" Wide G15 
PowerMouse
HEC Power 475 MX518 
  hide details  
Reply
post #2 of 11
Your slot looks like its flipped around, so flip the card around and see what happens. I dunno from PCI slot pics the line should be to the back not to the front.

pink
post #3 of 11
That all looks normal to me, do the gold pins on the card stick out alot when pushed in?

Anymore than 2-3mm and id say you have a problem.
    
CPUMotherboardGraphicsRAM
i5 2500k @ 4.5GHz 1.4v ASRock Z68 Extreme3 Gen3 MSI R9 290x Gaming 2x4GB Corsair XMS3 1600 
Hard DriveHard DriveCoolingOS
Crucial BX100 250GB Toshiba 2TB Thermalright Macho 120 Rev.A Win 10 Sexy Phwoar bits 
MonitorKeyboardPowerCase
LG 29UM68 (2560x1080) Logitech MK600 SuperFlower GG HX 650W FD Define R4 White Window 
MouseMouse PadAudioAudio
Logitech G502 CM SWIFT-RX XXL Cheap USB DAC Epiphany Acoustics EHP-O2 
Audio
AKG K612 Pro 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
i5 2500k @ 4.5GHz 1.4v ASRock Z68 Extreme3 Gen3 MSI R9 290x Gaming 2x4GB Corsair XMS3 1600 
Hard DriveHard DriveCoolingOS
Crucial BX100 250GB Toshiba 2TB Thermalright Macho 120 Rev.A Win 10 Sexy Phwoar bits 
MonitorKeyboardPowerCase
LG 29UM68 (2560x1080) Logitech MK600 SuperFlower GG HX 650W FD Define R4 White Window 
MouseMouse PadAudioAudio
Logitech G502 CM SWIFT-RX XXL Cheap USB DAC Epiphany Acoustics EHP-O2 
Audio
AKG K612 Pro 
  hide details  
Reply
post #4 of 11
You should not have to push hard, if it doesn't go in than something is wrong. Look at both the slot and the connector closely and see where it doesn't match up.
Gaming Rig
(13 items)
 
  
CPUMotherboardGraphicsRAM
AMD Athlon 64 x2 4600+ AM2 Dell 0CT103 EVGA GeForce 9600GT 512MB 4 x 1GB Wintec (DDR2-667) 
Hard DriveOSMonitorCase
SAMSUNG HD160JJ/P SATA-II 160GB Windows Vista Ultimate x64 Dell 1907FP 19" Dell Dimension E521 
Mouse
Logitech MX518 
  hide details  
Reply
Gaming Rig
(13 items)
 
  
CPUMotherboardGraphicsRAM
AMD Athlon 64 x2 4600+ AM2 Dell 0CT103 EVGA GeForce 9600GT 512MB 4 x 1GB Wintec (DDR2-667) 
Hard DriveOSMonitorCase
SAMSUNG HD160JJ/P SATA-II 160GB Windows Vista Ultimate x64 Dell 1907FP 19" Dell Dimension E521 
Mouse
Logitech MX518 
  hide details  
Reply
post #5 of 11
Even though your X-Fi has more notches, its because those certain pins arn't used.. Plugging it in will be fine

My networking cards on my other computers are the same
My Rigasaurus-reX
(13 items)
 
  
CPUMotherboardGraphicsRAM
Toledo 3800 X2 E6 (CCBWE) DFI nF4 LanParty Ultra-D XFX 6800GS 500/1200 2x512MB OCZ Enhanced Latency 
Hard DriveOptical DriveOSMonitor
250GB WD-Caviar 16M 3GB/s NEC ND-3550A Windows XP Pro SP2 17in. ŁĊĐ 
KeyboardPowerCaseMouse
Logitech G11 Åntec TRUEPOWERII 550W ThermalTake Tsunami Logitech G7 Wireless 
Mouse Pad
SteelPad S&S 
  hide details  
Reply
My Rigasaurus-reX
(13 items)
 
  
CPUMotherboardGraphicsRAM
Toledo 3800 X2 E6 (CCBWE) DFI nF4 LanParty Ultra-D XFX 6800GS 500/1200 2x512MB OCZ Enhanced Latency 
Hard DriveOptical DriveOSMonitor
250GB WD-Caviar 16M 3GB/s NEC ND-3550A Windows XP Pro SP2 17in. ŁĊĐ 
KeyboardPowerCaseMouse
Logitech G11 Åntec TRUEPOWERII 550W ThermalTake Tsunami Logitech G7 Wireless 
Mouse Pad
SteelPad S&S 
  hide details  
Reply
post #6 of 11
Thread Starter 
Okay, I got it in. I guess I just wasn't pushing hard enough because I give it a good firm push on both ends and it 'clicked' in.

But my problems got a looooot bigger.

I got my computer all plugged in and everything, went to turn it on. Click. Nothing happens. I make sure everything is plugged in and the power supply is not manually switched off. Click. Nothing happens. Open up computer to check connections, everything looks fine. Close it up, click, nothing happens. Open it again, and then a third time, Click, nothing happens.

Finally, on the forth time I opened it again because at this point I'm just puzzled. I found nothing so I closed it up again. Click. It worked.

Does anyone have any idea what just happened?!
My System
(13 items)
 
  
CPUMotherboardGraphicsRAM
Pentium D 4.05GHz Asus P5WD2-E Premium BFG 7900 GTX OC 2GB Crucial Ballistix 
Hard DriveOSMonitorKeyboard
Seagate 250GB +80GB +30GB Vista Premium Dell E207WFP 20.1" Wide G15 
PowerMouse
HEC Power 475 MX518 
  hide details  
Reply
My System
(13 items)
 
  
CPUMotherboardGraphicsRAM
Pentium D 4.05GHz Asus P5WD2-E Premium BFG 7900 GTX OC 2GB Crucial Ballistix 
Hard DriveOSMonitorKeyboard
Seagate 250GB +80GB +30GB Vista Premium Dell E207WFP 20.1" Wide G15 
PowerMouse
HEC Power 475 MX518 
  hide details  
Reply
post #7 of 11
Remove the PCI slots and X-FI and see if that helps.
post #8 of 11
Thread Starter 
I did, and my computer wouldn't start, so I just put the X-Fi back in and kept trying. Later the computer did boot, with the X-Fi inside and connected That's what's puzzling me. You'd think the problem would be connected with the X-Fi because the problem occurred right after I connected it, yet the problem seems to have solved itself and the X-Fi didn't seem to matter.
My System
(13 items)
 
  
CPUMotherboardGraphicsRAM
Pentium D 4.05GHz Asus P5WD2-E Premium BFG 7900 GTX OC 2GB Crucial Ballistix 
Hard DriveOSMonitorKeyboard
Seagate 250GB +80GB +30GB Vista Premium Dell E207WFP 20.1" Wide G15 
PowerMouse
HEC Power 475 MX518 
  hide details  
Reply
My System
(13 items)
 
  
CPUMotherboardGraphicsRAM
Pentium D 4.05GHz Asus P5WD2-E Premium BFG 7900 GTX OC 2GB Crucial Ballistix 
Hard DriveOSMonitorKeyboard
Seagate 250GB +80GB +30GB Vista Premium Dell E207WFP 20.1" Wide G15 
PowerMouse
HEC Power 475 MX518 
  hide details  
Reply
post #9 of 11
with the riser in the computer might have been like:
"wait... it shows i have 4 PCi slots when im only supposed to have three *calculates and divides IRQ for 1/2 hour*"

I dunno, so its working fine?

~Higgins
    
CPUMotherboardGraphicsRAM
Intel 2500k Gigabyte Z68X-UD3H-B3 XFX HD5870 16GB G.Skill RipjawsX 
Hard DriveOptical DriveCoolingOS
60GB OCZ Vertex 3 + 2x TB Seagate LG DVD+RW Stock Intel Windows 7 64bit / OSX Mountain Lion 
MonitorKeyboardPowerCase
Dell ST2210 + 17" IBM Das Ultimate S Antec TruePower 650W Antec P183 
MouseMouse PadAudioAudio
Logitech MX Revolution X-Trac Ripper Objective 2 + ODAC Combo Sennheiser HD650 + Klipsch 2.1 Promedia 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
Intel 2500k Gigabyte Z68X-UD3H-B3 XFX HD5870 16GB G.Skill RipjawsX 
Hard DriveOptical DriveCoolingOS
60GB OCZ Vertex 3 + 2x TB Seagate LG DVD+RW Stock Intel Windows 7 64bit / OSX Mountain Lion 
MonitorKeyboardPowerCase
Dell ST2210 + 17" IBM Das Ultimate S Antec TruePower 650W Antec P183 
MouseMouse PadAudioAudio
Logitech MX Revolution X-Trac Ripper Objective 2 + ODAC Combo Sennheiser HD650 + Klipsch 2.1 Promedia 
  hide details  
Reply
post #10 of 11
Thread Starter 
Quote:
Originally Posted by Higgins View Post
with the riser in the computer might have been like:
"wait... it shows i have 4 PCi slots when im only supposed to have three *calculates and divides IRQ for 1/2 hour*"

I dunno, so its working fine?

~Higgins
Flawlessly, for the moment. I guess the test will be (once I'm done with these drivers) to restart and see if it boots.

(Speaking of the drivers, should I also look for updates online since the CD drivers might be out of date?)
My System
(13 items)
 
  
CPUMotherboardGraphicsRAM
Pentium D 4.05GHz Asus P5WD2-E Premium BFG 7900 GTX OC 2GB Crucial Ballistix 
Hard DriveOSMonitorKeyboard
Seagate 250GB +80GB +30GB Vista Premium Dell E207WFP 20.1" Wide G15 
PowerMouse
HEC Power 475 MX518 
  hide details  
Reply
My System
(13 items)
 
  
CPUMotherboardGraphicsRAM
Pentium D 4.05GHz Asus P5WD2-E Premium BFG 7900 GTX OC 2GB Crucial Ballistix 
Hard DriveOSMonitorKeyboard
Seagate 250GB +80GB +30GB Vista Premium Dell E207WFP 20.1" Wide G15 
PowerMouse
HEC Power 475 MX518 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Sound Cards and Computer Audio
Overclock.net › Forums › Components › Sound Cards and Computer Audio › HELP! Can't figure out how to install my X-Fi