Overclock.net › Forums › Software, Programming and Coding › Other Software › Need help with Teamspeak 3 echoing
New Posts  All Forums:Forum Nav:

Need help with Teamspeak 3 echoing

post #1 of 7
Thread Starter 
Hi!
Im using the fatal1ty gaming headset from creative and when I'm in teamspeak, my friends can hear them selves trough me.
My volume isn't loud at all and i cant hear them talking from 5cm away the headset but they can still hear them.
This issue came up about a month ago and last time i got the problem fixed by turning echo cancellation off, this didn't work this time. I never had it before, even tho i used this pair for 4-6 months before.
I'm using on-board audio on my mobo
Also, I don't like to use push to talk because we play a lot of competitive games like CS and Dota...
Could this be an issue in my headset? I had a pair of these already braking down, and i could honestly buy new ones rolleyes.gif

Im using TS3 on Win 7 ultimate 64-bit and my headset is the 3.5mm plug version
Quote:
Originally Posted by StormX2 View Post

built in audio on the Mobo?
Yes
Edited by EPiiKK - 1/24/13 at 11:16am
post #2 of 7
built in audio on the Mobo?
Nameless Traitor
(14 items)
 
†he cu|†
(13 items)
 
 
CPUMotherboardGraphicsRAM
Core I7 920@3.8ghz Asus P6T-Deluxe GTX 570 1.2gb ;p Mushkin RedLine: 3x2GB 1600mhz 998805 
Hard DriveCoolingOSMonitor
128GB Crucial M4 SSD + 2 x 250GB + 500GB Extern... Noctua U12P Win7 Ultimate 64-bit 20in Wide LCD 1680x1050 
KeyboardPowerCaseMouse
Ducky OCN 1008 MX Brown MechBoard Corsair CMPSU-750HX HAF 932! Logitech G5 
Mouse Pad
Cool Warhammer Print 
CPUMotherboardGraphicsRAM
Opty 165 CCBBE @ 300fsb DFI LanP UT SLI-DR eVGA 8800gts 640mb 2x1gb Corsair XMS TwinX P 
Hard DriveOptical DriveOSMonitor
250 g sataII Max†or NEC DVD+/-DL XP pro 20.1 inch wide 5ms 
KeyboardPowerCaseMouse
Some old Thing OCZ GameXstream 600w Spire Baby! Logitech G5 
Mouse Pad
What? 
  hide details  
Reply
Nameless Traitor
(14 items)
 
†he cu|†
(13 items)
 
 
CPUMotherboardGraphicsRAM
Core I7 920@3.8ghz Asus P6T-Deluxe GTX 570 1.2gb ;p Mushkin RedLine: 3x2GB 1600mhz 998805 
Hard DriveCoolingOSMonitor
128GB Crucial M4 SSD + 2 x 250GB + 500GB Extern... Noctua U12P Win7 Ultimate 64-bit 20in Wide LCD 1680x1050 
KeyboardPowerCaseMouse
Ducky OCN 1008 MX Brown MechBoard Corsair CMPSU-750HX HAF 932! Logitech G5 
Mouse Pad
Cool Warhammer Print 
CPUMotherboardGraphicsRAM
Opty 165 CCBBE @ 300fsb DFI LanP UT SLI-DR eVGA 8800gts 640mb 2x1gb Corsair XMS TwinX P 
Hard DriveOptical DriveOSMonitor
250 g sataII Max†or NEC DVD+/-DL XP pro 20.1 inch wide 5ms 
KeyboardPowerCaseMouse
Some old Thing OCZ GameXstream 600w Spire Baby! Logitech G5 
Mouse Pad
What? 
  hide details  
Reply
post #3 of 7
Thread Starter 
Yep
post #4 of 7
increase the db of your microphone though the settings in the sounds option.
post #5 of 7
Thread Starter 
Quote:
Originally Posted by Indiegreg View Post

increase the db of your microphone though the settings in the sounds option.
It's up the roof. Didn't help to turn up the boost too.
Did you mean Mic properties > levels > Microphone / mic boost ?
post #6 of 7
Thread Starter 
Ok so i plugged my headset into the backpanel audio ports, its working fine now. but i do want to use my speakers too.
Could they be picking each other up somewhere in the motherboard? or could the onboard audio chip be broken/bad?
post #7 of 7
Thread Starter 
Could a new soundcard fix this? Is there any soundcard that has plugs for headphones and speakers?
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Other Software
Overclock.net › Forums › Software, Programming and Coding › Other Software › Need help with Teamspeak 3 echoing