Overclock.net › Forums › Graphics Cards › AMD/ATI › Did my brand new Sapphire HD 7870 GPU just die?
New Posts  All Forums:Forum Nav:

Did my brand new Sapphire HD 7870 GPU just die? - Page 2

post #11 of 15
Thread Starter 
Quote:
Originally Posted by 1ceMaster View Post

Well cheers on getting it to work again. PC components can be a very mysterious thing sometimes. Don't forget to stress test your GPU with something like Heaven Benchmark just to make sure that your card isn't faulty.

Awesome, thank you so much. Never conducted a stress test and the name itself sounds unnerving but I'll definitely give it a shot to see what happens.
Thank you everyone - I really appreciate your input!
post #12 of 15
Bench your card with Ungine Heaven and check your Power supply and PCI-E connections to make sure there's no card creep?

You may want to check which batch of Sapphire 7870s it is. http://www.techpowerup.com/174858/Some-Sapphire-Radeon-HD-7870-Cards-Affected-by-quot-Black-Screen-quot-Issue.html
Workstation stuff
(407 photos)
SpecViewperf 12.0.1
(152 photos)
 
Reply
Workstation stuff
(407 photos)
SpecViewperf 12.0.1
(152 photos)
 
Reply
post #13 of 15
Thread Starter 
Here is my benchmark results [if I did this right...otherwise, I can do it again]

As far as I know my connections are working great. I had my previous GPU hooked up using the same PSU for upwards of 4 years without any issues whatsoever. I know that may not necessarily mean things aren't failing over time but what would be a way for me to test weather my connections are secure?

I'm looking into that Sapphire website. In the meatime, my RMA via Newegg has expired but I filed a case ticket with Sapphire regarding this issue and am hoping to hear back from them regarding, at the very least, a replacement GPU. Kind of kicking myself in the ass about choosing AMD over NVIDIA this build.
post #14 of 15
Most of the time if you send back your GPU to Sapphire and they test it and find nothing wrong with it. They will send it back and you will have to pay for shipping so you lose a few bucks in the end on top of not getting a replacement. It has happened to a lot of people even though the card itself has issues but Sapphire can't seem to find them when they test it in their labs.
post #15 of 15
maybe you got lucky and it got itself unseated or something just upset your systems stability.
Taiga's 2nd wind
(14 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i5 6600K Gigabyte GA-Z170XP-SLI Gigabyte GTX 970 G1 Gaming G.Skill Ripjaws V series 
Hard DriveHard DriveCoolingOS
Western Digital 1TB HDD Mushkin Enhanced Eco2 SSD Silverstone TD02-Lite Windows 7 Ultimate 64bit 
MonitorKeyboardPowerCase
Acer G257HU Roccat Isku Corsair CX600M Antec P182 
MouseMouse Pad
Roccat Kone+ SteelSeries 
  hide details  
Reply
Taiga's 2nd wind
(14 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i5 6600K Gigabyte GA-Z170XP-SLI Gigabyte GTX 970 G1 Gaming G.Skill Ripjaws V series 
Hard DriveHard DriveCoolingOS
Western Digital 1TB HDD Mushkin Enhanced Eco2 SSD Silverstone TD02-Lite Windows 7 Ultimate 64bit 
MonitorKeyboardPowerCase
Acer G257HU Roccat Isku Corsair CX600M Antec P182 
MouseMouse Pad
Roccat Kone+ SteelSeries 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: AMD/ATI
Overclock.net › Forums › Graphics Cards › AMD/ATI › Did my brand new Sapphire HD 7870 GPU just die?