Overclock.net › Forums › Graphics Cards › AMD/ATI › ATI Drivers and Overclocking Software › EYEFinity troubleshooting, 1 screen goes blank when gaming, red lines on screen HELP!!!
New Posts  All Forums:Forum Nav:

EYEFinity troubleshooting, 1 screen goes blank when gaming, red lines on screen HELP!!!

post #1 of 6
Thread Starter 
So hi all, i just recently got my rig up and working again thumb.gif

and i am going for my eyefinity setup,

the parts used are

i have 3 of these exact monitors http://www.newegg.com/Product/Product.aspx?Item=N82E16824009316

DP to active DVI

http://www.superbiiz.com/detail.php?p=AT-DP_DVI&c=fr&pid=a7eddf43c0c03d787e2411088787ebc4cc11cc8dcd379b135e13d8b570dfc3b5&gclid=CP7jhZ7wh7UCFegWMgodAhcACg

2 DVI-D Single like (1 more, as 1 came with each of the monitors)

1 DVI-D Dual link

and 2 Crossfired http://www.newegg.com/Product/Product.aspx?Item=N82E16814102987

6950 2GB OC Dirt 3 Edition x2

FX-8150

16GB Ram

Sabertooth 990FX

1000w PSU

SSD's (Samsung 840 PRO 128) for OS

So now that we know the exact hardware use, let's do software

Windows 7 64bit PRO

CCC 13.1, (am not using Hydravision, or and Profile packs) planning on it though (Just for ultimate stability, and peace of mind if thats what they are intended for)

So I start out by disabling extending all the desktops, they all work fine, Brand new, hardly used (all by me)

I'm not the type of person to F*** around with their equipment i take extreme care of them. So one thing i'm sure of is that it has nothing to do with Crossfire, as it does the same with or without them.

So i got eyefinity to run last night (just desktop) and then today again, and ran L4D2 on 3 screens all maxed 60fps with one card, (I was kinda shocked, GPU-Z said only 88% GPU Load)

So Then i am like Hmm, i wonder if battlefield will run 3 Screen, So i turn down the settings to low, (i already know it will not run all screens at ultra more or less 60fps, it can hardly do one screen 60 without the other card, ULTRA that is.)

But no i launch battlefield change the resolution to 5760x1080, and when it launched it just had battlefield on 2 duplicate screen and the leftmost screen went blank, but did not state signal loss, just went blank, this was the screen with the DP adapter and a singlelink.

So im like great, i quit the game and go to desktop thinking that the screen will come back on, nope. only 2 screens are setup

So i unplug all cables except for the middle screen, and it returns to normal. (only one screen is lit up now) Middle has the Dual link.
_______________________

onto the second problem i'm unsure of whether my GPU might be failing or not or if it is just a cable. (note drivers are uninstalled at this moment, probably the cause but i want to make sure i don't have a GPU problem)

as when i plugged in a single link to the middle monitor it had red lines going horizontal. So i plug it into the monitor to the left same thing, so i know that it isn't the monitor's fault or that they are failing.

So i plug in a different cable to the rightmost monitor, (the other single link) and it comes on perfectly, on the exact same port that had the red lines

basically my cards look like
[ DVI ] [HDMI] [DP]
[ DVI ]

the one that had the red lines was the top DVI port, but that port worked fine with the other monitor (which also had another cable) and didnt have red lines

But that cable was also a Single-link

So is this probably just a bad cable scenario?




So thank you for reading this long article i give you props if you did.

But my questions are

1. Is my gpu possibley failing?

2. What kind of cable's are recommended for EYEFINITY

3. Why is my monitor cutting out, when i go into Battlefield, or sometimes it just even happens when configuring eyefinity.

(Note: this is a 4 day fresh windows install)

4. When the monitor doesn't say "No Signal" but doesn't show anything, does this mean the signal is simply not strong enough? Should i bump up the power in CCC?

the configuration went like so, Left monitor = DP Adapter, Single link , Middle= Dual link, Right= Single link
Edited by powerdemon292 - 1/26/13 at 10:45pm
Dark Retribution
(21 items)
 
Concealed Fiend
(12 items)
 
 
CPUGraphicsRAMHard Drive
i5 3210m Nvidia GTX 660m 8GB DDR3 160mhz SODIMM 750GB 
Hard DriveOSMonitorKeyboard
Plextor 128GB mSATA SSD Windows 7 64bit PRO  14" 720p Standard Backlit 
CaseMouseMouse PadAudio
Asus ROG G46VW Razer Naga Razer vespuela Yasper standard headset with mic 
  hide details  
Reply
Dark Retribution
(21 items)
 
Concealed Fiend
(12 items)
 
 
CPUGraphicsRAMHard Drive
i5 3210m Nvidia GTX 660m 8GB DDR3 160mhz SODIMM 750GB 
Hard DriveOSMonitorKeyboard
Plextor 128GB mSATA SSD Windows 7 64bit PRO  14" 720p Standard Backlit 
CaseMouseMouse PadAudio
Asus ROG G46VW Razer Naga Razer vespuela Yasper standard headset with mic 
  hide details  
Reply
post #2 of 6
Thread Starter 
EDIT: now it has shown green lines all over the screens, now this is making me feel like it is failing, tried on other card, nope no artifacts, starting to feel like i should just rma it
Dark Retribution
(21 items)
 
Concealed Fiend
(12 items)
 
 
CPUGraphicsRAMHard Drive
i5 3210m Nvidia GTX 660m 8GB DDR3 160mhz SODIMM 750GB 
Hard DriveOSMonitorKeyboard
Plextor 128GB mSATA SSD Windows 7 64bit PRO  14" 720p Standard Backlit 
CaseMouseMouse PadAudio
Asus ROG G46VW Razer Naga Razer vespuela Yasper standard headset with mic 
  hide details  
Reply
Dark Retribution
(21 items)
 
Concealed Fiend
(12 items)
 
 
CPUGraphicsRAMHard Drive
i5 3210m Nvidia GTX 660m 8GB DDR3 160mhz SODIMM 750GB 
Hard DriveOSMonitorKeyboard
Plextor 128GB mSATA SSD Windows 7 64bit PRO  14" 720p Standard Backlit 
CaseMouseMouse PadAudio
Asus ROG G46VW Razer Naga Razer vespuela Yasper standard headset with mic 
  hide details  
Reply
post #3 of 6
Most likely the DP adapter is defective.

Get an active DP adapter that support dual link. the one that works with a usb power source and plug that usb power on an always on 1A usb port found outside of the PC (plugging it in one of the ports on the PC makes it fickle and might disconnect). I use a power source built into the power connections feeding the pc.

Hydra
(13 items)
 
Hydra 2
(23 items)
 
 
CPUMotherboardGraphicsRAM
Intel i7 3930k @4.4ghz@1.44v Asrock X79 Fataility Champion 3xInno3d GTX 780 with Full Nickel EK Waterblocks Gskill RipjawsX 4x4GB@2400mhz 11-11-11-31 
Hard DriveCoolingMonitorKeyboard
2xSamsung 830 256gb Custom H2O - 3x XSPC RX360 with EK Blocks Surround Gaming 3x1440@96hz (X-Star) Cooler Master Trigger Red Caps 
PowerCaseMouseAudio
Seasonic 1250 watt Danger Den Double Wide 21 Roccat Kone+ Creative ZX (Incoming) 
Audio
Roccat Kave 5.1 Headphones 
CPUMotherboardGraphicsGraphics
4930k Asus Extreme Black Edition Sapphire R9 290x Sapphire R9 290x 
GraphicsGraphicsRAMHard Drive
Sapphire R9 290x Sapphire R9 290x Gskil TridentX 2400mhz Samsung 830 256GB 
Hard DriveCoolingCoolingCooling
Samsung 840 500GB EK Supramacy 4x EK Blocks 6x EK XTX480 
CoolingOSMonitorMonitor
EK XT360 Windows 8.1 BenQ 3201 32in 4k IPS Qnix 32in 1440 MVA 
MonitorKeyboardPowerCase
Qnix 32in 1440 MVA Coolermaster Storm Trigger 2x Seasonic 1250watt Case Labs TH10 
MouseAudioAudio
Roccat Kone Creative ZX AKG K7XX 
  hide details  
Reply
Hydra
(13 items)
 
Hydra 2
(23 items)
 
 
CPUMotherboardGraphicsRAM
Intel i7 3930k @4.4ghz@1.44v Asrock X79 Fataility Champion 3xInno3d GTX 780 with Full Nickel EK Waterblocks Gskill RipjawsX 4x4GB@2400mhz 11-11-11-31 
Hard DriveCoolingMonitorKeyboard
2xSamsung 830 256gb Custom H2O - 3x XSPC RX360 with EK Blocks Surround Gaming 3x1440@96hz (X-Star) Cooler Master Trigger Red Caps 
PowerCaseMouseAudio
Seasonic 1250 watt Danger Den Double Wide 21 Roccat Kone+ Creative ZX (Incoming) 
Audio
Roccat Kave 5.1 Headphones 
CPUMotherboardGraphicsGraphics
4930k Asus Extreme Black Edition Sapphire R9 290x Sapphire R9 290x 
GraphicsGraphicsRAMHard Drive
Sapphire R9 290x Sapphire R9 290x Gskil TridentX 2400mhz Samsung 830 256GB 
Hard DriveCoolingCoolingCooling
Samsung 840 500GB EK Supramacy 4x EK Blocks 6x EK XTX480 
CoolingOSMonitorMonitor
EK XT360 Windows 8.1 BenQ 3201 32in 4k IPS Qnix 32in 1440 MVA 
MonitorKeyboardPowerCase
Qnix 32in 1440 MVA Coolermaster Storm Trigger 2x Seasonic 1250watt Case Labs TH10 
MouseAudioAudio
Roccat Kone Creative ZX AKG K7XX 
  hide details  
Reply
post #4 of 6
Thread Starter 
K so that could be about the adapter, ive done this setup before, and sometimes i guess it feels like woking, plus this is the sapphire DP, so i should have no problems anyway. Well

on a side note, i have been seeing green and red lines all over my screen, only during POST though, im running a memtest right now to see if that will tell me anything (doubt it)
Dark Retribution
(21 items)
 
Concealed Fiend
(12 items)
 
 
CPUGraphicsRAMHard Drive
i5 3210m Nvidia GTX 660m 8GB DDR3 160mhz SODIMM 750GB 
Hard DriveOSMonitorKeyboard
Plextor 128GB mSATA SSD Windows 7 64bit PRO  14" 720p Standard Backlit 
CaseMouseMouse PadAudio
Asus ROG G46VW Razer Naga Razer vespuela Yasper standard headset with mic 
  hide details  
Reply
Dark Retribution
(21 items)
 
Concealed Fiend
(12 items)
 
 
CPUGraphicsRAMHard Drive
i5 3210m Nvidia GTX 660m 8GB DDR3 160mhz SODIMM 750GB 
Hard DriveOSMonitorKeyboard
Plextor 128GB mSATA SSD Windows 7 64bit PRO  14" 720p Standard Backlit 
CaseMouseMouse PadAudio
Asus ROG G46VW Razer Naga Razer vespuela Yasper standard headset with mic 
  hide details  
Reply
post #5 of 6
Hi,

I've been dealing with this issue for the last year at least. The only fix is to turn on Vsync. It use to work prior to the 12.4 release but since then nothing but stripes running across eyefinity to infinity. They say this happens because of a timing issue between the displayport adapter + monitor and the dvi monitors. Technically speaking it could (maybe) be corrected if AMD would step up and patch the drivers. I have tried two different dp adapters including the ACCELL brand recommended by AMD. For now I have vsync on as I'm happy with 60fps if I can get it at 5670x1080 resolution. The only thing is you might note that gpu utilization may decrease with Vsync on. For now just turn on Vsync is my recommendation but first go through the initial troubleshooting steps. Test the cards with out crossfire in single monitor, swap your crossfire cable, another brand dp adapter, and please post a photo of whats going on!



Good luck.
post #6 of 6
Thread Starter 
well i've got it working i have my dual link in my DP as i saw lines and such on the single link with DP, and i noticed that V-Sync does F*** with my settings but IT WORKS!!

im happy with the setup and im thinking that sometimes it just might fail and ill just have to fix it again.. o well thats ok. For now im getting BF3 on 5760x1080 with 40 frames on low, with one of my cards, i think that is just awesome. ill probably put my second card in for medium setting and 60frames, hopefully.

but ive been using just this card for eyefinity atm as i saw some artifacts and am now just testing it... hopefully when i xfire windows will be cool and just accept it
Dark Retribution
(21 items)
 
Concealed Fiend
(12 items)
 
 
CPUGraphicsRAMHard Drive
i5 3210m Nvidia GTX 660m 8GB DDR3 160mhz SODIMM 750GB 
Hard DriveOSMonitorKeyboard
Plextor 128GB mSATA SSD Windows 7 64bit PRO  14" 720p Standard Backlit 
CaseMouseMouse PadAudio
Asus ROG G46VW Razer Naga Razer vespuela Yasper standard headset with mic 
  hide details  
Reply
Dark Retribution
(21 items)
 
Concealed Fiend
(12 items)
 
 
CPUGraphicsRAMHard Drive
i5 3210m Nvidia GTX 660m 8GB DDR3 160mhz SODIMM 750GB 
Hard DriveOSMonitorKeyboard
Plextor 128GB mSATA SSD Windows 7 64bit PRO  14" 720p Standard Backlit 
CaseMouseMouse PadAudio
Asus ROG G46VW Razer Naga Razer vespuela Yasper standard headset with mic 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
Overclock.net › Forums › Graphics Cards › AMD/ATI › ATI Drivers and Overclocking Software › EYEFinity troubleshooting, 1 screen goes blank when gaming, red lines on screen HELP!!!