Overclock.net › Forums › Components › Sound Cards and Computer Audio › Can't get my brand-new Modmic to work (other mics seem to work)
New Posts  All Forums:Forum Nav:

Can't get my brand-new Modmic to work (other mics seem to work)

post #1 of 4
Thread Starter 
So I just received my new Modmic from Antlion, but after several hours of troubleshooting I've been unable to get it to record sound. The problem isn't that the volume is very low or anything; even when shouting into it and having it very close to my mouth it doesn't receive anything. Windows recognizes it, but the only thing it receives seems to be distorted sounds and "crackling" when I wave it around (that also seems to be the only way to get the green bars in Audio Devices to increase).

I run Windows 7, and don't have a dedicated sound card (my MB is Asus p8p67 Pro, rev 3.1 I think, and just today I updated my Realtek audio as well as my BIOS from asus.com (though the mic didn't work before that either)). I've tried putting the mic into both my front and back audio jacks (the pink-coded ones), and I've been changing various settings in audio devices (like microphone boosting) and Realtek HD Audio Manager back and forth with no success.

I also tried using an ancient no-brand headset with a build-in mic a bit earlier today, and it worked pretty much perfectly without altering any settings (but I won't use that headset 'cause it's a Medieval torture device and I got the damn mic shipped half across the world). I can't imagine that the mic has been damaged somehow; I'd barely even touched it before I noticed that it wasn't working (haven't even attached it to a pair of headphones yet) and it was shipped in a very compact, secure package.

Can anyone help me?
post #2 of 4
Sounds like a dud. The antlion doesn't require anything special. It's just a regular mic plug, so I think it's probably just a defective unit.

Try it in another PC as a last resort and if doesn't work, try to get it exchanged.
Hotbox
(16 items)
 
  
CPUMotherboardGraphicsRAM
6850k Asrock X99M Killer USB 3.1 Titan X Pascal Corsair 32GB 3400 
Hard DriveHard DriveHard DriveHard Drive
Crucial M550 1TB Crucial M550 1TB Crucial M550 1TB Crucial M550 1TB 
Hard DriveCoolingOSMonitor
Intel 750 PCIe 1.2TB H100i V2 Windows 10 x64 Acer X34 
KeyboardPowerCaseMouse
Corsair K65 EVGA 1000 G3 Corsair Air 240 Logitech G9 
  hide details  
Reply
Hotbox
(16 items)
 
  
CPUMotherboardGraphicsRAM
6850k Asrock X99M Killer USB 3.1 Titan X Pascal Corsair 32GB 3400 
Hard DriveHard DriveHard DriveHard Drive
Crucial M550 1TB Crucial M550 1TB Crucial M550 1TB Crucial M550 1TB 
Hard DriveCoolingOSMonitor
Intel 750 PCIe 1.2TB H100i V2 Windows 10 x64 Acer X34 
KeyboardPowerCaseMouse
Corsair K65 EVGA 1000 G3 Corsair Air 240 Logitech G9 
  hide details  
Reply
post #3 of 4
Yo Drome-
I work at Antlion. Email customer service and we'll get you a replacement ASAP.
If other PC mics work fine on your box then it's likely the mic.
Even though we do QC twice before the product ships- capsule microphones are notorious for being troublesome. The most we can do is get you swapped out quick.
I hope this sort of post isn't against OC policy, but I couldn't not get in here and lend a hand. It sucks to get a DOA product.
J
post #4 of 4
Thread Starter 
Alright, I tried the Modmic on a couple of laptops in my house, and it didnt work any better on either of them (though the old headset I mentioned did). I guess it's defective then. I'll send an e-mail for a replacement to Antlion shortly, thanks for the replies.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Sound Cards and Computer Audio
Overclock.net › Forums › Components › Sound Cards and Computer Audio › Can't get my brand-new Modmic to work (other mics seem to work)