Overclock.net › Forums › Video Games › PC Gaming › Battlefield 3: Micro-stuttering and sluggish gameplay
New Posts  All Forums:Forum Nav:

Battlefield 3: Micro-stuttering and sluggish gameplay - Page 3

post #21 of 34
For BF3 sluttering, try this : Use latest driver or the new 313.96 Nvidia beta driver. Go in the Nvidia control panel, under 3D parameter manager, change Maximum Pre-Rendered Frames to 1 (It's better to program this only for BF3). You can also try to use Adaptative Vsync in Nvidia Control panel who help a lot for GTX 680 (and disable Vsync in the game itself).

It work for me, BF3 is smooth now.
post #22 of 34
Thread Starter 
Quote:
Originally Posted by zzzronin View Post

For BF3 sluttering, try this : Use latest driver or the new 313.96 Nvidia beta driver. Go in the Nvidia control panel, under 3D parameter manager, change Maximum Pre-Rendered Frames to 1 (It's better to program this only for BF3). You can also try to use Adaptative Vsync in Nvidia Control panel who help a lot for GTX 680 (and disable Vsync in the game itself).

It work for me, BF3 is smooth now.

nop, didn't work frown.gif
post #23 of 34
Try lowering your OC(s), BF3 is very finicky when it comes to OCs.
post #24 of 34
Thread Starter 
I tried everything on its default settings, still.
post #25 of 34
Quote:
Originally Posted by 1b0b1 View Post

I tried everything on its default settings, still.

Mmm, that's weird.

Do you by any chance have any real time AV software installed? if so, disable it.

You may also wanna give Razer's GameBooster software a try, it will disable any unnecessary Windows service(s) just before running any game.

EDIT: One more, disable the "Ram Mouse Input" option from the in-game settings.
Edited by SlackerITGuy - 2/6/13 at 10:56am
post #26 of 34
Thread Starter 
Quote:
Originally Posted by SlackerITGuy View Post

Mmm, that's weird.

Do you by any chance have any real time AV software installed? if so, disable it.

Nop, nothing installed.

You may also wanna give Razer's GameBooster software a try, it will disable any unnecessary Windows service(s) just before running any game.

already tried the gamebooster but didn't work

EDIT: One more, disable the "Ram Mouse Input" option from the in-game settings

Again, already tested tongue.gif

.



I've really tested every fix out there, Thanks for the effort though.
post #27 of 34
Quote:
Originally Posted by 1b0b1 View Post

I've really tested every fix out there, Thanks for the effort though.

Somewhat of a last resort mate, and I know I'll be getting some heat from other OCN members for suggesting this but, how about trying the latest version of Lucid's Virtu MVP?: http://lucidlogix.com/driverdownloads-mvp2.shtml

Enable Virtual VSync and get back to us.
post #28 of 34
Thread Starter 
Quote:
Originally Posted by SlackerITGuy View Post

Somewhat of a last resort mate, and I know I'll be getting some heat from other OCN members for suggesting this but, how about trying the latest version of Lucid's Virtu MVP?: http://lucidlogix.com/driverdownloads-mvp2.shtml

Enable Virtual VSync and get back to us.

From what I've heard, BF3 doesn't like MVP.
post #29 of 34
Thread Starter 
Quote:
Originally Posted by SlackerITGuy View Post

Somewhat of a last resort mate, and I know I'll be getting some heat from other OCN members for suggesting this but, how about trying the latest version of Lucid's Virtu MVP?: http://lucidlogix.com/driverdownloads-mvp2.shtml

Enable Virtual VSync and get back to us.

For what its worth, I've tested it and the results were awful biggrin.gif
post #30 of 34
Quote:
Originally Posted by 1b0b1 View Post

For what its worth, I've tested it and the results were awful biggrin.gif

Quick question:

Did you end up creating an "user.cfg" in your Origin Games\Battlefield 3 folder?

What does it say on the "type" row for the user.cfg file? text document?
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: PC Gaming
Overclock.net › Forums › Video Games › PC Gaming › Battlefield 3: Micro-stuttering and sluggish gameplay