Overclock.net › Forums › Video Games › PC Gaming › Crysis (One) FPS Drop When Looking Around Too Fast?
New Posts  All Forums:Forum Nav:

Crysis (One) FPS Drop When Looking Around Too Fast? - Page 3

post #21 of 46
Quote:
Originally Posted by doomlord52 View Post

Ok, but I've only been working with Crysis since beta stage in Sept. 2007, and worked on some of the most popular .cfg files of all time (CCC mod). Also, Crysis needs overhead. This is what usually causes that kind of lag. It's one of the issues with the engine back then (CE3 doesn't do this), and how it handled assets. In an attempt to keep the FPS high, it would only really load in what was needed for those frames. That means when you spin around, it needs to quickly load in a ton of textures, as well as increase the draw calls by an insane amount. If you're already at max load, it'll stutter as it uses what little CPU/GPU time it has to load in the stuff.

It makes perfect sense, too. Slower turning means less new "stuff" in frame, which means less streaming. Faster spinning means faster streaming.

In any event, just to cross hardware out, set everything to low (absolutely everything, no AA or AF, no mods, etc.), and drop the resolution to 720p or something. If there's still crazy lag, yea, it's software. If it's gone, then it's because of overhead.


Also something I remembered. I had a similar issue a while back (2009) that was caused by my hard-drive having a TON of bad sectors (it was dying). Have you checked that?

You're The doomlord? Of the AI tweak? Awesome job man. I always use that. +rep

OP, Doomlords explanation makes sense. But it doesn't explain how you were able to play it before. Also, since changing the settings to low doesn't change this, its very peculiar.
Defrag the game, scan for bad sectors, maybe even run gamebooster.

Also, get your hands on a non steam version and see if you have the same issue.

Try running the 32bit-exe and in dx9
TRON3000
(15 items)
 
 
ASUSness
(5 items)
 
CPUMotherboardGraphicsRAM
Q6600 G0 SLACR @ 3.0 GHz Gigabyte GA-EP31-DS3L MSI 7950 OC BE 3GB 2X2 GB 800 mhz Corsair 
Hard DriveOptical DriveOSOS
Seagate Barracuda 7200rpm 500GB LG super multi Windows 8.1 Pro 64 bit Windows 8 pro 64 bit 
OSMonitorPower
Ubuntu 12.10 Acer 19"W 4ms AL1916W Coolermaster 500W 
CPUGraphicsRAMHard Drive
Intel Core i5-5200U Intel HD Graphics 5500 4GB DDR3L 1600 MHz 128GB SSD 
OSMonitorAudio
Windows 10 64-bit 13.3 in Full HD infinity display Waves MaxxAudio 
CPUGraphicsRAMOS
Intel Core i3 3217U Intel(R) HD Graphics 4000 4.00GB DDR3 Windows 10 64-bit 
Monitor
14" Multitouch 1366x768 
  hide details  
Reply
TRON3000
(15 items)
 
 
ASUSness
(5 items)
 
CPUMotherboardGraphicsRAM
Q6600 G0 SLACR @ 3.0 GHz Gigabyte GA-EP31-DS3L MSI 7950 OC BE 3GB 2X2 GB 800 mhz Corsair 
Hard DriveOptical DriveOSOS
Seagate Barracuda 7200rpm 500GB LG super multi Windows 8.1 Pro 64 bit Windows 8 pro 64 bit 
OSMonitorPower
Ubuntu 12.10 Acer 19"W 4ms AL1916W Coolermaster 500W 
CPUGraphicsRAMHard Drive
Intel Core i5-5200U Intel HD Graphics 5500 4GB DDR3L 1600 MHz 128GB SSD 
OSMonitorAudio
Windows 10 64-bit 13.3 in Full HD infinity display Waves MaxxAudio 
CPUGraphicsRAMOS
Intel Core i3 3217U Intel(R) HD Graphics 4000 4.00GB DDR3 Windows 10 64-bit 
Monitor
14" Multitouch 1366x768 
  hide details  
Reply
post #22 of 46
Thread Starter 
Quote:
Originally Posted by doomlord52 View Post

Did you try dropping everything to low?

The point is to eliminated unknown/unlikely issues, so we at least know what we're working with. Simply assuming that it's not a hardware issue isn't a great method. It'll take you all of 2 minutes to check.



While your at it, try dumping the shader cache. C:/Users/[Account name]/Documents/My Games/Crysis
Can't remember the exact name of the folder, it's either Cache or shader cache. Delete it.

Will do when I get home.

Shader cache may be the issue since I didn't know such a thing existed. Could be reading shaders from the previous install (non-Steam version). I'll check out both.
post #23 of 46
Quote:
Originally Posted by kenpachiroks View Post

You're The doomlord? Of the AI tweak? Awesome job man. I always use that. +rep
Yup, that's me. Glad to see you're enjoying the AI mod.


@Victus
Yea, it's possible. The shader cache from C1 was horribly volatile. Even certain cvar changes could cause the entire thing to go bad for no real reason.
Base2
(21 items)
 
Edi
(13 items)
 
Zenbook
(7 items)
 
CPUMotherboardGraphicsRAM
Core i7 2600k @ 4.75ghz @ 1.352v Asus p8p67 Deluxe Asus GTX 970 Strix ADATA XPG1 (2x8gb) @ 1600mhz 
Hard DriveHard DriveHard DriveHard Drive
2x OCZ Agility 3  2x Toshiba 2tb Sata 3 OCZ Vertex 2 Seagate Barracuda 500gb 
Optical DriveCoolingCoolingCooling
LG Blu-Ray-RW  Corsair H70 3x Corsair AF 120 Silent Edition 2x AF 140 
OSMonitorMonitorKeyboard
Windows 7 x64 Home Premium Asus VG248QE Asus VG248QE Ducky Shine 3 (MX Black) 
PowerCaseMouseAudio
Corsair AX 1200 Corsair 450D Razer Deathadder 2013 Creative X-FI Titanium HD 
Other
Sennheiser PC 350 
CPUGraphicsRAMHard Drive
Core i7 740QM GTX 460m 2x 4gb DDR3 OCZ Agility 3 
OSMonitor
Windows 7 x64 15.1" (1920x1080) 
CPUGraphicsRAMHard Drive
Core i3 2367M Intel HD 3000 4GB DDR3 Hitachi HDD 
Hard DriveOSMonitor
SanDisk SSD Windows 7 Home Premium x64 13.3" 1366x768 
  hide details  
Reply
Base2
(21 items)
 
Edi
(13 items)
 
Zenbook
(7 items)
 
CPUMotherboardGraphicsRAM
Core i7 2600k @ 4.75ghz @ 1.352v Asus p8p67 Deluxe Asus GTX 970 Strix ADATA XPG1 (2x8gb) @ 1600mhz 
Hard DriveHard DriveHard DriveHard Drive
2x OCZ Agility 3  2x Toshiba 2tb Sata 3 OCZ Vertex 2 Seagate Barracuda 500gb 
Optical DriveCoolingCoolingCooling
LG Blu-Ray-RW  Corsair H70 3x Corsair AF 120 Silent Edition 2x AF 140 
OSMonitorMonitorKeyboard
Windows 7 x64 Home Premium Asus VG248QE Asus VG248QE Ducky Shine 3 (MX Black) 
PowerCaseMouseAudio
Corsair AX 1200 Corsair 450D Razer Deathadder 2013 Creative X-FI Titanium HD 
Other
Sennheiser PC 350 
CPUGraphicsRAMHard Drive
Core i7 740QM GTX 460m 2x 4gb DDR3 OCZ Agility 3 
OSMonitor
Windows 7 x64 15.1" (1920x1080) 
CPUGraphicsRAMHard Drive
Core i3 2367M Intel HD 3000 4GB DDR3 Hitachi HDD 
Hard DriveOSMonitor
SanDisk SSD Windows 7 Home Premium x64 13.3" 1366x768 
  hide details  
Reply
post #24 of 46
Thread Starter 
Well I've ruled out hardware 100%. Everything on low and still the same issue. I've also cleared shader cache and will now re-install the game.
post #25 of 46
Thread Starter 
Okay, re-installed and still having the same issue. Another thing I noticed is the menu does the same thing. When I go from option to option slowly the buttons respond to the rollover just fine. When I mouse over them fast it lags out. So it must be the software. I'll try more tweaks later tonight but I'm headed out for the evening. Thanks for the help thus far and hope we can figure this out soon!
post #26 of 46
Okay that is a bit strange. And I'm assuming this is the ONLY game that does this for you?

Out of question, in the menu, does the FPS counter actually drop as well temporarily? (Use the built in one, open console, type in r_displayinfo = 1)\
It seems really, really strange that it would do that. Does it still do it if you turn off SLI?
Base2
(21 items)
 
Edi
(13 items)
 
Zenbook
(7 items)
 
CPUMotherboardGraphicsRAM
Core i7 2600k @ 4.75ghz @ 1.352v Asus p8p67 Deluxe Asus GTX 970 Strix ADATA XPG1 (2x8gb) @ 1600mhz 
Hard DriveHard DriveHard DriveHard Drive
2x OCZ Agility 3  2x Toshiba 2tb Sata 3 OCZ Vertex 2 Seagate Barracuda 500gb 
Optical DriveCoolingCoolingCooling
LG Blu-Ray-RW  Corsair H70 3x Corsair AF 120 Silent Edition 2x AF 140 
OSMonitorMonitorKeyboard
Windows 7 x64 Home Premium Asus VG248QE Asus VG248QE Ducky Shine 3 (MX Black) 
PowerCaseMouseAudio
Corsair AX 1200 Corsair 450D Razer Deathadder 2013 Creative X-FI Titanium HD 
Other
Sennheiser PC 350 
CPUGraphicsRAMHard Drive
Core i7 740QM GTX 460m 2x 4gb DDR3 OCZ Agility 3 
OSMonitor
Windows 7 x64 15.1" (1920x1080) 
CPUGraphicsRAMHard Drive
Core i3 2367M Intel HD 3000 4GB DDR3 Hitachi HDD 
Hard DriveOSMonitor
SanDisk SSD Windows 7 Home Premium x64 13.3" 1366x768 
  hide details  
Reply
Base2
(21 items)
 
Edi
(13 items)
 
Zenbook
(7 items)
 
CPUMotherboardGraphicsRAM
Core i7 2600k @ 4.75ghz @ 1.352v Asus p8p67 Deluxe Asus GTX 970 Strix ADATA XPG1 (2x8gb) @ 1600mhz 
Hard DriveHard DriveHard DriveHard Drive
2x OCZ Agility 3  2x Toshiba 2tb Sata 3 OCZ Vertex 2 Seagate Barracuda 500gb 
Optical DriveCoolingCoolingCooling
LG Blu-Ray-RW  Corsair H70 3x Corsair AF 120 Silent Edition 2x AF 140 
OSMonitorMonitorKeyboard
Windows 7 x64 Home Premium Asus VG248QE Asus VG248QE Ducky Shine 3 (MX Black) 
PowerCaseMouseAudio
Corsair AX 1200 Corsair 450D Razer Deathadder 2013 Creative X-FI Titanium HD 
Other
Sennheiser PC 350 
CPUGraphicsRAMHard Drive
Core i7 740QM GTX 460m 2x 4gb DDR3 OCZ Agility 3 
OSMonitor
Windows 7 x64 15.1" (1920x1080) 
CPUGraphicsRAMHard Drive
Core i3 2367M Intel HD 3000 4GB DDR3 Hitachi HDD 
Hard DriveOSMonitor
SanDisk SSD Windows 7 Home Premium x64 13.3" 1366x768 
  hide details  
Reply
post #27 of 46
Thread Starter 
Yes and yes. FPS drops and both in and out of SLI.
post #28 of 46
Try getting rid of fraps. They like to inject itself into .dll's causing issues. I was having issues with games recently, uninstalled Fraps and wallah, issues solved
Hobbes
(16 items)
 
  
CPUMotherboardGraphicsRAM
Intel I7 4790K GA-Z97X-SOC Gigabyte GTX 1080 Gaming Samsung MV-3V4G3D/US 16GB 
Hard DriveCoolingOSKeyboard
Samsung 850 EVO 250GB EK Predator 240mm Windows 7 x64 Das Keyboard 4 Professional CherryMX Blue 
PowerCaseMouseAudio
Seasonic X750 Gold Corsair Carbide Air 540 Logitech G900 Schiit Bifrost Uber W/ USB Gen 2 DAC 
AudioAudioAudioAudio
Schiit Asgard 2 Headphone Amp Audioengine N22 Speaker Amp AudioQuest Nighthawk Audioengine P4 Monitors. 
  hide details  
Reply
Hobbes
(16 items)
 
  
CPUMotherboardGraphicsRAM
Intel I7 4790K GA-Z97X-SOC Gigabyte GTX 1080 Gaming Samsung MV-3V4G3D/US 16GB 
Hard DriveCoolingOSKeyboard
Samsung 850 EVO 250GB EK Predator 240mm Windows 7 x64 Das Keyboard 4 Professional CherryMX Blue 
PowerCaseMouseAudio
Seasonic X750 Gold Corsair Carbide Air 540 Logitech G900 Schiit Bifrost Uber W/ USB Gen 2 DAC 
AudioAudioAudioAudio
Schiit Asgard 2 Headphone Amp Audioengine N22 Speaker Amp AudioQuest Nighthawk Audioengine P4 Monitors. 
  hide details  
Reply
post #29 of 46
Thread Starter 
Quote:
Originally Posted by SpykeZ View Post

Try getting rid of fraps. They like to inject itself into .dll's causing issues. I was having issues with games recently, uninstalled Fraps and wallah, issues solved

Except it's only THIS game that is getting the FRAPS error? VERY doubtful.
post #30 of 46
Change compatibility to win xp (exe poperties)
Are you running the 32 or 64 bit exe?


Also when you experience this menu lag, "Alt + Enter" to enter windowed mode. Check if it persists.
Edited by kenpachiroks - 2/4/13 at 10:46pm
TRON3000
(15 items)
 
 
ASUSness
(5 items)
 
CPUMotherboardGraphicsRAM
Q6600 G0 SLACR @ 3.0 GHz Gigabyte GA-EP31-DS3L MSI 7950 OC BE 3GB 2X2 GB 800 mhz Corsair 
Hard DriveOptical DriveOSOS
Seagate Barracuda 7200rpm 500GB LG super multi Windows 8.1 Pro 64 bit Windows 8 pro 64 bit 
OSMonitorPower
Ubuntu 12.10 Acer 19"W 4ms AL1916W Coolermaster 500W 
CPUGraphicsRAMHard Drive
Intel Core i5-5200U Intel HD Graphics 5500 4GB DDR3L 1600 MHz 128GB SSD 
OSMonitorAudio
Windows 10 64-bit 13.3 in Full HD infinity display Waves MaxxAudio 
CPUGraphicsRAMOS
Intel Core i3 3217U Intel(R) HD Graphics 4000 4.00GB DDR3 Windows 10 64-bit 
Monitor
14" Multitouch 1366x768 
  hide details  
Reply
TRON3000
(15 items)
 
 
ASUSness
(5 items)
 
CPUMotherboardGraphicsRAM
Q6600 G0 SLACR @ 3.0 GHz Gigabyte GA-EP31-DS3L MSI 7950 OC BE 3GB 2X2 GB 800 mhz Corsair 
Hard DriveOptical DriveOSOS
Seagate Barracuda 7200rpm 500GB LG super multi Windows 8.1 Pro 64 bit Windows 8 pro 64 bit 
OSMonitorPower
Ubuntu 12.10 Acer 19"W 4ms AL1916W Coolermaster 500W 
CPUGraphicsRAMHard Drive
Intel Core i5-5200U Intel HD Graphics 5500 4GB DDR3L 1600 MHz 128GB SSD 
OSMonitorAudio
Windows 10 64-bit 13.3 in Full HD infinity display Waves MaxxAudio 
CPUGraphicsRAMOS
Intel Core i3 3217U Intel(R) HD Graphics 4000 4.00GB DDR3 Windows 10 64-bit 
Monitor
14" Multitouch 1366x768 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: PC Gaming
Overclock.net › Forums › Video Games › PC Gaming › Crysis (One) FPS Drop When Looking Around Too Fast?