Overclock.net › Forums › Video Games › PC Gaming › Far Cry 3 Inconsistent FPS and GPU usage
New Posts  All Forums:Forum Nav:

Far Cry 3 Inconsistent FPS and GPU usage - Page 2

post #11 of 19
Thread Starter 
HOLY MOTHER OF GOD!!!
After searching internet for clues and testing for many goddammit week, the effort has finally paid off!
Here's what I did to the final result, maximum pre-rendered frames 1, triple buffering enabled and FXAA off through the NVCP, v-sync ingame on and PostFxQuality="false".

I can't f***ing believe I have made it!!! Now I can play FAR CRY 3 with smooth FPS 50-60!!! I hope this can help you guys who have the same issue with me.
Edited by Crazy6a3er - 2/7/13 at 7:28am
post #12 of 19
Thanks for the update, I will give it a try
Main Rig
(15 items)
 
 
Living Room PC
(12 items)
 
CPUMotherboardGraphicsRAM
i7 4790K @ 4800 G1 Sniper 5 GTX 780Ti SLI @ 1300MHz 16GB DDR3 @ 2200 9-11-11-31 1T 
Hard DriveHard DriveOptical DriveCooling
2TB Hitatchi HDD 1TB Samsung 840 EVO samsung DVDRW DL Custom Water loop 
OSMonitorPowerCase
Win7 64 LG 27" 1080p EVGA 1000P Corsair 700D 
CPUMotherboardGraphicsRAM
i7 3770K @ 5000 Z77X-UP7 GTX770 2x4GB DDR3 7-8-7-21 1T 
Hard DriveHard DriveOptical DriveCooling
WD Velociraptor 250GB 840Evo DVD Burner Coolermaster hyper 212+ 
OSPowerCase
Win 7 x64 OCZ GameXtreme 700W  Dimastech mini v1 
CPUMotherboardGraphicsRAM
i7 2600 Asus P8Z77-V Pro GTX580 8GB DDR3 @ 1600 9-9-9 1T 
Hard DriveHard DriveOptical DriveCooling
2TB hitachi 500GB 850EVO Blue Ray Hyper 212+ 
OSMonitorPowerCase
Win7 64` 42" Panasonic Plasma TX650 Tuniq Tower 3 
  hide details  
Reply
Main Rig
(15 items)
 
 
Living Room PC
(12 items)
 
CPUMotherboardGraphicsRAM
i7 4790K @ 4800 G1 Sniper 5 GTX 780Ti SLI @ 1300MHz 16GB DDR3 @ 2200 9-11-11-31 1T 
Hard DriveHard DriveOptical DriveCooling
2TB Hitatchi HDD 1TB Samsung 840 EVO samsung DVDRW DL Custom Water loop 
OSMonitorPowerCase
Win7 64 LG 27" 1080p EVGA 1000P Corsair 700D 
CPUMotherboardGraphicsRAM
i7 3770K @ 5000 Z77X-UP7 GTX770 2x4GB DDR3 7-8-7-21 1T 
Hard DriveHard DriveOptical DriveCooling
WD Velociraptor 250GB 840Evo DVD Burner Coolermaster hyper 212+ 
OSPowerCase
Win 7 x64 OCZ GameXtreme 700W  Dimastech mini v1 
CPUMotherboardGraphicsRAM
i7 2600 Asus P8Z77-V Pro GTX580 8GB DDR3 @ 1600 9-9-9 1T 
Hard DriveHard DriveOptical DriveCooling
2TB hitachi 500GB 850EVO Blue Ray Hyper 212+ 
OSMonitorPowerCase
Win7 64` 42" Panasonic Plasma TX650 Tuniq Tower 3 
  hide details  
Reply
post #13 of 19
Thread Starter 
If you're playing SLI, you may try this : http://www.evga.com/forums/tm.aspx?m=1811997&mpage=1
post #14 of 19
Thanks for the link. I had changed some things around with nvidia inspector before I installed the newer drivers and I think they were messing with me. I changed them back to defaults (what the fix was in that thread) and it has helped out a lot for me in dx11 mode.
Main Rig
(15 items)
 
 
Living Room PC
(12 items)
 
CPUMotherboardGraphicsRAM
i7 4790K @ 4800 G1 Sniper 5 GTX 780Ti SLI @ 1300MHz 16GB DDR3 @ 2200 9-11-11-31 1T 
Hard DriveHard DriveOptical DriveCooling
2TB Hitatchi HDD 1TB Samsung 840 EVO samsung DVDRW DL Custom Water loop 
OSMonitorPowerCase
Win7 64 LG 27" 1080p EVGA 1000P Corsair 700D 
CPUMotherboardGraphicsRAM
i7 3770K @ 5000 Z77X-UP7 GTX770 2x4GB DDR3 7-8-7-21 1T 
Hard DriveHard DriveOptical DriveCooling
WD Velociraptor 250GB 840Evo DVD Burner Coolermaster hyper 212+ 
OSPowerCase
Win 7 x64 OCZ GameXtreme 700W  Dimastech mini v1 
CPUMotherboardGraphicsRAM
i7 2600 Asus P8Z77-V Pro GTX580 8GB DDR3 @ 1600 9-9-9 1T 
Hard DriveHard DriveOptical DriveCooling
2TB hitachi 500GB 850EVO Blue Ray Hyper 212+ 
OSMonitorPowerCase
Win7 64` 42" Panasonic Plasma TX650 Tuniq Tower 3 
  hide details  
Reply
Main Rig
(15 items)
 
 
Living Room PC
(12 items)
 
CPUMotherboardGraphicsRAM
i7 4790K @ 4800 G1 Sniper 5 GTX 780Ti SLI @ 1300MHz 16GB DDR3 @ 2200 9-11-11-31 1T 
Hard DriveHard DriveOptical DriveCooling
2TB Hitatchi HDD 1TB Samsung 840 EVO samsung DVDRW DL Custom Water loop 
OSMonitorPowerCase
Win7 64 LG 27" 1080p EVGA 1000P Corsair 700D 
CPUMotherboardGraphicsRAM
i7 3770K @ 5000 Z77X-UP7 GTX770 2x4GB DDR3 7-8-7-21 1T 
Hard DriveHard DriveOptical DriveCooling
WD Velociraptor 250GB 840Evo DVD Burner Coolermaster hyper 212+ 
OSPowerCase
Win 7 x64 OCZ GameXtreme 700W  Dimastech mini v1 
CPUMotherboardGraphicsRAM
i7 2600 Asus P8Z77-V Pro GTX580 8GB DDR3 @ 1600 9-9-9 1T 
Hard DriveHard DriveOptical DriveCooling
2TB hitachi 500GB 850EVO Blue Ray Hyper 212+ 
OSMonitorPowerCase
Win7 64` 42" Panasonic Plasma TX650 Tuniq Tower 3 
  hide details  
Reply
post #15 of 19
Thread Starter 
In case of conflict between the previous driver and the new driver, you should remove them thoroughly.
Here's the link: http://www.overclock.net/t/1150443/how-to-remove-your-nvidia-gpu-drivers

Edit: Oh and thanks for your rep!biggrin.gif I never knew I could help someone who had the same problem with me.
Edited by Crazy6a3er - 2/7/13 at 10:45pm
post #16 of 19
Thread Starter 
Update:
Bad new:Still doesn't fix FPS and GPU usage drops entirely...... frown.gif

Good new: FPS and GPU usage seem more stable than before, at least it's playable for me......

SIGH......
post #17 of 19

I have the same issue. 

 

It seems the game is poorly optimized. Kinda puts me off from playing any further.

My Rig
(18 items)
 
Gaming Laptop
(7 items)
 
 
CPUMotherboardGraphicsRAM
i7 4790k Asus Z97-A Asus GTX 1070 Corsair Vengance Pro 16gb @2400mhz 
Hard DriveHard DriveHard DriveCooling
WD 1TB @7200 RPM Kingston SSDnow 120GB Sandisk Plus 480GB Corsair H60 
OSMonitorKeyboardPower
Windows 10 (NSA Edition) Acer XB241H 144hz Gsync Bloody 740A Mechanical Evga SuperNOVA G2 750W  
CaseMouseMouse PadAudio
Corsair 400R Logitech G502 Razer Goliathus Extended Skullcandy PLYR1 
AudioAudio
Sound Blaster Z DT 990 Pro 250 OHM All Black 
CPUGraphicsRAMHard Drive
i7 2630QM Geforce GTX460M 8GB DDR3 @ 1333mhz 1TB 
OSMonitorMouse
Windows 10 (NSA edition) 17.3 inch 1080p Logitech M560 
  hide details  
Reply
My Rig
(18 items)
 
Gaming Laptop
(7 items)
 
 
CPUMotherboardGraphicsRAM
i7 4790k Asus Z97-A Asus GTX 1070 Corsair Vengance Pro 16gb @2400mhz 
Hard DriveHard DriveHard DriveCooling
WD 1TB @7200 RPM Kingston SSDnow 120GB Sandisk Plus 480GB Corsair H60 
OSMonitorKeyboardPower
Windows 10 (NSA Edition) Acer XB241H 144hz Gsync Bloody 740A Mechanical Evga SuperNOVA G2 750W  
CaseMouseMouse PadAudio
Corsair 400R Logitech G502 Razer Goliathus Extended Skullcandy PLYR1 
AudioAudio
Sound Blaster Z DT 990 Pro 250 OHM All Black 
CPUGraphicsRAMHard Drive
i7 2630QM Geforce GTX460M 8GB DDR3 @ 1333mhz 1TB 
OSMonitorMouse
Windows 10 (NSA edition) 17.3 inch 1080p Logitech M560 
  hide details  
Reply
post #18 of 19
You shouldn't be using any driver except 295.73 if you have a 580gtx or lower. More information buried in:



http://www.overclock.net/t/1433882/gaming-and-mouse-response-bios-optimization-guide-for-modern-pc-hardware-2013-r0ach-edition
post #19 of 19
Quote:
Originally Posted by r0ach View Post

You shouldn't be using any driver except 295.73 if you have a 580gtx or lower. More information buried in:



http://www.overclock.net/t/1433882/gaming-and-mouse-response-bios-optimization-guide-for-modern-pc-hardware-2013-r0ach-edition

Got a 780 here...

 

Problem is I can run the game fine no issues. But there is this random point in game the GPU usage becomes 99% and lowering my FPS to 40s.

 

There is nothing different going on at those times. I am not running the game on ultra settings and have turned off all the AA.. Still I get this issue.

My Rig
(18 items)
 
Gaming Laptop
(7 items)
 
 
CPUMotherboardGraphicsRAM
i7 4790k Asus Z97-A Asus GTX 1070 Corsair Vengance Pro 16gb @2400mhz 
Hard DriveHard DriveHard DriveCooling
WD 1TB @7200 RPM Kingston SSDnow 120GB Sandisk Plus 480GB Corsair H60 
OSMonitorKeyboardPower
Windows 10 (NSA Edition) Acer XB241H 144hz Gsync Bloody 740A Mechanical Evga SuperNOVA G2 750W  
CaseMouseMouse PadAudio
Corsair 400R Logitech G502 Razer Goliathus Extended Skullcandy PLYR1 
AudioAudio
Sound Blaster Z DT 990 Pro 250 OHM All Black 
CPUGraphicsRAMHard Drive
i7 2630QM Geforce GTX460M 8GB DDR3 @ 1333mhz 1TB 
OSMonitorMouse
Windows 10 (NSA edition) 17.3 inch 1080p Logitech M560 
  hide details  
Reply
My Rig
(18 items)
 
Gaming Laptop
(7 items)
 
 
CPUMotherboardGraphicsRAM
i7 4790k Asus Z97-A Asus GTX 1070 Corsair Vengance Pro 16gb @2400mhz 
Hard DriveHard DriveHard DriveCooling
WD 1TB @7200 RPM Kingston SSDnow 120GB Sandisk Plus 480GB Corsair H60 
OSMonitorKeyboardPower
Windows 10 (NSA Edition) Acer XB241H 144hz Gsync Bloody 740A Mechanical Evga SuperNOVA G2 750W  
CaseMouseMouse PadAudio
Corsair 400R Logitech G502 Razer Goliathus Extended Skullcandy PLYR1 
AudioAudio
Sound Blaster Z DT 990 Pro 250 OHM All Black 
CPUGraphicsRAMHard Drive
i7 2630QM Geforce GTX460M 8GB DDR3 @ 1333mhz 1TB 
OSMonitorMouse
Windows 10 (NSA edition) 17.3 inch 1080p Logitech M560 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: PC Gaming
Overclock.net › Forums › Video Games › PC Gaming › Far Cry 3 Inconsistent FPS and GPU usage